libgsf.spec revision 12424
10668N/A#
10668N/A# spec file for package libgsf
10668N/A#
20829N/A# Copyright 2008 Sun Microsystems, Inc.
10668N/A# This file and all modifications and additions to the pristine
10668N/A# package are under the same license as the package itself.
10668N/A#
17185N/A# Owner:halton
10668N/A#
17182N/A
17182N/AName: libgsf
17182N/ALicense: LGPL
10668N/AGroup: System/Libraries
19981N/AVersion: 1.14.7
10668N/ARelease: 1
20829N/ADistribution: Java Desktop System
10668N/AVendor: Sun Microsystems, Inc.
10668N/ASummary: The GNOME Structured File Library
10668N/ASource: http://ftp.gnome.org/pub/gnome/sources/libgsf/1.14/%{name}-%{version}.tar.bz2
10668N/A# date:2004-04-12 owner:yippi type:branding
18947N/APatch0: libgsf-01-uninstalled-pc.diff
10668N/AURL: http://ftp.gnome.org/pub/gnome/sources/libgsf/
10668N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10668N/ADocdir: %{_defaultdocdir}/doc
10668N/AAutoreqprov: on
10668N/APrereq: /sbin/ldconfig
10668N/A
10668N/A#####################################
10668N/A## Package Defines Section ##
10668N/A#####################################
10668N/A
10668N/A%define glib2_version 2.6.0
10668N/A%define zlib_version 1.2.1
10668N/A%define libxml2_version 2.6.7
10668N/A%define bzip2_version 1.0.2
10668N/A%define libbonobo_version 2.6.0
10668N/A%define gnome_vfs_version 2.6.0
10668N/A
10668N/A#####################################
10668N/A## Package Requirements Section ##
10668N/A#####################################
10668N/A
10668N/ARequires: glib2 >= %{glib2_version}
10668N/ARequires: libxml2 >= %{libxml2_version}
10668N/ARequires: zlib >= %{zlib_version}
10668N/ARequires: bzip2 >= %{bzip2_version}
10668N/ARequires: libbonobo >= %{libbonobo_version}
10668N/ARequires: gnome-vfs >= %{gnome_vfs_version}
10668N/ABuildRequires: glib2-devel >= %{glib2_version}
10668N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10668N/ABuildRequires: zlib-devel >= %{zlib_version}
10668N/ABuildRequires: bzip2 >= %{bzip2_version}
10668N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10668N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
10668N/A
10668N/A#####################################
10668N/A## Package Description Section ##
10668N/A#####################################
10668N/A
10668N/A%description
10668N/Alibgsf project aims to provide an efficient extensible i/o abstraction for
10668N/Adealing with different structured file formats.
10668N/A
10668N/A#####################################
10668N/A## Package Development Section ##
10668N/A#####################################
10668N/A
10668N/A%package devel
10668N/ASummary: libgsf development headers
10668N/AGroup: Development/Libraries
10668N/ARequires: %{name} = %{version}
10668N/ARequires: glib2-devel >= %{glib2_version}
10668N/ARequires: libxml2-devel >= %{libxml2_version}
10668N/ARequires: zlib-devel >= %{zlib_version}
10668N/ARequires: bzip2 >= %{bzip2_version}
10668N/ARequires: libbonobo-devel >= %{libbonobo_version}
10668N/ARequires: gnome-vfs-devel >= %{gnome_vfs_version}
10668N/A
10668N/A%description devel
10668N/Alibgsf development headers
10668N/A
10668N/A#####################################
10668N/A## Package Preparation Section ##
10668N/A#####################################
10668N/A
10668N/A%prep
10668N/A%setup -q
10668N/A%patch0 -p1
10668N/A
10668N/A#####################################
20829N/A## Package Build Section ##
20829N/A#####################################
18947N/A
18947N/A
16904N/A%build
16904N/A%ifos linux
16212N/Aif [ -x /usr/bin/getconf ]; then
16212N/A CPUS=`getconf _NPROCESSORS_ONLN`
10668N/Afi
10668N/A%else
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
libtoolize --force
intltoolize --copy --force --automake
aclocal $ACLOCAL_FLAGS -I ./m4
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
--bindir=%{_bindir} \
--libdir=%{_libdir} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
--mandir=%{_mandir} \
--with-gnome \
--with-bz2 \
%gtk_doc_option
make -j $CPUS
%install
make install DESTDIR=$RPM_BUILD_ROOT
#Clean up unpackaged files
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
#########################################
## Package Post[Un] Install Section ##
#########################################
%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
%postun
/sbin/ldconfig
%preun
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
#####################################
## Package Files Section ##
#####################################
%files
%defattr(-,root,root)
%{_bindir}/*
%{_sysconfdir}/gconf/schemas
%{_libdir}/*.so.*
%{_datadir}/locale
%{_mandir}/man1
%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*
%{_datadir}/gtk-doc/html/libgsf/*
%changelog
* Wed Feb 20 2008 - halton.huo@sun.com
- Add comment for uninstalled-pc.diff.
- Unremove gtk-doc when gtk_doc is false
* Fri Sep 14 2007 - nonsea@users.sourceforge.net
- Add libtoolize and intltoolize to fix build fail.
* Mon Sep 10 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.7.
* Mon Aug 13 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.5.
* Thu May 03 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.3.
- use %gtk_doc_option in configure so that it can be
disabled using --without-gtk-doc
* Fri Jun 09 2006 - damien.carbery@sun.com
- Bump to 1.14.1.
* Fri Mar 10 2006 - damien.carbery@sun.com
- Bump to 1.14.0.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 1.13.3
* Tue Sep 27 2005 - damien.carbery@sun.com
- Bump to 1.12.3
* Wed Jun 15 2005 - matt.keenan@sun.com
- Bump to 1.12.1
* Tue May 24 2005 - brian.cameron@sun.com
- Turn on --enable-gtk-doc on Solaris since it works now.
* Tue May 24 2005 - laszlo.kovacs@sun.com
- libgsf-02-gtkdoc.diff removed
* Thu May 19 2005 - laszlo.kovacs@sun.com
- ported to 2.10
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected
on Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- added patch 01 (gtkdoc) back - it's needed to build on linux
* Mon Sep 13 2004 - damien.carbery@sun.com
- Disable gtk-doc on Solaris to get module to build.
* Wed Sep 01 2004 - laszlo.kovacs@sun.com
- fixed gtk-doc path problem
* Tue Aug 24 2004 - brian.cmaeron@sun.com
- Enabling gtk-docs and setting with-html-dir to place them in
the standard gtk-doc location.
* Thu Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Mon Apr 12 2004 - <brian.cameron@sun.com
- Added patch 1 to add uninstalled.pc file for Solaris build.
* Tue Feb 24 2004 - <michael.twomey@sun.com>
- Fixed distro typo
* Tue Feb 24 2004 - <matt.keenan@sun.com>
- Update Distro
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to 1.8.2.
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Thu Jul 17 2003 - michael.twomey@sun.com
- Initial package