libgnome.spec revision 12225
18861N/A#
18861N/A# spec file for package libgnome
18861N/A#
18861N/A# Copyright (c) 2008 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A# Owner: alo
18861N/A#
18861N/AName: libgnome
18861N/ALicense: LGPL
18861N/AGroup: System/Libraries/GNOME
18861N/AVersion: 2.20.1.1
18861N/ARelease: 5
18861N/ADistribution: Java Desktop System
18861N/AVendor: Sun Microsystems, Inc.
18861N/ASummary: GNOME Base Library
18861N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libgnome/2.20/libgnome-%{version}.tar.bz2
18861N/A%if %option_with_sun_branding
18861N/A# owner:alo date:2005-04-26 type:branding
18861N/APatch1: libgnome-01-sun-default-background.diff
18861N/A%endif
18861N/A%if %option_with_indiana_branding
18861N/A# owner:gman date:2008-01-18 type:branding
18861N/APatch1: libgnome-01-indiana-default-background.diff
18861N/APatch2: libgnome-02-indiana-default-theme.diff
18861N/A%endif
18861N/A%if %option_with_sun_branding
18861N/A# owner:alo date:2005-07-18 type:branding
18861N/APatch2: libgnome-02-default-theme.diff
18861N/A%endif
18861N/A# owner:mattman date:2005-07-18 type:branding bugzilla:395887
18861N/APatch3: libgnome-03-lockdown-schemas.diff
18861N/A# owner:alo date:2005-07-18 type:branding
18861N/APatch4: libgnome-04-input-method-status-style.diff
18861N/AURL: http://www.gnome.org
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ADocdir: %{_defaultdocdir}/doc
18861N/AAutoreqprov: on
18861N/APrereq: /sbin/ldconfig
18861N/A
18861N/A%define GConf_version 2.6.1
18861N/A%define gnome_vfs_version 2.6.0
18861N/A%define libbonobo_version 2.6.0
18861N/A%define libxslt_version 1.1.2
18861N/A%define audiofile_version 0.2.5
18861N/A%define esound_version 0.2.33
18861N/A%define gtk_doc_version 1.1
18861N/A%define popt_version 1.7
18861N/A
18861N/ABuildRequires: GConf-devel >= %{GConf_version}
18861N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
18861N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
18861N/ABuildRequires: libxslt-devel >= %{libxslt_version}
18861N/ABuildRequires: esound-devel >= %{esound_version}
18861N/A# Audio file header files are include in base pkg in SuSE 9.1
18861N/ABuildRequires: audiofile >= %{audiofile_version}
18861N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
18861N/ABuildRequires: popt-devel >= %{popt_version}
18861N/ARequires: GConf >= %{GConf_version}
18861N/ARequires: libbonobo >= %{libbonobo_version}
18861N/ARequires: esound >= %{esound_version}
18861N/ARequires: audiofile >= %{audiofile_version}
18861N/ARequires: libxslt >= %{libxslt_version}
18861N/A
18861N/A%description
18861N/Alibgnome is one of the base GNOME libraries, containing convenient API for
18861N/Aconfiguration, help, initialization and web links, all specific to the
18861N/AGNOME desktop.
18861N/A
18861N/A%package devel
18861N/ASummary: GNOME Base Development Library
18861N/AGroup: Development/Libraries/GNOME
18861N/ARequires: %name = %version-%release
18861N/ARequires: popt-devel >= %{popt_version}
18861N/ARequires: libbonobo-devel >= %{libbonobo_version}
18861N/A
18861N/A%description devel
18861N/Alibgnome is one of the base GNOME libraries, containing convenient API for
18861N/Aconfiguration, help, initialization and web links, all specific to the
18861N/AGNOME desktop.
18861N/A
18861N/A%prep
18861N/A%setup -q
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/A%patch3 -p1
18861N/A%patch4 -p1
18861N/A
18861N/A%build
18861N/A%ifos linux
18861N/Aif [ -x /usr/bin/getconf ]; then
18861N/A CPUS=`getconf _NPROCESSORS_ONLN`
18861N/Afi
18861N/A%else
18861N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/A%endif
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Alibtoolize --force
18861N/Aglib-gettextize --copy --force
18861N/Aintltoolize --copy --force --automake
18861N/Aaclocal $ACLOCAL_FLAGS -I .
18861N/Aautoconf
18861N/Aautoheader
18861N/Agtkdocize --copy
18861N/Aautomake -a -c -f
18861N/ACFLAGS="$RPM_OPT_FLAGS" \
18861N/A./configure --prefix=%{_prefix} \
18861N/A --datadir=%{_datadir} \
18861N/A --sysconfdir=%{_sysconfdir} \
18861N/A --libexecdir=%{_libexecdir} \
18861N/A --mandir=%{_mandir} \
18861N/A %{gtk_doc_option}
18861N/A./config.status
18861N/Amake -j $CPUS
18861N/A
18861N/A%install
18861N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18861N/Amake DESTDIR=$RPM_BUILD_ROOT install
18861N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
18861N/A
18861N/A#Copy zh_HK from zh_TW
18861N/A#Fixes bug 4930405
18861N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
18861N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.a
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.la
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%post
18861N/A/sbin/ldconfig
18861N/ASCHEMAS="desktop_gnome_accessibility_keyboard.schemas \
18861N/A desktop_gnome_accessibility_startup.schemas \
18861N/A desktop_gnome_applications_browser.schemas \
18861N/A desktop_gnome_applications_help_viewer.schemas \
18861N/A desktop_gnome_applications_terminal.schemas \
18861N/A desktop_gnome_applications_window_manager.schemas \
18861N/A desktop_gnome_background.schemas \
18861N/A desktop_gnome_file_views.schemas \
18861N/A desktop_gnome_interface.schemas \
18861N/A desktop_gnome_peripherals_keyboard.schemas \
18861N/A desktop_gnome_peripherals_mouse.schemas \
18861N/A desktop_gnome_sound.schemas \
18861N/A desktop_gnome_thumbnailers.schemas \
18861N/A desktop_gnome_typing_break.schemas \
18861N/A desktop_gnome_lockdown.schemas"
18861N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
18861N/Afor S in $SCHEMAS; do
18861N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
18861N/Adone
18861N/A
18861N/A%postun
18861N/A/sbin/ldconfig
18861N/A
18861N/A%files
18861N/A%defattr(-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_bindir}/gnome-open
%{_sysconfdir}/sound/events/*.soundlist
%{_sysconfdir}/gconf/schemas/*
%{_libdir}/libgnome*so.*
%{_libdir}/bonobo/monikers/*so*
%{_libdir}/bonobo/servers/*.server
%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/libgnome-2.0.pc
%{_includedir}/libgnome-2.0/libgnome/*.h
%{_datadir}/gtk-doc/*
%{_libdir}/libgnome*so
%{_mandir}/man1/*
%{_mandir}/man3/*
%{_mandir}/man7/*
%changelog
* Fri Jan 18 2007 - glynn.foster@sun.com
- Addition of Indiana default theme patch
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 2.20.1.1.
* Wed Oct 3 2007 - laca@sun.com
- add indiana default background patch
* Wed Sep 19 2007 - damien.carbery@sun.com
- Bump to 2.20.0.
* Wed Aug 29 2007 - damien.carbery@sun.com
- Add --automake to intltoolize call for consistency with other modules.
* Mon Jul 30 2007 - damien.carbery@sun.com
- Bump to 2.19.1.
* Tue Jun 19 2007 - damien.carbery@sun.com
- Bump to 2.19.0.
* Mon Mar 12 2007 - damien.carbery@sun.com
- Bump to 2.18.0.
* Mon Mar 05 2007 - damien.carbery@sun.com
- Bump to 2.17.92.
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 2.17.91.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.17.90.
* Wed Jan 10 2007 - damien.carbery@sun.com
- Bump to 2.17.3.
* Tue Jan 09 2007 - damien.carbery@sun.com
- Bump to 2.17.2.
* Thu Dec 07 2006 - damien.carbery@sun.com
- Bump to 2.17.1.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 2.17.0.
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Mon Sep 04 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Tue Aug 08 2006 - padraig.obriain@sun.com
- Bump to 2.15.2.
* Fri Jul 21 2006 - padraig.obriain@sun.com
- Bump to 2.15.1.
* Tue Apr 11 2006 - damien.carbery@sun.com
- Bump to 2.14.1.
* Mon Mar 13 2006 - damien.carbery@sun.com
- Bump to 2.14.0.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 2.13.90.
* Thu Feb 16 2006 - brian.cameron@sun.com
- Set libexecdir or else we get /usr/libexec in the
libgnome.pc file.
* Tue Jan 17 2006 - damien.carbery@sun.com
- Bump to 2.13.5
* Wed Dec 21 2005 - brian.cameron@sun.com
- Bump to 2.13.4.
* Thu Sep 15 2005 - brian.cameron@sun.com
- Bump to 2.12.0.1.
* Fri Sep 09 2005 - laca@sun.com
- reorder autofoo: move intltoolize after glib-gettextize is the correct
po/Makefile.in.in is used
* Tue Sep 06 2005 - damien.carbery@sun.com
- Call intltoolize, glib-gettextize and gtkdocize to add missing files.
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.3.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.2.
* Tue Jul 19 2005 - muktha.narayan@wipro.com
- Modify libgnome-02-default-theme.diff,
libgnome-03-lockdown-schemas.diff and
libgnome-04-input-method-status-style.diff
so that the changes are applied to the .schemas.in
files instead of .schemas files.
* Thu Jun 23 2005 - muktha.narayan@wipro.com
- Modified libgnome-03-lockdown-schemas.diff to
include starsuite and starsuite-printeradmin in the
allowed_applications list.
Fixes bug #6288742.
* Fri May 20 2005 - glynn.foster@sun.com
- Remove backgrounds and put them in gnome-backgrounds
package. Sanitizes things a lot.
* Thu May 12 2005 - muktha.narayan@wipro.com
- Modified libgnome-03-lockdown-schemas.diff to
update the entries in the allowed_applications list.
Fixes bug #6266517.
* Fri May 06 2005 - glynn.foster@sun.com
- Bump to 2.10.0
* Fri Dec 24 2004 - srirama.sharma@wipro.com
- Replacing /usr/bin/staroffice with /usr/bin/soffice in
libgnome-03-lockdown-schemas.diff. Fixes Bug #6208251.
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add gnome-open.1 man page
* Thu Oct 21 2004 - vinay.mandyakoppal@wipro.com
- Add patch to fix Launcher to be usable as root.
* Wed Sep 15 2004 - yuriy.kuznetsov@sun.com
- Added libgnome-07-g11n-potfiles.diff
* Wed Aug 18 2004 - brian.cameron@sun.com
- added --enable-gtk-doc.
* Mon Aug 09 2004 - vinay.mandyakoppal@wipro.com
- Added desktop_gnome_typing_break.schemas
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to libgnome-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- Ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Tue May 25 2004 - yuriy.kuznetsov@sun.com
- Added libgnome-06-g11n-potfiles.diff
* Thu May 20 2004 - hidetoshi.tajima@sun.com
Add libgnome-05-input-method-status-style.diff again.
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to libgnome-l10n-po-1.1.tar.bz2
* Tue May 11 2004 - laszlo.kovacs@sun.com
- rename jdshelp script
* Thu May 06 2004 - laszlo.kovacs@sun.com
- replacing yelp with jds-help.sh in libgnome-03-lockdown-schemas.diff
* Mon May 3 2004 - glynn.foster@wipro.com
- Add bindir, so we get the joys of gnome-open
* Wed Apr 14 2004 - archana.shah@wipro.com
- Removed desktop_gnome_url_handlers.schemas from spec file.
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to libgnome-l10n-po-1.0.tar.bz2
* Mon Mar 22 2004 - glynn.foster@sun.com
- Bump to 2.6.0. Remove the the uninstalled pc patch since
it's upstream.
* Wed Mar 04 2004 - matt.keenan@sun.com
- Bump to 2.5.90, as it contains partial lockdown schema file
- re-engineer lockdown schema patch
- Remove the OrigTree.pm hack
* Mon Feb 23 2004 - stephen.browne@sun.com
- Bump to 2.5.4
* Mon Feb 02 2004 - niall.power@sun.com
- Bump to 2.5.3
- Add OrigTree.pm as source 5.
- Unpack source 1 after build into RPM_BUILD_ROOT (fixes solaris breakage).
- Add patch to add an -uninstalled.pc file for pkgconfig
* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
- Add patch 06 to search in /usr for intltool perl modules
* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
- Add dependency on intltool
* Mon Dec 15 2003 - glynn.foster@sun.com
- Bump to 2.5.1
* Tue Oct 21 2003 - matt.keenan@sun.com
- lockdown schema patch
* Wed Oct 08 2003 - stephen.browne@sun.com
- Updated for 2.4
* Fri Sep 05 2003 - michael.twomey@sun.com
- Add libgnome-04-schemas-chinese.diff to fix font sizes.
Fixes bug 4915643.
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Thu Aug 07 2003 - glynn.foster@sun.com
- Update tarball, reset release, bump version.
* Thu Jul 24 2003 - Laszlo.Kovacs@sun.com
- added libgnome-04-background.diff
* Thu Jul 10 2003 - michael.twomey@sun.com
- Added .po tarball
* Thu Jul 03 2003 - glynn.foster@sun.com
- Remove the joint theme/background patch and separate them
out
* Wed Apr 30 2003 - niall.power@sun.com
- Create new spec file for libgnome