10139N/A#
10139N/A# spec file for package libexif-gtk
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner gheet
10139N/A# bugdb: http://sourceforge.net/tracker/index.php?func=detail&group_id=12272&atid=112272&aid=
10139N/A#
17178N/A
18644N/A%define OSR delivered in s10:n/a
17178N/A
10139N/AName: libexif-gtk
18982N/ALicense: LGPLv2
10139N/AGroup: Development/Libraries/C and C++
10139N/AVersion: 0.3.5
10139N/ARelease: 2
10139N/ADistribution: Java Desktop System
18615N/AVendor: Sourceforge
10139N/ASummary: GTK widgets for viewing EXIF information
16580N/ASource: %{sf_download}/libexif/%{name}-%{version}.tar.bz2
10139N/A# date:2004-01-16 owner:mattman type:bug bugzilla:1616317
10139N/APatch1: libexif-gtk-01-enable-deprecated.diff
13483N/A# date:2004-06-02 owner:laca type:bug bugzilla:1616397 bugster:6570425
10139N/APatch2: libexif-gtk-02-gettext.diff
10139N/A# date:2004-06-02 owner:yippi type:bug bugzilla:1616320
10139N/APatch3: libexif-gtk-03-solaris.diff
17364N/A# date:2004-06-02 owner:gheet type:feature bugzilla:1643242
10139N/APatch4: libexif-gtk-04-uninstalled-pc.diff
10139N/A# date:2006-02-21 owner:dcarbery type:bug bugzilla:1394423
10139N/APatch5: libexif-gtk-05-sf-bug-1394423.diff
16781N/A# date:2009-07-15 owner:chrisk type:bug
16781N/APatch6: libexif-gtk-06-bad-include.diff
10139N/AURL: http://sourceforge.net/projects/libexif
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocDir: %{_defaultdocdir}/libexif-gtk
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A
10139N/A%define libexif_version 0.5.9
10139N/ARequires: libexif >= %{libexif_version}
10139N/ARequires: gtk2
10139N/ABuildRequires: libexif >= %{libexif_version}
10139N/ABuildRequires: gtk2-devel
10139N/A
10139N/A%description
10139N/AThis library contains GTK widgets for viewing the EXIF informations within
10139N/AJPEG images created by some types of digital cameras.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
16781N/A%patch6 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$CFLAGS $RPM_OPT_FLAGS" \
10139N/A ./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10139N/A --disable-static
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=${RPM_BUILD_ROOT}/ install-strip
10139N/A#clean up unpackaged files
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
12889N/A#%check
12889N/Amake check
12889N/A
10139N/A%clean
10139N/Arm -rf ${RPM_BUILD_ROOT}
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/lib*so*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_includedir}/*
10139N/A%{_datadir}/locale/*
10139N/A
10139N/A%changelog -n libexif-gtk
16781N/A* Wed Jul 15 2009 - christian.kelly@sun.com
16781N/A- Looks like gtk doesn't allow include of anything but gtk.h. Create patch 6 to
16781N/A change includes.
16781N/A
16580N/A* Tue Jun 02 2009 - harry.lu@sun.com
16580N/A- Change download URL to generic %{sf_download}
16580N/A
12889N/A* Wed Apr 16 2008 - damien.carbery@sun.com
12889N/A- Add 'make check' call after %install.
12889N/A
10173N/A* Mon Mar 05 2006 - dermot.mccluskey@sun.com
10173N/A- Correct license to LGPL, as per the source files
10173N/A
10139N/A* Tue Feb 21 2006 - damien.carbery@sun.com
10139N/A- Add patch, 05-sf-bug-1394423, to fix configure bug, already logged at sf.net.
10139N/A
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Add hack to fix infinite loop problem in po/Makefile.
10139N/A
10139N/A* Wed Jun 15 2005 - laca@sun.com
10139N/A- Add more libs to LDADD so that it builds with the new pkgconfig
10139N/A
10139N/A* Wed Jun 15 2005 - matt.keenan@sun.com
10139N/A- Bump to 0.3.5
10139N/A
10139N/A* Wed Jul 13 2004 - niall.power@sun.com
10139N/A- fix for rpm4 packaging
10139N/A
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to libexif-gtk-l10n-po-1.2.tar.bz2
10139N/A
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A
10139N/A* Thu Jun 17 2004 - hidetoshi.tajima@sun.com
10139N/A- Run glib-gettextize and replace po/Makefile.in.in with standard
10139N/A ones found in %{_datadir}/glib-2.0/gettext/.
10139N/A
10139N/A* Wed Jun 06 2004 - brian.cameron@sun.com
10139N/A- Added needed patches for Solaris.
10139N/A
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to libexif-gtk-l10n-po-1.1.tar.bz2
10139N/A
10139N/A* Mon Apr 12 2004 - brian.cameron@sun.com
10139N/A- Add $ACLOCAL_FLAGS to aclocal call, making Solaris more happy.
10139N/A
10139N/A* Wed Mar 31 2004 - brian.cameron@sun.com
10139N/A- replace tar jxf with the more solaris friendly
10139N/A bzcat piped through tar
10139N/A
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to libexif-gtk-l10n-po-1.0.tar.bz2
10139N/A
10139N/A* Thu Mar 18 2004 - <matt.keenan@sun.com>
10139N/A- Added URL Tag
10139N/A
10139N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
10139N/A- added libexif-gtk-03-g11n-potfiles.diff
10139N/A
10139N/A* Wed Feb 04 2004 - <matt.keenan@sun.com>
10139N/A- l10n tarball, and patch
10139N/A
10139N/A* Fri Jan 16 2004 - <matt.keenan@sun.com>
10139N/A- Enable Deprecated patch
10139N/A
10139N/A* Tue Oct 14 2003 - <matt.keenan@sun.com>
10139N/A- Upgrade tarball to 0.3.3 for QS
10139N/A
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- remove *.a, *.la
10139N/A
10139N/A* Wed Jul 16 2003 - matt.keenan@sun.com
10139N/A- Initial version