10785N/A#
10785N/A# spec file for package libdaemon
10785N/A#
18220N/A# Copyright (c) 2010 Sun Microsystems, Inc.
10785N/A# This file and all modifications and additions to the pristine
10785N/A# package are under the same license as the package itself.
10785N/A#
17185N/A%define owner padraig
17048N/A#
17181N/A
17181N/A%define OSR 6984:0.12
17181N/A
10785N/AName: libdaemon
18220N/ALicense: LGPLv2.1
10785N/AGroup: System/Libraries
18220N/AVersion: 0.14
10785N/ARelease: 1
10785N/ADistribution: Java Desktop System
18615N/AVendor: 0pointer.de
10785N/ASummary: Lightweight C library for writing Unix daemons
10785N/ASource: http://0pointer.de/lennart/projects/libdaemon/%{name}-%{version}.tar.gz
18220N/APatch1: libdaemon-01-configure.diff
10785N/AURL: http://0pointer.de/lennart/projects/libdaemon/
10785N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10785N/ADocdir: %{_defaultdocdir}/doc
10785N/AAutoreqprov: on
10785N/APrereq: /sbin/ldconfig
10785N/A
10785N/A%description
10785N/Alibdaemon is a lightweight C library which eases the writing of UNIX daemons.
10785N/AIt consists of the following parts:
10785N/A
10785N/A- A wrapper around fork() which does the correct daemonization procedure of
10785N/A a process
10785N/A- A wrappeer around syslog() for simpler and compatible log output to Syslog
10785N/A or STDERR
10785N/A- An API for writing PID files
10785N/A- An API for serializing UNIX signals into a pipe for usage with select()
10785N/A or poll()
10785N/A- an API for running subprocesses with STDOUT and STDERR redirected to syslog
10785N/A
10785N/A%package devel
10785N/ASummary: A lightweight C library for writing UNXI daemons.
10785N/AGroup: Development/Libraries
10785N/ARequires: %{name} = %{version}
10785N/A
10785N/A%description devel
10785N/Alibdaemon is a lightweight C library which eases the writing of UNIX daemons.
10785N/AIt consists of the following parts:
10785N/A
10785N/A- A wrapper around fork() which does the correct daemonization procedure of
10785N/A a process
10785N/A- A wrappeer around syslog() for simpler and compatible log output to Syslog
10785N/A or STDERR
10785N/A- An API for writing PID files
10785N/A- An API for serializing UNIX signals into a pipe for usage with select()
10785N/A or poll()
10785N/A- an API for running subprocesses with STDOUT and STDERR redirected to syslog
10785N/A
10785N/A%prep
10785N/A%setup -q
16894N/A%patch1 -p1
10785N/A
10785N/A%build
10785N/A%ifos linux
10785N/Aif [ -x /usr/bin/getconf ]; then
10785N/A CPUS=`getconf _NPROCESSORS_ONLN`
10785N/Afi
10785N/A%else
10785N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10785N/A%endif
10785N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10785N/A CPUS=1
10785N/Afi
10785N/A
10785N/ACONFLAGS="--prefix=%{_prefix} --disable-lynx"
18220N/Aaclocal $ACLOCAL_FLAGS -I ./m4
10785N/Aautoconf
18220N/Aautomake -a -c -f
10785N/ACFLAGS="$RPM_OPT_FLAGS"
10785N/A./configure $CONFLAGS
10785N/A
10785N/Amake -j $CPUS
10785N/A
10785N/A%install
10785N/A
10785N/Amake DESTDIR=$RPM_BUILD_ROOT install
10785N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/libdaemon*a
10785N/A
10785N/A%clean
10785N/Arm -rf $RPM_BUILD_ROOT
10785N/A
10785N/A%post
10785N/A/sbin/ldconfig
10785N/A
10785N/A%postun
10785N/A/sbin/ldconfig
10785N/A
10785N/A%files
10785N/A%defattr(-, root, root)
10785N/A%{_libdir}/libdaemon*.so*
10785N/A
10785N/A%files devel
10785N/A%defattr(-, root, root)
10785N/A%{_libdir}/*.so
10785N/A%{_includedir}/libdaemon/*
10785N/A%{_libdir}/pkgconfig/*
10785N/A
10785N/A%changelog
18220N/A* Thu Jan 28 2010 - brian.cameron@sun.com
18220N/A- Bump to 0.14.
16894N/A* Tue Jul 28 2009 - christian.kelly@sun.com
16894N/A- Bump to 0.13.
16894N/A- Add patch to fix build issue.
11103N/A* Wed Aug 22 2006 - damien.carbery@sun.com
11103N/A- Bump to 0.12.
10785N/A* Mon May 29 2006 - padraig.obriain@sun.com
10785N/A- Initial spec file for libdaemon.