libcroco.spec revision 12411
10139N/A#
10139N/A# spec file for package libcroco
10139N/A#
12279N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A#
17178N/A#####################################
18603N/A## Package Information Section ##
17178N/A#####################################
10139N/A
19064N/AName: libcroco
10139N/ALicense: LGPL
19064N/AGroup: System/Libraries
19064N/AVersion: 0.6.1
10139N/ARelease: 1
18615N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
16135N/ASummary: Cascading Style Sheet (CSS) parsing and manipulation toolkit
12773N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libcroco/0.6/%{name}-%{version}.tar.bz2
12773N/A#owner:yippi date:2009-02-19 type:bug bugster:6549227 bugzilla:484666 state:upstream
12773N/APatch1: libcroco-01-fixheader.diff
10139N/AURL: http://www.freespiders.org/projects/libcroco/index.html
16353N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
18061N/AAutoreqprov: on
18580N/APrereq: /sbin/ldconfig
18061N/A
10139N/A#####################################
10139N/A## Package Defines Section ##
10139N/A#####################################
10139N/A
10139N/A%define glib2_version 2.6.0
10139N/A%define zlib_version 1.2.1
10139N/A%define libxml2_version 2.6.7
10139N/A%define bzip2_version 1.0.2
10139N/A%define libbonobo_version 2.6.0
10139N/A%define gnome_vfs_version 2.6.0
10139N/A
10139N/A#####################################
10139N/A## Package Requirements Section ##
10139N/A#####################################
10139N/A
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10139N/A
10139N/A#####################################
10139N/A## Package Description Section ##
10139N/A#####################################
10139N/A
10139N/A%description
10139N/Alibcroco project aims to build a generic Cascading Style Sheet (CSS)
10139N/Aparsing and manipulation toolkit.
10139N/A
10139N/A#####################################
10139N/A## Package Development Section ##
10139N/A#####################################
10139N/A
10139N/A%package devel
10139N/ASummary: libcroco development headers
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
17512N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/ARequires: zlib-devel >= %{zlib_version}
10139N/ARequires: bzip2 >= %{bzip2_version}
10139N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/ARequires: gnome-vfs-devel >= %{gnome_vfs_version}
10139N/A
10139N/A%description devel
10139N/Alibcroco development headers
10139N/A
10139N/A#####################################
10139N/A## Package Preparation Section ##
10139N/A#####################################
10139N/A
10139N/A%prep
10139N/A%setup -q
11139N/A%patch1 -p1
12773N/A
12773N/A#####################################
12773N/A## Package Build Section ##
12773N/A#####################################
12773N/A
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A#Clean up unpackaged files
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A#########################################
10139N/A## Package Post[Un] Install Section ##
10139N/A#########################################
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A#####################################
10139N/A## Package Files Section ##
10139N/A#####################################
10139N/A
19064N/A%files
19064N/A%defattr(-,root,root)
18575N/A%{_bindir}
18575N/A%{_libdir}/*.so.*
17512N/A
17512N/A%files devel
17512N/A%defattr(-,root,root)
17379N/A%{_includedir}/*
17379N/A%{_libdir}/*.so
16135N/A%{_libdir}/pkgconfig/*
16135N/A
14555N/A%changelog
14555N/A* Tue Feb 19 2009 - brian.cameron@sun.com
13789N/A- Add patch libcroco-01-fixheader.diff to fix bug 6549227.
13789N/A* Mon Mar 6 2006 - damien.carbery@sun.com
13539N/A- Bump to 0.6.1.
13539N/A* Fri Feb 24 2006 - damien.carbery@sun.com
13419N/A- Update URL and Summary.
13419N/A* Wed Jul 27 2005 - brian.cameron@sun.com
12574N/A - Created.
12574N/A