libcanberra.spec revision 17183
#
# spec file for package libcanberra
#
# includes module(s): libcanberra
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
# bugdb: bugzilla.freedesktop.org
#
%define OSR 9780:0.6
Name: libcanberra
License: LGPL v2.1
Group: Libraries/Multimedia
Version: 0.16
Distribution: Java Desktop System
Vendor: Sun Microsystems, Inc.
Summary: Event Sound API Using XDG Sound Theming Specification
Source: http://0pointer.de/lennart/projects/libcanberra/libcanberra-%{version}.tar.gz
# This patch is needed until autoconf is updated to 2.63 and libtool to 2.2.
#owner:yippi date:2008-09-02 type:branding
Patch1: libcanberra-01-solaris.diff
URL: http://0pointer.de/blog/projects/sixfold-announcement.html
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
%package root
Summary: %{summary} - / filesystem
SUNW_BaseDir: /
%package devel
Summary: %{summary} - development files
SUNW_BaseDir: %{_basedir}
Requires: %name
%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
glib-gettextize -f
aclocal $ACLOCAL_FLAGS -I ./m4
autoheader
autoconf
automake -a -c -f
export CFLAGS="%optflags"
export LDFLAGS="%_ldflags"
./configure --prefix=%{_prefix} --mandir=%{_mandir} \
--libdir=%{_libdir} --bindir=%{_bindir} \
--libexecdir=%{_libexecdir} \
--sysconfdir=%{_sysconfdir} \
--disable-static
make -j$CPUS
%install
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif
%clean
rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Aug 27 2009 - brian.cameron@sun.com
- Bump to 0.16.
* Wed Aug 05 2009 - brian.cameron@sun.com
- Bump to 0.15.
* Fri Jul 24 2009 - ke.wang@sun.com
- Split from SUNWlibcanberra.spec to add 64-bit support