libIDL.spec revision 18615
10139N/A#
10139N/A# spec file for package libIDL
10139N/A#
12151N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner gheet
10139N/A#
10139N/A
10139N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
15322N/A
10139N/AName: libIDL
14030N/ALicense: LGPL
14030N/AGroup: System/Libraries
14133N/AVersion: 0.8.14
12578N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Gnome Community
10139N/ASummary: IDL parsing library
11256N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
10142N/AURL: http://www.gnome.org
12773N/ADocdir: %{_defaultdocdir}/doc
12773N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12773N/AAutoReqProv: on
11358N/APrereq: /sbin/ldconfig
10139N/A
11358N/A%define glib2_version 2.4.0
11358N/A%define pkgconfig_version 0.15.0
11358N/A
11358N/ARequires: glib2 >= %{glib2_version}
11358N/ABuildRequires: glib2-devel >= %{glib2_version}
11358N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
14126N/A
11002N/A%description
13025N/AlibIDL is a small library for creating parse trees of CORBA v2.2
13025N/Acompliant Interface Definition Language (IDL) files, which is a
13907N/Aspecification for defining interfaces which can be used between
13907N/Adifferent CORBA implementations.
13664N/A
13664N/A%package devel
14520N/ASummary: IDL parsing library development libraries and header files.
15230N/AGroup: Development/Languages/Other
15389N/ARequires: %{name} = %{version}
14568N/ARequires: glib2-devel >= %{glib2_version}
15389N/A
15247N/A%description devel
15389N/AlibIDL is a small library for creating parse trees of CORBA v2.2
15358N/Acompliant Interface Definition Language (IDL) files, which is a
15389N/Aspecification for defining interfaces which can be used between
15460N/Adifferent CORBA implementations.
15460N/A
15460N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport CFLAGS="%optflags"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/*.so.*
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/*
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_libdir}/*.so
10139N/A%{_includedir}/*
10139N/A%{_mandir}/man3/*
10139N/A%{_infodir}/*.info.gz
10139N/A
10139N/A%changelog
10139N/A* Sat Apr 3 2010 - christian.kelly@sun.com
10139N/A- Bump to 0.8.14.
12274N/A* Wed Mar 18 2009 - dave.lin@sun.com
12274N/A- Bump to 0.8.13
12274N/A* Wed Dec 03 2008 - dave.lin@sun.com
12274N/A- Bump to 0.8.12
10139N/A* Thu Aug 21 2008 - dave.lin@sun.com
10139N/A- Bump to 0.8.11
10139N/A* Wed Jan 30 2008 - damien.carbery@sun.com
10139N/A- Bump to 0.8.10.
10142N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- convert to new style multi-ISA build
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11358N/A- Bump to 0.8.9.
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
11358N/A- Removed adding ccdir to PATH
11358N/A* Tue Mar 06 2005 - damien.carbery@sun.com
11358N/A- Bump to 0.8.8.
11358N/A* Mon Aug 15 2005 - damien.carbery@sun.com
11002N/A- Bump to 0.8.6.
13025N/A* Fri May 06 2005 - glynn.foster@sun.com
12830N/A- Bump to 0.8.5
13664N/A* Fri Oct 29 2004 - laca@sun.com
15389N/A- use $CC64 for the 64-bit build if defined
15389N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
14568N/A- Create 64bit libraries for Solaris
15389N/A* Thu Jul 08 2004 - niall.power@sun.com
15460N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed Jan 28 2004 - <laca@sun.com> 0.8.3-1
10139N/A- Upgrade to 0.8.3
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Add back the man pages.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 0.8.2-1
10139N/A- Upgrade to 0.8.2
10139N/A* Tue May 20 2003 - <Niall.Power@Sun.COM>
10139N/A- initial Sun release
10139N/A