libIDL.spec revision 18603
20837N/A#
20837N/A# spec file for package libIDL
20837N/A#
20837N/A# Copyright 2008 Sun Microsystems, Inc.
20837N/A# This file and all modifications and additions to the pristine
20894N/A# package are under the same license as the package itself.
20837N/A#
20837N/A%define owner gheet
20837N/A#
20837N/A
20837N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
20843N/A
20843N/AName: libIDL
20837N/ALicense: LGPL
20837N/AGroup: System/Libraries
20843N/AVersion: 0.8.14
20843N/ARelease: 1
20843N/ADistribution: Java Desktop System
20843N/AVendor: Sun Microsystems, Inc.
20843N/ASummary: IDL parsing library
20837N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
20843N/AURL: http://www.gnome.org
20837N/ADocdir: %{_defaultdocdir}/doc
20837N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20879N/AAutoReqProv: on
20837N/APrereq: /sbin/ldconfig
20843N/A
20843N/A%define glib2_version 2.4.0
20843N/A%define pkgconfig_version 0.15.0
20867N/A
20843N/ARequires: glib2 >= %{glib2_version}
20837N/ABuildRequires: glib2-devel >= %{glib2_version}
20837N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
20837N/A
20897N/A%description
20837N/AlibIDL is a small library for creating parse trees of CORBA v2.2
20897N/Acompliant Interface Definition Language (IDL) files, which is a
20837N/Aspecification for defining interfaces which can be used between
20910N/Adifferent CORBA implementations.
20910N/A
20910N/A%package devel
20910N/ASummary: IDL parsing library development libraries and header files.
20910N/AGroup: Development/Languages/Other
20910N/ARequires: %{name} = %{version}
20910N/ARequires: glib2-devel >= %{glib2_version}
20897N/A
20897N/A%description devel
20897N/AlibIDL is a small library for creating parse trees of CORBA v2.2
20897N/Acompliant Interface Definition Language (IDL) files, which is a
20897N/Aspecification for defining interfaces which can be used between
20897N/Adifferent CORBA implementations.
20897N/A
20897N/A%prep
20910N/A%setup -q
20837N/A
20837N/A%build
20837N/A%ifos linux
20837N/Aif [ -x /usr/bin/getconf ]; then
20837N/A CPUS=`getconf _NPROCESSORS_ONLN`
20897N/Afi
20837N/A%else
20837N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20837N/A%endif
20837N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20837N/A CPUS=1
20837N/Afi
20897N/A
20837N/Aexport CFLAGS="%optflags"
20837N/Aexport LDFLAGS="%_ldflags"
20837N/A./configure --prefix=%{_prefix} \
20909N/A --mandir=%{_mandir} \
20837N/A --datadir=%{_datadir} \
20837N/A --libdir=%{_libdir} \
20837N/A --bindir=%{_bindir} \
20897N/A --sysconfdir=%{_sysconfdir}
20837N/A
20837N/Amake -j $CPUS
20837N/A
20837N/A%install
20843N/Amake DESTDIR=$RPM_BUILD_ROOT install
20843N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
20843N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
20843N/A
20843N/A%clean
20843N/Arm -rf $RPM_BUILD_ROOT
20837N/A
20843N/A%post
20843N/A/sbin/ldconfig
20842N/A
20867N/A%postun
20867N/A/sbin/ldconfig
20867N/A
20837N/A%files
20904N/A%defattr(-,root,root)
20904N/A%{_libdir}/*.so.*
20904N/A
20904N/A%files devel
20904N/A%defattr(-,root,root)
20904N/A%{_bindir}/*
20904N/A%{_libdir}/pkgconfig/*.pc
20904N/A%{_libdir}/*.so
20904N/A%{_includedir}/*
20904N/A%{_mandir}/man3/*
20843N/A%{_infodir}/*.info.gz
20904N/A
20849N/A%changelog
20849N/A* Sat Apr 3 2010 - christian.kelly@sun.com
20837N/A- Bump to 0.8.14.
20837N/A* Wed Mar 18 2009 - dave.lin@sun.com
20837N/A- Bump to 0.8.13
20837N/A* Wed Dec 03 2008 - dave.lin@sun.com
20899N/A- Bump to 0.8.12
20837N/A* Thu Aug 21 2008 - dave.lin@sun.com
20899N/A- Bump to 0.8.11
20843N/A* Wed Jan 30 2008 - damien.carbery@sun.com
20843N/A- Bump to 0.8.10.
20843N/A* Fri Sep 28 2007 - laca@sun.com
20837N/A- convert to new style multi-ISA build
20837N/A* Tue Sep 18 2007 - damien.carbery@sun.com
20843N/A- Bump to 0.8.9.
20843N/A* Wed Mar 15 2007 - dougs@truemail.co.th
20904N/A- Removed adding ccdir to PATH
20849N/A* Tue Mar 06 2005 - damien.carbery@sun.com
20849N/A- Bump to 0.8.8.
20843N/A* Mon Aug 15 2005 - damien.carbery@sun.com
20899N/A- Bump to 0.8.6.
20843N/A* Fri May 06 2005 - glynn.foster@sun.com
20899N/A- Bump to 0.8.5
20843N/A* Fri Oct 29 2004 - laca@sun.com
20843N/A- use $CC64 for the 64-bit build if defined
20843N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
20837N/A- Create 64bit libraries for Solaris
20837N/A* Thu Jul 08 2004 - niall.power@sun.com
20837N/A- ported to rpm4
20837N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
20843N/A- added "-j $CPUS" to make to speed up builds
20843N/A* Wed Jan 28 2004 - <laca@sun.com> 0.8.3-1
20843N/A- Upgrade to 0.8.3
20837N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
20843N/A- Add back the man pages.
20843N/A* Thu Aug 14 2003 - <laca@sun.com>
20849N/A- move lib*.so to -devel, remove *.a, *.la
20843N/A* Fri Aug 01 2003 - <markmc@sun.com> 0.8.2-1
20843N/A- Upgrade to 0.8.2
20837N/A* Tue May 20 2003 - <Niall.Power@Sun.COM>
20849N/A- initial Sun release
20851N/A