libIDL.spec revision 16186
10139N/A#
10139N/A# spec file for package libIDL
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
18970N/A# package are under the same license as the package itself.
18970N/A#
10139N/A# Owner: gheet
10139N/A#
10139N/AName: libIDL
17185N/ALicense: LGPL
10139N/AGroup: System/Libraries
17178N/AVersion: 0.8.13
18644N/ARelease: 1
17178N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
12132N/ASummary: IDL parsing library
12132N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
17355N/AURL: http://www.gnome.org
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AAutoReqProv: on
18970N/APrereq: /sbin/ldconfig
18593N/A
10139N/A%define glib2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
19013N/A
18908N/ARequires: glib2 >= %{glib2_version}
10385N/ABuildRequires: glib2-devel >= %{glib2_version}
15760N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
15767N/A
15760N/A%description
15760N/AlibIDL is a small library for creating parse trees of CORBA v2.2
15760N/Acompliant Interface Definition Language (IDL) files, which is a
15760N/Aspecification for defining interfaces which can be used between
15760N/Adifferent CORBA implementations.
10139N/A
12707N/A%package devel
10139N/ASummary: IDL parsing library development libraries and header files.
10139N/AGroup: Development/Languages/Other
19142N/ARequires: %{name} = %{version}
16401N/ARequires: glib2-devel >= %{glib2_version}
16401N/A
10139N/A%description devel
10139N/AlibIDL is a small library for creating parse trees of CORBA v2.2
10139N/Acompliant Interface Definition Language (IDL) files, which is a
10139N/Aspecification for defining interfaces which can be used between
15760N/Adifferent CORBA implementations.
18688N/A
18688N/A%prep
15762N/A%setup -q
16493N/A
16493N/A%build
19142N/A%ifos linux
16493N/Aif [ -x /usr/bin/getconf ]; then
16493N/A CPUS=`getconf _NPROCESSORS_ONLN`
16493N/Afi
16493N/A%else
15762N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15760N/A%endif
19142N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
16401N/A CPUS=1
16401N/Afi
15760N/A
15760N/Aexport CFLAGS="%optflags"
15760N/Aexport LDFLAGS="%_ldflags"
16224N/A./configure --prefix=%{_prefix} \
15760N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
12754N/A --sysconfdir=%{_sysconfdir}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
11149N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
12773N/A
12773N/A%clean
12773N/Arm -rf $RPM_BUILD_ROOT
12773N/A
12773N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/*.so.*
11311N/A
11311N/A%files devel
11311N/A%defattr(-,root,root)
11311N/A%{_bindir}/*
10139N/A%{_libdir}/pkgconfig/*.pc
11311N/A%{_libdir}/*.so
10139N/A%{_includedir}/*
11311N/A%{_mandir}/man3/*
11311N/A%{_infodir}/*.info.gz
11311N/A
11311N/A%changelog
11311N/A* Wed Mar 18 2009 - dave.lin@sun.com
15824N/A- Bump to 0.8.13
15824N/A* Wed Dec 03 2008 - dave.lin@sun.com
15824N/A- Bump to 0.8.12
11311N/A* Thu Aug 21 2008 - dave.lin@sun.com
11311N/A- Bump to 0.8.11
15760N/A* Wed Jan 30 2008 - damien.carbery@sun.com
15760N/A- Bump to 0.8.10.
15760N/A* Fri Sep 28 2007 - laca@sun.com
15161N/A- convert to new style multi-ISA build
15824N/A* Tue Sep 18 2007 - damien.carbery@sun.com
15161N/A- Bump to 0.8.9.
15760N/A* Wed Mar 15 2007 - dougs@truemail.co.th
15824N/A- Removed adding ccdir to PATH
15760N/A* Tue Mar 06 2005 - damien.carbery@sun.com
15760N/A- Bump to 0.8.8.
15760N/A* Mon Aug 15 2005 - damien.carbery@sun.com
15760N/A- Bump to 0.8.6.
15760N/A* Fri May 06 2005 - glynn.foster@sun.com
15760N/A- Bump to 0.8.5
15760N/A* Fri Oct 29 2004 - laca@sun.com
15760N/A- use $CC64 for the 64-bit build if defined
15824N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
15760N/A- Create 64bit libraries for Solaris
15824N/A* Thu Jul 08 2004 - niall.power@sun.com
15824N/A- ported to rpm4
15767N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
15760N/A- added "-j $CPUS" to make to speed up builds
15760N/A* Wed Jan 28 2004 - <laca@sun.com> 0.8.3-1
15824N/A- Upgrade to 0.8.3
15760N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
15824N/A- Add back the man pages.
15760N/A* Thu Aug 14 2003 - <laca@sun.com>
15161N/A- move lib*.so to -devel, remove *.a, *.la
15767N/A* Fri Aug 01 2003 - <markmc@sun.com> 0.8.2-1
15767N/A- Upgrade to 0.8.2
10139N/A* Tue May 20 2003 - <Niall.Power@Sun.COM>
10139N/A- initial Sun release
10139N/A