libIDL.spec revision 15448
10139N/A#
10139N/A# spec file for package libIDL
10139N/A#
17185N/A# Copyright 2008 Sun Microsystems, Inc.
13600N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
18644N/A# Owner:gheet
18593N/A#
10139N/AName: libIDL
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
10139N/AVersion: 0.8.12
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18609N/AVendor: Sun Microsystems, Inc.
17928N/ASummary: IDL parsing library
17928N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
17928N/AURL: http://www.gnome.org
17928N/ADocdir: %{_defaultdocdir}/doc
17928N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18609N/AAutoReqProv: on
10139N/APrereq: /sbin/ldconfig
18632N/A
18632N/A%define glib2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
10139N/A
18593N/ARequires: glib2 >= %{glib2_version}
17953N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
18243N/A%description
18067N/AlibIDL is a small library for creating parse trees of CORBA v2.2
18243N/Acompliant Interface Definition Language (IDL) files, which is a
18243N/Aspecification for defining interfaces which can be used between
10139N/Adifferent CORBA implementations.
16555N/A
16555N/A%package devel
16555N/ASummary: IDL parsing library development libraries and header files.
16555N/AGroup: Development/Languages/Other
16633N/ARequires: %{name} = %{version}
11999N/ARequires: glib2-devel >= %{glib2_version}
16051N/A
10354N/A%description devel
15191N/AlibIDL is a small library for creating parse trees of CORBA v2.2
17940N/Acompliant Interface Definition Language (IDL) files, which is a
16051N/Aspecification for defining interfaces which can be used between
15191N/Adifferent CORBA implementations.
16597N/A
16051N/A%prep
16051N/A%setup -q
15715N/A
18251N/A%build
18251N/A%ifos linux
18251N/Aif [ -x /usr/bin/getconf ]; then
18251N/A CPUS=`getconf _NPROCESSORS_ONLN`
16845N/Afi
17940N/A%else
16845N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
16845N/A%endif
16053N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
16053N/A CPUS=1
16053N/Afi
16053N/A
16053N/Aexport CFLAGS="%optflags"
16053N/Aexport LDFLAGS="%_ldflags"
16053N/A./configure --prefix=%{_prefix} \
16053N/A --mandir=%{_mandir} \
17339N/A --datadir=%{_datadir} \
17940N/A --libdir=%{_libdir} \
17339N/A --bindir=%{_bindir} \
17339N/A --sysconfdir=%{_sysconfdir}
16053N/A
16053N/Amake -j $CPUS
16053N/A
16555N/A%install
16555N/Amake DESTDIR=$RPM_BUILD_ROOT install
16555N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
16555N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
16555N/A
16601N/A%clean
16555N/Arm -rf $RPM_BUILD_ROOT
16555N/A
17940N/A%post
16846N/A/sbin/ldconfig
16845N/A
16845N/A%postun
17940N/A/sbin/ldconfig
16845N/A
16555N/A%files
17214N/A%defattr(-,root,root)
17214N/A%{_libdir}/*.so.*
17214N/A
17940N/A%files devel
17940N/A%defattr(-,root,root)
17940N/A%{_bindir}/*
17940N/A%{_libdir}/pkgconfig/*.pc
18012N/A%{_libdir}/*.so
18012N/A%{_includedir}/*
18012N/A%{_mandir}/man3/*
18012N/A%{_infodir}/*.info.gz
18012N/A
18012N/A%changelog
18728N/A* Wed Dec 03 2008 - dave.lin@sun.com
18728N/A- Bump to 0.8.12
18728N/A* Thu Aug 21 2008 - dave.lin@sun.com
10139N/A- Bump to 0.8.11
10139N/A* Wed Jan 30 2008 - damien.carbery@sun.com
10139N/A- Bump to 0.8.10.
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- convert to new style multi-ISA build
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.8.9.
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10139N/A- Removed adding ccdir to PATH
10139N/A* Tue Mar 06 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.8.8.
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.8.6.
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 0.8.5
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Thu Jul 08 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed Jan 28 2004 - <laca@sun.com> 0.8.3-1
10139N/A- Upgrade to 0.8.3
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Add back the man pages.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 0.8.2-1
17953N/A- Upgrade to 0.8.2
17953N/A* Tue May 20 2003 - <Niall.Power@Sun.COM>
17953N/A- initial Sun release
17953N/A