10139N/A#
10139N/A# spec file for package libIDL
10139N/A#
12301N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner gheet
10139N/A#
17177N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17177N/A
10139N/AName: libIDL
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
18544N/AVersion: 0.8.14
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: Gnome Community
10139N/ASummary: IDL parsing library
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
10139N/AURL: http://www.gnome.org
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AAutoReqProv: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define glib2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
10139N/A
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
10139N/A%description
10139N/AlibIDL is a small library for creating parse trees of CORBA v2.2
10139N/Acompliant Interface Definition Language (IDL) files, which is a
10139N/Aspecification for defining interfaces which can be used between
10139N/Adifferent CORBA implementations.
10139N/A
10139N/A%package devel
10139N/ASummary: IDL parsing library development libraries and header files.
10139N/AGroup: Development/Languages/Other
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10139N/A
10139N/A%description devel
10139N/AlibIDL is a small library for creating parse trees of CORBA v2.2
10139N/Acompliant Interface Definition Language (IDL) files, which is a
10139N/Aspecification for defining interfaces which can be used between
10139N/Adifferent CORBA implementations.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
11322N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
11314N/Aexport CFLAGS="%optflags"
11314N/Aexport LDFLAGS="%_ldflags"
11314N/A./configure --prefix=%{_prefix} \
11314N/A --mandir=%{_mandir} \
11314N/A --datadir=%{_datadir} \
11314N/A --libdir=%{_libdir} \
11314N/A --bindir=%{_bindir} \
11314N/A --sysconfdir=%{_sysconfdir}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/*.so.*
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/*
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_libdir}/*.so
10139N/A%{_includedir}/*
10139N/A%{_mandir}/man3/*
10139N/A%{_infodir}/*.info.gz
10139N/A
10139N/A%changelog
18544N/A* Sat Apr 3 2010 - christian.kelly@sun.com
18544N/A- Bump to 0.8.14.
16186N/A* Wed Mar 18 2009 - dave.lin@sun.com
16186N/A- Bump to 0.8.13
15448N/A* Wed Dec 03 2008 - dave.lin@sun.com
15448N/A- Bump to 0.8.12
13951N/A* Thu Aug 21 2008 - dave.lin@sun.com
13951N/A- Bump to 0.8.11
12301N/A* Wed Jan 30 2008 - damien.carbery@sun.com
12301N/A- Bump to 0.8.10.
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- convert to new style multi-ISA build
11249N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11249N/A- Bump to 0.8.9.
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed adding ccdir to PATH
10199N/A* Tue Mar 06 2005 - damien.carbery@sun.com
10199N/A- Bump to 0.8.8.
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.8.6.
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 0.8.5
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Thu Jul 08 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed Jan 28 2004 - <laca@sun.com> 0.8.3-1
10139N/A- Upgrade to 0.8.3
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Add back the man pages.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 0.8.2-1
10139N/A- Upgrade to 0.8.2
10139N/A* Tue May 20 2003 - <Niall.Power@Sun.COM>
10139N/A- initial Sun release