20843N/A#
20843N/A# spec file for package json-c
20843N/A#
20843N/A# Copyright (c) 2011, Oracle and/or its affiliates. All rights reserved.
20843N/A# This file and all modifications and additions to the pristine
20843N/A# package are under the same license as the package itself.
20843N/A#
20843N/A%define owner yippi
20843N/A#
20843N/A
20843N/AName: json-c
20843N/ASummary: JSON Implementation in C
20843N/AVersion: 0.9
20843N/ALicense: MIT
20843N/ASource: http://oss.metaparadigm.com/json-c/json-c-%{version}.tar.gz
20843N/APatch1: json-c-01-compile.diff
20843N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20843N/A
20843N/A%prep
20843N/A%setup -q -n json-c-%version
20843N/A%patch1 -p1
20843N/A
20843N/A%build
20843N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20843N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20843N/A CPUS=1
20843N/Afi
20843N/A
20843N/Aexport CFLAGS="%optflags"
20843N/Aexport LDFLAGS="%{_ldflags}"
20843N/A
20843N/Alibtoolize --force
20843N/Aaclocal $ACLOCAL_FLAGS
20843N/Aautomake -a -c -f
20843N/A./configure --prefix=%{_prefix} \
20843N/A --bindir=%{_bindir} \
20843N/A --libdir=%{_libdir} \
20843N/A --includedir=%{_includedir} \
20843N/A --mandir=%{_mandir} \
20843N/A --disable-static
20843N/A
20843N/Agmake -j $CPUS
20843N/A
20843N/A
20843N/A%install
20843N/Agmake install DESTDIR=$RPM_BUILD_ROOT
20843N/Arm -f $RPM_BUILD_ROOT%{_libdir}/lib*.*a
20843N/A
20843N/A%if %{!?_without_gtk_doc:0}%{?_without_gtk_doc:1}
20843N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
20843N/A%endif
20843N/A
20843N/A%clean
20843N/Arm -rf $RPM_BUILD_ROOT
20843N/A
20843N/A%changelog
20843N/A* Thu Oct 06 2011 - Brian Cameron
20843N/A- Split from SUNWjson-c.spec and now build amd64.
20843N/A