java-atk-wrapper.spec revision 16756
#
# spec file for package java-atk-wrapper
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: wangke
#
Name: java-atk-wrapper
License: LGPL v2.1
Group: System/Libraries/GNOME
Version: 0.27.3
Release: 1
URL: http://live.gnome.org/Accessibility/JavaATKWrapper
Distribution: Java Desktop System
Vendor: Sun Microsystems, Inc.
Summary: A wrapper of ATK Bridge for Java Swing apps.
Source: http://ftp.gnome.org/pub/GNOME/sources/java-atk-wrapper/0.27/%{name}-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%define glib2_version 2.5.7
%define atk_version 1.4.0
%define at_spi_version 1.1.8
%define at_spi_release 1
BuildRequires: atk-devel >= %{atk_version}
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: at-spi-devel >= %{at_spi_version}-%{at_spi_release}
Requires: atk >= %{atk_version}
Requires: glib2 >= %{glib2_version}
Requires: at-spi >= %{at_spi_version}
%prep
%setup -q -n %{name}-%{version}
%build
aclocal
autoconf
automake -a -c -f
CFLAGS="%optflags"
LDFLAGS="%{_ldflags}"
./configure --prefix=%{_prefix} \
--libdir=%{_libdir}
make jni
%if %build_java
make wrapper
%endif
%install
make install jni DESTDIR=$RPM_BUILD_ROOT
%if %build_java
make install wrapper DESTDIR=$RPM_BUILD_ROOT
%endif
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Jul 6, 2009 - ke.wang@sun.com
- Remove dependency on gtk2
* Mon Jul 6, 2009 - ke.wang@sun.com
- Initial spec.