10139N/A#
10139N/A# spec file for package gtkam
10139N/A#
18636N/A# Copyright 2010 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17765N/A%define owner wangke
10139N/A# bugdb: http://sourceforge.net/tracker/index.php?func=detail&group_id=8874&atid=108874&aid=
10139N/A#
17177N/A
17177N/A%define OSR 4196:0.1.12
17177N/A
10139N/A%include l10n.inc
10139N/A%define gexif_version 0.5
10139N/A
10139N/AName: gtkam
10139N/ALicense: GPL
10139N/AGroup: Hardware/Other
18636N/AVersion: 0.1.17
18636N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: Sourceforge
10139N/ASummary: A GTK Digital Camera Viewing Tool
18988N/ASource: %{sf_download}/gphoto/%{name}-%{version}.tar.bz2
18988N/ASource1: %{sf_download}/libexif/gexif-%{gexif_version}.tar.bz2
10139N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
10396N/ASource3: gtkam-icons.tar.bz2
12773N/A%if %build_l10n
12773N/ASource4: l10n-configure.sh
12773N/A%endif
10139N/A# date:2003-08-15 type:branding owner:mattman bugid:1619752
10139N/APatch1: gtkam-01-menu-entry.diff
13374N/A# date:2004-02-04 type:bug owner:fujiwara bugid:1616317,1616320,1616397,1990311 bugster:6329710
14065N/APatch2: gtkam-02-fixgexif.diff
13538N/A# date:2008-07-10 owner:dcarbery type:bug
14065N/APatch3: gtkam-03-gtk-deprecated.diff
13733N/A# date:2008-08-01 owner:mattman type:branding
14065N/APatch4: gtkam-04-man.diff
20324N/APatch5: gtkam-05-help.diff
10139N/AURL: http://www.gphoto.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_datadir}/doc
10139N/A
10139N/A%define libgphoto2_version 2.1.1
10139N/A%define libexif_gtk_version 0.3.2
10139N/A
10139N/ARequires: libgphoto2 >= %{libgphoto2_version}
10139N/ARequires: libexif-gtk >= %{libexif_gtk_version}
10139N/ABuildRequires: libgphoto2 >= %{libgphoto2_version}
10139N/ABuildRequires: libexif-gtk >= %{libexif_gtk_version}
10139N/ABuildRequires: gimp-devel
10139N/A
10139N/A%description
10139N/AGTKam is a GTK/GNOME based tool to access Digital Cameras,
10139N/Aview thumbnails and download pictures from the camera.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/Abzcat %SOURCE1 | tar xf -
10396N/Abzcat %SOURCE3 | tar xf -
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
12004N/A%patch4 -p1
20324N/A%patch5 -p1
13800N/A%if %build_l10n
13800N/Ash -x %SOURCE4 --enable-sun-linguas
13800N/Abzcat %SOURCE2 | tar xf -
13800N/Acd po-sun; make; cd ..
13800N/A%endif
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Agnome-doc-common
10139N/Alibtoolize --force
10139N/Aintltoolize --copy --force --automake
12773N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE4 --enable-copyright
12773N/A%endif
12773N/A
11353N/Aaclocal $ACLOCAL_FLAGS -I ./m4m -I ./gexif-*/m4
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir} \
10139N/A --mandir=%{_mandir} \
10139N/A --with-libintl-prefix=/usr
10715N/Amake -j $CPUS INTLLIBS= GMSGFMT=msgfmt
10139N/A
10139N/Acd gexif-*
10139N/A glib-gettextize -f
10139N/A libtoolize --force
10139N/A intltoolize --copy --force --automake
10139N/A aclocal $ACLOCAL_FLAGS
10139N/A automake -a -c -f
10139N/A autoconf
13538N/A CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s %{?arch_ldadd}" ./configure --prefix=%{_prefix}
10715N/A make INTLLIBS= GMSGFMT=msgfmt
10139N/Acd ..
10139N/A
10139N/A%install
10139N/Amkdir -p $RPM_BUILD_ROOT%{_prefix}
10715N/Amake DESTDIR=$RPM_BUILD_ROOT GMSGFMT=msgfmt install-strip
10139N/Acd gexif-*
10715N/A make prefix=$RPM_BUILD_ROOT%{_prefix} GMSGFMT=msgfmt install-strip
10139N/Acd ..
10139N/A
10139N/A
10139N/A# FIXME: Remove scrollkeeper files
10139N/Arm -rf $RPM_BUILD_ROOT%{_prefix}/var/scrollkeeper
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT;
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%doc AUTHORS COPYING NEWS README TODO
10139N/A%attr(755,root,root) %{_bindir}/gtkam
10139N/A%attr(755,root,root) %{_bindir}/gexif
10139N/A%{_datadir}/gtkam
10139N/A%{_datadir}/images/gtkam
10139N/A%{_datadir}/pixmaps/*
10139N/A%{_datadir}/locale/*/*/*
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/gnome/help
10139N/A%{_datadir}/omf/*
10139N/A%{_libdir}/gimp/*/plug-ins/gtkam-gimp
10139N/A%{_mandir}/man1/*
10139N/A
10139N/A%changelog
18636N/A* Tue Apr 20 2010 - brian.cameron@sun.com
18636N/A- bump to 0.1.17.
14115N/A* Tue Sep 02 2008 - matt.keenan@sun.com
14115N/A- Patch to set figdir correctly on Makefile.am's for help
14065N/A* Fri Aug 29 2008 - takao.fujiwara@sun.com
14065N/A- Bump to 0.1.15. Fixes the part of 3149.
13800N/A* Fri Aug 08 2008 - harry.fu@sun.com
13800N/A- Add 'sh -x l10n-configure.sh --enable-sun-linguas' line before po-sun tarball is extracted
13733N/A* Fri Aug 01 2008 - matt.keenan@sun.com
13733N/A- Add gtkam-06-man.diff Attributes man page patch
13538N/A* Thu Jul 10 2008 - damien.carbery@sun.com
13538N/A- Remove "-lgailutil" as libgnomecanvas build issue has been fixed.
13538N/A Add patch 05-gtk-deprecated to change GtkType to GType.
13538N/A* Fri Jun 06 2008 - damien.carbery@sun.com
13362N/A- Add "-lgailutil" to LDFLAGS so that libgailutil is linked in when
13362N/A libgnomecanvas is linked. libgnomecanvas.so includes some gail functions.
12004N/A* Wed Nov 28 2007 - brian.cameron@sun.com
12004N/A- Add patch gtkam-04-remove-gp-gettext-flags.diff to avoid using gettext
12004N/A m4 macros. This patch should go away when GNU gettext is added to
12004N/A Nevada.
11358N/A* Fri Oct 5 2007 - laca@sun.com
11358N/A- add %{arch_ldadd} to LDFLAGS for GNU libiconv/libintl
11353N/A* Thu Oct 4 2007 - laca@sun.com
11353N/A- add gexit-*/m4 to the aclocal search path for AM_LC_MESSAGES, defined
11353N/A in lcmessage.m4
10715N/A* Fri Jun 01 2007 - takao.fujiwara@sun.com
10715N/A- Add GMSFMT=msgfmt for the workaround of bug 6559323/sourforge #1599622.
10396N/A* Wed Apr 04 2007 - glynn.foster@sun.com
10396N/A- Temporary addition of icon tarball to replace corrupt icons.
10139N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Tue Feb 06 2007 - matt.keenan@sun.com
10139N/A- Update patch comments
10139N/A* Tue Dec 19 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.1.14. Fix patches, removing upstream patches.
10139N/A* Thu Dec 14 2006 - matt.keenan@sun.com
10139N/A- Remove gtkam-05-short-cut-key.diff : not needed anymore
10139N/A* Tue Dec 12 2006 - takao.fujiwara@sun.com
10139N/A- Added gtkam-06-g11n-i18n-menu.diff. Fixes 6488200
10139N/A* Mon Jul 24 2006 - irene.huang@sun.com
10139N/A- add option --with-libintl-prefix=/usr
10139N/A* Mon May 29 2006 - glynn.foster@sun.com
10139N/A- Remove sfw patch since we're now in /usr/bin by default.
10139N/A* Tue Jan 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.1.13.
10139N/A- Remove obsolete patches -06-wall and -07-gimp-plugin. Renumber remaining.
10139N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
10139N/A- Added gtkam-08-sfw-path.diff to use the absolute path of the executable
10139N/A in the .desktop file as usr/sfw/bin should not be included in $PATH.
10139N/A Fixes bug #6345489.
10139N/A* Tue Nov 29 2005 - laca.com
10139N/A- remove javahelp stuff
10139N/A* Sun Sep 18 2005 - glynn.foster@sun.com
10139N/A- Add gimp-devel as BuildRequires, and add patch so that we install into the
10139N/A correct plugin directory.
10139N/A* Fri Jul 08 2005 - damien.carbery@sun.com
10139N/A- Add patch 08 to remove '-W -Wall -Wno-unused' as they do not work on Solaris.
10139N/A* Wed Jun 15 2005 - matt.keenan@sun.com
10139N/A- Bump to 0.1.12
10139N/A* Thu May 05 2005 - damien.carbery@sun.com
10139N/A- 6227253: Change xml file in gtkam-C.omf from gtkam.xml to
10139N/A sample_apps_info.xml (part of gnome-user-docs). Bit of a hack but a very easy
10139N/A one to maintain.
10139N/A* Thu Mar 10 2005 - damien.carbery@sun.com
10139N/A- Add docs tarball (Source4) to %setup section.
10139N/A* Fri Feb 25 2005 - kazuhiko.maekawa@sun.com
10139N/A- Added dummy l10n online help to follow base update
10139N/A* Wed Feb 16 2005 - damien.carbery@sun.com
10139N/A- Integrate docs tarball (gtkam-docs-0.1) from irene.ryan@sun.com.
10139N/A* Fri Nov 12 2004 - laca@sun.com
10139N/A- added --libdir and --bindir to configure opts so they can be redirected
10139N/A on Solaris
10139N/A* Mon Oct 11 2004 - brian.cameron@sun.com
10139N/A- Move gtkam-gimp plugin to lib/gimp/2.0.
10139N/A* Wed Sep 15 2004 - yuriy.kuznetsov@sun.com
10139N/A- Added gtkam-06-g11n-potfiles.diff
10139N/A* Mon Sep 13 2004 - vinay.mandyakoppal@wipro.com
10139N/A- Added code to install javahelp documents. Fixes #5096653
10139N/A* Wed Aug 25 2004 - laszlo.kovacs@sun.com
10139N/A- fixed man pages and docs installation
10139N/A* Wed Aug 25 2004 - laszlo.kovacs@sun.com
10139N/A- fixed glib-gettextize call
10139N/A* Wed Aug 25 2004 - damien.carbery@sun.com
10139N/A- Add unpackaged files to %files section.
10139N/A* Mon Aug 09 2004 - archana.shah@wipro.com
10139N/A- Added patch gtkam-05-short-cut-key.diff
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtkam-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri Jun 18 2004 - hidetoshi.tajima@sun.com
10139N/A- Run glib-gettexttize and intltoolize for both Solaris and Linux
10139N/A- merge i18n patches
10139N/A* Thu Jun 10 2004 - dermot.mccluskey@sun.com
10139N/A- make patch5 solaris-only
10139N/A* Wed Jun 02 2004 - brian.cameron@sun.com
10139N/A- Added needed patches for Solaris.
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtkam-l10n-po-1.1.tar.bz2
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtkam-l10n-po-1.0.tar.bz2
10139N/A* Thu Mar 18 2004 - matt.keenan@sun.com
10139N/A- Bump to 0.1.11
10139N/A* Thu Mar 04 2004 - takao.fujiwara@sun.com
10139N/A- Updated gtkam-03-l10n-and-utf8.diff to gtkam-03-g11n-i18n-ui.diff
10139N/A to fix 4935751, 4981813
10139N/A* Thu Feb 04 2004 - matt.keenan@sun.com
10139N/A- Add l10n tarball, edit to gtkam-04-gexif-i18n.diff
10139N/A* Wed Feb 04 2004 - matt.keenan@sun.com
10139N/A- Port Patches, gexif version
10139N/A* Fri Jan 16 2004 - matt.keenan@sun.com
10139N/A- Enable deprecated patch
10139N/A* Thu Aug 14 2003 - matt.keenan@sun.com
10139N/A- desktop file for menu entry
10139N/A* Wed Jul 16 2003 - matt.keenan@sun.com
10139N/A- Initial version