gtk2.spec revision 16134
10139N/A#
10139N/A# spec file for package gtk2
10139N/A#
12158N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: erwannc
10139N/A#
17181N/A%include l10n.inc
17181N/AName: gtk2
17181N/ALicense: LGPL
10139N/AGroup: System/Libraries
10139N/AVersion: 2.15.5
10139N/ARelease: 3
10139N/ADistribution: Java Desktop System
17557N/AVendor: Sun Microsystems, Inc.
10752N/ASummary: GTK+ - GIMP Toolkit Library for creation of graphical user interfaces
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.15/gtk+-%{version}.tar.bz2
10139N/ASource1: gtk.unset-hack.sh
10139N/ASource2: gtk.unset-hack.csh
17379N/ASource3: %{name}-po-sun-%{po_sun_version}.tar.bz2
10139N/ASource4: l10n-configure.sh
10139N/A#owner:erwannc date:2000-00-00 type:feature
10318N/APatch1: gtk+-01-window-icons-for-message-dialog.diff
10943N/A#owner:niall date:2003-07-11 type:feature
10139N/APatch2: gtk+-02-fileseldlg-navbuttons.diff
10139N/A#owner:erwannc date:2004-05-17 bugster:5035382 type:bug
10139N/APatch3: gtk+-03-use-xim-for-all-locales.diff
10139N/A#owner:erwannc date:2004-08-12 type:feature
10139N/APatch4: gtk+-04-sun-copy-paste-keybindings.diff
13922N/A#owner:erwannc date:2004-08-12 bugzilla:74223 type:feature
10139N/APatch5: gtk+-05-sun-pgdn-pgup-keybindings.diff
13922N/A#owner:laca date:2004-09-18 type:feature
10139N/APatch6: gtk+-06-solaris-2.0.0-compat.diff
13922N/A#owner:erwannc date:2006-05-01 type:feature
10139N/APatch7: gtk+-07-trusted-extensions.diff
13922N/A# date:2006-09-17 bugster:6494571 bugzilla:382676 owner:gheet type:bug
10139N/APatch8: gtk+-08-printing-papi-backend.diff
13922N/A# date:2007-07-12 bugster:6563388 bugzilla:456137 owner:bewitche type:bug
16686N/APatch9: gtk+-09-null-print.diff
16762N/A# date:2007-11-07 bugster:6625702 launchpad:144326 owner:erwannc type:bug
16762N/APatch10: gtk+-10-gdk-window-null-checks.diff
16762N/A# date:2008-08-14 bugzilla:546817 bugster:6725919 owner:bewitche type:bug
16768N/APatch11: gtk+-11-hidewindow.diff
16522N/A# date:2008-01-11 bugster:6630867 bugzilla:505857 owner:bewitche type:bug
17271N/APatch12: gtk+-12-filechooser-enterkey.diff
17399N/A# date:2008-03-25 bugster:6676839 owner:gheet type:bug
17412N/APatch13: gtk+-13-printing-cups-support.diff
17412N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17543N/ADocdir: %{_defaultdocdir}/doc
17543N/AAutoreqprov: on
16168N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define cairo_version 0.9.2
10139N/A%define atk_version 1.7.0
10139N/A%define pango_version 1.9.0
10139N/A%define glib2_version 2.7.1
10139N/A%define libpng_version 1.2.5
10139N/A%define libjpeg_version 6.2.0
10139N/A
10139N/ABuildRequires: cairo-devel >= %{cairo_version}
10139N/ABuildRequires: atk-devel >= %{atk_verGsion}
10139N/ABuildRequires: pango-devel >= %{pango_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libpng-devel >= %{libpng_version}
13922N/ABuildRequires: libjpeg >= %{libjpeg_version}
10139N/ARequires: cairo >= %{cairo_version}
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: atk >= %{atk_version}
10139N/ARequires: pango >= %{pango_version}
10139N/ARequires: libpng >= %{libpng_version}
10139N/ARequires: libjpeg >= %{libjpeg_version}
10139N/A
10139N/A%description
10139N/AThis fast and versatile library is used all over the world for all
10139N/AGNOME applications, the GIMP and several others. Originally it was
10139N/Awritten for the GIMP and hence has the name Gimp ToolKit. Many people
10139N/Alike it because it is small, efficient and very configurable.
10139N/A
10139N/A%package devel
10139N/ASummary: Library for creation of graphical user interfaces
10139N/AGroup: Development/Libraries/X11
10139N/AAutoreqprov: on
10139N/ARequires: %{name} = %{version}
10139N/ARequires: cairo-devel >= %{cairo_version}
10139N/ARequires: atk-devel >= %{atk_version}
10139N/ARequires: pango-devel >= %{pango_version}
10139N/A
10139N/A%description devel
10139N/AThis fast and versatile library is used all over the world for all
10139N/AGNOME applications, the GIMP and several others. Originally it was
10139N/Awritten for the GIMP and hence has the name Gimp ToolKit. Many people
10139N/Alike it because it is small, efficient and very configurable.
10139N/A
10139N/A%prep
10139N/A%setup -q -n gtk+-%{version}
10139N/A
10139N/A# Fixes build error. Solaris msgfmt does not have '-c'.
10139N/Afor f in po/Makefile.in.in po-properties/Makefile.in.in ; do
10139N/A sed -e 's/$(GMSGFMT) -c/$(GMSGFMT)/g' $f > $f$$
10139N/A mv $f$$ $f
10139N/A d=`dirname $f`
10139N/A touch $d/*.po
10139N/Adone
10139N/A
10463N/A%if %build_l10n
10463N/A# workaround for bugster 6581452, bugzilla 457863
10139N/Ash -x %SOURCE4 --disable-gnu-extensions
10139N/A
10139N/Abzcat %SOURCE3 | tar xf -
10943N/Acd po-sun; make; cd ..
12754N/A%endif
10943N/A%patch1 -p1
10318N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A
10139N/A%ifos solaris
10139N/A%patch4 -p1
13922N/A%endif
10139N/A
10139N/A%patch5 -p1
13922N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A%patch8 -p1
13922N/A%patch9 -p1
10752N/A%patch10 -p1
10553N/A%patch11 -p1
10139N/A%patch12 -p1
10752N/A%patch13 -p1
10553N/A
17220N/A%build
17412N/A%ifos linux
17543N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Agtkdocize
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags -I/usr/X11/include"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
12601N/A --bindir=%{_bindir} \
10318N/A --datadir=%{_datadir} \
10318N/A --with-native-locale=yes \
10318N/A --with-xinput=xfree \
10318N/A --mandir=%{_mandir} \
10318N/A --infodir=%{_infodir} \
10318N/A --enable-shm \
10318N/A --enable-xim \
10318N/A --enable-fbmanager \
10318N/A --with-gdktarget=x11 \
10318N/A --sysconfdir=%{_sysconfdir} \
10318N/A --enable-explicit-deps=yes \
10318N/A --without-libjasper \
10318N/A %{gtk_doc_option}
10139N/A
10960N/A# Build needed uninstalled.pc file
13298N/Amake gdk-x11-2.0-uninstalled.pc
10139N/A
10139N/Amake -j $CPUS
10553N/A
10553N/A%install
10553N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0
10139N/Amkdir -p $RPM_BUILD_ROOT/etc/profile.d
10139N/Acp %SOURCE1 $RPM_BUILD_ROOT/etc/profile.d/
10139N/Acp %SOURCE2 $RPM_BUILD_ROOT/etc/profile.d
17234N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/immodules/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/loaders/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/printbackends/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
13310N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/gtk.immodules
10139N/A%{_bindir}/gdk-pixbuf-query-loaders > %{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
10139N/A
10139N/A%postun
10139N/A#If this is the last version of the package remove the config files
10139N/Aif [ $1 = 0 ]
10139N/Athen
10139N/A rm %{_sysconfdir}/gtk-2.0/gtk.immodules
10139N/A rm %{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
10139N/Afi
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%{_bindir}/*query*
10139N/A%{_bindir}/gtk-update-icon-cache
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_libdir}/gtk-2.0/*/immodules/*.so
10139N/A%{_libdir}/gtk-2.0/*/loaders/*.so
10139N/A%{_libdir}/gtk-2.0/*/engines/*.so
10139N/A%{_datadir}/themes/*/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_sysconfdir}/profile.d/gtk.unset-hack.sh
10139N/A%{_sysconfdir}/profile.d/gtk.unset-hack.csh
10139N/A%dir %{_sysconfdir}/gtk-2.0
10139N/A%{_mandir}/man1/*.gz
10139N/A
10139N/A%files devel
10139N/A%{_bindir}/*-demo
10139N/A%{_bindir}/*-csource
10139N/A%{_includedir}/gtk-2.0
10139N/A%{_libdir}/lib*.so
10139N/A%{_libdir}/gtk-2.0/include
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/gtk-2.0
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/gtk-doc/html/*
10139N/A%{_mandir}/man3/*.gz
10139N/A
10139N/A%changelog -n gtk2
10139N/A* Fri Mar 13 2009 - dave.lin@sun.com
10139N/A- Bump to 2.15.5
10139N/A* Wed Feb 18 2009 - dave.lin@sun.com
10139N/A- Bump to 2.15.4
17557N/A* Fri Feb 13 2009 - dave.lin@sun.com
17557N/A- Bump to 2.15.3
17543N/A* Thu Jan 08 2009 - christian.kelly@sun.com
17543N/A- Remove old reference to patch14.
17496N/A* Wed Jan 07 2009 - christian.kelly@sun.com
17496N/A- Bump to 2.15.0.
17379N/A- Remove gtk+-11-hidewindow.diff.
17379N/A* Tue Dec 09 2008 - chris.wang@sun.com
17379N/A- removed upstreamed patch 15 print-dbl-free
17379N/A* Mon Dec 08 2008 - dave.lin@sun.com
17271N/A- Bump to 2.14.5
17271N/A* Sat Sep 27 2008 patrick.ale@gmail.com
17234N/A- Correct download URL
17234N/A* Thu Sep 25 2008 chris.wang@sun.com
17234N/A- Add patch gtk+-15-print-dbl-free.diff to fix bugzilla 553241, the patch has
17201N/A been accpted by upstream
17201N/A* Wed 24 2008 ghee.teo@sun.com
17201N/A- Remove gtk+-15-gdk-x-error.diff, #bugzilla:521371 is obsolete.
17121N/A* Thu Sep 18 2008 - chris.wang@sun.com
17121N/A- Add patch 02-gdk-x-error to fix bug 6717703
17099N/A* Sat Sep 06 2008 - christian.kelly@sun.com
17099N/A- Bump to 2.14.1.
17099N/A* Tue Aug 19 2008 - dave.lin@sun.com
17097N/A- Bump to 2.13.7
17004N/A- Removed the upstreamed patches
17004N/A gtk+-16-sun-xinerama.diff
17004N/A gtk+-17-sun-xinerama-2.diff
16979N/A gtk+-18-void-func.diff
16979N/A* Thu Aug 14 2008 - chris.wang@sun.com
16979N/A- Add patch 19-hidewindow to fix bug 6725919, trunk code showed the window
16867N/A after reparent, this is not match with the API description. the slip unveiled
16867N/A a bug xtbin based FF plugin work no properly on Xsun. A new bug will log
16804N/A against this.
16804N/A* Wed Aug 13 2008 - damien.carbery@sun.com
16768N/A- Add patch 18-void-func to fix bugzilla 547555.
16768N/A* Tue Aug 12 2008 - erwann.chenede@sun.com
16740N/A- Bump to 2.13.6. Add patch 17-sun-xinerama-2 to make init_solaris_xinerama
16740N/A compile. Bugzilla 547456.
16686N/A* Tue Jul 22 2008 - christian.kelly@sun.com
16686N/A- Bump to 2.13.5.
16686N/A* Tue Jun 24 2008 - damien.carbery@sun.com
16686N/A- Add patch 17-gail-uninstalled to fix 536430. Previous version of patch
16686N/A pointed to wrong gail .la file and required -lgailutil to be added to
16487N/A LDFLAGS of multiple modules. These modules can now have that change removed.
16487N/A* Mon Jun 16 2008 - damien.carbery@sun.com
16487N/A- Bump to 2.13.3. Remove upstream patch, 17-gail-uninstalled.
16487N/A* Wed Jun 04 2008 - damien.carbery@sun.com
16425N/A- Bump to 2.13.2.
16425N/A* Sat May 31 2008 - damien.carbery@sun.com
16425N/A- Add patch, 17-gail-uninstalled, to correct the paths in the
16425N/A gail-uninstalled.pc.in file. Fixes bugzilla #536430.
16423N/A* Sat May 31 2008 - damien.carbery@sun.com
16423N/A- Add --without-libjasper to configure as libjasper is not on Solaris.
16420N/A* Tue Mar 25 2008 - ghee.teo@sun.com
16420N/A- Added gtk+-15-printing-cups-support.diff
16420N/A* Thu Mar 13 2008 - damien.carbery@sun.com
16420N/A- Add -I/usr/X11/include to CFLAGS after update of SUNWwinc.
16421N/A* Wed Mar 12 2008 - damien.carbery@sun.com
16367N/A- Bump to 2.12.9.
16367N/A* Tue Feb 26 2008 - damien.carbery@sun.com
16175N/A- Revert to 2.12.8 as it 2.12.x will be in GNOME 2.22.
16175N/A* Mon Feb 25 2008 - damien.carbery@sun.com
16134N/A- Bump to 2.13.0.
16134N/A* Wed Feb 13 2008 - damien.carbery@sun.com
15880N/A- Bump to 2.12.8.
15880N/A* Wed Feb 08 2008 - brian.cameron@sun.com
15838N/A- Remove patch gtk+-08-blank-popup-menu-fix.diff. The actual problem was
15838N/A fixed in separate bug 129463. This patch causes combo buttons that are
15626N/A defined to be appears-as-lists to crash, since they do not have menus.
15626N/A* Wed Jan 30 2008 - damien.carbery@sun.com
15613N/A- Bump to 2.12.7.
15613N/A* Tue Jan 29 2008 - damien.carbery@sun.com
15613N/A- Bump to 2.12.6.
15490N/A* Fri Jan 11 2008 - chris.wang@sun.com
15490N/A- Add gtk+-14-filechooser-enterkey.diff to fix bug 6630867 Nautilus : icon
15477N/A customization dialog box doesn't support Enter key by adding some dialog
15477N/A action with gtk_dialog_set_default_response to filechooser.
14545N/A* Wed Jan 09 2008 - damien.carbery@sun.com
14545N/A- Bump to 2.12.5.
14499N/A* Tue Jan 08 2008 - damien.carbery@sun.com
14499N/A- Bump to 2.12.4.
14499N/A* Wed Dec 05 2007 - damien.carbery@sun.com
14493N/A- Bump to 2.12.3.
14493N/A* Mon Dec 03 2007 - takao.fujiwara@sun.com
14390N/A- Added gtk+-13-g11n-xim-spotlocation.diff to replace the vte patch.
14390N/A* Tue Nov 27 2007 - damien.carbery@sun.com
14172N/A- Bump to 2.12.2.
14172N/A* Mon Oct 22 2007 - damien.carbery@sun.com
13910N/A- Bump to 2.12.1. Remove upstream patch, 12-g11n-filechooser-date.
13910N/A* Tue Oct 16 2007 - takao.fujiwara@sun.com
13910N/A- Add gtk+-12-g11n-filechooser-date.diff to fix correct encodings and cast.
13910N/A* Wed Sep 19 2007 - brian.cameron@sun.com
13910N/A- Fix URL so it can download.
13910N/A* Wed Jul 25 2007 - damien.carbery@sun.com
13863N/A- Add --enable-explicit-deps=yes to configure to ensure all libs mentioned in
13863N/A gdk-pixbuf-2.0.pc file (otherwise subsequent modules break).
13863N/A* Tue Jul 24 2007 - damien.carbery@sun.com
13863N/A- Bump to 2.11.6.
13863N/A* Wed Jul 18 2007 - takao.fujiwara@sun.com
13853N/A- Add l10n-configure.sh to remove "%Id". Fixes 6581452
13853N/A* Thr Jul 12 2007 - chris.wang@sun.com
13853N/A- Add patch gtk+-13-print-null.diff fix the bug gaim/pidgin dies on startup
13853N/A with SIGABRT
13853N/A* Tue Jul 03 2007 - damien.carbery@sun.com
13620N/A- Bump to 2.11.5.
13620N/A* Wed Jun 20 2007 - damien.carbery@sun.com
13469N/A- Bump to 2.11.4.
13469N/A* Mon Jun 18 2007 - damien.carbery@sun.com
13469N/A- Bump to 2.11.3.
13469N/A* Wed Jun 07 2007 - brian.cameron@sun.com
13412N/A- Bump to 2.11.2. Remove unneeded tooltip patch fixed upstream.
13412N/A* Wed Jun 06 2007 - brian.cameron@sun.com
13324N/A- Add patch gtk+-14=fixtooltip.diff to fix problem with tooltips crashing
13324N/A when the window they are associated with are destroyed before the
13298N/A tooltip timeout function is called.
13310N/A* Tue Jun 05 2007 - damien.carbery@sun.com
13310N/A- Bump to 2.11.1. Remove upstream patch, 14-fix-destdir.
13310N/A* Tue May 29 2007 - damien.carbery@sun.com
13298N/A- Add upstream patch, 14-fix-destdir, to fix build error where two files are
12644N/A installed to $RPM_BUILD_ROOT/$RPM_BUILD_ROOT.
12644N/A* Fri May 25 2007 - damien.carbery@sun.com
12601N/A- Bump to 2.11.0.
12601N/A* Thu May 03 2007 - damien.carbery@sun.com
12593N/A- Bump to 2.10.12.
12593N/A* Tue May 01 2007 - brian.cameron@sun.com
12465N/A- Remove patch to add gdk-x11-uninstalled-pc.diff and instead call
12465N/A "make gdk-x11-2.0-uninstalled.pc" before calling "make". According
12451N/A to bugzilla bug #304128, this is the right way to build this file.
12451N/A* Thu Apr 12 2007 - takao.fujiwara@sun.com
12371N/A- Add 'touch *.po' so that .mo files are compatible with Solaris gettext.
12371N/A Fixes 6544910
12346N/A* Thu Mar 15 2007 - laca@sun.com
12346N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
12346N/A* Wed Mar 15 2007 - dougs@truemail.co.th
12346N/A- Removed adding ccdir to PATH
12346N/A* Wed Mar 14 2007 - damien.carbery@sun.com
12300N/A- Bump to 2.10.11.
12346N/A* Tue Mar 13 2007 - damien.carbery@sun.com
12287N/A- Bump to 2.10.10.
12177N/A* Fri Feb 16 2007 - takao.fujiwara@sun.com
12177N/A- Removed '-c' option of msgfmt in po*/Makefile.in.in
12177N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
12177N/A- Add l10n tarball.
12346N/A* Mon Jan 22 2007 - damien.carbery@sun.com
12168N/A- Bump to 2.10.9.
12346N/A* Wed Jan 17 2007 - damien.carbery@sun.com
12158N/A- Bump to 2.10.8. Removed upstream patches, 15-load-gdm-modules.
12027N/A* Mon Jan 08 2007 - damien.carbery@sun.com
12027N/A- Bump to 2.10.7. Remove upstream patches, 15-hidden and 17-recent-files-crash.
12020N/A Renumber remainder.
12020N/A* Wed Dec 13 2006 - padraig.obriain@sun.com
11989N/A- remove patch 08-nofocus-empty.diff as it is not needed.
11989N/A* Wed Dec 06 2006 - ghee.teo@sun.com
11426N/A- Include bugzilla id for 19-printing-papi-backend.diff which is now cleaned up.
11426N/A* Thu Nov 23 2006 - padraig.obriain@sun.com
11406N/A- added patch 20-gedit-menu-shortcuts.diff
11406N/A* Thu Nov 16 2006 - ghee.teo@sun.com
11277N/A- added patch 19-printing-papi-backend.diff
11277N/A* Fri Nov 3 2006 - laca@sun.com
10960N/A- use %gtk_doc_option in configure so that it can be disabled using
10960N/A --without-gtk-doc
10960N/A- add --datadir=%{_datadir} to the configure options, fixes 6443777
10951N/A* Thu Oct 26 2006 padraig.obriain@sun.com
10951N/A- Add patch, 18-recent-files-crash, for bugster 6485464, bugzilla 365031.
10943N/A* Mon Oct 18 2006 - brian.cameron@sun.com
10943N/A- Call autoconf after autoheader/automake.
10928N/A* Fri Oct 13 2006 - damien.carbery@sun.com
10928N/A- Delete .a and .la files.
10928N/A* Wed Oct 04 2006 - damien.carbery@sun.com
10896N/A- Bump to 2.10.6.
10896N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10828N/A- Add patch, 17-stock_icons_typo, to fix typo in Makefile. Already fixed
10828N/A upstream.
10810N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10810N/A- Bump to 2.10.5. Remove upstream patch, 17-hang-on-mutex.
10752N/A* Wed Sep 27 2006 - padraig.obriain@sun.com
10752N/A- Add patch hang-on-mutex as part fix for bug 6475663
10737N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10737N/A* Tue Sep 26 2006 - damien.carbery@sun.com
10737N/A- Bump to 2.10.4.
10737N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10732N/A- Bump to 2.10.3.
10732N/A* Fri Aug 18 2006 - damien.carbery@sun.com
10701N/A- Bump to 2.10.2.
10701N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10701N/A- Bump to 2.10.1.
10687N/A* Thu Jul 20 2006 - damien.carbery@sun.com
10687N/A- Bump to 2.10.0.
10573N/A* Mon Jul 10 2006 - brian.cameron@sun.com
10573N/A- Bump to 2.8.20.
10553N/A* Tue Jul 04 2006 - ghee.teo@sun.com
10553N/A- added gtk+-15-truested-extensions.diff
10553N/A* Tue Jun 27 2006 - yuriy.kuznetsov@sun.com
10553N/A- remove line with "cp po/Makefile.in.in po-properties"
10463N/A to fix CR#6439573
10463N/A* Wed Apr 26 2006 - damien.carbery@sun.com
10463N/A- Bump to 2.8.17.
10318N/A* Thu Mar 16 2006 - damien.carbery@sun.com
10318N/A- Bump to 2.8.16.
10307N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10307N/A- Bump to 2.8.15.
10295N/A* Thu Mar 9 2006 - damien.carbery@sun.com
10295N/A- Bump to 2.8.14.
10280N/A* Sun Feb 26 2006 - damien.carbery@sun.com
10280N/A- Bump to 2.8.13.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.8.12.
10139N/A* Sun Jan 29 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.8.11
10139N/A* Tue Dec 20 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.8.9.
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.8.8.
10139N/A- Remove upstream patches 15-gtkcalendar and 16-glib-mkenums.
10139N/A* Mon Nov 28 2005 - laca@sun.com
10139N/A- prepare for building from CVS snapshots:
10139N/A- use a macro for Version
10139N/A- fix autotool order, add some more
10139N/A- cp mkinstalldirs so that we don't need to add even more autotool foo
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.8.6
10139N/A- Add patch, gtk+-15-gtkcalendar, to declare a missing var. #318578.
10139N/A- Add patch, gtk+-16-glib-mkenums, to use macro instead of hardcoding. #318582.
10139N/A* Tue Sep 13 2005 - brian.cameron@sun.com
10139N/A- Bump to 2.8.3 fixing a core dumping problem for the panel and
10139N/A nautilus on Solaris x86.
10139N/A* Mon Aug 15 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.8.0
10139N/A* Fri May 06 2005 - brian.cameron@sun.com
10139N/A- Added a patch and then backed it out.
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.6.7
10139N/A* Wed May 04 2005 - srirama.sharma@wipro.com
10139N/A- Added gtk+-17-treeview-keynav.diff to modify the keynav
10139N/A in treeview. Fixes bug #6216594.
10139N/A* Mon Mar 21 2005 - vinay.mandyakoppal@wipro.com
10139N/A- Edited patch gtk+-02-fileseldlg-navbuttons.diff to make
10139N/A save attachment Desktop button work. Fixes #6240188.
10139N/A* Tue Feb 22 2005 - vijaykumar.patwari@wipro.com
10139N/A- Added patch gtk+-16-blank-popup-menu-fix.diff to
10139N/A fix blank popup menu area.
10139N/A* Wed Dec 15 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.14
10139N/A* Thu Nov 25 2004 - yong.sun@sun.com
10139N/A- Patch 19 for bugster #6199166: Cinnabar [linux] Styles are not localized
10139N/A in Gtk/Gnome font selector dialog
10139N/A* Sat Nov 06 2004 - srirama.sharma@wipro.com
10139N/A- Patch for the Bug #6185180 is rolled to the original
10139N/A gtk+-06-file-chooser.diff.
10139N/A* Thu Nov 04 2004 - srirama.sharma@wipro.com
10139N/A- Rolled in the patch for Bug #6178360 to the original
10139N/A gtk+-06-file-chooser.diff
10139N/A* Fri Oct 29 2004 - padraig.obriain@sun.com
10139N/A- Add patch gtk+-17-iter-inside-word.diff for bugzilla 153628.
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Thu Sep 30 2004 - vijaykumar.patwari@wipro.com
10139N/A- Fix image code security issue.
10139N/A* Sat Sep 18 2004 - laca@sun.com
10139N/A- Add patch 15 for ABI compatibility with gdk in the Solaris GNOME 2.0 release
10139N/A* Wed Sep 15 2004 - muktha.narayan@wipro.com
10139N/A- Added patch gtk+-14-solaris-xinerama-support.diff to
10139N/A enable xinerama flags on Solaris.
10139N/A* Sat Sep 11 2004 - laca@sun.com
10139N/A- Move Solaris specific LDFLAGS to the Solaris spec file
10139N/A* Fri Sep 10 2004 - damien.carbery@sun.com
10139N/A- Set LDFLAGS so Xrandr and Xrender can be found.
10139N/A* Thu Aug 26 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.9
10139N/A* Tue Aug 24 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.7
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- added --enable-gtk-doc.
10139N/A* Tue Aug 17 2004 - balamurali.viswanathan@wipro.com
10139N/A- Added Sun branding patch gtk+-15-sun-pgdn-pgup-keybinding.diff
10139N/A Sun keyboard bindings for Keypad keys PageUp, PageDown, Home and End.
10139N/A The patch has been rejected by the GTK maintainers as a WONTFIX as they feel
10139N/A its a bug in the Sun Xserver. Corresponding sun-patch is 085-74223-w.diff
10139N/A* Thu Aug 12 2004 - narayana.pattipati@wipro.com
10139N/A- Added Sun branding patch gtk+-14-sun-copy-paste-keybindings.diff
10139N/A to provide copy, paste, cut key bindings in Sun Keyboards. The patch is
10139N/A ported from GNOME 2.0 (sun-patches/gtk+/190-00000-s.diff). It was rejected
10139N/A by community. So, it will be a SUN specific patch.
10139N/A* Thu Jul 22 2004 - padraig.obriain@sun.com
10139N/A- Added patches gtk+-10-combo-a11y.diff for bugzilla #132847
10139N/A gtk+-11-nofocus-empty.diff for bugzilla #126295
10139N/A gtk+-12-file-chooser-a11y-names.diff for bugzilla #144405
10139N/A gtk+-13-single-row-treeview.diff for bugzilla #131226
10139N/A* Wed Jul 14 2004 - Yong.Sun@Sun.COM
10139N/A- Added a new -09 patch to fix bugtraq #5048804
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtk2-l10n-po-1.2.tar.bz2
10139N/A* Thu Jul 08 2004 - niall.power@sun.com
10139N/A- run libtoolize to fix some weirdness
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- Ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Mon May 17 2004 - hidetoshi.tajima@sun.com
10139N/A- Added a new -07 patch to fix bugtraq #5035382.
10139N/A- Moved the previous revision 07 patch to fix bug 141190 to revision 08
10139N/A as the last patch, since the same fix is already in community's cvs server,
10139N/A hence the patch should be removed eventually when the fix comes from a
10139N/A new version of gtk+ tarball, including gtkimcontextxim.c revision 1.47 or
10139N/A newer.
10139N/A* Fri May 14 2004 - danek.duvall@sun.com
10139N/A- Applied patch to fix bug 141190, bringing gtkimcontextxim.c
10139N/A up to revision 1.47. Revision 1.46, included in 2.4.1, broke
10139N/A compilation on Solaris.
10139N/A* Fri May 14 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.1. Remove render icon patch, since upstream.
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtk2-l10n-po-1.1.tar.bz2
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtk2-l10n-po-1.0.tar.bz2
10139N/A* Thu Mar 25 2004 - glynn.foster@sun.com
10139N/A- Use JDS autotools.
10139N/A* Wed Mar 24 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.0 and remove upstream file chooser patch.
10139N/A* Mon Mar 22 2004 - <brian.cameron@sun.com>
10139N/A- added patch 7 to add mediaLib support. Also added autoconf/
10139N/A automake since this patch changes configure.in/Makefile.am
10139N/A files.
10139N/A* Thu Mar 18 2004 - hidetoshi.tajima@sun.com
10139N/A- don't install unsupported gtk-2.0/*/immodules/im-*.so
10139N/A* Tue Mar 16 2004 - <brian.cameron@sun.com>
10139N/A- Add patch 6 to fix -1 enumeration issue on Solaris. This
10139N/A fixed many programs from crashing (panel, gdm, nautilus).
10139N/A* Mon Mar 15 2004 - <laca@sun.com>
10139N/A- Add patch to fix build on Solaris. In cvs.gnome.org already.
10139N/A* Thu Mar 11 2004 - <glynn.foster@sun.com>
10139N/A- Remove patches 4 and 5 - they're upstream.
10139N/A* Wed Mar 10 2004 - <niall.power@sun.com>
10139N/A- Bump to 2.3.6, update dependenciy versions.
10139N/A* Tue Feb 10 2004 - <matt.keenan@sun.com>
10139N/A- Bump to 2.3.2, and l10n to 0.7, and port patch 05
10139N/A* Fri Jan 09 2004 - <laca@sun.com>
10139N/A- add a missing .pc file
10139N/A- clean up for Solaris builds
10139N/A* Wed Jan 07 2004 - <glynn.foster@sun.com>
10139N/A- Remove the tab cycling patch for notebooks, since it's already
10139N/A upstream.
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Bump to 2.3.1
10139N/A* Mon Aug 25 2003 - <ghee.teo@sun.com>
10139N/A- Fix input method hanged in zh_CN.gb18030 locale.
10139N/A Taken patch from community for bugzilla 115077 and 105909.
10139N/A Fixed 4894673, 4908025.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Jul 25 2003 - niall.power@sun.com
10139N/A- /etc/gtk-2.0 needs to exist before postinstall script is run.
10139N/A run ./mkinstalldirs to ensure this.
10139N/A* Fri Jul 18 2003 - <michael.twomey@sun.com>
10139N/A- Fixing %postun action so that config files are only removed on final
10139N/A uninstall of gtk2.
10139N/A* Fri Jul 11 2003 - <niall.power@sun.com>
10139N/A- add file selection dialog shortcuts patch
10139N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Mon Jul 07 2003 - <markmc@sun.com>
10139N/A- add new patch to make message dialogs have window icons.
10139N/A See bug #116896.
10139N/A* Mon Jun 30 2003 - <glynn.foster@sun.com>
10139N/A- Add new patch to make sure that rendering on pixbufs is okay. This
10139N/A fixes an issue with gnome-theme-manager
10139N/A* Mon Jun 30 2003 - <glynn.foster@sun.com>
10139N/A- Bump version number for new tarballs, and reset release number.
10139N/A* Wed Jun 25 2003 - <markmc@sun.com>
10139N/A- add gtk-unset-hack.sh and gtk-unset-hack.csh to workaround
10139N/A SuSE's gtk-1.2 rpms installing crackrock scripts into
10139N/A /etc/profile.d
10139N/A* Thu May 29 2003 - <Laszlo.Kovacs@sun.com>
10139N/A- added patch gtk+-01-tab-change-with-ctrl-alt-pageup-pagedn.diff
10139N/A* Tue May 13 2003 - Stephen.Browne@sun.com
10139N/A- initial release
10139N/A