gtk2.spec revision 10573
10139N/A#
10139N/A# spec file for package gtk2
10139N/A#
12158N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: erwannc
10139N/A#
10139N/A%include l10n.inc
10139N/AName: gtk2
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
16367N/AVersion: 2.10.12
10752N/ARelease: 2
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: GTK+ - GIMP Toolkit Library for creation of graphical user interfaces
16168N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.10/gtk+-%{version}.tar.bz2
10139N/ASource1: gtk.unset-hack.sh
10139N/ASource2: gtk.unset-hack.csh
10318N/ASource3: %{name}-po-sun-%{po_sun_version}.tar.bz2
10943N/A#owner:erwannc date:2000-00-00 type:feature
10139N/APatch1: gtk+-01-window-icons-for-message-dialog.diff
10139N/A#owner:niall date:2003-07-11 type:feature
10139N/APatch2: gtk+-02-fileseldlg-navbuttons.diff
10139N/A#owner:yippi date:2005-08-11 type:feature bugzilla:344813
10139N/APatch3: gtk+-03-mediaLib.diff
13922N/A#owner:gman date:2004-04-30 type:feature
10139N/APatch4: gtk+-04-file-chooser.diff
13922N/A#owner:erwannc date:2004-05-17 bugster:5035382 type:bug
10139N/APatch5: gtk+-05-use-xim-for-all-locales.diff
13922N/A#owner:erwannc date:2004-08-12 type:feature
10139N/APatch6: gtk+-06-sun-copy-paste-keybindings.diff
13922N/A#owner:erwannc date:2004-08-12 bugzilla:74223 type:feature
10139N/APatch7: gtk+-07-sun-pgdn-pgup-keybinding.diff
13922N/A#owner:laca date:2004-09-18 type:feature
10139N/APatch8: gtk+-08-solaris-2.0.0-compat.diff
13922N/A#owner:erwannc date:2004-11-25 bugzilla:153829 bugster:5087948 type:bug
10928N/APatch9: gtk+-09-blank-popup-menu-fix.diff
13922N/A#Patch10: gtk+-10-treeview-keynav.diff
11883N/A#owner:erwannc date:2006-05-01 type:feature
13922N/APatch11: gtk+-11-trusted-extensions.diff
15613N/A# date:2006-09-17 bugster:6494571 bugzilla:382676 owner:gheet type:bug
15613N/APatch12: gtk+-12-printing-papi-backend.diff
12177N/A# date:2006-11-22 bugster:6438587 bugzilla:335796 owner:padraig type:bug
13922N/APatch13: gtk+-13-gedit-menu-shortcuts.diff
12644N/A
13923N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
16168N/ADocdir: %{_defaultdocdir}/doc
16168N/AAutoreqprov: on
16387N/APrereq: /sbin/ldconfig
16387N/A
16420N/A%define cairo_version 0.9.2
16420N/A%define atk_version 1.7.0
16168N/A%define pango_version 1.9.0
10139N/A%define glib2_version 2.7.1
10139N/A%define libpng_version 1.2.5
10139N/A%define libjpeg_version 6.2.0
10139N/A
10139N/ABuildRequires: cairo-devel >= %{cairo_version}
10139N/ABuildRequires: atk-devel >= %{atk_version}
10139N/ABuildRequires: pango-devel >= %{pango_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libpng-devel >= %{libpng_version}
10139N/ABuildRequires: libjpeg >= %{libjpeg_version}
10139N/ARequires: cairo >= %{cairo_version}
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: atk >= %{atk_version}
13922N/ARequires: pango >= %{pango_version}
10139N/ARequires: libpng >= %{libpng_version}
10139N/ARequires: libjpeg >= %{libjpeg_version}
10139N/A
10139N/A%description
10139N/AThis fast and versatile library is used all over the world for all
10139N/AGNOME applications, the GIMP and several others. Originally it was
10139N/Awritten for the GIMP and hence has the name Gimp ToolKit. Many people
10139N/Alike it because it is small, efficient and very configurable.
10139N/A
10139N/A%package devel
10139N/ASummary: Library for creation of graphical user interfaces
10139N/AGroup: Development/Libraries/X11
10139N/AAutoreqprov: on
10139N/ARequires: %{name} = %{version}
10139N/ARequires: cairo-devel >= %{cairo_version}
10139N/ARequires: atk-devel >= %{atk_version}
10139N/ARequires: pango-devel >= %{pango_version}
10139N/A
10139N/A%description devel
10139N/AThis fast and versatile library is used all over the world for all
10139N/AGNOME applications, the GIMP and several others. Originally it was
10139N/Awritten for the GIMP and hence has the name Gimp ToolKit. Many people
10139N/Alike it because it is small, efficient and very configurable.
10139N/A
10139N/A%prep
10139N/A%setup -q -n gtk+-%{version}
10139N/A
10139N/A# Fixes build error. Solaris msgfmt does not have '-c'.
10139N/Afor f in po/Makefile.in.in po-properties/Makefile.in.in ; do
10139N/A sed -e 's/$(GMSGFMT) -c/$(GMSGFMT)/g' $f > $f$$
10139N/A mv $f$$ $f
10139N/A d=`dirname $f`
10139N/A touch $d/*.po
10139N/Adone
10139N/A
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE3 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10463N/A%patch1 -p1
10463N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10943N/A
12754N/A%ifos solaris
10943N/A%patch6 -p1
10318N/A%endif
10139N/A
10139N/A%patch7 -p1
10139N/A%patch8 -p1
10139N/A
13922N/A%patch9 -p1
10139N/A#%patch10 -p1
10139N/A%patch11 -p1
13922N/A%patch12 -p1
10139N/A%patch13 -p1
10139N/A
13922N/A%build
10752N/A%ifos linux
10553N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
11239N/Afi
10752N/A%else
10553N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
11883N/A%endif
12020N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
16168N/A CPUS=1
16387N/Afi
16420N/A
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Agtkdocize
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --datadir=%{_datadir} \
10139N/A --with-native-locale=yes \
10139N/A --with-xinput=xfree \
10139N/A --mandir=%{_mandir} \
10139N/A --infodir=%{_infodir} \
10139N/A --enable-shm \
10139N/A --enable-xim \
10139N/A --enable-fbmanager \
12601N/A --with-gdktarget=x11 \
10318N/A --sysconfdir=%{_sysconfdir} \
10318N/A %{gtk_doc_option}
10318N/A
10318N/A# Build needed uninstalled.pc file
10318N/Amake gdk-x11-2.0-uninstalled.pc
10318N/A
10318N/Amake -j $CPUS
10318N/A
10318N/A%install
10318N/Amake DESTDIR=$RPM_BUILD_ROOT install
10318N/A./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0
10318N/Amkdir -p $RPM_BUILD_ROOT/etc/profile.d
10318N/Acp %SOURCE1 $RPM_BUILD_ROOT/etc/profile.d/
10139N/Acp %SOURCE2 $RPM_BUILD_ROOT/etc/profile.d
10960N/A#Copy zh_HK from zh_TW
13298N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10553N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/immodules/*.la
10553N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/loaders/*.la
10553N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/printbackends/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/gtk.immodules
10139N/A%{_bindir}/gdk-pixbuf-query-loaders > %{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
10139N/A
10139N/A%postun
10139N/A#If this is the last version of the package remove the config files
10139N/Aif [ $1 = 0 ]
10139N/Athen
10139N/A rm %{_sysconfdir}/gtk-2.0/gtk.immodules
13310N/A rm %{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
10139N/Afi
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%{_bindir}/*query*
10139N/A%{_bindir}/gtk-update-icon-cache
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_libdir}/gtk-2.0/*/immodules/*.so
10139N/A%{_libdir}/gtk-2.0/*/loaders/*.so
10139N/A%{_libdir}/gtk-2.0/*/engines/*.so
10139N/A%{_datadir}/themes/*/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_sysconfdir}/profile.d/gtk.unset-hack.sh
10139N/A%{_sysconfdir}/profile.d/gtk.unset-hack.csh
10139N/A%dir %{_sysconfdir}/gtk-2.0
10139N/A%{_mandir}/man1/*.gz
10139N/A
10139N/A%files devel
10139N/A%{_bindir}/*-demo
10139N/A%{_bindir}/*-csource
10139N/A%{_includedir}/gtk-2.0
10139N/A%{_libdir}/lib*.so
10139N/A%{_libdir}/gtk-2.0/include
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/gtk-2.0
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/gtk-doc/html/*
10139N/A%{_mandir}/man3/*.gz
10139N/A
10139N/A%changelog -n gtk2
10139N/A* Thu May 03 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.10.12.
10139N/A* Tue May 01 2007 - brian.cameron@sun.com
10139N/A- Remove patch to add gdk-x11-uninstalled-pc.diff and instead call
10139N/A "make gdk-x11-2.0-uninstalled.pc" before calling "make". According
10139N/A to bugzilla bug #304128, this is the right way to build this file.
10139N/A* Thu Apr 12 2007 - takao.fujiwara@sun.com
10139N/A- Add 'touch *.po' so that .mo files are compatible with Solaris gettext.
10139N/A Fixes 6544910
10139N/A* Thu Mar 15 2007 - laca@sun.com
10139N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10139N/A- Removed adding ccdir to PATH
10139N/A* Wed Mar 14 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.10.11.
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
16420N/A- Bump to 2.10.10.
16420N/A* Fri Feb 16 2007 - takao.fujiwara@sun.com
16420N/A- Removed '-c' option of msgfmt in po*/Makefile.in.in
16420N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
16421N/A- Add l10n tarball.
16367N/A* Mon Jan 22 2007 - damien.carbery@sun.com
16367N/A- Bump to 2.10.9.
16175N/A* Wed Jan 17 2007 - damien.carbery@sun.com
16175N/A- Bump to 2.10.8. Removed upstream patches, 15-load-gdm-modules.
16134N/A* Mon Jan 08 2007 - damien.carbery@sun.com
16134N/A- Bump to 2.10.7. Remove upstream patches, 15-hidden and 17-recent-files-crash.
15880N/A Renumber remainder.
15880N/A* Wed Dec 13 2006 - padraig.obriain@sun.com
15838N/A- remove patch 08-nofocus-empty.diff as it is not needed.
15838N/A* Wed Dec 06 2006 - ghee.teo@sun.com
15626N/A- Include bugzilla id for 19-printing-papi-backend.diff which is now cleaned up.
15626N/A* Thu Nov 23 2006 - padraig.obriain@sun.com
15613N/A- added patch 20-gedit-menu-shortcuts.diff
15613N/A* Thu Nov 16 2006 - ghee.teo@sun.com
15613N/A- added patch 19-printing-papi-backend.diff
15490N/A* Fri Nov 3 2006 - laca@sun.com
15490N/A- use %gtk_doc_option in configure so that it can be disabled using
15477N/A --without-gtk-doc
15477N/A- add --datadir=%{_datadir} to the configure options, fixes 6443777
14545N/A* Thu Oct 26 2006 padraig.obriain@sun.com
14545N/A- Add patch, 18-recent-files-crash, for bugster 6485464, bugzilla 365031.
14499N/A* Mon Oct 18 2006 - brian.cameron@sun.com
14499N/A- Call autoconf after autoheader/automake.
14499N/A* Fri Oct 13 2006 - damien.carbery@sun.com
14493N/A- Delete .a and .la files.
14493N/A* Wed Oct 04 2006 - damien.carbery@sun.com
14390N/A- Bump to 2.10.6.
14390N/A* Tue Oct 03 2006 - damien.carbery@sun.com
14172N/A- Add patch, 17-stock_icons_typo, to fix typo in Makefile. Already fixed
14172N/A upstream.
13910N/A* Mon Oct 02 2006 - damien.carbery@sun.com
13910N/A- Bump to 2.10.5. Remove upstream patch, 17-hang-on-mutex.
13910N/A* Wed Sep 27 2006 - padraig.obriain@sun.com
13910N/A- Add patch hang-on-mutex as part fix for bug 6475663
13910N/A* Tue Sep 05 2006 - damien.carbery@sun.com
13910N/A* Tue Sep 26 2006 - damien.carbery@sun.com
13863N/A- Bump to 2.10.4.
13863N/A* Tue Sep 05 2006 - damien.carbery@sun.com
13863N/A- Bump to 2.10.3.
13863N/A* Fri Aug 18 2006 - damien.carbery@sun.com
13863N/A- Bump to 2.10.2.
13853N/A* Mon Jul 24 2006 - damien.carbery@sun.com
13853N/A- Bump to 2.10.1.
13853N/A* Thu Jul 20 2006 - damien.carbery@sun.com
13853N/A- Bump to 2.10.0.
13853N/A* Mon Jul 10 2006 - brian.cameron@sun.com
13620N/A- Bump to 2.8.20.
13620N/A* Tue Jul 04 2006 - ghee.teo@sun.com
13469N/A- added gtk+-15-truested-extensions.diff
13469N/A* Tue Jun 27 2006 - yuriy.kuznetsov@sun.com
13469N/A- remove line with "cp po/Makefile.in.in po-properties"
13469N/A to fix CR#6439573
13412N/A* Wed Apr 26 2006 - damien.carbery@sun.com
13412N/A- Bump to 2.8.17.
13324N/A* Thu Mar 16 2006 - damien.carbery@sun.com
13324N/A- Bump to 2.8.16.
13298N/A* Mon Mar 13 2006 - damien.carbery@sun.com
13310N/A- Bump to 2.8.15.
13310N/A* Thu Mar 9 2006 - damien.carbery@sun.com
13310N/A- Bump to 2.8.14.
13298N/A* Sun Feb 26 2006 - damien.carbery@sun.com
12644N/A- Bump to 2.8.13.
12644N/A* Mon Feb 13 2006 - damien.carbery@sun.com
12601N/A- Bump to 2.8.12.
12601N/A* Sun Jan 29 2006 - damien.carbery@sun.com
12593N/A- Bump to 2.8.11
12593N/A* Tue Dec 20 2005 - damien.carbery@sun.com
12465N/A- Bump to 2.8.9.
12465N/A* Tue Nov 29 2005 - damien.carbery@sun.com
12451N/A- Bump to 2.8.8.
12451N/A- Remove upstream patches 15-gtkcalendar and 16-glib-mkenums.
12371N/A* Mon Nov 28 2005 - laca@sun.com
12371N/A- prepare for building from CVS snapshots:
12346N/A- use a macro for Version
12346N/A- fix autotool order, add some more
12346N/A- cp mkinstalldirs so that we don't need to add even more autotool foo
12346N/A* Tue Oct 11 2005 - damien.carbery@sun.com
12346N/A- Bump to 2.8.6
12300N/A- Add patch, gtk+-15-gtkcalendar, to declare a missing var. #318578.
12346N/A- Add patch, gtk+-16-glib-mkenums, to use macro instead of hardcoding. #318582.
12287N/A* Tue Sep 13 2005 - brian.cameron@sun.com
12177N/A- Bump to 2.8.3 fixing a core dumping problem for the panel and
12177N/A nautilus on Solaris x86.
12177N/A* Mon Aug 15 2005 - glynn.foster@sun.com
12177N/A- Bump to 2.8.0
12346N/A* Fri May 06 2005 - brian.cameron@sun.com
12168N/A- Added a patch and then backed it out.
12346N/A* Fri May 06 2005 - glynn.foster@sun.com
12158N/A- Bump to 2.6.7
12027N/A* Wed May 04 2005 - srirama.sharma@wipro.com
12027N/A- Added gtk+-17-treeview-keynav.diff to modify the keynav
12020N/A in treeview. Fixes bug #6216594.
12020N/A* Mon Mar 21 2005 - vinay.mandyakoppal@wipro.com
11989N/A- Edited patch gtk+-02-fileseldlg-navbuttons.diff to make
11989N/A save attachment Desktop button work. Fixes #6240188.
11426N/A* Tue Feb 22 2005 - vijaykumar.patwari@wipro.com
11426N/A- Added patch gtk+-16-blank-popup-menu-fix.diff to
11406N/A fix blank popup menu area.
11406N/A* Wed Dec 15 2004 - glynn.foster@sun.com
11277N/A- Bump to 2.4.14
11277N/A* Thu Nov 25 2004 - yong.sun@sun.com
10960N/A- Patch 19 for bugster #6199166: Cinnabar [linux] Styles are not localized
10960N/A in Gtk/Gnome font selector dialog
10960N/A* Sat Nov 06 2004 - srirama.sharma@wipro.com
10951N/A- Patch for the Bug #6185180 is rolled to the original
10951N/A gtk+-06-file-chooser.diff.
10943N/A* Thu Nov 04 2004 - srirama.sharma@wipro.com
10943N/A- Rolled in the patch for Bug #6178360 to the original
10928N/A gtk+-06-file-chooser.diff
10928N/A* Fri Oct 29 2004 - padraig.obriain@sun.com
10928N/A- Add patch gtk+-17-iter-inside-word.diff for bugzilla 153628.
10896N/A* Fri Oct 29 2004 - laca@sun.com
10896N/A- use $CC64 for the 64-bit build if defined
10828N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10828N/A- Create 64bit libraries for Solaris
10810N/A* Thu Sep 30 2004 - vijaykumar.patwari@wipro.com
10810N/A- Fix image code security issue.
10752N/A* Sat Sep 18 2004 - laca@sun.com
10752N/A- Add patch 15 for ABI compatibility with gdk in the Solaris GNOME 2.0 release
10737N/A* Wed Sep 15 2004 - muktha.narayan@wipro.com
10737N/A- Added patch gtk+-14-solaris-xinerama-support.diff to
10737N/A enable xinerama flags on Solaris.
10737N/A* Sat Sep 11 2004 - laca@sun.com
10732N/A- Move Solaris specific LDFLAGS to the Solaris spec file
10732N/A* Fri Sep 10 2004 - damien.carbery@sun.com
10701N/A- Set LDFLAGS so Xrandr and Xrender can be found.
10701N/A* Thu Aug 26 2004 - glynn.foster@sun.com
10701N/A- Bump to 2.4.9
10687N/A* Tue Aug 24 2004 - glynn.foster@sun.com
10687N/A- Bump to 2.4.7
10573N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10573N/A- added --enable-gtk-doc.
10553N/A* Tue Aug 17 2004 - balamurali.viswanathan@wipro.com
10553N/A- Added Sun branding patch gtk+-15-sun-pgdn-pgup-keybinding.diff
10553N/A Sun keyboard bindings for Keypad keys PageUp, PageDown, Home and End.
10553N/A The patch has been rejected by the GTK maintainers as a WONTFIX as they feel
10463N/A its a bug in the Sun Xserver. Corresponding sun-patch is 085-74223-w.diff
10463N/A* Thu Aug 12 2004 - narayana.pattipati@wipro.com
10463N/A- Added Sun branding patch gtk+-14-sun-copy-paste-keybindings.diff
10318N/A to provide copy, paste, cut key bindings in Sun Keyboards. The patch is
10318N/A ported from GNOME 2.0 (sun-patches/gtk+/190-00000-s.diff). It was rejected
10307N/A by community. So, it will be a SUN specific patch.
10307N/A* Thu Jul 22 2004 - padraig.obriain@sun.com
10295N/A- Added patches gtk+-10-combo-a11y.diff for bugzilla #132847
10295N/A gtk+-11-nofocus-empty.diff for bugzilla #126295
10280N/A gtk+-12-file-chooser-a11y-names.diff for bugzilla #144405
10280N/A gtk+-13-single-row-treeview.diff for bugzilla #131226
10139N/A* Wed Jul 14 2004 - Yong.Sun@Sun.COM
10139N/A- Added a new -09 patch to fix bugtraq #5048804
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtk2-l10n-po-1.2.tar.bz2
10139N/A* Thu Jul 08 2004 - niall.power@sun.com
10139N/A- run libtoolize to fix some weirdness
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- Ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Mon May 17 2004 - hidetoshi.tajima@sun.com
10139N/A- Added a new -07 patch to fix bugtraq #5035382.
10139N/A- Moved the previous revision 07 patch to fix bug 141190 to revision 08
10139N/A as the last patch, since the same fix is already in community's cvs server,
10139N/A hence the patch should be removed eventually when the fix comes from a
10139N/A new version of gtk+ tarball, including gtkimcontextxim.c revision 1.47 or
10139N/A newer.
10139N/A* Fri May 14 2004 - danek.duvall@sun.com
10139N/A- Applied patch to fix bug 141190, bringing gtkimcontextxim.c
10139N/A up to revision 1.47. Revision 1.46, included in 2.4.1, broke
10139N/A compilation on Solaris.
10139N/A* Fri May 14 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.1. Remove render icon patch, since upstream.
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtk2-l10n-po-1.1.tar.bz2
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gtk2-l10n-po-1.0.tar.bz2
10139N/A* Thu Mar 25 2004 - glynn.foster@sun.com
10139N/A- Use JDS autotools.
10139N/A* Wed Mar 24 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.0 and remove upstream file chooser patch.
10139N/A* Mon Mar 22 2004 - <brian.cameron@sun.com>
10139N/A- added patch 7 to add mediaLib support. Also added autoconf/
10139N/A automake since this patch changes configure.in/Makefile.am
10139N/A files.
10139N/A* Thu Mar 18 2004 - hidetoshi.tajima@sun.com
10139N/A- don't install unsupported gtk-2.0/*/immodules/im-*.so
10139N/A* Tue Mar 16 2004 - <brian.cameron@sun.com>
10139N/A- Add patch 6 to fix -1 enumeration issue on Solaris. This
10139N/A fixed many programs from crashing (panel, gdm, nautilus).
10139N/A* Mon Mar 15 2004 - <laca@sun.com>
10139N/A- Add patch to fix build on Solaris. In cvs.gnome.org already.
10139N/A* Thu Mar 11 2004 - <glynn.foster@sun.com>
10139N/A- Remove patches 4 and 5 - they're upstream.
10139N/A* Wed Mar 10 2004 - <niall.power@sun.com>
10139N/A- Bump to 2.3.6, update dependenciy versions.
10139N/A* Tue Feb 10 2004 - <matt.keenan@sun.com>
10139N/A- Bump to 2.3.2, and l10n to 0.7, and port patch 05
10139N/A* Fri Jan 09 2004 - <laca@sun.com>
10139N/A- add a missing .pc file
10139N/A- clean up for Solaris builds
10139N/A* Wed Jan 07 2004 - <glynn.foster@sun.com>
10139N/A- Remove the tab cycling patch for notebooks, since it's already
10139N/A upstream.
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Bump to 2.3.1
10139N/A* Mon Aug 25 2003 - <ghee.teo@sun.com>
10139N/A- Fix input method hanged in zh_CN.gb18030 locale.
10139N/A Taken patch from community for bugzilla 115077 and 105909.
10139N/A Fixed 4894673, 4908025.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Jul 25 2003 - niall.power@sun.com
10139N/A- /etc/gtk-2.0 needs to exist before postinstall script is run.
10139N/A run ./mkinstalldirs to ensure this.
10139N/A* Fri Jul 18 2003 - <michael.twomey@sun.com>
10139N/A- Fixing %postun action so that config files are only removed on final
10139N/A uninstall of gtk2.
10139N/A* Fri Jul 11 2003 - <niall.power@sun.com>
10139N/A- add file selection dialog shortcuts patch
10139N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Mon Jul 07 2003 - <markmc@sun.com>
10139N/A- add new patch to make message dialogs have window icons.
10139N/A See bug #116896.
10139N/A* Mon Jun 30 2003 - <glynn.foster@sun.com>
10139N/A- Add new patch to make sure that rendering on pixbufs is okay. This
10139N/A fixes an issue with gnome-theme-manager
10139N/A* Mon Jun 30 2003 - <glynn.foster@sun.com>
10139N/A- Bump version number for new tarballs, and reset release number.
10139N/A* Wed Jun 25 2003 - <markmc@sun.com>
10139N/A- add gtk-unset-hack.sh and gtk-unset-hack.csh to workaround
10139N/A SuSE's gtk-1.2 rpms installing crackrock scripts into
10139N/A /etc/profile.d
10139N/A* Thu May 29 2003 - <Laszlo.Kovacs@sun.com>
10139N/A- added patch gtk+-01-tab-change-with-ctrl-alt-pageup-pagedn.diff
10139N/A* Tue May 13 2003 - Stephen.Browne@sun.com
10139N/A- initial release
10139N/A