gtk-vnc.spec revision 18540
10139N/A#
10139N/A# spec file for package gtk-vnc
10139N/A#
11314N/A# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner halton
10139N/A#
10139N/A
10139N/A%define OSR gnome.org:0
10139N/A
10139N/AName: gtk-vnc
11020N/ALicense: LGPL v2.1, MIT, MPL 1.1
10139N/AGroup: Development/Libraries
10139N/AVersion: 0.3.10
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10874N/AURL: http://gtk-vnc.sf.net/
10139N/ASummary: A GTK widget for VNC clients
10139N/ASource: http://download.gnome.org/sources/%{name}/0.3/%{name}-%{version}.tar.bz2
10139N/A# date:2008-11-28 owner:fujiwara type:feature bugster:6777514 bugzilla:591523
10139N/APatch1: gtk-vnc-01-cp-utf8.diff
10139N/A# date:2008-12-16 owner:halton type:bug bugzilla:564718
10139N/APatch2: gtk-vnc-02-ff3.6.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/A
10139N/ABuildRequires: gtk2-devel pygtk2-devel python-devel
10139N/A
10139N/A%{?!pythonver:%define pythonver %default_python_version}
10139N/A
10139N/A%description
10139N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/A%package devel
10139N/ASummary: Libraries, includes, etc. to compile with the gtk-vnc library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: pkgconfig
10139N/ARequires: pygtk2-devel gtk2-devel
10139N/A
10139N/A%description devel
10139N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/ALibraries, includes, etc. to compile with the gtk-vnc library
10139N/A
10139N/A%package python
10139N/ASummary: Python bindings for the gtk-vnc library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description python
10139N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/AA module allowing use of the GTK-VNC widget from python
10139N/A
10139N/A%prep
10139N/A%setup -q
10392N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
11881N/A%build
11314N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
11314N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport PYTHON=/usr/bin/python%{pythonver}
10139N/A
10139N/Alibtoolize --force --force
10139N/A# FIXME: community is doing i18n thing, disable it for now.
10139N/A#intltoolize --automake -c -f
10139N/Aaclocal -I gnulib/m4
10139N/Aautoheader
10139N/Aautomake --add-missing --copy
10139N/Aautoconf
10139N/A
10139N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libdir=%{_libdir} \
10139N/A --datadir=%{_datadir} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A%if %debug_build
10139N/A --enable-debug=yes \
10139N/A%endif
10139N/A%if %with_brower_plugin
10139N/A --enable-plugin
10139N/A%endif
10139N/A
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A# move to vendor-packages
10139N/A%if %with_64
10139N/Acd $RPM_BUILD_ROOT%{_libdir}/..
10139N/Amkdir -p python%{pythonver}/vendor-packages/64
10139N/Amv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/64
11881N/A%else
11881N/Acd $RPM_BUILD_ROOT%{_libdir}
11881N/Amkdir -p python%{pythonver}/vendor-packages
11314N/Amv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/
11314N/A%endif
11020N/Armdir python%{pythonver}/site-packages
11020N/A
10392N/A%clean
10392N/Arm -rf $RPM_BUILD_ROOT
10307N/A
10307N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog NEWS README COPYING.LIB
%{_libdir}/lib*.so.*
%files devel
%defattr(-, root, root)
%doc AUTHORS ChangeLog NEWS README COPYING.LIB
%doc examples/gvncviewer.c
%{_libdir}/lib*.so
%dir %{_includedir}/%{name}-1.0/
%{_includedir}/%{name}-1.0/*.h
%{_libdir}/pkgconfig/%{name}-1.0.pc
%files python
%defattr(-, root, root)
%doc AUTHORS ChangeLog NEWS README COPYING.LIB
%doc examples/gvncviewer.py
%{_libdir}/python*/site-packages/gtkvnc.so
%changelog
* Mon Jan 25 2010 - ginn.chen@sun.com
- Remove gtk-vnc-02-ff3.1.diff, add gtk-vnc-02-ff3.6.diff.
* Tue Nov 11 2009 - halton.huo@sun.com
- Remove hacking stuff cause 591524 is fixed
* Wed Oct 21 2009 - halton.huo@sun.com
- Bump to 0.3.10
- Remove upstreamed patch sasl.diff
* Wed Aug 12 2009 - halton.huo@sun.com
- Bump to 0.3.9
- Remove obsoleted patch textdomain.diff and reorder
- Add patch sasl.diff to fix bugzilla #592521
* Tue Dec 16 2008 - halton.huo@sun.com
- Add ff3.1.diff to fix the build issue when FF bumped to 3.1
* Thu Dec 11 2008 - halton.huo@sun.com
- Bump to 0.3.8
* Fri Nov 28 2008 - takao.fujiwara@sun.com
- Add patch textdomain.diff to support message i18n.
- Add patch cp-utf8.diff to copy multibyte chars.
* Wed Nov 26 2008 - halton.huo@sun.com
- use %{pythonver} macro to select which version of Python to build with
* Thu Nov 13 2008 - halton.huo@sun.com
- Moved from SFE
* Tue Sep 09 2008 - halton.huo@sun.com
- Bump to 0.3.7
* Tue May 06 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.6
- Remove upsteamed patch solaris-ld-ast.diff
* Tue Apr 22 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.5
* Fri Mar 07 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.4
* Wed Feb 20 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.3
- Remove upstreamed patch suncc-range-case.diff
* Thu Jan 10 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.2
- Add patch suncc-range-case.diff to fix build issue.
* Fri Dec 14 2007 - nonsea@users.sourceforge.net
- Bump to 0.3.1
* Thu Dec 13 2007 - nonsea@users.sourceforge.net
- Bump to 0.3.0
- Remove upsreamed patches: makefile.diff, macro.diff,
yield.diff and coroutine.diff
- Add new patch solaris-ld-ast.diff
* Tue Oct 30 2007 - nonsea@users.sourceforge.net
- Add debug option.
* Thu Oct 25 2007 - nonsea@users.sourceforge.net
- Initial version