gtk-vnc.spec revision 17495
15341N/A#
15341N/A# spec file for package gtk-vnc
15341N/A#
15341N/A# Copyright 2008 Sun Microsystems, Inc.
15341N/A# This file and all modifications and additions to the pristine
15341N/A# package are under the same license as the package itself.
15341N/A#
17185N/A%define owner halton
15341N/A#
15341N/A
17181N/A%define OSR gnome.org:0
15341N/A
15341N/AName: gtk-vnc
15341N/ALicense: LGPL v2.1, MIT, MPL 1.1
15341N/AGroup: Development/Libraries
16995N/AVersion: 0.3.9
15341N/ARelease: 1
15341N/ADistribution: Java Desktop System
15341N/AVendor: Sun Microsystems, Inc.
15341N/AURL: http://gtk-vnc.sf.net/
15341N/ASummary: A GTK widget for VNC clients
15955N/ASource: http://download.gnome.org/sources/%{name}/0.3/%{name}-%{version}.tar.bz2
16995N/A# date:2008-11-28 owner:fujiwara type:feature bugster:6777514 bugzilla:591523
16995N/APatch1: gtk-vnc-01-cp-utf8.diff
15531N/A# date:2008-12-16 owner:halton type:bug bugzilla:564718
16995N/APatch2: gtk-vnc-02-ff3.1.diff
16995N/A# date:2009-08-12 owner:halton type:bug bugzilla:591521
16995N/APatch3: gtk-vnc-03-sasl.diff
15341N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
15341N/A
15341N/ABuildRequires: gtk2-devel pygtk2-devel python-devel
15341N/A
17495N/A%{?!pythonver:%define pythonver %default_python_version}
15406N/A
15341N/A%description
15341N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
15341N/Aallowing it to be completely asynchronous while remaining single threaded.
15341N/A
15341N/A%package devel
15341N/ASummary: Libraries, includes, etc. to compile with the gtk-vnc library
15341N/AGroup: Development/Libraries
15341N/ARequires: %{name} = %{version}
15341N/ARequires: pkgconfig
15341N/ARequires: pygtk2-devel gtk2-devel
15341N/A
15341N/A%description devel
15341N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
15341N/Aallowing it to be completely asynchronous while remaining single threaded.
15341N/A
15341N/ALibraries, includes, etc. to compile with the gtk-vnc library
15341N/A
15341N/A%package python
15341N/ASummary: Python bindings for the gtk-vnc library
15341N/AGroup: Development/Libraries
15341N/ARequires: %{name} = %{version}
15341N/A
15341N/A%description python
15341N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
15341N/Aallowing it to be completely asynchronous while remaining single threaded.
15341N/A
15341N/AA module allowing use of the GTK-VNC widget from python
15341N/A
15341N/A%prep
15341N/A%setup -q
15428N/A%patch1 -p1
15428N/A%patch2 -p1
15549N/A%patch3 -p1
15341N/A
16995N/A#FIXME: When #591524 fixed in next release, remove following lines
16995N/Arm -f gnulib/m4/lt~obsolete.m4
16995N/Arm -f gnulib/m4/ltoptions.m4
16995N/Arm -f gnulib/m4/libtool.m4
16995N/Arm -f gnulib/m4/ltsugar.m4
16995N/Arm -f gnulib/m4/ltversion.m4
16995N/A
15341N/A%build
15341N/A%ifos linux
15341N/Aif [ -x /usr/bin/getconf ]; then
15341N/A CPUS=`getconf _NPROCESSORS_ONLN`
15341N/Afi
15341N/A%else
15341N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15341N/A%endif
15341N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15341N/A CPUS=1
15341N/Afi
15341N/A
16120N/Aexport PYTHON=/usr/bin/python%{pythonver}
15406N/A
15500N/Alibtoolize --force --force
16995N/A# FIXME: community is doing i18n thing, disable it for now.
16995N/A#intltoolize --automake -c -f
15500N/Aaclocal -I gnulib/m4
15341N/Aautoheader
15500N/Aautomake --add-missing --copy
15341N/Aautoconf
15341N/A
15341N/A./configure --prefix=%{_prefix} \
15341N/A --bindir=%{_bindir} \
15341N/A --mandir=%{_mandir} \
15341N/A --libdir=%{_libdir} \
15341N/A --datadir=%{_datadir} \
15341N/A --includedir=%{_includedir} \
15341N/A --sysconfdir=%{_sysconfdir} \
15341N/A%if %debug_build
15341N/A --enable-debug=yes \
15341N/A%endif
15341N/A%if %with_brower_plugin
15341N/A --enable-plugin
15341N/A%endif
15341N/A
15341N/A
15341N/Amake -j $CPUS
15341N/A
15341N/A%install
15341N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
15341N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
15341N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
15341N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
15341N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
15341N/A
15406N/A# move to vendor-packages
15406N/A%if %with_64
15406N/Acd $RPM_BUILD_ROOT%{_libdir}/..
15406N/Amkdir -p python%{pythonver}/vendor-packages/64
15406N/Amv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/64
15406N/A%else
15406N/Acd $RPM_BUILD_ROOT%{_libdir}
15406N/Amkdir -p python%{pythonver}/vendor-packages
15406N/Amv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/
15406N/A%endif
15406N/Armdir python%{pythonver}/site-packages
15406N/A
15341N/A%clean
15341N/Arm -rf $RPM_BUILD_ROOT
15341N/A
15341N/A%post
15341N/A/sbin/ldconfig
15341N/A
15341N/A%postun
15341N/A/sbin/ldconfig
15341N/A
15341N/A%files
15341N/A%defattr(-, root, root)
15341N/A%doc AUTHORS ChangeLog NEWS README COPYING.LIB
15341N/A%{_libdir}/lib*.so.*
15341N/A
15341N/A%files devel
15341N/A%defattr(-, root, root)
15341N/A%doc AUTHORS ChangeLog NEWS README COPYING.LIB
15341N/A%doc examples/gvncviewer.c
15341N/A%{_libdir}/lib*.so
15341N/A%dir %{_includedir}/%{name}-1.0/
15341N/A%{_includedir}/%{name}-1.0/*.h
15341N/A%{_libdir}/pkgconfig/%{name}-1.0.pc
15341N/A
15341N/A%files python
15341N/A%defattr(-, root, root)
15341N/A%doc AUTHORS ChangeLog NEWS README COPYING.LIB
15341N/A%doc examples/gvncviewer.py
15341N/A%{_libdir}/python*/site-packages/gtkvnc.so
15341N/A
15341N/A%changelog
16995N/A* Wed Aug 12 2009 - halton.huo@sun.com
16995N/A- Bump to 0.3.9
16995N/A- Remove obsoleted patch textdomain.diff and reorder
16995N/A- Add patch sasl.diff to fix bugzilla #592521
15531N/A* Tue Dec 16 2008 - halton.huo@sun.com
15531N/A- Add ff3.1.diff to fix the build issue when FF bumped to 3.1
15500N/A* Thu Dec 11 2008 - halton.huo@sun.com
15500N/A- Bump to 0.3.8
15428N/A* Fri Nov 28 2008 - takao.fujiwara@sun.com
15428N/A- Add patch textdomain.diff to support message i18n.
15428N/A- Add patch cp-utf8.diff to copy multibyte chars.
15406N/A* Wed Nov 26 2008 - halton.huo@sun.com
15406N/A- use %{pythonver} macro to select which version of Python to build with
15344N/A* Thu Nov 13 2008 - halton.huo@sun.com
15344N/A- Moved from SFE
15341N/A* Tue Sep 09 2008 - halton.huo@sun.com
15341N/A- Bump to 0.3.7
15341N/A* Tue May 06 2008 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.6
15341N/A- Remove upsteamed patch solaris-ld-ast.diff
15341N/A* Tue Apr 22 2008 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.5
15341N/A* Fri Mar 07 2008 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.4
15341N/A* Wed Feb 20 2008 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.3
15341N/A- Remove upstreamed patch suncc-range-case.diff
15341N/A* Thu Jan 10 2008 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.2
15341N/A- Add patch suncc-range-case.diff to fix build issue.
15341N/A* Fri Dec 14 2007 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.1
15341N/A* Thu Dec 13 2007 - nonsea@users.sourceforge.net
15341N/A- Bump to 0.3.0
15341N/A- Remove upsreamed patches: makefile.diff, macro.diff,
15341N/A yield.diff and coroutine.diff
15341N/A- Add new patch solaris-ld-ast.diff
15341N/A* Tue Oct 30 2007 - nonsea@users.sourceforge.net
15341N/A- Add debug option.
15341N/A* Thu Oct 25 2007 - nonsea@users.sourceforge.net
15341N/A- Initial version