gtk-vnc.spec revision 15955
10139N/A#
10139N/A# spec file for package gtk-vnc
10139N/A#
18218N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: halton
10139N/A#
17181N/A
17181N/A
17181N/AName: gtk-vnc
10139N/ALicense: LGPL v2.1, MIT, MPL 1.1
18218N/AGroup: Development/Libraries
10139N/AVersion: 0.3.8
18218N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/AURL: http://gtk-vnc.sf.net/
18615N/ASummary: A GTK widget for VNC clients
10139N/ASource: http://download.gnome.org/sources/%{name}/0.3/%{name}-%{version}.tar.bz2
10139N/A# date:2008-11-28 owner:fujiwara type:feature bugster:6777514 bugzilla:2354859
10139N/APatch1: gtk-vnc-01-textdomain.diff
10139N/A# date:2008-11-28 owner:fujiwara type:feature bugster:6777514 bugzilla:2354851
10139N/APatch2: gtk-vnc-02-cp-utf8.diff
10139N/A# date:2008-12-16 owner:halton type:bug bugzilla:564718
10139N/APatch3: gtk-vnc-03-ff3.1.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/A
10139N/ABuildRequires: gtk2-devel pygtk2-devel python-devel
10139N/A
10139N/A%{?!pythonver:%define pythonver 2.4}
10139N/A
10139N/A%description
10139N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/A%package devel
10392N/ASummary: Libraries, includes, etc. to compile with the gtk-vnc library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: pkgconfig
10139N/ARequires: pygtk2-devel gtk2-devel
10139N/A
10139N/A%description devel
10139N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/ALibraries, includes, etc. to compile with the gtk-vnc library
10139N/A
10139N/A%package python
10139N/ASummary: Python bindings for the gtk-vnc library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
18218N/A%description python
18218N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
17036N/Aallowing it to be completely asynchronous while remaining single threaded.
17036N/A
16903N/AA module allowing use of the GTK-VNC widget from python
16903N/A
16625N/A%prep
16625N/A%setup -q
16253N/A%patch1 -p1
16253N/A%patch2 -p1
13507N/A%patch3 -p1
13352N/A
12046N/A%build
12046N/A%ifos linux
10392N/Aif [ -x /usr/bin/getconf ]; then
10392N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
export PYTHON=%{_bindir}/python%{pythonver}
libtoolize --force --force
intltoolize --automake -c -f
aclocal -I gnulib/m4
autoheader
automake --add-missing --copy
autoconf
./configure --prefix=%{_prefix} \
--bindir=%{_bindir} \
--mandir=%{_mandir} \
--libdir=%{_libdir} \
--datadir=%{_datadir} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
%if %debug_build
--enable-debug=yes \
%endif
%if %with_brower_plugin
--enable-plugin
%endif
make -j $CPUS
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
# move to vendor-packages
%if %with_64
cd $RPM_BUILD_ROOT%{_libdir}/..
mkdir -p python%{pythonver}/vendor-packages/64
mv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/64
%else
cd $RPM_BUILD_ROOT%{_libdir}
mkdir -p python%{pythonver}/vendor-packages
mv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/
%endif
rmdir python%{pythonver}/site-packages
%clean
rm -rf $RPM_BUILD_ROOT
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog NEWS README COPYING.LIB
%{_libdir}/lib*.so.*
%files devel
%defattr(-, root, root)
%doc AUTHORS ChangeLog NEWS README COPYING.LIB
%doc examples/gvncviewer.c
%{_libdir}/lib*.so
%dir %{_includedir}/%{name}-1.0/
%{_includedir}/%{name}-1.0/*.h
%{_libdir}/pkgconfig/%{name}-1.0.pc
%files python
%defattr(-, root, root)
%doc AUTHORS ChangeLog NEWS README COPYING.LIB
%doc examples/gvncviewer.py
%{_libdir}/python*/site-packages/gtkvnc.so
%changelog
* Tue Dec 16 2008 - halton.huo@sun.com
- Add ff3.1.diff to fix the build issue when FF bumped to 3.1
* Thu Dec 11 2008 - halton.huo@sun.com
- Bump to 0.3.8
* Fri Nov 28 2008 - takao.fujiwara@sun.com
- Add patch textdomain.diff to support message i18n.
- Add patch cp-utf8.diff to copy multibyte chars.
* Wed Nov 26 2008 - halton.huo@sun.com
- use %{pythonver} macro to select which version of Python to build with
* Thu Nov 13 2008 - halton.huo@sun.com
- Moved from SFE
* Tue Sep 09 2008 - halton.huo@sun.com
- Bump to 0.3.7
* Tue May 06 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.6
- Remove upsteamed patch solaris-ld-ast.diff
* Tue Apr 22 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.5
* Fri Mar 07 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.4
* Wed Feb 20 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.3
- Remove upstreamed patch suncc-range-case.diff
* Thu Jan 10 2008 - nonsea@users.sourceforge.net
- Bump to 0.3.2
- Add patch suncc-range-case.diff to fix build issue.
* Fri Dec 14 2007 - nonsea@users.sourceforge.net
- Bump to 0.3.1
* Thu Dec 13 2007 - nonsea@users.sourceforge.net
- Bump to 0.3.0
- Remove upsreamed patches: makefile.diff, macro.diff,
yield.diff and coroutine.diff
- Add new patch solaris-ld-ast.diff
* Tue Oct 30 2007 - nonsea@users.sourceforge.net
- Add debug option.
* Thu Oct 25 2007 - nonsea@users.sourceforge.net
- Initial version