gtk-vnc.spec revision 15406
10139N/A#
10139N/A# spec file for package gtk-vnc
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:halton
10139N/A#
10139N/A
10139N/A
10139N/AName: gtk-vnc
10810N/ALicense: LGPL v2.1, MIT, MPL 1.1
10737N/AGroup: Development/Libraries
10139N/AVersion: 0.3.7
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10740N/AVendor: Sun Microsystems, Inc.
10139N/AURL: http://gtk-vnc.sf.net/
10139N/ASummary: A GTK widget for VNC clients
10737N/ASource: http://easynews.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.gz
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10737N/A
10139N/ABuildRequires: gtk2-devel pygtk2-devel python-devel
10737N/A
10139N/A%{?!pythonver:%define pythonver 2.4}
10737N/A
10139N/A%description
10737N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10737N/A
10139N/A%package devel
10737N/ASummary: Libraries, includes, etc. to compile with the gtk-vnc library
10737N/AGroup: Development/Libraries
10737N/ARequires: %{name} = %{version}
10737N/ARequires: pkgconfig
10769N/ARequires: pygtk2-devel gtk2-devel
10737N/A
10769N/A%description devel
10737N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/ALibraries, includes, etc. to compile with the gtk-vnc library
10139N/A
10139N/A%package python
10139N/ASummary: Python bindings for the gtk-vnc library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description python
10139N/Agtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
10139N/Aallowing it to be completely asynchronous while remaining single threaded.
10139N/A
10139N/AA module allowing use of the GTK-VNC widget from python
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%build
10139N/A%ifos linux
10737N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10737N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10737N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10740N/A CPUS=1
10740N/Afi
10139N/A
10740N/Aexport PYTHON=%{_bindir}/python%{pythonver}
10139N/A
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libdir=%{_libdir} \
10139N/A --datadir=%{_datadir} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A%if %debug_build
10139N/A --enable-debug=yes \
10139N/A%endif
10139N/A%if %with_brower_plugin
10139N/A --enable-plugin
10139N/A%endif
10139N/A
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A# move to vendor-packages
10139N/A%if %with_64
10139N/Acd $RPM_BUILD_ROOT%{_libdir}/..
10139N/Amkdir -p python%{pythonver}/vendor-packages/64
10139N/Amv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/64
10139N/A%else
10139N/Acd $RPM_BUILD_ROOT%{_libdir}
10139N/Amkdir -p python%{pythonver}/vendor-packages
10139N/Amv python%{pythonver}/site-packages/* python%{pythonver}/vendor-packages/
10139N/A%endif
10139N/Armdir python%{pythonver}/site-packages
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS ChangeLog NEWS README COPYING.LIB
10139N/A%{_libdir}/lib*.so.*
10139N/A
10142N/A%files devel
10142N/A%defattr(-, root, root)
10139N/A%doc AUTHORS ChangeLog NEWS README COPYING.LIB
10139N/A%doc examples/gvncviewer.c
10139N/A%{_libdir}/lib*.so
10139N/A%dir %{_includedir}/%{name}-1.0/
10139N/A%{_includedir}/%{name}-1.0/*.h
10139N/A%{_libdir}/pkgconfig/%{name}-1.0.pc
10139N/A
10810N/A%files python
10810N/A%defattr(-, root, root)
10740N/A%doc AUTHORS ChangeLog NEWS README COPYING.LIB
10740N/A%doc examples/gvncviewer.py
10740N/A%{_libdir}/python*/site-packages/gtkvnc.so
10740N/A
10737N/A%changelog
10737N/A* Wed Nov 26 2008 - halton.huo@sun.com
10695N/A- use %{pythonver} macro to select which version of Python to build with
10695N/A* Thu Nov 13 2008 - halton.huo@sun.com
10280N/A- Moved from SFE
10280N/A* Tue Sep 09 2008 - halton.huo@sun.com
10139N/A- Bump to 0.3.7
10139N/A* Tue May 06 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.6
10139N/A- Remove upsteamed patch solaris-ld-ast.diff
10139N/A* Tue Apr 22 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.5
10139N/A* Fri Mar 07 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.4
10139N/A* Wed Feb 20 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.3
10139N/A- Remove upstreamed patch suncc-range-case.diff
10139N/A* Thu Jan 10 2008 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.2
10139N/A- Add patch suncc-range-case.diff to fix build issue.
10139N/A* Fri Dec 14 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.1
10139N/A* Thu Dec 13 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 0.3.0
10139N/A- Remove upsreamed patches: makefile.diff, macro.diff,
10139N/A yield.diff and coroutine.diff
10139N/A- Add new patch solaris-ld-ast.diff
10139N/A* Tue Oct 30 2007 - nonsea@users.sourceforge.net
10139N/A- Add debug option.
10139N/A* Thu Oct 25 2007 - nonsea@users.sourceforge.net
10139N/A- Initial version
10139N/A