gtk-doc.spec revision 17181
10139N/A#
20255N/A# spec file for package gtk-doc
10139N/A#
20255N/A# Copyright 2008 Sun Microsystems, Inc.
18593N/A# This file and all modifications and additions to the pristine
18632N/A# package are under the same license as the package itself.
18593N/A#
13600N/A# Owner: laca
10139N/A#
10139N/A
10139N/A%define pythonver 2.6
10139N/A
10139N/A%define OSR gnome.org:0
10139N/A
10139N/AName: gtk-doc
20814N/ALicense: GPL
20814N/AGroup: Utilities/Text
10139N/ABuildArchitectures: noarch
18632N/AVersion: 1.11
18632N/ARelease: 2
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
18593N/ASummary: GTK+ DocBook Documentation Generator
17338N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/1.11/gtk-doc-%{version}.tar.bz2
10139N/A# owner:davelam date:2009-03-18 type:bug
10139N/APatch1: gtk-doc-01-cmp-space-escape.diff
20255N/AURL: http://www.gnome.org
20255N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20255N/ADocdir: %{_defaultdocdir}/doc
17811N/AAutoreqprov: on
17811N/A
17811N/A%define libxslt_version 1.0.19
20255N/A%define libxml2_version 2.5.3
20255N/A
16554N/ABuildRequires: docbook-xsl-stylesheets
10139N/ARequires: libxml2 >= %{libxml2_version}
19967N/ARequires: libxslt >= %{libxslt_version}
19967N/A
19967N/A%description
18384N/Agtk-doc is a set of perl scripts that generate API reference documention in
20814N/ADocBook format. It can extract documentation from source code comments in a
19967N/Amanner similar to java-doc. It is used to generate the documentation for
20814N/AGLib, Gtk+, and GNOME.
20255N/A
20255N/A%prep
20255N/A%setup -q
20255N/A%patch1 -p1
18384N/A
18384N/A%build
16633N/A%ifos linux
11999N/Aif [ -x /usr/bin/getconf ]; then
20814N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
20255N/A%else
20255N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20814N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12830N/A CPUS=1
12830N/Afi
20814N/A
12830N/Alibtoolize --force
13914N/Aaclocal $ACLOCAL_FLAGS
13915N/Aautomake -a -c -f
20814N/Aautoconf
14425N/ACFLAGS="$RPM_OPT_FLAGS"
20255N/Aexport PYTHON=/usr/bin/python%{pythonver}
20255N/A./configure $MYARCH_FLAGS --prefix=%{_prefix} \
20814N/A --disable-scrollkeeper \
15190N/A --sysconfdir=%{_sysconfdir}
16597N/Amake -j $CPUS
15536N/A
20814N/A%install
15216N/Afor f in `find . -name '*.omf' -print`; do
20255N/A echo Creating $f.out
20814N/A loc=`echo $f | sed -e 's/.*-\([a-zA-Z_]*\).omf/\1/'`
15418N/A sed -e 's,url=",url="file://%{_datadir}/gnome/help/gtk-doc-manual/'${loc}'/,' $f > $f.out
16554N/Adone
16554N/A
20814N/Amake DESTDIR=$RPM_BUILD_ROOT install
16554N/A
16554N/A%clean
20255N/Arm -rf $RPM_BUILD_ROOT
20814N/A
15516N/A%files
20814N/A%defattr(-,root,root)
20814N/A%{_bindir}/*
20814N/A%{_datadir}/gtk-doc/*
17811N/A%{_datadir}/aclocal/*
20255N/A%{_datadir}/sgml/*
20814N/A%{_libdir}/pkgconfig/*
17338N/A
15536N/A%changelog
20814N/A* Wed mar 18 2009 - dave.lin@sun.com
15529N/A- Add patch 01-cmp-space-escape.diff to handle the file name that contains space.
17811N/A* Thu Mar 12 2009 - brian.cameron@sun.com
20814N/A- Change pythonver from 2.5 to 2.6.
15761N/A* Fri Dec 5 2008 - laca@sun.com
16020N/A- delete old scrollkeeper hack and disable scrollkeeper install properly
20255N/A* Thu Dec 04 2008 - dave.lin@sun.com
20814N/A- Bump to 1.11
16020N/A* Mon Mar 31 2008 - patrick.ale@gmail.com
16020N/A- Change download directory to 1.10
17964N/A* Sun Mar 23 2008 - damien.carbery@sun.com
20814N/A- Bump to 1.10.
17811N/A* Tue Oct 2 2007 - damien.carbery@sun.com
17811N/A- Bump to 1.9.
20814N/A* Fri Feb 16 2007 - damien.carbery@sun.com
20255N/A- Bump to 1.8.
20255N/A* Sat Sep 16 2006 - laca@sun.com
20814N/A- set scrollkeeper_config so that docs are always installed
16549N/A- create .omf.out files using sed since scrollkeeper-preinstall is not
20255N/A available yet
20814N/A* Mon Jul 31 2006 - damien.carbery@sun.com
16532N/A- Bump to 1.7.
20255N/A* Tue Apr 11 2006 - damien.carbery@sun.com
20814N/A- Specify ACLOCAL_FLAGS for use on Solaris to find a pkgconfig macro.
17811N/A* Mon Apr 10 2006 - damien.carbery@sun.com
20255N/A- Bump to 1.6.
20814N/A* Tue Mar 7 2006 - damien.carbery@sun.com
18036N/A- Bump to 1.5.
20255N/A* Fri May 06 2005 - glynn.foster@sun.com
20255N/A- Bump to 1.3
20814N/A* Tue Aug 24 2004 - ghee.teo@sun.com
18190N/A- Added BuildRequires with docbook-xsl-stylesheets.
20255N/A so that this can be detected even at -bp state.
20814N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
20255N/A- added "-j $CPUS" to make to speed up builds
20255N/A* Mon Feb 23 2004 - matt.keenan@sun.com
20814N/A- Back up to 1.1 as 1.2 DTD XML is causing build failures... DANG
18251N/A* Mon Dec 15 2003 - glynn.foster@sun.com
18384N/A- Add the m4 macro to installation
18384N/A* Sat Oct 04 2003 - laca@sun.com
18384N/A- upgrade to 1.1
20814N/A* Thu May 12 2003 - ghee.teo@Sun.COM
18384N/A- Created new spec file for gtk-doc
18384N/A