gtk-doc.spec revision 16128
19033N/A#
19033N/A# spec file for package gtk-doc
19033N/A#
19033N/A# Copyright 2008 Sun Microsystems, Inc.
19033N/A# This file and all modifications and additions to the pristine
19033N/A# package are under the same license as the package itself.
19033N/A#
19033N/A# Owner: laca
19033N/A#
19033N/A
19033N/A%define pythonver 2.6
19033N/A
19033N/AName: gtk-doc
19033N/ALicense: GPL
19033N/AGroup: Utilities/Text
19033N/ABuildArchitectures: noarch
19033N/AVersion: 1.11
19033N/ARelease: 2
19033N/ADistribution: Java Desktop System
19033N/AVendor: Sun Microsystems, Inc.
19033N/ASummary: GTK+ DocBook Documentation Generator
19033N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gtk-doc/1.11/gtk-doc-%{version}.tar.bz2
19033N/AURL: http://www.gnome.org
19033N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
19033N/ADocdir: %{_defaultdocdir}/doc
19033N/AAutoreqprov: on
19033N/A
19033N/A%define libxslt_version 1.0.19
19033N/A%define libxml2_version 2.5.3
19033N/A
19033N/ABuildRequires: docbook-xsl-stylesheets
19033N/ARequires: libxml2 >= %{libxml2_version}
19033N/ARequires: libxslt >= %{libxslt_version}
19033N/A
19033N/A%description
19033N/Agtk-doc is a set of perl scripts that generate API reference documention in
19033N/ADocBook format. It can extract documentation from source code comments in a
19033N/Amanner similar to java-doc. It is used to generate the documentation for
19033N/AGLib, Gtk+, and GNOME.
19033N/A
19033N/A%prep
19033N/A%setup -q
19033N/A
19033N/A%build
19033N/A%ifos linux
19033N/Aif [ -x /usr/bin/getconf ]; then
19033N/A CPUS=`getconf _NPROCESSORS_ONLN`
19033N/Afi
19033N/A%else
19033N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
19033N/A%endif
19033N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
19033N/A CPUS=1
19033N/Afi
19033N/A
19033N/Alibtoolize --force
19033N/Aaclocal $ACLOCAL_FLAGS
19033N/Aautomake -a -c -f
19033N/Aautoconf
19033N/ACFLAGS="$RPM_OPT_FLAGS"
19033N/Aexport PYTHON=/usr/bin/python%{pythonver}
19033N/A./configure $MYARCH_FLAGS --prefix=%{_prefix} \
19033N/A --disable-scrollkeeper \
19033N/A --sysconfdir=%{_sysconfdir}
19033N/Amake -j $CPUS
19033N/A
19033N/A%install
19033N/Afor f in `find . -name '*.omf' -print`; do
19117N/A echo Creating $f.out
19033N/A loc=`echo $f | sed -e 's/.*-\([a-zA-Z_]*\).omf/\1/'`
19033N/A sed -e 's,url=",url="file://%{_datadir}/gnome/help/gtk-doc-manual/'${loc}'/,' $f > $f.out
19033N/Adone
20353N/A
20353N/Amake DESTDIR=$RPM_BUILD_ROOT install
19098N/A
19033N/A%clean
19033N/Arm -rf $RPM_BUILD_ROOT
19033N/A
19033N/A%files
19033N/A%defattr(-,root,root)
19033N/A%{_bindir}/*
19117N/A%{_datadir}/gtk-doc/*
19033N/A%{_datadir}/aclocal/*
19117N/A%{_datadir}/sgml/*
19033N/A%{_libdir}/pkgconfig/*
19033N/A
19033N/A%changelog
19033N/A* Thu Mar 12 2009 - brian.cameron@sun.com
19033N/A- Change pythonver from 2.5 to 2.6.
19033N/A* Fri Dec 5 2008 - laca@sun.com
19033N/A- delete old scrollkeeper hack and disable scrollkeeper install properly
19033N/A* Thu Dec 04 2008 - dave.lin@sun.com
19033N/A- Bump to 1.11
19033N/A* Mon Mar 31 2008 - patrick.ale@gmail.com
19033N/A- Change download directory to 1.10
19033N/A* Sun Mar 23 2008 - damien.carbery@sun.com
19033N/A- Bump to 1.10.
19033N/A* Tue Oct 2 2007 - damien.carbery@sun.com
19033N/A- Bump to 1.9.
19033N/A* Fri Feb 16 2007 - damien.carbery@sun.com
19033N/A- Bump to 1.8.
19033N/A* Sat Sep 16 2006 - laca@sun.com
19033N/A- set scrollkeeper_config so that docs are always installed
19033N/A- create .omf.out files using sed since scrollkeeper-preinstall is not
19033N/A available yet
19033N/A* Mon Jul 31 2006 - damien.carbery@sun.com
19033N/A- Bump to 1.7.
19033N/A* Tue Apr 11 2006 - damien.carbery@sun.com
19033N/A- Specify ACLOCAL_FLAGS for use on Solaris to find a pkgconfig macro.
19033N/A* Mon Apr 10 2006 - damien.carbery@sun.com
19033N/A- Bump to 1.6.
19033N/A* Tue Mar 7 2006 - damien.carbery@sun.com
19033N/A- Bump to 1.5.
19033N/A* Fri May 06 2005 - glynn.foster@sun.com
19033N/A- Bump to 1.3
19033N/A* Tue Aug 24 2004 - ghee.teo@sun.com
19033N/A- Added BuildRequires with docbook-xsl-stylesheets.
19033N/A so that this can be detected even at -bp state.
19033N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
19033N/A- added "-j $CPUS" to make to speed up builds
19033N/A* Mon Feb 23 2004 - matt.keenan@sun.com
19033N/A- Back up to 1.1 as 1.2 DTD XML is causing build failures... DANG
19033N/A* Mon Dec 15 2003 - glynn.foster@sun.com
19033N/A- Add the m4 macro to installation
19033N/A* Sat Oct 04 2003 - laca@sun.com
19033N/A- upgrade to 1.1
19033N/A* Thu May 12 2003 - ghee.teo@Sun.COM
19033N/A- Created new spec file for gtk-doc
19033N/A