gst.spec revision 20903
10139N/A#
10139N/A# spec file for package gstreamer
10139N/A#
12151N/A# Copyright (c) 2003, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner yippi
10139N/A#
10139N/A
10139N/A%define OSR 8760:0.10.19
10139N/A
10139N/AName: gstreamer
11838N/ALicense: LGPL v2, Public Domain
13024N/AGroup: Libraries/Multimedia
12578N/AVersion: 0.10.36
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: freedesktop.org
11256N/ASummary: GStreamer streaming media framework runtime.
10142N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
12773N/A%if %build_l10n
12773N/ASource1: l10n-configure.sh
12773N/A%endif
11358N/A
10139N/A#owner:laca date:2005-08-11 type:bug bugster:6570425
11358N/APatch1: gst-01-gettext.diff
11358N/A#owner:yippi date:2012-04-03 type:bug
11358N/APatch2: gst-02-amd64.diff
11358N/A#owner:yippi date:2012-05-02 type:bug
11358N/APatch3: gst-03-compile.diff
11358N/AURL: http://gstreamer.net/
11002N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11002N/ADocdir: %{_defaultdocdir}/doc
13025N/AAutoreqprov: on
13025N/ADocdir: %{_defaultdocdir}/doc
12830N/AAutoreqprov: on
12830N/APrereq: /sbin/ldconfig
13083N/A
13083N/A%define glib2_version 2.0.1
13317N/A%define libxml2_version 2.4.0
13317N/A
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: popt
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10139N/ABuildRequires: flex
10139N/ABuildRequires: gtk-doc >= 0.7
10139N/ABuildRequires: gcc
10139N/ABuildRequires: zlib-devel
10139N/ABuildRequires: popt
10139N/ABuildRequires: pyxml
10139N/A
10139N/A%description
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/A%package devel
10139N/ASummary: Libraries/include files for GStreamer streaming media frame
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10139N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/A
10139N/A%description devel
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the libraries and includes files necessary to develop
10139N/Aapplications and plugins for GStreamer.
10139N/A
10139N/A%package tools
10139N/ASummary: tools for GStreamer streaming media framework.
10139N/AGroup: Libraries/Multimedia
10139N/A
10139N/A%description tools
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the basic command-line tools used for GStreamer, like
10139N/Agst-launch. It is split off to allow parallel-installability in the future.
10139N/A
10139N/A%prep
10139N/A%setup -q
12274N/A%patch1 -p1
12274N/A%patch2 -p1
12274N/A%patch3 -p1
12274N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10142N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
11358N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
11358N/A CPUS=1
11358N/Afi
11358N/A
11358N/Aglib-gettextize -f
11002N/Alibtoolize --copy --force
13025N/Aintltoolize --copy --force --automake
12830N/Aaclocal -I ./m4 -I common/m4 $ACLOCAL_FLAGS -I .
13083N/A
13317N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aautoheader
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A %{gtk_doc_option} \
10139N/A --disable-tests --disable-examples \
10139N/A --program-suffix="" --disable-check
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10617N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A
10139N/A%clean
10617N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%post tools
12773N/A/sbin/ldconfig
12773N/A
12773N/A%post devel
12773N/A/sbin/ldconfig
12773N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_libdir}/gstreamer-*/libgst*.so*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
11189N/A%{_includedir}/*
11155N/A%{_libdir}/lib*.so
12830N/A%{_libdir}/pkgconfig
10617N/A%{_datadir}/aclocal
10139N/A%{_datadir}/gtk-doc
10139N/A%{_mandir}/man3
10139N/A
10139N/A%files tools
10139N/A%{_bindir}/gst-*
10139N/A%{_mandir}/man1/gst-*
10139N/A
10139N/A%changelog
10139N/A* Wed May 02 2012 - brian.cameron@oracle.com
10139N/A- Bump to 0.10.36.
12893N/A* Fri Apr 27 2012 - brian.cameron@oracle.com
10139N/A- Add patch gst-02-amd64.diff.
10139N/A* Sat Oct 01 2011 - brian.cameron@oracle.com
11358N/A- Bump to 0.10.35.
11358N/A* Mon Jan 24 2011 - brian.cameron@oracle.com
11358N/A- bump to 0.10.32.
11358N/A* Fri Jan 14 2011 - brian.cameron@oracle.com
10248N/A- Bump to 0.10.31.
10248N/A* Thu Jul 15 2010 - brian.cameron@oracle.com
10139N/A- Bump to 0.10.30.
10139N/A* Thu Apr 29 2010 - brian.cameron@sun.com
10139N/A- Bump to 0.10.29.
10139N/A* Thu Mar 11 2010 - christian.kelly@sun.com
10139N/A- Bump to 0.10.28.
10139N/A* Thu Feb 11 2010 - brian.cameron@sun.com
10139N/A- Bump to 0.10.26.
10139N/A* Tue Nov 17 2009 - brian.cameron@sun.com
10139N/A- Change --with-check=no to --disable-check.
10139N/A* Wed Oct 14 2009 - dave.lin@sun.com
10139N/A- Bump to 0.10.25.
10139N/A* Wed Aug 12 2009 - christian.kelly@sun.com
10139N/A- Bump to 0.10.24.
10139N/A* Mon May 11 2009 - brian.cameron@sun.com
10139N/A- Bump to 0.10.23.
10139N/A* Mon Jan 19 2009 - brian.cameron@sun.com
10139N/A- Bump to 0.10.22.
10139N/A* Sat Oct 04 2008 - christian.kelly@sun.com
10139N/A- Bump to 0.10.21.
10139N/A* Thu Jun 19 2008 - damien.carbery@sun.com
10139N/A- Bump to 0.10.20.
10139N/A* Mon Apr 07 2008 - damien.carbery@sun.com
10139N/A- Bump to 0.10.19.
10139N/A* Thu Mar 20 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.18.
10139N/A* Mon Jan 30 2008 - jan.schmidt@sun.com
10139N/A- Bump to 0.10.17 paper bag release.
10139N/A* Mon Jan 28 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.16.
10139N/A* Fri Nov 16 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.15.
10139N/A* Fri Aug 03 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.14.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.13.
10139N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10139N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
10139N/A breaks when it finds the package.
10139N/A* Thu Mar 07 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.12.
10139N/A* Sat Mar 04 2007 - damien.carbery@sun.com
10139N/A- Add intltoolize call to expand MSGFMT_OPTS.
10139N/A* Tue Feb 06 2006 - brian.cameron@sun.com
10139N/A- Remove unneeded patch.
10139N/A* Mon Dec 11 2006 - brian.cameron@sun.com
10139N/A- Remove nofork patch since this is now fixed upstream.
10139N/A* Thu Dec 7 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.11.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Mon Oct 16 2006 - damien.carbery@sun.com
10139N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
10139N/A module source will be seen as a build error and action can be taken.
13317N/A* Mon Sep 11 2006 - brian.cameron@sun.com
13318N/A- Bump to 0.10.9.
13083N/A* Tue Aug 8 2006 - yandong.yao@sun.com
13083N/A- Add l10n-configure.sh script for l10n pkgs
13083N/A* Tue Jun 13 2006 - brian.cameron@sun.com
13024N/A- Bump to 0.10.8.
13024N/A* Tue Mar 14 2006 - damien.carbery@sun.com
12985N/A- Bump to 0.10.4.
12985N/A* Wed Feb 15 2006 - damien.carbery@sun.com
12985N/A- Bump to 0.10.3.
12985N/A* Mon Feb 13 2006 - damien.carbery@sun.com
12985N/A- Add hack to fix infinite loop problem in po/Makefile.
12985N/A* Sun Jan 22 2006 - damien.carbery@sun.com
12973N/A- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
12973N/A* Mon Jan 09 2006 - brian.cameron@sun.com
12872N/A- Bump to 0.10.1 The packaging will need some work if someone wants to build
12872N/A this for Linux.
12893N/A* Tue Sep 20 2005 - brian.cameron@sun.com
12830N/A- Bump to 0.8.11.
12830N/A* Thu Sep 08 2005 - damien.carbery@sun.com
12797N/A- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
12797N/A* Wed Sep 07 2005 - damien.carbery@sun.com
12578N/A- Bump to 0.9.2. Update %files.
12797N/A* Mon Jun 06 2005 - brian.cameron@sun.com
12508N/A- Removed patch for modifying uninstalled-pc file since it
12508N/A is no longer needed.
12151N/A* Wed May 11 2005 - brian.cameron@sun.com
12151N/A- Updated to call automake, now needed.
11991N/A* Wed Nov 17 2004 - matt.keenan@sun.com
11991N/A- #6195855, install correct man page.
11991N/A* Thu Oct 28 2004 - matt.keenan@sun.com
11989N/A- Add gst-*, libgst*.
11989N/A* Wed Sep 29 2004 - takao.fujiwara@sun.com
11898N/A- Update gst-02-g11n-potfiles.diff.
11898N/A- Update gst-03-gettext.diff to fix 5068957.
11416N/A- Remove gst-04-g11n-potfiles.diff.
11416N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
11358N/A- Add gst-04-g11n-potfiles.diff.
11358N/A* Sun Aug 29 2004 - laca@sun.com
11358N/A- Now packaging gtk-docs.
11256N/A* Tue Aug 23 2004 - brian.cameron@sun.com
11256N/A- Now building gtk-docs.
11205N/A* Fri Aug 20 2004 - brian.cameron@sun.com
11205N/A- Fixed typo.
11123N/A* Fri Aug 20 2004 - laszlo.kovacs@sun.com
11123N/A- gst-xmlinspect man page packaged.
11072N/A* Mon Aug 09 2004 - brian.cameron@sun.com
11072N/A- Corrected Linux packaging. Corrected Release to 2 since
11002N/A this is the 2nd change after bumping the release last
11002N/A Thursday.
10979N/A* Thu Jul 29 2004 - brian.cameron@sun.com
10979N/A- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
10934N/A since they were integrated into CVS head.
10934N/A* Fri Jul 15 2004 - brian.cameron@sun.com
10917N/A- Added patch to change the default scheduler to basicgthread which
10917N/A works better than opt for audio and opt doesn't work at all for
10840N/A video on Solaris.
10840N/A* Mon Jul 12 2004 - niall.power@sun.com
10840N/A- ported to rpm4, pkg'd some missing files.
10810N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10810N/A- Adding gst-l10n-po-1.2.tar.bz2 l10n content.
10776N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10776N/A- added "-j $CPUS" to make to speed up builds.
10776N/A* Fri May 14 2004 - brian.cameron@sun.com
10776N/A- added patch 03 from CVS head to support aligned memory access,
10723N/A needed for Solaris.
10776N/A* Wed May 12 2004 - ghee.teo@sun.com
10709N/A- Updated to tarball 0.8.1 version as per Laca and yippi request.
10624N/A* Mon May 10 2004 - laca@sun.com
10625N/A- autotools-jdsize to fix Makefile problem.
10625N/A* Thu May 02 2004 - brian.cameron@sun.com
10625N/A- Add glib-gettextize, aclocal, and autoconf calls
10624N/A so that gettext patches to configure.in/configure.ac
10617N/A get included. Added patches mentioned above to
10617N/A appropriate spec files.
10617N/A* Mon Apr 05 2004 - ghee.teo@sun.com
10617N/A- changed majorminor version to 0.8.
10609N/A* Fri Apr 02 2004 - ghee.teo@sun.com
10609N/A- Upgraded tarball to 0.8.0 which is released for 2.6.
10470N/A* Tue Mar 16 2004 - takao.fujiwara@sun.com
10470N/A- Added gst-02-g11n-potfiles.diff.
10470N/A* Mon Mar 08 2004 - niall.power@sun.com
10470N/A- add patch to fix gst-*-uninstslled.pc Cflags.
10470N/A- disable docs build on Solaris for now (causes gthread error) .
10444N/A* Fri Feb 13 2004 - matt.keenan@sun.com
10444N/A- Bump to 0.7.4, update tools files.
10444N/A* Mon Jan 05 2004 - ghee.teo@sun.com
10444N/A- Fixed the postinstall problem. Basically, gst has allowed for parallel
10437N/A installed and had decided to have program named by
10437N/A /usr/bin/gst-regsiter-<majorminor>
10345N/A since we do not have parallel installed on our distro, so configure with
10345N/A --program-suffix="" to remove the version number.
10345N/A* Wed Dec 17 2003 - glynn.foster@sun.com
10279N/A- bump to 0.7.2
10279N/A* Fri Oct 10 2003 - ghee.teo@sun.com
10279N/A- Removed the patch 01 which is already in 0.63 release of gstreamer
10264N/A updtaed spec file to build for Qs. and also include a patch from Bala
10264N/A as part of the fix to 4880305.
10248N/A* Fri Oct 03 2003 - ghee.teo@sun.com
10248N/A- Pulled out two patches from the 0.63 release that fixes a infinite loop
10248N/A and a crash, bugzilla 120741 and 104829.
10248N/A* Wed Jul 23 2003 - ghee.teo@sun.com
10248N/A- Added a patch to disable putbits which uses a potential patent ridden
10248N/A issue with mpeg.
10248N/A* Tue May 14 2003 - ghee.teo@sun.com
10155N/A- initial release version for gstreamer.
10155N/A