gst.spec revision 20901
10139N/A#
10139N/A# spec file for package gstreamer
10139N/A#
10139N/A# Copyright (c) 2003, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
16307N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner yippi
10139N/A#
17823N/A
10139N/A%define OSR 8760:0.10.19
10139N/A
10139N/AName: gstreamer
10139N/ALicense: LGPL v2, Public Domain
10139N/AGroup: Libraries/Multimedia
10139N/AVersion: 0.10.35
18688N/ARelease: 1
18688N/ADistribution: Java Desktop System
10139N/AVendor: freedesktop.org
19013N/ASummary: GStreamer streaming media framework runtime.
10139N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
10139N/A%if %build_l10n
12856N/ASource1: l10n-configure.sh
19140N/A%endif
10139N/A
10139N/A#owner:laca date:2005-08-11 type:bug bugster:6570425
19142N/APatch1: gst-01-gettext.diff
16401N/A#owner:yippi date:2012-04-03 type:bug
10139N/APatch2: gst-02-amd64.diff
16401N/AURL: http://gstreamer.net/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11379N/ADocdir: %{_defaultdocdir}/doc
16307N/AAutoreqprov: on
13384N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
12032N/APrereq: /sbin/ldconfig
12032N/A
12032N/A%define glib2_version 2.0.1
12032N/A%define libxml2_version 2.4.0
19142N/A
12032N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: popt
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
19142N/ABuildRequires: flex
10139N/ABuildRequires: gtk-doc >= 0.7
10139N/ABuildRequires: gcc
10139N/ABuildRequires: zlib-devel
10139N/ABuildRequires: popt
10139N/ABuildRequires: pyxml
10139N/A
19126N/A%description
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
19126N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
19142N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/A%package devel
10139N/ASummary: Libraries/include files for GStreamer streaming media frame
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10139N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/A
10139N/A%description devel
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
13423N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the libraries and includes files necessary to develop
10139N/Aapplications and plugins for GStreamer.
10139N/A
10139N/A%package tools
10139N/ASummary: tools for GStreamer streaming media framework.
10139N/AGroup: Libraries/Multimedia
10139N/A
10139N/A%description tools
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the basic command-line tools used for GStreamer, like
10139N/Agst-launch. It is split off to allow parallel-installability in the future.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
10139N/A%build
16307N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
16307N/Afi
12032N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Alibtoolize --copy --force
10139N/Aintltoolize --copy --force --automake
10139N/Aaclocal -I ./m4 -I common/m4 $ACLOCAL_FLAGS -I .
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
17401N/Aautoheader
17401N/Aautoconf
17401N/Aautomake -a -c -f
17401N/A./configure \
17156N/A --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
12032N/A --libdir=%{_libdir} \
12032N/A --libexecdir=%{_libexecdir} \
12032N/A --sysconfdir=%{_sysconfdir} \
12032N/A --mandir=%{_mandir} \
12032N/A %{gtk_doc_option} \
10139N/A --disable-tests --disable-examples \
10139N/A --program-suffix="" --disable-check
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%post tools
10139N/A/sbin/ldconfig
10139N/A
16307N/A%post devel
16307N/A/sbin/ldconfig
14308N/A
14308N/A%postun
13423N/A/sbin/ldconfig
13423N/A
13423N/A%files
13384N/A%defattr(-, root, root)
13384N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
12112N/A%{_libdir}/lib*.so.*
12112N/A%{_libdir}/gstreamer-*/libgst*.so*
12032N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
12032N/A
11379N/A%files devel
11379N/A%defattr(-, root, root)
11379N/A%{_includedir}/*
11379N/A%{_libdir}/lib*.so
10139N/A%{_libdir}/pkgconfig
10139N/A%{_datadir}/aclocal
10139N/A%{_datadir}/gtk-doc
10139N/A%{_mandir}/man3
10139N/A
10139N/A%files tools
10139N/A%{_bindir}/gst-*
10139N/A%{_mandir}/man1/gst-*
10139N/A
10139N/A%changelog
10139N/A* Fri Apr 27 2012 - brian.cameron@oracle.com
10139N/A- Add patch gst-02-amd64.diff.
10139N/A* Sat Oct 01 2011 - brian.cameron@oracle.com
10139N/A- Bump to 0.10.35.
10139N/A* Mon Jan 24 2011 - brian.cameron@oracle.com
10139N/A- bump to 0.10.32.
10139N/A* Fri Jan 14 2011 - brian.cameron@oracle.com
10139N/A- Bump to 0.10.31.
10139N/A* Thu Jul 15 2010 - brian.cameron@oracle.com
10139N/A- Bump to 0.10.30.
10139N/A* Thu Apr 29 2010 - brian.cameron@sun.com
10139N/A- Bump to 0.10.29.
10139N/A* Thu Mar 11 2010 - christian.kelly@sun.com
10139N/A- Bump to 0.10.28.
10139N/A* Thu Feb 11 2010 - brian.cameron@sun.com
10139N/A- Bump to 0.10.26.
10139N/A* Tue Nov 17 2009 - brian.cameron@sun.com
10139N/A- Change --with-check=no to --disable-check.
10139N/A* Wed Oct 14 2009 - dave.lin@sun.com
10139N/A- Bump to 0.10.25.
10139N/A* Wed Aug 12 2009 - christian.kelly@sun.com
10139N/A- Bump to 0.10.24.
10139N/A* Mon May 11 2009 - brian.cameron@sun.com
10139N/A- Bump to 0.10.23.
16401N/A* Mon Jan 19 2009 - brian.cameron@sun.com
19223N/A- Bump to 0.10.22.
19540N/A* Sat Oct 04 2008 - christian.kelly@sun.com
- Bump to 0.10.21.
* Thu Jun 19 2008 - damien.carbery@sun.com
- Bump to 0.10.20.
* Mon Apr 07 2008 - damien.carbery@sun.com
- Bump to 0.10.19.
* Thu Mar 20 2008 - brian.cameron@sun.com
- Bump to 0.10.18.
* Mon Jan 30 2008 - jan.schmidt@sun.com
- Bump to 0.10.17 paper bag release.
* Mon Jan 28 2008 - brian.cameron@sun.com
- Bump to 0.10.16.
* Fri Nov 16 2007 - damien.carbery@sun.com
- Bump to 0.10.15.
* Fri Aug 03 2007 - damien.carbery@sun.com
- Bump to 0.10.14.
* Tue Jun 19 2007 - damien.carbery@sun.com
- Bump to 0.10.13.
* Wed Mar 21 2007 - damien.carbery@sun.com
- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
breaks when it finds the package.
* Thu Mar 07 2007 - damien.carbery@sun.com
- Bump to 0.10.12.
* Sat Mar 04 2007 - damien.carbery@sun.com
- Add intltoolize call to expand MSGFMT_OPTS.
* Tue Feb 06 2006 - brian.cameron@sun.com
- Remove unneeded patch.
* Mon Dec 11 2006 - brian.cameron@sun.com
- Remove nofork patch since this is now fixed upstream.
* Thu Dec 7 2006 - brian.cameron@sun.com
- Bump to 0.10.11.
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Mon Oct 16 2006 - damien.carbery@sun.com
- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
module source will be seen as a build error and action can be taken.
* Mon Sep 11 2006 - brian.cameron@sun.com
- Bump to 0.10.9.
* Tue Aug 8 2006 - yandong.yao@sun.com
- Add l10n-configure.sh script for l10n pkgs
* Tue Jun 13 2006 - brian.cameron@sun.com
- Bump to 0.10.8.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Bump to 0.10.4.
* Wed Feb 15 2006 - damien.carbery@sun.com
- Bump to 0.10.3.
* Mon Feb 13 2006 - damien.carbery@sun.com
- Add hack to fix infinite loop problem in po/Makefile.
* Sun Jan 22 2006 - damien.carbery@sun.com
- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
* Mon Jan 09 2006 - brian.cameron@sun.com
- Bump to 0.10.1 The packaging will need some work if someone wants to build
this for Linux.
* Tue Sep 20 2005 - brian.cameron@sun.com
- Bump to 0.8.11.
* Thu Sep 08 2005 - damien.carbery@sun.com
- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
* Wed Sep 07 2005 - damien.carbery@sun.com
- Bump to 0.9.2. Update %files.
* Mon Jun 06 2005 - brian.cameron@sun.com
- Removed patch for modifying uninstalled-pc file since it
is no longer needed.
* Wed May 11 2005 - brian.cameron@sun.com
- Updated to call automake, now needed.
* Wed Nov 17 2004 - matt.keenan@sun.com
- #6195855, install correct man page.
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add gst-*, libgst*.
* Wed Sep 29 2004 - takao.fujiwara@sun.com
- Update gst-02-g11n-potfiles.diff.
- Update gst-03-gettext.diff to fix 5068957.
- Remove gst-04-g11n-potfiles.diff.
* Mon Aug 30 2004 - takao.fujiwara@sun.com
- Add gst-04-g11n-potfiles.diff.
* Sun Aug 29 2004 - laca@sun.com
- Now packaging gtk-docs.
* Tue Aug 23 2004 - brian.cameron@sun.com
- Now building gtk-docs.
* Fri Aug 20 2004 - brian.cameron@sun.com
- Fixed typo.
* Fri Aug 20 2004 - laszlo.kovacs@sun.com
- gst-xmlinspect man page packaged.
* Mon Aug 09 2004 - brian.cameron@sun.com
- Corrected Linux packaging. Corrected Release to 2 since
this is the 2nd change after bumping the release last
Thursday.
* Thu Jul 29 2004 - brian.cameron@sun.com
- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
since they were integrated into CVS head.
* Fri Jul 15 2004 - brian.cameron@sun.com
- Added patch to change the default scheduler to basicgthread which
works better than opt for audio and opt doesn't work at all for
video on Solaris.
* Mon Jul 12 2004 - niall.power@sun.com
- ported to rpm4, pkg'd some missing files.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Adding gst-l10n-po-1.2.tar.bz2 l10n content.
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds.
* Fri May 14 2004 - brian.cameron@sun.com
- added patch 03 from CVS head to support aligned memory access,
needed for Solaris.
* Wed May 12 2004 - ghee.teo@sun.com
- Updated to tarball 0.8.1 version as per Laca and yippi request.
* Mon May 10 2004 - laca@sun.com
- autotools-jdsize to fix Makefile problem.
* Thu May 02 2004 - brian.cameron@sun.com
- Add glib-gettextize, aclocal, and autoconf calls
so that gettext patches to configure.in/configure.ac
get included. Added patches mentioned above to
appropriate spec files.
* Mon Apr 05 2004 - ghee.teo@sun.com
- changed majorminor version to 0.8.
* Fri Apr 02 2004 - ghee.teo@sun.com
- Upgraded tarball to 0.8.0 which is released for 2.6.
* Tue Mar 16 2004 - takao.fujiwara@sun.com
- Added gst-02-g11n-potfiles.diff.
* Mon Mar 08 2004 - niall.power@sun.com
- add patch to fix gst-*-uninstslled.pc Cflags.
- disable docs build on Solaris for now (causes gthread error) .
* Fri Feb 13 2004 - matt.keenan@sun.com
- Bump to 0.7.4, update tools files.
* Mon Jan 05 2004 - ghee.teo@sun.com
- Fixed the postinstall problem. Basically, gst has allowed for parallel
installed and had decided to have program named by
/usr/bin/gst-regsiter-<majorminor>
since we do not have parallel installed on our distro, so configure with
--program-suffix="" to remove the version number.
* Wed Dec 17 2003 - glynn.foster@sun.com
- bump to 0.7.2
* Fri Oct 10 2003 - ghee.teo@sun.com
- Removed the patch 01 which is already in 0.63 release of gstreamer
updtaed spec file to build for Qs. and also include a patch from Bala
as part of the fix to 4880305.
* Fri Oct 03 2003 - ghee.teo@sun.com
- Pulled out two patches from the 0.63 release that fixes a infinite loop
and a crash, bugzilla 120741 and 104829.
* Wed Jul 23 2003 - ghee.teo@sun.com
- Added a patch to disable putbits which uses a potential patent ridden
issue with mpeg.
* Tue May 14 2003 - ghee.teo@sun.com
- initial release version for gstreamer.