gst.spec revision 20841
10710N/A#
10710N/A# spec file for package gstreamer
10710N/A#
10710N/A# Copyright (c) 2003, 2011, Oracle and/or its affiliates. All rights reserved.
10710N/A# This file and all modifications and additions to the pristine
10710N/A# package are under the same license as the package itself.
10710N/A#
20129N/A%define owner yippi
10843N/A#
10843N/A
10710N/A%define OSR 8760:0.10.19
17178N/A
17178N/AName: gstreamer
17178N/ALicense: LGPL v2, Public Domain
10710N/AGroup: Libraries/Multimedia
10710N/AVersion: 0.10.35
20777N/ARelease: 1
10710N/ADistribution: Java Desktop System
10710N/AVendor: freedesktop.org
10710N/ASummary: GStreamer streaming media framework runtime.
10710N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
18616N/A%if %build_l10n
10710N/ASource1: l10n-configure.sh
19875N/A%endif
12773N/A
15153N/A#owner:laca date:2005-08-11 type:bug bugster:6570425
15153N/APatch1: gst-01-gettext.diff
12773N/AURL: http://gstreamer.net/
16604N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10881N/ADocdir: %{_defaultdocdir}/doc
16604N/AAutoreqprov: on
13952N/ADocdir: %{_defaultdocdir}/doc
16604N/AAutoreqprov: on
10881N/APrereq: /sbin/ldconfig
16604N/A
10881N/A%define glib2_version 2.0.1
16604N/A%define libxml2_version 2.4.0
11114N/A
13957N/ARequires: glib2 >= %{glib2_version}
13957N/ARequires: libxml2 >= %{libxml2_version}
17391N/ARequires: popt
17012N/ABuildRequires: glib2-devel >= %{glib2_version}
17216N/ABuildRequires: libxml2-devel >= %{libxml2_version}
17216N/ABuildRequires: flex
17216N/ABuildRequires: gtk-doc >= 0.7
17216N/ABuildRequires: gcc
17455N/ABuildRequires: zlib-devel
17455N/ABuildRequires: popt
17455N/ABuildRequires: pyxml
18757N/A
18757N/A%description
18757N/AGStreamer is a streaming-media framework, based on graphs of filters which
10710N/Aoperate on media data. Applications using this library can do anything
10710N/Afrom real-time sound processing to playing videos, and just about anything
10710N/Aelse media-related. Its plugin-based architecture means that new data
10710N/Atypes or processing capabilities can be added simply by installing new
13079N/Aplugins.
10710N/A
10710N/A%package devel
10710N/ASummary: Libraries/include files for GStreamer streaming media frame
10710N/AGroup: Development/Libraries
10710N/ARequires: %{name} = %{version}
10710N/ARequires: glib2-devel >= %{glib2_version}
10710N/ARequires: libxml2-devel >= %{libxml2_version}
10710N/A
10710N/A%description devel
10710N/AGStreamer is a streaming-media framework, based on graphs of filters which
10710N/Aoperate on media data. Applications using this library can do anything
10710N/Afrom real-time sound processing to playing videos, and just about anything
10710N/Aelse media-related. Its plugin-based architecture means that new data
10710N/Atypes or processing capabilities can be added simply by installing new
10710N/Aplugins.
10710N/A
10710N/AThis package contains the libraries and includes files necessary to develop
10710N/Aapplications and plugins for GStreamer.
10710N/A
10710N/A%package tools
10710N/ASummary: tools for GStreamer streaming media framework.
10710N/AGroup: Libraries/Multimedia
10710N/A
10710N/A%description tools
10710N/AGStreamer is a streaming-media framework, based on graphs of filters which
10710N/Aoperate on media data. Applications using this library can do anything
10710N/Afrom real-time sound processing to playing videos, and just about anything
10710N/Aelse media-related. Its plugin-based architecture means that new data
10710N/Atypes or processing capabilities can be added simply by installing new
10710N/Aplugins.
13079N/A
13079N/AThis package contains the basic command-line tools used for GStreamer, like
13079N/Agst-launch. It is split off to allow parallel-installability in the future.
13079N/A
10710N/A%prep
10710N/A%setup -q
10710N/A%patch1 -p1
10710N/A
11114N/A%build
13957N/A%ifos linux
17012N/Aif [ -x /usr/bin/getconf ]; then
17216N/A CPUS=`getconf _NPROCESSORS_ONLN`
17455N/Afi
18757N/A%else
10710N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10710N/A%endif
10710N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10710N/A CPUS=1
10710N/Afi
10710N/A
10710N/Aglib-gettextize -f
10710N/Alibtoolize --copy --force
10710N/Aintltoolize --copy --force --automake
10710N/Aaclocal -I ./m4 -I common/m4 $ACLOCAL_FLAGS -I .
10710N/A
10710N/A%if %build_l10n
10710N/Abash -x %SOURCE1 --enable-copyright
10710N/A%endif
10710N/A
11149N/Aautoheader
12773N/Aautoconf
12773N/Aautomake -a -c -f
12773N/A./configure \
12773N/A --prefix=%{_prefix} \
12773N/A --bindir=%{_bindir} \
10710N/A --libdir=%{_libdir} \
10710N/A --libexecdir=%{_libexecdir} \
10710N/A --sysconfdir=%{_sysconfdir} \
10710N/A --mandir=%{_mandir} \
10710N/A %{gtk_doc_option} \
10710N/A --disable-tests --disable-examples \
10710N/A --program-suffix="" --disable-check
10710N/A
10710N/A# FIXME: hack: stop the build from looping
10710N/Atouch po/stamp-it
10710N/A
10710N/Amake -j $CPUS
10710N/A
10710N/A%install
10710N/Amake DESTDIR=$RPM_BUILD_ROOT install
10710N/A
10710N/A%clean
12831N/Arm -rf $RPM_BUILD_ROOT
18240N/A
13282N/A%post
13079N/A/sbin/ldconfig
13079N/A
13466N/A%post tools
17239N/A/sbin/ldconfig
17239N/A
10710N/A%post devel
10710N/A/sbin/ldconfig
10710N/A
17195N/A%postun
17195N/A/sbin/ldconfig
17195N/A
17195N/A%files
17195N/A%defattr(-, root, root)
17195N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
10710N/A%{_libdir}/lib*.so.*
10710N/A%{_libdir}/gstreamer-*/libgst*.so*
10710N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10710N/A
12741N/A%files devel
10710N/A%defattr(-, root, root)
10710N/A%{_includedir}/*
10710N/A%{_libdir}/lib*.so
12557N/A%{_libdir}/pkgconfig
10881N/A%{_datadir}/aclocal
10881N/A%{_datadir}/gtk-doc
10881N/A%{_mandir}/man3
11947N/A
12741N/A%files tools
12741N/A%{_bindir}/gst-*
10710N/A%{_mandir}/man1/gst-*
10710N/A
10710N/A%changelog
10710N/A* Sat Oct 01 2011 - brian.cameron@oracle.com
10710N/A- Bump to 0.10.35.
10710N/A* Mon Jan 24 2011 - brian.cameron@oracle.com
10710N/A- bump to 0.10.32.
10710N/A* Fri Jan 14 2011 - brian.cameron@oracle.com
10710N/A- Bump to 0.10.31.
10710N/A* Thu Jul 15 2010 - brian.cameron@oracle.com
10710N/A- Bump to 0.10.30.
10710N/A* Thu Apr 29 2010 - brian.cameron@sun.com
10710N/A- Bump to 0.10.29.
10710N/A* Thu Mar 11 2010 - christian.kelly@sun.com
17061N/A- Bump to 0.10.28.
17061N/A* Thu Feb 11 2010 - brian.cameron@sun.com
17061N/A- Bump to 0.10.26.
17061N/A* Tue Nov 17 2009 - brian.cameron@sun.com
10710N/A- Change --with-check=no to --disable-check.
10710N/A* Wed Oct 14 2009 - dave.lin@sun.com
10710N/A- Bump to 0.10.25.
10710N/A* Wed Aug 12 2009 - christian.kelly@sun.com
10710N/A- Bump to 0.10.24.
10710N/A* Mon May 11 2009 - brian.cameron@sun.com
10710N/A- Bump to 0.10.23.
10710N/A* Mon Jan 19 2009 - brian.cameron@sun.com
10710N/A- Bump to 0.10.22.
10710N/A* Sat Oct 04 2008 - christian.kelly@sun.com
10710N/A- Bump to 0.10.21.
20777N/A* Thu Jun 19 2008 - damien.carbery@sun.com
20777N/A- Bump to 0.10.20.
20777N/A* Mon Apr 07 2008 - damien.carbery@sun.com
20777N/A- Bump to 0.10.19.
20131N/A* Thu Mar 20 2008 - brian.cameron@sun.com
20131N/A- Bump to 0.10.18.
20031N/A* Mon Jan 30 2008 - jan.schmidt@sun.com
20031N/A- Bump to 0.10.17 paper bag release.
19959N/A* Mon Jan 28 2008 - brian.cameron@sun.com
19959N/A- Bump to 0.10.16.
19923N/A* Fri Nov 16 2007 - damien.carbery@sun.com
19923N/A- Bump to 0.10.15.
19881N/A* Fri Aug 03 2007 - damien.carbery@sun.com
19881N/A- Bump to 0.10.14.
19843N/A* Tue Jun 19 2007 - damien.carbery@sun.com
19843N/A- Bump to 0.10.13.
19136N/A* Wed Mar 21 2007 - damien.carbery@sun.com
19136N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
19104N/A breaks when it finds the package.
19104N/A* Thu Mar 07 2007 - damien.carbery@sun.com
19104N/A- Bump to 0.10.12.
19077N/A* Sat Mar 04 2007 - damien.carbery@sun.com
18950N/A- Add intltoolize call to expand MSGFMT_OPTS.
18950N/A* Tue Feb 06 2006 - brian.cameron@sun.com
18811N/A- Remove unneeded patch.
18811N/A* Mon Dec 11 2006 - brian.cameron@sun.com
18757N/A- Remove nofork patch since this is now fixed upstream.
18757N/A* Thu Dec 7 2006 - brian.cameron@sun.com
18742N/A- Bump to 0.10.11.
18742N/A* Fri Nov 3 2006 - laca@sun.com
18542N/A- use %gtk_doc_option in configure so that it can be disabled using
18542N/A --without-gtk-doc
18380N/A* Mon Oct 16 2006 - damien.carbery@sun.com
18380N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
18318N/A module source will be seen as a build error and action can be taken.
18318N/A* Mon Sep 11 2006 - brian.cameron@sun.com
18240N/A- Bump to 0.10.9.
18240N/A* Tue Aug 8 2006 - yandong.yao@sun.com
18240N/A- Add l10n-configure.sh script for l10n pkgs
18038N/A* Tue Jun 13 2006 - brian.cameron@sun.com
18038N/A- Bump to 0.10.8.
18030N/A* Tue Mar 14 2006 - damien.carbery@sun.com
18030N/A- Bump to 0.10.4.
18026N/A* Wed Feb 15 2006 - damien.carbery@sun.com
18026N/A- Bump to 0.10.3.
17945N/A* Mon Feb 13 2006 - damien.carbery@sun.com
17945N/A- Add hack to fix infinite loop problem in po/Makefile.
17808N/A* Sun Jan 22 2006 - damien.carbery@sun.com
17808N/A- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
17808N/A* Mon Jan 09 2006 - brian.cameron@sun.com
17563N/A- Bump to 0.10.1 The packaging will need some work if someone wants to build
17563N/A this for Linux.
17808N/A* Tue Sep 20 2005 - brian.cameron@sun.com
17455N/A- Bump to 0.8.11.
17455N/A* Thu Sep 08 2005 - damien.carbery@sun.com
17391N/A- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
17391N/A* Wed Sep 07 2005 - damien.carbery@sun.com
17239N/A- Bump to 0.9.2. Update %files.
17239N/A* Mon Jun 06 2005 - brian.cameron@sun.com
17216N/A- Removed patch for modifying uninstalled-pc file since it
17216N/A is no longer needed.
17217N/A* Wed May 11 2005 - brian.cameron@sun.com
17195N/A- Updated to call automake, now needed.
17195N/A* Wed Nov 17 2004 - matt.keenan@sun.com
17068N/A- #6195855, install correct man page.
17068N/A* Thu Oct 28 2004 - matt.keenan@sun.com
17061N/A- Add gst-*, libgst*.
17061N/A* Wed Sep 29 2004 - takao.fujiwara@sun.com
16720N/A- Update gst-02-g11n-potfiles.diff.
16720N/A- Update gst-03-gettext.diff to fix 5068957.
16705N/A- Remove gst-04-g11n-potfiles.diff.
16705N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
16546N/A- Add gst-04-g11n-potfiles.diff.
16546N/A* Sun Aug 29 2004 - laca@sun.com
16546N/A- Now packaging gtk-docs.
16503N/A* Tue Aug 23 2004 - brian.cameron@sun.com
16503N/A- Now building gtk-docs.
16503N/A* Fri Aug 20 2004 - brian.cameron@sun.com
16388N/A- Fixed typo.
16388N/A* Fri Aug 20 2004 - laszlo.kovacs@sun.com
16388N/A- gst-xmlinspect man page packaged.
16121N/A* Mon Aug 09 2004 - brian.cameron@sun.com
16121N/A- Corrected Linux packaging. Corrected Release to 2 since
16121N/A this is the 2nd change after bumping the release last
16104N/A Thursday.
16104N/A* Thu Jul 29 2004 - brian.cameron@sun.com
16104N/A- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
16028N/A since they were integrated into CVS head.
16028N/A* Fri Jul 15 2004 - brian.cameron@sun.com
16028N/A- Added patch to change the default scheduler to basicgthread which
15590N/A works better than opt for audio and opt doesn't work at all for
15590N/A video on Solaris.
15590N/A* Mon Jul 12 2004 - niall.power@sun.com
15255N/A- ported to rpm4, pkg'd some missing files.
15255N/A* Thu Jul 08 2004 - damien.donlon@sun.com
15255N/A- Adding gst-l10n-po-1.2.tar.bz2 l10n content.
15232N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
15232N/A- added "-j $CPUS" to make to speed up builds.
15232N/A* Fri May 14 2004 - brian.cameron@sun.com
14097N/A- added patch 03 from CVS head to support aligned memory access,
14097N/A needed for Solaris.
14097N/A* Wed May 12 2004 - ghee.teo@sun.com
13957N/A- Updated to tarball 0.8.1 version as per Laca and yippi request.
13957N/A* Mon May 10 2004 - laca@sun.com
13957N/A- autotools-jdsize to fix Makefile problem.
13952N/A* Thu May 02 2004 - brian.cameron@sun.com
13952N/A- Add glib-gettextize, aclocal, and autoconf calls
13952N/A so that gettext patches to configure.in/configure.ac
13510N/A get included. Added patches mentioned above to
13510N/A appropriate spec files.
13510N/A* Mon Apr 05 2004 - ghee.teo@sun.com
13466N/A- changed majorminor version to 0.8.
13466N/A* Fri Apr 02 2004 - ghee.teo@sun.com
13466N/A- Upgraded tarball to 0.8.0 which is released for 2.6.
13466N/A* Tue Mar 16 2004 - takao.fujiwara@sun.com
13466N/A- Added gst-02-g11n-potfiles.diff.
13466N/A* Mon Mar 08 2004 - niall.power@sun.com
13303N/A- add patch to fix gst-*-uninstslled.pc Cflags.
13303N/A- disable docs build on Solaris for now (causes gthread error) .
13466N/A* Fri Feb 13 2004 - matt.keenan@sun.com
13282N/A- Bump to 0.7.4, update tools files.
13282N/A* Mon Jan 05 2004 - ghee.teo@sun.com
13282N/A- Fixed the postinstall problem. Basically, gst has allowed for parallel
13079N/A installed and had decided to have program named by
13079N/A /usr/bin/gst-regsiter-<majorminor>
12557N/A since we do not have parallel installed on our distro, so configure with
12557N/A --program-suffix="" to remove the version number.
12557N/A* Wed Dec 17 2003 - glynn.foster@sun.com
12543N/A- bump to 0.7.2
12543N/A* Fri Oct 10 2003 - ghee.teo@sun.com
12543N/A- Removed the patch 01 which is already in 0.63 release of gstreamer
12126N/A updtaed spec file to build for Qs. and also include a patch from Bala
12126N/A as part of the fix to 4880305.
12126N/A* Fri Oct 03 2003 - ghee.teo@sun.com
12042N/A- Pulled out two patches from the 0.63 release that fixes a infinite loop
12042N/A and a crash, bugzilla 120741 and 104829.
12042N/A* Wed Jul 23 2003 - ghee.teo@sun.com
11867N/A- Added a patch to disable putbits which uses a potential patent ridden
11867N/A issue with mpeg.
11867N/A* Tue May 14 2003 - ghee.teo@sun.com
11847N/A- initial release version for gstreamer.
11847N/A