gst.spec revision 19026
10139N/A#
10139N/A# spec file for package gstreamer
10139N/A#
12184N/A# Copyright (c) 2010 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17822N/A%define owner yippi
10139N/A#
17180N/A
18603N/A%define OSR 8760:0.10.19
17180N/A
10139N/AName: gstreamer
10139N/ALicense: LGPL v2, Public Domain
10139N/AGroup: Libraries/Multimedia
10139N/AVersion: 0.10.30
10139N/ARelease: 1
19036N/ADistribution: Java Desktop System
10139N/AVendor: freedesktop.org
10139N/ASummary: GStreamer streaming media framework runtime.
18615N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
10139N/A%if %build_l10n
18532N/ASource1: l10n-configure.sh
10139N/A%endif
12773N/A
12773N/A#owner:laca date:2005-08-11 type:bug bugster:6570425
12773N/APatch1: gst-01-gettext.diff
10139N/AURL: http://gstreamer.net/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define glib2_version 2.0.1
10139N/A%define libxml2_version 2.4.0
10139N/A
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: popt
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10139N/ABuildRequires: flex
10139N/ABuildRequires: gtk-doc >= 0.7
10139N/ABuildRequires: gcc
10139N/ABuildRequires: zlib-devel
10139N/ABuildRequires: popt
10139N/ABuildRequires: pyxml
10139N/A
10139N/A%description
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/A%package devel
10139N/ASummary: Libraries/include files for GStreamer streaming media frame
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10504N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/A
10139N/A%description devel
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the libraries and includes files necessary to develop
10139N/Aapplications and plugins for GStreamer.
10139N/A
11439N/A%package tools
10139N/ASummary: tools for GStreamer streaming media framework.
10139N/AGroup: Libraries/Multimedia
11149N/A
12773N/A%description tools
12773N/AGStreamer is a streaming-media framework, based on graphs of filters which
12773N/Aoperate on media data. Applications using this library can do anything
12773N/Afrom real-time sound processing to playing videos, and just about anything
12773N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the basic command-line tools used for GStreamer, like
10139N/Agst-launch. It is split off to allow parallel-installability in the future.
10139N/A
10139N/A%prep
10139N/A%setup -q
12043N/A%patch1 -p1
13557N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
12184N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Alibtoolize --copy --force
10139N/Aintltoolize --copy --force --automake
10139N/Aaclocal -I ./m4 -I common/m4 $ACLOCAL_FLAGS -I .
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
12184N/A
10139N/Aautoheader
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_libexecdir} \
19036N/A --sysconfdir=%{_sysconfdir} \
19036N/A --mandir=%{_mandir} \
18685N/A %{gtk_doc_option} \
18685N/A --disable-tests --disable-examples \
18532N/A --program-suffix="" --disable-check
18532N/A
18449N/A# FIXME: hack: stop the build from looping
18449N/Atouch po/stamp-it
17570N/A
17570N/Amake -j $CPUS
17397N/A
17397N/A%install
17167N/Amake DESTDIR=$RPM_BUILD_ROOT install
17167N/A
17167N/A%clean
16561N/Arm -rf $RPM_BUILD_ROOT
16561N/A
14463N/A%post
14463N/A/sbin/ldconfig
14463N/A
13883N/A%post tools
13883N/A/sbin/ldconfig
13883N/A
13820N/A%post devel
13820N/A/sbin/ldconfig
13643N/A
13643N/A%postun
13557N/A/sbin/ldconfig
13557N/A
13557N/A%files
13461N/A%defattr(-, root, root)
13461N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
13457N/A%{_libdir}/lib*.so.*
13457N/A%{_libdir}/gstreamer-*/libgst*.so*
13272N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
13272N/A
12808N/A%files devel
12808N/A%defattr(-, root, root)
12586N/A%{_includedir}/*
12586N/A%{_libdir}/lib*.so
12360N/A%{_libdir}/pkgconfig
12360N/A%{_datadir}/aclocal
12288N/A%{_datadir}/gtk-doc
12295N/A%{_mandir}/man3
12184N/A
12184N/A%files tools
12043N/A%{_bindir}/gst-*
12043N/A%{_mandir}/man1/gst-*
12022N/A
12022N/A%changelog
11989N/A* Thu Jul 15 2010 - brian.cameron@oracle.com
11989N/A- Bump to 0.10.30.
11960N/A* Thu Apr 29 2010 - brian.cameron@sun.com
11960N/A- Bump to 0.10.29.
11416N/A* Thu Mar 11 2010 - christian.kelly@sun.com
11416N/A- Bump to 0.10.28.
11253N/A* Thu Feb 11 2010 - brian.cameron@sun.com
11253N/A- Bump to 0.10.26.
11149N/A* Tue Nov 17 2009 - brian.cameron@sun.com
11149N/A- Change --with-check=no to --disable-check.
11123N/A* Wed Oct 14 2009 - dave.lin@sun.com
11123N/A- Bump to 0.10.25.
10979N/A* Wed Aug 12 2009 - christian.kelly@sun.com
10979N/A- Bump to 0.10.24.
10917N/A* Mon May 11 2009 - brian.cameron@sun.com
10917N/A- Bump to 0.10.23.
10817N/A* Mon Jan 19 2009 - brian.cameron@sun.com
10817N/A- Bump to 0.10.22.
10642N/A* Sat Oct 04 2008 - christian.kelly@sun.com
10642N/A- Bump to 0.10.21.
10611N/A* Thu Jun 19 2008 - damien.carbery@sun.com
10611N/A- Bump to 0.10.20.
10504N/A* Mon Apr 07 2008 - damien.carbery@sun.com
10504N/A- Bump to 0.10.19.
10474N/A* Thu Mar 20 2008 - brian.cameron@sun.com
10474N/A- Bump to 0.10.18.
10285N/A* Mon Jan 30 2008 - jan.schmidt@sun.com
10285N/A- Bump to 0.10.17 paper bag release.
10139N/A* Mon Jan 28 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.16.
10139N/A* Fri Nov 16 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.15.
10139N/A* Fri Aug 03 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.14.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.13.
10139N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10139N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
10139N/A breaks when it finds the package.
10139N/A* Thu Mar 07 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.12.
10139N/A* Sat Mar 04 2007 - damien.carbery@sun.com
10139N/A- Add intltoolize call to expand MSGFMT_OPTS.
10139N/A* Tue Feb 06 2006 - brian.cameron@sun.com
10139N/A- Remove unneeded patch.
10139N/A* Mon Dec 11 2006 - brian.cameron@sun.com
10139N/A- Remove nofork patch since this is now fixed upstream.
10139N/A* Thu Dec 7 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.11.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Mon Oct 16 2006 - damien.carbery@sun.com
10139N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
10139N/A module source will be seen as a build error and action can be taken.
10139N/A* Mon Sep 11 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.9.
10139N/A* Tue Aug 8 2006 - yandong.yao@sun.com
10139N/A- Add l10n-configure.sh script for l10n pkgs
10139N/A* Tue Jun 13 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.8.
10139N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.10.4.
10139N/A* Wed Feb 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.10.3.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Add hack to fix infinite loop problem in po/Makefile.
10139N/A* Sun Jan 22 2006 - damien.carbery@sun.com
10139N/A- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
* Mon Jan 09 2006 - brian.cameron@sun.com
- Bump to 0.10.1 The packaging will need some work if someone wants to build
this for Linux.
* Tue Sep 20 2005 - brian.cameron@sun.com
- Bump to 0.8.11.
* Thu Sep 08 2005 - damien.carbery@sun.com
- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
* Wed Sep 07 2005 - damien.carbery@sun.com
- Bump to 0.9.2. Update %files.
* Mon Jun 06 2005 - brian.cameron@sun.com
- Removed patch for modifying uninstalled-pc file since it
is no longer needed.
* Wed May 11 2005 - brian.cameron@sun.com
- Updated to call automake, now needed.
* Wed Nov 17 2004 - matt.keenan@sun.com
- #6195855, install correct man page.
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add gst-*, libgst*.
* Wed Sep 29 2004 - takao.fujiwara@sun.com
- Update gst-02-g11n-potfiles.diff.
- Update gst-03-gettext.diff to fix 5068957.
- Remove gst-04-g11n-potfiles.diff.
* Mon Aug 30 2004 - takao.fujiwara@sun.com
- Add gst-04-g11n-potfiles.diff.
* Sun Aug 29 2004 - laca@sun.com
- Now packaging gtk-docs.
* Tue Aug 23 2004 - brian.cameron@sun.com
- Now building gtk-docs.
* Fri Aug 20 2004 - brian.cameron@sun.com
- Fixed typo.
* Fri Aug 20 2004 - laszlo.kovacs@sun.com
- gst-xmlinspect man page packaged.
* Mon Aug 09 2004 - brian.cameron@sun.com
- Corrected Linux packaging. Corrected Release to 2 since
this is the 2nd change after bumping the release last
Thursday.
* Thu Jul 29 2004 - brian.cameron@sun.com
- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
since they were integrated into CVS head.
* Fri Jul 15 2004 - brian.cameron@sun.com
- Added patch to change the default scheduler to basicgthread which
works better than opt for audio and opt doesn't work at all for
video on Solaris.
* Mon Jul 12 2004 - niall.power@sun.com
- ported to rpm4, pkg'd some missing files.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Adding gst-l10n-po-1.2.tar.bz2 l10n content.
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds.
* Fri May 14 2004 - brian.cameron@sun.com
- added patch 03 from CVS head to support aligned memory access,
needed for Solaris.
* Wed May 12 2004 - ghee.teo@sun.com
- Updated to tarball 0.8.1 version as per Laca and yippi request.
* Mon May 10 2004 - laca@sun.com
- autotools-jdsize to fix Makefile problem.
* Thu May 02 2004 - brian.cameron@sun.com
- Add glib-gettextize, aclocal, and autoconf calls
so that gettext patches to configure.in/configure.ac
get included. Added patches mentioned above to
appropriate spec files.
* Mon Apr 05 2004 - ghee.teo@sun.com
- changed majorminor version to 0.8.
* Fri Apr 02 2004 - ghee.teo@sun.com
- Upgraded tarball to 0.8.0 which is released for 2.6.
* Tue Mar 16 2004 - takao.fujiwara@sun.com
- Added gst-02-g11n-potfiles.diff.
* Mon Mar 08 2004 - niall.power@sun.com
- add patch to fix gst-*-uninstslled.pc Cflags.
- disable docs build on Solaris for now (causes gthread error) .
* Fri Feb 13 2004 - matt.keenan@sun.com
- Bump to 0.7.4, update tools files.
* Mon Jan 05 2004 - ghee.teo@sun.com
- Fixed the postinstall problem. Basically, gst has allowed for parallel
installed and had decided to have program named by
/usr/bin/gst-regsiter-<majorminor>
since we do not have parallel installed on our distro, so configure with
--program-suffix="" to remove the version number.
* Wed Dec 17 2003 - glynn.foster@sun.com
- bump to 0.7.2
* Fri Oct 10 2003 - ghee.teo@sun.com
- Removed the patch 01 which is already in 0.63 release of gstreamer
updtaed spec file to build for Qs. and also include a patch from Bala
as part of the fix to 4880305.
* Fri Oct 03 2003 - ghee.teo@sun.com
- Pulled out two patches from the 0.63 release that fixes a infinite loop
and a crash, bugzilla 120741 and 104829.
* Wed Jul 23 2003 - ghee.teo@sun.com
- Added a patch to disable putbits which uses a potential patent ridden
issue with mpeg.
* Tue May 14 2003 - ghee.teo@sun.com
- initial release version for gstreamer.