gst.spec revision 15322
10139N/A#
10139N/A# spec file for package gstreamer
10139N/A#
16880N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A#
16880N/AName: gstreamer
17178N/ALicense: LGPL v2, Public Domain
17178N/AGroup: Libraries/Multimedia
10139N/AVersion: 0.10.21
16880N/ARelease: 1
10139N/ADistribution: Java Desktop System
17724N/AVendor: Sun Microsystems, Inc.
12578N/ASummary: GStreamer streaming media framework runtime.
10139N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
17724N/A%endif
16880N/A
17733N/A#owner:laca date:2005-08-11 type:bug bugster:6570425
16880N/APatch1: gst-01-gettext.diff
17753N/AURL: http://gstreamer.net/
16880N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17089N/ADocdir: %{_defaultdocdir}/doc
17089N/AAutoreqprov: on
16880N/ADocdir: %{_defaultdocdir}/doc
16880N/AAutoreqprov: on
16880N/APrereq: /sbin/ldconfig
16880N/A
16880N/A%define glib2_version 2.0.1
17753N/A%define libxml2_version 2.4.0
16880N/A
16880N/ARequires: glib2 >= %{glib2_version}
16880N/ARequires: libxml2 >= %{libxml2_version}
16880N/ARequires: popt
17733N/ABuildRequires: glib2-devel >= %{glib2_version}
16880N/ABuildRequires: libxml2-devel >= %{libxml2_version}
17089N/ABuildRequires: flex
17073N/ABuildRequires: gtk-doc >= 0.7
17089N/ABuildRequires: gcc
17733N/ABuildRequires: zlib-devel
17074N/ABuildRequires: popt
17089N/ABuildRequires: pyxml
17733N/A
17733N/A%description
17222N/AGStreamer is a streaming-media framework, based on graphs of filters which
17725N/Aoperate on media data. Applications using this library can do anything
17247N/Afrom real-time sound processing to playing videos, and just about anything
17725N/Aelse media-related. Its plugin-based architecture means that new data
17285N/Atypes or processing capabilities can be added simply by installing new
17725N/Aplugins.
17753N/A
17753N/A%package devel
17753N/ASummary: Libraries/include files for GStreamer streaming media frame
17753N/AGroup: Development/Libraries
17753N/ARequires: %{name} = %{version}
17753N/ARequires: glib2-devel >= %{glib2_version}
17753N/ARequires: libxml2-devel >= %{libxml2_version}
17753N/A
17753N/A%description devel
17402N/AGStreamer is a streaming-media framework, based on graphs of filters which
17753N/Aoperate on media data. Applications using this library can do anything
17725N/Afrom real-time sound processing to playing videos, and just about anything
17535N/Aelse media-related. Its plugin-based architecture means that new data
17725N/Atypes or processing capabilities can be added simply by installing new
17546N/Aplugins.
17753N/A
17733N/AThis package contains the libraries and includes files necessary to develop
17733N/Aapplications and plugins for GStreamer.
17629N/A
17753N/A%package tools
17733N/ASummary: tools for GStreamer streaming media framework.
17672N/AGroup: Libraries/Multimedia
17753N/A
16880N/A%description tools
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
12274N/Atypes or processing capabilities can be added simply by installing new
12274N/Aplugins.
12274N/A
12274N/AThis package contains the basic command-line tools used for GStreamer, like
10139N/Agst-launch. It is split off to allow parallel-installability in the future.
10139N/A
10139N/A%prep
10139N/A%setup -q
11002N/A%patch1 -p1
13025N/A
17693N/A%build
17693N/A%ifos linux
17693N/Aif [ -x /usr/bin/getconf ]; then
17693N/A CPUS=`getconf _NPROCESSORS_ONLN`
17693N/Afi
17725N/A%else
17693N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17693N/A%endif
17725N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17693N/A CPUS=1
17693N/Afi
17693N/A
17693N/Aglib-gettextize -f
10139N/Aaclocal -I common/m4 $ACLOCAL_FLAGS
10139N/Alibtoolize --copy --force
10139N/Aintltoolize --copy --force --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aautoheader
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
16880N/A --sysconfdir=%{_sysconfdir} \
16880N/A --mandir=%{_mandir} \
16880N/A %{gtk_doc_option} \
16880N/A --disable-tests --disable-examples \
16880N/A --program-suffix="" --with-check=no
16880N/A
10139N/A# FIXME: hack: stop the build from looping
16880N/Atouch po/stamp-it
16880N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
16880N/Amake DESTDIR=$RPM_BUILD_ROOT install
16880N/Arm $RPM_BUILD_ROOT%{_libdir}/*/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
16880N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
11155N/A
16880N/A%clean
16880N/Arm -rf $RPM_BUILD_ROOT
17249N/A
17249N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%post tools
10139N/A/sbin/ldconfig
16880N/A
16880N/A%post devel
16880N/A/sbin/ldconfig
16880N/A
10139N/A%postun
17059N/A/sbin/ldconfig
17059N/A
17059N/A%files
16880N/A%defattr(-, root, root)
16880N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
16880N/A%{_libdir}/lib*.so.*
17059N/A%{_libdir}/gstreamer-*/libgst*.so*
17059N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
17611N/A
11358N/A%files devel
16880N/A%defattr(-, root, root)
16880N/A%{_includedir}/*
10248N/A%{_libdir}/lib*.so
17669N/A%{_libdir}/pkgconfig
16880N/A%{_datadir}/aclocal
16880N/A%{_datadir}/gtk-doc
10139N/A%{_mandir}/man3
10139N/A
10139N/A%files tools
10139N/A%{_bindir}/gst-*
10139N/A%{_mandir}/man1/gst-*
16880N/A
16880N/A%changelog
16880N/A* Sat Oct 04 2008 - christian.kelly@sun.com
16880N/A- Bump to 0.10.21.
16880N/A* Thu Jun 19 2008 - damien.carbery@sun.com
16880N/A- Bump to 0.10.20.
16880N/A* Mon Apr 07 2008 - damien.carbery@sun.com
16880N/A- Bump to 0.10.19.
16880N/A* Thu Mar 20 2008 - brian.cameron@sun.com
16880N/A- Bump to 0.10.18.
16880N/A* Mon Jan 30 2008 - jan.schmidt@sun.com
16880N/A- Bump to 0.10.17 paper bag release.
16880N/A* Mon Jan 28 2008 - brian.cameron@sun.com
16880N/A- Bump to 0.10.16.
16880N/A* Fri Nov 16 2007 - damien.carbery@sun.com
16880N/A- Bump to 0.10.15.
16880N/A* Fri Aug 03 2007 - damien.carbery@sun.com
16880N/A- Bump to 0.10.14.
16880N/A* Tue Jun 19 2007 - damien.carbery@sun.com
16880N/A- Bump to 0.10.13.
16880N/A* Wed Mar 21 2007 - damien.carbery@sun.com
16880N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
16880N/A breaks when it finds the package.
16880N/A* Thu Mar 07 2007 - damien.carbery@sun.com
16880N/A- Bump to 0.10.12.
16880N/A* Sat Mar 04 2007 - damien.carbery@sun.com
16880N/A- Add intltoolize call to expand MSGFMT_OPTS.
16880N/A* Tue Feb 06 2006 - brian.cameron@sun.com
16880N/A- Remove unneeded patch.
16880N/A* Mon Dec 11 2006 - brian.cameron@sun.com
16880N/A- Remove nofork patch since this is now fixed upstream.
10139N/A* Thu Dec 7 2006 - brian.cameron@sun.com
16880N/A- Bump to 0.10.11
16880N/A* Fri Nov 3 2006 - laca@sun.com
16880N/A- use %gtk_doc_option in configure so that it can be disabled using
16880N/A --without-gtk-doc
10139N/A* Mon Oct 16 2006 - damien.carbery@sun.com
10139N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
17753N/A module source will be seen as a build error and action can be taken.
17753N/A* Mon Sep 11 2006 - brian.cameron@sun.com
17724N/A- Bump to 0.10.9.
17724N/A* Tue Aug 8 2006 - yandong.yao@sun.com
17665N/A- Add l10n-configure.sh script for l10n pkgs
17669N/A* Tue Jun 13 2006 - brian.cameron@sun.com
17669N/A- Bump to 0.10.8.
17669N/A* Tue Mar 14 2006 - damien.carbery@sun.com
17668N/A- Bump to 0.10.4.
17668N/A* Wed Feb 15 2006 - damien.carbery@sun.com
17668N/A- Bump to 0.10.3.
17665N/A* Mon Feb 13 2006 - damien.carbery@sun.com
17621N/A- Add hack to fix infinite loop problem in po/Makefile.
17621N/A* Sun Jan 22 2006 - damien.carbery@sun.com
17610N/A- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
17610N/A* Mon Jan 09 2006 - brian.cameron@sun.com
17610N/A- Bump to 0.10.1 The packaging will need some work if someone wants to build
17610N/A this for Linux.
17562N/A* Tue Sep 20 2005 - brian.cameron@sun.com
17562N/A- Bump to 0.8.11.
17546N/A* Thu Sep 08 2005 - damien.carbery@sun.com
17546N/A- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
17535N/A* Wed Sep 07 2005 - damien.carbery@sun.com
17546N/A- Bump to 0.9.2. Update %files.
17546N/A* Mon Jun 06 2005 - brian.cameron@sun.com
17485N/A- Removed patch for modifying uninstalled-pc file since it
17485N/A is no longer needed.
17437N/A* Wed May 11 2005 - brian.cameron@sun.com
17437N/A- Updated to call automake, now needed.
17437N/A* Wed Nov 17 2004 - matt.keenan@sun.com
17402N/A- #6195855, install correct man page
17402N/A* Thu Oct 28 2004 - matt.keenan@sun.com
17346N/A- Add gst-*, libgst*
17346N/A* Wed Sep 29 2004 - takao.fujiwara@sun.com
17285N/A- Update gst-02-g11n-potfiles.diff
17285N/A- Update gst-03-gettext.diff to fix 5068957
17277N/A- Remove gst-04-g11n-potfiles.diff
17277N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
17277N/A- Add gst-04-g11n-potfiles.diff
17247N/A* Sun Aug 29 2004 - laca@sun.com
17277N/A- Now packaging gtk-docs.
17246N/A* Tue Aug 23 2004 - brian.cameron@sun.com
17246N/A- Now building gtk-docs.
17277N/A* Fri Aug 20 2004 - brian.cameron@sun.com
17245N/A- Fixed typo.
17245N/A* Fri Aug 20 2004 - laszlo.kovacs@sun.com
17245N/A- gst-xmlinspect man page packaged
17222N/A* Mon Aug 09 2004 - brian.cameron@sun.com
17222N/A- Corrected Linux packaging. Corrected Release to 2 since
17222N/A this is the 2nd change after bumping the release last
17209N/A Thursday.
17245N/A* Thu Jul 29 2004 - brian.cameron@sun.com
17200N/A- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
17245N/A since they were integrated into CVS head.
17186N/A* Fri Jul 15 2004 - brian.cameron@sun.com
17245N/A- Added patch to change the default scheduler to basicgthread which
17089N/A works better than opt for audio and opt doesn't work at all for
17089N/A video on Solaris.
17552N/A* Mon Jul 12 2004 - niall.power@sun.com
17073N/A- ported to rpm4, pkg'd some missing files
17059N/A* Thu Jul 08 2004 - damien.donlon@sun.com
17059N/A- Adding gst-l10n-po-1.2.tar.bz2 l10n content
17059N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
16880N/A- added "-j $CPUS" to make to speed up builds
16880N/A* Fri May 14 2004 - brian.cameron@sun.com
16880N/A- added patch 03 from CVS head to support aligned memory access,
16623N/A needed for Solaris.
16623N/A* Wed May 12 2004 - ghee.teo@sun.com
16511N/A- Updated to tarball 0.8.1 version as per Laca and yippi request.
16511N/A* Mon May 10 2004 - laca@sun.com
16395N/A- autotools-jdsize to fix Makefile problem
16395N/A* Thu May 02 2004 - brian.cameron@sun.com
16193N/A- Add glib-gettextize, aclocal, and autoconf calls
16193N/A so that gettext patches to configure.in/configure.ac
16190N/A get included. Added patches mentioned above to
16190N/A appropriate spec files.
16054N/A* Mon Apr 05 2004 - ghee.teo@sun.com
16054N/A- changed majorminor version to 0.8
16013N/A* Fri Apr 02 2004 - ghee.teo@sun.com
16013N/A- Upgraded tarball to 0.8.0 which is released for 2.6
16013N/A* Tue Mar 16 2004 - takao.fujiwara@sun.com
16038N/A- Added gst-02-g11n-potfiles.diff
15968N/A* Mon Mar 08 2004 - niall.power@sun.com
15968N/A- add patch to fix gst-*-uninstslled.pc Cflags.
15968N/A- disable docs build on Solaris for now (causes gthread error)
15792N/A* Fri Feb 13 2004 - matt.keenan@sun.com
15792N/A- Bump to 0.7.4, update tools files
15591N/A* Mon Jan 05 2004 - ghee.teo@sun.com
15591N/A- Fixed the postinstall problem. Basically, gst has allowed for parallel
15591N/A installed and had decided to have program named by
15543N/A /usr/bin/gst-regsiter-<majorminor>
15543N/A since we do not have parallel installed on our distro, so configure with
15543N/A --program-suffix="" to remove the version number.
15543N/A* Wed Dec 17 2003 - glynn.foster@sun.com
15503N/A- bump to 0.7.2
15503N/A* Fri Oct 10 2003 - ghee.teo@sun.com
15460N/A- Removed the patch 01 which is already in 0.63 release of gstreamer
15460N/A updtaed spec file to build for Qs. and also include a patch from Bala
15389N/A as part of the fix to 4880305.
15389N/A* Fri Oct 03 2003 - ghee.teo@sun.com
15389N/A- Pulled out two patches from the 0.63 release that fixes a infinite loop
15347N/A and a crash, bugzilla 120741 and 104829.
15347N/A* Wed Jul 23 2003 - ghee.teo@sun.com
15347N/A- Added a patch to disable putbits which uses a potential patent ridden
15347N/A issue with mpeg
15247N/A* Tue May 14 2003 - ghee.teo@sun.com
15247N/A- initial release version for gstreamer
15230N/A