gst.spec revision 11951
20903N/A#
10139N/A# spec file for package gstreamer
10139N/A#
20903N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A#
17177N/AName: gstreamer
18603N/ALicense: LGPL
17177N/AGroup: Libraries/Multimedia
10139N/AVersion: 0.10.15
19112N/ARelease: 4
10139N/ADistribution: Java Desktop System
22050N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: GStreamer streaming media framework runtime.
10139N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
18615N/ASource1: l10n-configure.sh
10139N/A
20903N/A#owner:laca date:2005-08-11 type:bug bugster:6329710
10139N/APatch1: gst-01-gettext.diff
16360N/AURL: http://gstreamer.net/
16428N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
16428N/ADocdir: %{_defaultdocdir}/doc
16428N/AAutoreqprov: on
16428N/ADocdir: %{_defaultdocdir}/doc
16428N/AAutoreqprov: on
10491N/APrereq: /sbin/ldconfig
12088N/A
10139N/A%define glib2_version 2.0.1
12088N/A%define libxml2_version 2.4.0
10139N/A
12088N/ARequires: glib2 >= %{glib2_version}
12176N/ARequires: libxml2 >= %{libxml2_version}
12196N/ARequires: popt
12306N/ABuildRequires: glib2-devel >= %{glib2_version}
12368N/ABuildRequires: libxml2-devel >= %{libxml2_version}
20216N/ABuildRequires: flex
20216N/ABuildRequires: gtk-doc >= 0.7
13088N/ABuildRequires: gcc
13278N/ABuildRequires: zlib-devel
16768N/ABuildRequires: popt
20216N/ABuildRequires: pyxml
20118N/A
20824N/A%description
20127N/AGStreamer is a streaming-media framework, based on graphs of filters which
20216N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/A%package devel
10139N/ASummary: Libraries/include files for GStreamer streaming media frame
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10139N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/A
10139N/A%description devel
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the libraries and includes files necessary to develop
10139N/Aapplications and plugins for GStreamer.
10139N/A
10139N/A%package tools
10139N/ASummary: tools for GStreamer streaming media framework.
10139N/AGroup: Libraries/Multimedia
10139N/A
10139N/A%description tools
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the basic command-line tools used for GStreamer, like
10139N/Agst-launch. It is split off to allow parallel-installability in the future.
12819N/A
12288N/A%prep
20216N/A%setup -q
15377N/A%patch1 -p1
14363N/A
15959N/Abash -x %SOURCE1
18549N/A
20824N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
20778N/Aaclocal -I common/m4 $ACLOCAL_FLAGS
20790N/Alibtoolize --copy --force
10139N/Aintltoolize --copy --force --automake
10139N/Aautoheader
10139N/Aautoconf
20790N/Aautomake -a -c -f
20216N/A./configure \
10139N/A --prefix=%{_prefix} \
18138N/A --sysconfdir=%{_sysconfdir} \
20127N/A --mandir=%{_mandir} \
20903N/A %{gtk_doc_option} \
10318N/A --disable-tests --disable-examples \
10318N/A --program-suffix="" --with-check=no
10318N/A
10318N/A# FIXME: hack: stop the build from looping
10318N/Atouch po/stamp-it
10139N/A
12140N/Amake -j $CPUS
20216N/A
20841N/A%install
20903N/Amake DESTDIR=$RPM_BUILD_ROOT install
16309N/Arm $RPM_BUILD_ROOT%{_libdir}/*/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
20790N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%post tools
20903N/A/sbin/ldconfig
20903N/A
20216N/A%post devel
17379N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_libdir}/gstreamer-*/libgst*.so*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/*
10139N/A%{_libdir}/lib*.so
10139N/A%{_libdir}/pkgconfig
10139N/A%{_datadir}/aclocal
10139N/A%{_datadir}/gtk-doc
10139N/A%{_mandir}/man3
10139N/A
10139N/A%files tools
10139N/A%{_bindir}/gst-*
10139N/A%{_mandir}/man1/gst-*
10139N/A
10139N/A%changelog
10139N/A* Fri Nov 16 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.15.
10139N/A* Fri Aug 03 2007 - damien.carbery@sun.com
22050N/A- Bump to 0.10.14.
22050N/A* Tue Jun 19 2007 - damien.carbery@sun.com
20916N/A- Bump to 0.10.13.
20916N/A* Wed Mar 21 2007 - damien.carbery@sun.com
20903N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
20903N/A breaks when it finds the package.
20862N/A* Thu Mar 07 2007 - damien.carbery@sun.com
20862N/A- Bump to 0.10.12.
20841N/A* Sat Mar 04 2007 - damien.carbery@sun.com
20841N/A- Add intltoolize call to expand MSGFMT_OPTS.
20832N/A* Tue Feb 06 2006 - brian.cameron@sun.com
20832N/A- Remove unneeded patch.
20831N/A* Mon Dec 11 2006 - brian.cameron@sun.com
20831N/A- Remove nofork patch since this is now fixed upstream.
20824N/A* Thu Dec 7 2006 - brian.cameron@sun.com
20824N/A- Bump to 0.10.11
20778N/A* Fri Nov 3 2006 - laca@sun.com
20778N/A- use %gtk_doc_option in configure so that it can be disabled using
20127N/A --without-gtk-doc
20127N/A* Mon Oct 16 2006 - damien.carbery@sun.com
20127N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
20039N/A module source will be seen as a build error and action can be taken.
20039N/A* Mon Sep 11 2006 - brian.cameron@sun.com
19123N/A- Bump to 0.10.9.
19123N/A* Tue Aug 8 2006 - yandong.yao@sun.com
19088N/A- Add l10n-configure.sh script for l10n pkgs
19088N/A* Tue Jun 13 2006 - brian.cameron@sun.com
19088N/A- Bump to 0.10.8.
19088N/A* Tue Mar 14 2006 - damien.carbery@sun.com
19088N/A- Bump to 0.10.4.
19088N/A* Wed Feb 15 2006 - damien.carbery@sun.com
19088N/A- Bump to 0.10.3.
19088N/A* Mon Feb 13 2006 - damien.carbery@sun.com
19088N/A- Add hack to fix infinite loop problem in po/Makefile.
19088N/A* Sun Jan 22 2006 - damien.carbery@sun.com
18786N/A- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
18786N/A* Mon Jan 09 2006 - brian.cameron@sun.com
18623N/A- Bump to 0.10.1 The packaging will need some work if someone wants to build
18623N/A this for Linux.
18549N/A* Tue Sep 20 2005 - brian.cameron@sun.com
18549N/A- Bump to 0.8.11.
18521N/A* Thu Sep 08 2005 - damien.carbery@sun.com
18521N/A- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
18511N/A* Wed Sep 07 2005 - damien.carbery@sun.com
18511N/A- Bump to 0.9.2. Update %files.
18436N/A* Mon Jun 06 2005 - brian.cameron@sun.com
18436N/A- Removed patch for modifying uninstalled-pc file since it
18303N/A is no longer needed.
18303N/A* Wed May 11 2005 - brian.cameron@sun.com
18195N/A- Updated to call automake, now needed.
18195N/A* Wed Nov 17 2004 - matt.keenan@sun.com
17605N/A- #6195855, install correct man page
17605N/A* Thu Oct 28 2004 - matt.keenan@sun.com
17496N/A- Add gst-*, libgst*
17496N/A* Wed Sep 29 2004 - takao.fujiwara@sun.com
17379N/A- Update gst-02-g11n-potfiles.diff
17379N/A- Update gst-03-gettext.diff to fix 5068957
17320N/A- Remove gst-04-g11n-potfiles.diff
17320N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
17234N/A- Add gst-04-g11n-potfiles.diff
17234N/A* Sun Aug 29 2004 - laca@sun.com
17091N/A- Now packaging gtk-docs.
17091N/A* Tue Aug 23 2004 - brian.cameron@sun.com
17091N/A- Now building gtk-docs.
16821N/A* Fri Aug 20 2004 - brian.cameron@sun.com
16821N/A- Fixed typo.
16802N/A* Fri Aug 20 2004 - laszlo.kovacs@sun.com
16802N/A- gst-xmlinspect man page packaged
16802N/A* Mon Aug 09 2004 - brian.cameron@sun.com
16768N/A- Corrected Linux packaging. Corrected Release to 2 since
16667N/A this is the 2nd change after bumping the release last
16667N/A Thursday.
16667N/A* Thu Jul 29 2004 - brian.cameron@sun.com
16667N/A- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
16653N/A since they were integrated into CVS head.
16653N/A* Fri Jul 15 2004 - brian.cameron@sun.com
16367N/A- Added patch to change the default scheduler to basicgthread which
16367N/A works better than opt for audio and opt doesn't work at all for
16309N/A video on Solaris.
16309N/A* Mon Jul 12 2004 - niall.power@sun.com
16134N/A- ported to rpm4, pkg'd some missing files
16134N/A* Thu Jul 08 2004 - damien.donlon@sun.com
16030N/A- Adding gst-l10n-po-1.2.tar.bz2 l10n content
16030N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
15959N/A- added "-j $CPUS" to make to speed up builds
15959N/A* Fri May 14 2004 - brian.cameron@sun.com
15880N/A- added patch 03 from CVS head to support aligned memory access,
15880N/A needed for Solaris.
15860N/A* Wed May 12 2004 - ghee.teo@sun.com
15860N/A- Updated to tarball 0.8.1 version as per Laca and yippi request.
15838N/A* Mon May 10 2004 - laca@sun.com
15838N/A- autotools-jdsize to fix Makefile problem
15613N/A* Thu May 02 2004 - brian.cameron@sun.com
15613N/A- Add glib-gettextize, aclocal, and autoconf calls
15613N/A so that gettext patches to configure.in/configure.ac
15521N/A get included. Added patches mentioned above to
15521N/A appropriate spec files.
15521N/A* Mon Apr 05 2004 - ghee.teo@sun.com
15448N/A- changed majorminor version to 0.8
15448N/A* Fri Apr 02 2004 - ghee.teo@sun.com
15448N/A- Upgraded tarball to 0.8.0 which is released for 2.6
15448N/A* Tue Mar 16 2004 - takao.fujiwara@sun.com
14363N/A- Added gst-02-g11n-potfiles.diff
14363N/A* Mon Mar 08 2004 - niall.power@sun.com
14196N/A- add patch to fix gst-*-uninstslled.pc Cflags.
14196N/A- disable docs build on Solaris for now (causes gthread error)
14136N/A* Fri Feb 13 2004 - matt.keenan@sun.com
14136N/A- Bump to 0.7.4, update tools files
13910N/A* Mon Jan 05 2004 - ghee.teo@sun.com
13910N/A- Fixed the postinstall problem. Basically, gst has allowed for parallel
13910N/A installed and had decided to have program named by
13876N/A /usr/bin/gst-regsiter-<majorminor>
13876N/A since we do not have parallel installed on our distro, so configure with
13791N/A --program-suffix="" to remove the version number.
13791N/A* Wed Dec 17 2003 - glynn.foster@sun.com
13620N/A- bump to 0.7.2
13620N/A* Fri Oct 10 2003 - ghee.teo@sun.com
13519N/A- Removed the patch 01 which is already in 0.63 release of gstreamer
13519N/A updtaed spec file to build for Qs. and also include a patch from Bala
13497N/A as part of the fix to 4880305.
13497N/A* Fri Oct 03 2003 - ghee.teo@sun.com
13400N/A- Pulled out two patches from the 0.63 release that fixes a infinite loop
13400N/A and a crash, bugzilla 120741 and 104829.
13278N/A* Wed Jul 23 2003 - ghee.teo@sun.com
13278N/A- Added a patch to disable putbits which uses a potential patent ridden
13278N/A issue with mpeg
13109N/A* Tue May 14 2003 - ghee.teo@sun.com
13109N/A- initial release version for gstreamer
13088N/A