10139N/A#
10139N/A# spec file for package gstreamer
10139N/A#
20901N/A# Copyright (c) 2003, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner yippi
10139N/A#
17178N/A
17178N/A%define OSR 8760:0.10.19
17178N/A
10139N/AName: gstreamer
15322N/ALicense: LGPL v2, Public Domain
10139N/AGroup: Libraries/Multimedia
20903N/AVersion: 0.10.36
12282N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: freedesktop.org
10139N/ASummary: GStreamer streaming media framework runtime.
10139N/ASource: http://gstreamer.freedesktop.org/src/%{name}/%{name}-%{version}.tar.bz2
12773N/A%if %build_l10n
15694N/ASource1: l10n-configure.sh
12773N/A%endif
10139N/A
13483N/A#owner:laca date:2005-08-11 type:bug bugster:6570425
10139N/APatch1: gst-01-gettext.diff
20901N/A#owner:yippi date:2012-04-03 type:bug
20901N/APatch2: gst-02-amd64.diff
20903N/A#owner:yippi date:2012-05-02 type:bug
20903N/APatch3: gst-03-compile.diff
10139N/AURL: http://gstreamer.net/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
18584N/A%define glib2_version 2.0.1
18584N/A%define libxml2_version 2.4.0
10139N/A
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: popt
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10139N/ABuildRequires: flex
10139N/ABuildRequires: gtk-doc >= 0.7
10139N/ABuildRequires: gcc
10139N/ABuildRequires: zlib-devel
10139N/ABuildRequires: popt
10139N/ABuildRequires: pyxml
10139N/A
10139N/A%description
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/A%package devel
10139N/ASummary: Libraries/include files for GStreamer streaming media frame
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10139N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/A
10139N/A%description devel
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the libraries and includes files necessary to develop
10139N/Aapplications and plugins for GStreamer.
10139N/A
10139N/A%package tools
10139N/ASummary: tools for GStreamer streaming media framework.
10139N/AGroup: Libraries/Multimedia
10139N/A
10139N/A%description tools
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplugins.
10139N/A
10139N/AThis package contains the basic command-line tools used for GStreamer, like
10139N/Agst-launch. It is split off to allow parallel-installability in the future.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
20901N/A%patch2 -p1
20903N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Alibtoolize --copy --force
10165N/Aintltoolize --copy --force --automake
18707N/Aaclocal -I ./m4 -I common/m4 $ACLOCAL_FLAGS -I .
12773N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE1 --enable-copyright
12773N/A%endif
12773N/A
10139N/Aautoheader
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
18584N/A --bindir=%{_bindir} \
18584N/A --libdir=%{_libdir} \
18287N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A %{gtk_doc_option} \
10139N/A --disable-tests --disable-examples \
17723N/A --program-suffix="" --disable-check
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%post tools
10139N/A/sbin/ldconfig
10139N/A
10139N/A%post devel
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING README TODO ABOUT-NLS
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_libdir}/gstreamer-*/libgst*.so*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/*
10139N/A%{_libdir}/lib*.so
10139N/A%{_libdir}/pkgconfig
10139N/A%{_datadir}/aclocal
10139N/A%{_datadir}/gtk-doc
10139N/A%{_mandir}/man3
10139N/A
10139N/A%files tools
10139N/A%{_bindir}/gst-*
10139N/A%{_mandir}/man1/gst-*
10139N/A
10139N/A%changelog
20903N/A* Wed May 02 2012 - brian.cameron@oracle.com
20903N/A- Bump to 0.10.36.
20901N/A* Fri Apr 27 2012 - brian.cameron@oracle.com
20901N/A- Add patch gst-02-amd64.diff.
20841N/A* Sat Oct 01 2011 - brian.cameron@oracle.com
20841N/A- Bump to 0.10.35.
19983N/A* Mon Jan 24 2011 - brian.cameron@oracle.com
19983N/A- bump to 0.10.32.
19983N/A* Fri Jan 14 2011 - brian.cameron@oracle.com
19983N/A- Bump to 0.10.31.
19026N/A* Thu Jul 15 2010 - brian.cameron@oracle.com
19026N/A- Bump to 0.10.30.
18707N/A* Thu Apr 29 2010 - brian.cameron@sun.com
18707N/A- Bump to 0.10.29.
18431N/A* Thu Mar 11 2010 - christian.kelly@sun.com
18431N/A- Bump to 0.10.28.
18287N/A* Thu Feb 11 2010 - brian.cameron@sun.com
18287N/A- Bump to 0.10.26.
17723N/A* Tue Nov 17 2009 - brian.cameron@sun.com
17723N/A- Change --with-check=no to --disable-check.
17517N/A* Wed Oct 14 2009 - dave.lin@sun.com
18287N/A- Bump to 0.10.25.
17008N/A* Wed Aug 12 2009 - christian.kelly@sun.com
17008N/A- Bump to 0.10.24.
16496N/A* Mon May 11 2009 - brian.cameron@sun.com
16496N/A- Bump to 0.10.23.
15694N/A* Mon Jan 19 2009 - brian.cameron@sun.com
15694N/A- Bump to 0.10.22.
15205N/A* Sat Oct 04 2008 - christian.kelly@sun.com
15205N/A- Bump to 0.10.21.
13445N/A* Thu Jun 19 2008 - damien.carbery@sun.com
13445N/A- Bump to 0.10.20.
12793N/A* Mon Apr 07 2008 - damien.carbery@sun.com
12793N/A- Bump to 0.10.19.
12628N/A* Thu Mar 20 2008 - brian.cameron@sun.com
12628N/A- Bump to 0.10.18.
12304N/A* Mon Jan 30 2008 - jan.schmidt@sun.com
12304N/A- Bump to 0.10.17 paper bag release.
12282N/A* Mon Jan 28 2008 - brian.cameron@sun.com
12282N/A- Bump to 0.10.16.
11951N/A* Fri Nov 16 2007 - damien.carbery@sun.com
11951N/A- Bump to 0.10.15.
11010N/A* Fri Aug 03 2007 - damien.carbery@sun.com
11010N/A- Bump to 0.10.14.
10818N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10818N/A- Bump to 0.10.13.
10344N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10344N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
10344N/A breaks when it finds the package.
10232N/A* Thu Mar 07 2007 - damien.carbery@sun.com
10232N/A- Bump to 0.10.12.
10165N/A* Sat Mar 04 2007 - damien.carbery@sun.com
10165N/A- Add intltoolize call to expand MSGFMT_OPTS.
10139N/A* Tue Feb 06 2006 - brian.cameron@sun.com
10139N/A- Remove unneeded patch.
10139N/A* Mon Dec 11 2006 - brian.cameron@sun.com
10139N/A- Remove nofork patch since this is now fixed upstream.
10139N/A* Thu Dec 7 2006 - brian.cameron@sun.com
18287N/A- Bump to 0.10.11.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Mon Oct 16 2006 - damien.carbery@sun.com
10139N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
10139N/A module source will be seen as a build error and action can be taken.
10139N/A* Mon Sep 11 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.9.
10139N/A* Tue Aug 8 2006 - yandong.yao@sun.com
10139N/A- Add l10n-configure.sh script for l10n pkgs
10139N/A* Tue Jun 13 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.8.
10139N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.10.4.
10139N/A* Wed Feb 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.10.3.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Add hack to fix infinite loop problem in po/Makefile.
10139N/A* Sun Jan 22 2006 - damien.carbery@sun.com
10139N/A- Add patch, 02-solaris-resolv, to add '-lresolv' so inet_aton function found.
10139N/A* Mon Jan 09 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.1 The packaging will need some work if someone wants to build
10139N/A this for Linux.
10139N/A* Tue Sep 20 2005 - brian.cameron@sun.com
10139N/A- Bump to 0.8.11.
10139N/A* Thu Sep 08 2005 - damien.carbery@sun.com
10139N/A- Unbump back to 0.8.10 as 0.9.x is not in gnome2.12.
10139N/A* Wed Sep 07 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.9.2. Update %files.
10139N/A* Mon Jun 06 2005 - brian.cameron@sun.com
10139N/A- Removed patch for modifying uninstalled-pc file since it
10139N/A is no longer needed.
10139N/A* Wed May 11 2005 - brian.cameron@sun.com
10139N/A- Updated to call automake, now needed.
10139N/A* Wed Nov 17 2004 - matt.keenan@sun.com
18287N/A- #6195855, install correct man page.
10139N/A* Thu Oct 28 2004 - matt.keenan@sun.com
18287N/A- Add gst-*, libgst*.
10139N/A* Wed Sep 29 2004 - takao.fujiwara@sun.com
18287N/A- Update gst-02-g11n-potfiles.diff.
18287N/A- Update gst-03-gettext.diff to fix 5068957.
18287N/A- Remove gst-04-g11n-potfiles.diff.
10139N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
18287N/A- Add gst-04-g11n-potfiles.diff.
10139N/A* Sun Aug 29 2004 - laca@sun.com
10139N/A- Now packaging gtk-docs.
10139N/A* Tue Aug 23 2004 - brian.cameron@sun.com
10139N/A- Now building gtk-docs.
10139N/A* Fri Aug 20 2004 - brian.cameron@sun.com
10139N/A- Fixed typo.
10139N/A* Fri Aug 20 2004 - laszlo.kovacs@sun.com
18287N/A- gst-xmlinspect man page packaged.
10139N/A* Mon Aug 09 2004 - brian.cameron@sun.com
10139N/A- Corrected Linux packaging. Corrected Release to 2 since
10139N/A this is the 2nd change after bumping the release last
10139N/A Thursday.
10139N/A* Thu Jul 29 2004 - brian.cameron@sun.com
10139N/A- Bumped revision of gstreamer to 0.8.4, making patches 4 and 5 go away
10139N/A since they were integrated into CVS head.
10139N/A* Fri Jul 15 2004 - brian.cameron@sun.com
10139N/A- Added patch to change the default scheduler to basicgthread which
10139N/A works better than opt for audio and opt doesn't work at all for
10139N/A video on Solaris.
10139N/A* Mon Jul 12 2004 - niall.power@sun.com
18287N/A- ported to rpm4, pkg'd some missing files.
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
18287N/A- Adding gst-l10n-po-1.2.tar.bz2 l10n content.
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
18287N/A- added "-j $CPUS" to make to speed up builds.
10139N/A* Fri May 14 2004 - brian.cameron@sun.com
10139N/A- added patch 03 from CVS head to support aligned memory access,
10139N/A needed for Solaris.
10139N/A* Wed May 12 2004 - ghee.teo@sun.com
10139N/A- Updated to tarball 0.8.1 version as per Laca and yippi request.
10139N/A* Mon May 10 2004 - laca@sun.com
18287N/A- autotools-jdsize to fix Makefile problem.
10139N/A* Thu May 02 2004 - brian.cameron@sun.com
10139N/A- Add glib-gettextize, aclocal, and autoconf calls
10139N/A so that gettext patches to configure.in/configure.ac
10139N/A get included. Added patches mentioned above to
10139N/A appropriate spec files.
10139N/A* Mon Apr 05 2004 - ghee.teo@sun.com
18287N/A- changed majorminor version to 0.8.
10139N/A* Fri Apr 02 2004 - ghee.teo@sun.com
18287N/A- Upgraded tarball to 0.8.0 which is released for 2.6.
10139N/A* Tue Mar 16 2004 - takao.fujiwara@sun.com
18287N/A- Added gst-02-g11n-potfiles.diff.
10139N/A* Mon Mar 08 2004 - niall.power@sun.com
10139N/A- add patch to fix gst-*-uninstslled.pc Cflags.
18287N/A- disable docs build on Solaris for now (causes gthread error) .
10139N/A* Fri Feb 13 2004 - matt.keenan@sun.com
18287N/A- Bump to 0.7.4, update tools files.
10139N/A* Mon Jan 05 2004 - ghee.teo@sun.com
10139N/A- Fixed the postinstall problem. Basically, gst has allowed for parallel
10139N/A installed and had decided to have program named by
10139N/A /usr/bin/gst-regsiter-<majorminor>
10139N/A since we do not have parallel installed on our distro, so configure with
10139N/A --program-suffix="" to remove the version number.
10139N/A* Wed Dec 17 2003 - glynn.foster@sun.com
10139N/A- bump to 0.7.2
10139N/A* Fri Oct 10 2003 - ghee.teo@sun.com
10139N/A- Removed the patch 01 which is already in 0.63 release of gstreamer
10139N/A updtaed spec file to build for Qs. and also include a patch from Bala
10139N/A as part of the fix to 4880305.
10139N/A* Fri Oct 03 2003 - ghee.teo@sun.com
10139N/A- Pulled out two patches from the 0.63 release that fixes a infinite loop
10139N/A and a crash, bugzilla 120741 and 104829.
10139N/A* Wed Jul 23 2003 - ghee.teo@sun.com
10139N/A- Added a patch to disable putbits which uses a potential patent ridden
18287N/A issue with mpeg.
10139N/A* Tue May 14 2003 - ghee.teo@sun.com
18287N/A- initial release version for gstreamer.