gst-plugins-good.spec revision 15942
10139N/A#
10139N/A# spec file for package gst-plugins-good
10139N/A#
12219N/A# Copyright (c) 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A#
17176N/AName: gst-plugins-good
18603N/ALicense: LGPL v2, BSD
17176N/AVersion: 0.10.14
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
15291N/AVendor: Sun Microsystems, Inc.
10139N/AGroup: Libraries/Multimedia
10615N/ASummary: GStreamer Streaming-media framework plug-ins.
17866N/AURL: http://gstreamer.freedesktop.org/
18534N/ASource: http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.bz2
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A%endif
10139N/A#owner:laca date:2006-01-19 type:bug bugster:6570425
18532N/APatch1: gst-plugins-good-01-gettext.diff
10794N/A#owner:yippi date:2007-03-16 type:feature bugzilla:529741
10139N/APatch2: gst-plugins-good-02-cdda.diff
10794N/A#owner:jim date:2008-11-26 type:bug bugster:6774059
12773N/APatch3: gst-plugins-good-03-compiler.diff
12773N/A#owner:alfred date:2008-12-16 type:bug bugster:6787829
12773N/APatch4: gst-plugins-good-04-selector.diff
10794N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/ADocdir: %{_defaultdocdir}/doc
10640N/AAutoreqprov: on
17989N/APrereq: /sbin/ldconfig
18099N/A
16105N/A%define majorminor 0.10
18099N/A
10861N/A%define _glib2 1.3.12
18099N/A
18534N/ARequires: glib2 >= %_glib2
18534N/ARequires: gstreamer >= 0.10.0
13379N/ARequires: gst-plugins-base >= 0.10.0
18099N/ARequires: flac
15219N/ARequires: speex
18099N/ARequires: audiofile >= 0.2.1
16472N/ARequires: esound >= 0.2.8
18099N/ARequires: libjpeg
16472N/ARequires: libpng >= 1.2.0
18099N/ARequires: XFree86-libs
16690N/ARequires: GConf
18099N/ABuildRequires: glib2-devel >= %_glib2
18489N/ABuildRequires: gstreamer-devel >= 0.10.0
18489N/ABuildRequires: gstreamer-tools >= 0.10.0
10139N/ABuildRequires: gstreamer-plugins-devel >= 0.10.0
10139N/ABuildRequires: flac-devel
10139N/ABuildRequires: speex-devel
10139N/ABuildRequires: pyxml
10139N/ABuildRequires: audiofile-devel >= 0.2.1
10139N/ABuildRequires: esound-devel >= 0.2.8
10139N/ABuildRequires: libjpeg-devel
10139N/ABuildRequires: libpng-devel >= 1.2.0
10139N/ABuildRequires: glibc-devel
10139N/ABuildRequires: GConf-devel
10139N/A
10139N/A%description
10139N/AGStreamer is a streaming-media framework, based on graphs of filters which
10139N/Aoperate on media data. Applications using this library can do anything
10139N/Afrom real-time sound processing to playing videos, and just about anything
10139N/Aelse media-related. Its plugin-based architecture means that new data
10139N/Atypes or processing capabilities can be added simply by installing new
10139N/Aplug-ins.
10139N/A
10139N/A%prep
10139N/A%setup -n gst-plugins-good-%{version} -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A
10139N/A%build
10139N/ACFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
17891N/A# Turn off optimization as ss12 cores. Bugster: 6706089
17891N/A#CFLAGS=$(echo $CFLAGS | sed -e 's/-xO4//'); \
10139N/ACXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
10139N/AFFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
10139N/Aglib-gettextize -f
10139N/Alibtoolize --copy --force
10139N/Aintltoolize --copy --force --automake
10139N/Aaclocal -I ./m4 -I ./common/m4 $ACLOCAL_FLAGS
10139N/A
17891N/A%if %build_l10n
17891N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/A# If building Indiana, then always use xvimagesink since Xorg
10139N/A# will always be used in this situation. Otherwise, use
10139N/A# ximagsink on Sparc since Xsun does not support Xvideo.
10139N/A#
10139N/A%ifarch sparc
10139N/AVIDEOSINK_CONFIG="--with-default-videosink=ximagesink"
10139N/A%else
10139N/AVIDEOSINK_CONFIG="--with-default-videosink=xvimagesink"
10139N/A%endif
10139N/A
10139N/A%if %option_with_indiana_branding
10139N/AVIDEOSINK_CONFIG="--with-default-videosink=xvimagesink"
10139N/A%endif
10139N/A
10139N/Aautoheader
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --disable-cdio \
10139N/A %{gtk_doc_option} \
10139N/A $VIDEOSINK_CONFIG \
10139N/A --enable-external --with-check=no
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Aif [ "$SMP" != "" ]; then
10794N/A (make "MAKE=make -k -j $SMP"; exit 0)
12754N/A make
10139N/Aelse
10139N/A make
10139N/Afi
11087N/A
18099N/A%install
18099N/A[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ]
18099N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18466N/Amake DESTDIR=$RPM_BUILD_ROOT install
16769N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
13306N/A
17866N/A# Clean out files that should not be part of the rpm.
18099N/A# This is the recommended way of dealing with it for RH8
18099N/Arm $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/*.la
18489N/Arm $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/*.a
16998N/Arm $RPM_BUILD_ROOT%{_bindir}/gst-visualise-0.10
10139N/A
10139N/A%clean
10139N/A[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
17891N/A
17891N/A%files
17891N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING README REQUIREMENTS
10139N/A%{_libdir}/gstreamer-*/*.so
10139N/A%{_sysconfdir}/gconf/schemas/gstreamer-*.schemas
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
17891N/A%post
10139N/A%{_bindir}/gst-register > /dev/null 2> /dev/null
17891N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
17891N/ASCHEMAS="gstreamer-0.10.schemas"
17891N/Afor S in $SCHEMAS; do
17891N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
17891N/Adone
10139N/A
17891N/A%package devel
11344N/ASummary: GStreamer Plugin Library Headers.
11344N/AGroup: Development/Libraries
11344N/ARequires: gstreamer-plugins-devel >= 0.10.0
11344N/ARequires: %{name} = %{version}
11344N/AProvides: gstreamer-play-devel = %{version}
10139N/A
11994N/A%description devel
11994N/AGStreamer support libraries header files.
12773N/A
12773N/A%files devel
12773N/A%defattr(-, root, root)
12773N/A%{_datadir}/gtk-doc
12773N/A
17081N/A%changelog
10139N/A* Fri Feb 20 2009 - brian.cameron@sun.com
10139N/A- Bump to 0.10.14.
10139N/A* Thu Jan 22 2009 - brian.cameron@sun.com
10139N/A- Bump to 0.10.13. Add patch gst-plugins-good-07-makefile.diff
10139N/A* Wed Jan 07 2009 - alfred.peng@sun.com
10139N/A- Add gst-06-selector.diff to include selector element.
10139N/A* Thu Oct 30 2008 - brian.cameron@sun.com
10139N/A- Add gst-04-fixmixer.diff so that the AUDIO_MIXER_MULTIPLE_OPEN ioctl is
10139N/A called after we set the mixer file descriptor. Otherwise the ioctl is
10139N/A ignored.
10139N/A* Mon Oct 27 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.11.
10139N/A* Wed Aug 27 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.10.
11826N/A* Thu Jul 31 2008 - brian.cameron@sun.com
11344N/A- Bump to 0.10.9.
16786N/A* Fri Jun 06 2008 - brian.cameron@sun.com
17866N/A- Add patch gst-plugins-good-05-fixmixer.diff so that gnome-volume-control
17866N/A works properly with the SunAudio mixer applet. Fixes bugzilla bug
10139N/A #537031.
17891N/A* Fri May 23 2008 - damien.carbery@sun.com
10139N/A- Modify CFLAGS to turn off optimization as ss12 cores, bugster: 6706089.
10139N/A Add patch 04-disable-gcc-asm to workaround bugster 6706715. ss12 claims to
10139N/A support inline asm but fails when it encounters some.
10139N/A Disable both of these changes until we switch to building with ss12.
10139N/A* Fri May 09 2008 - brian.cameron@sun.com
10139N/A- Fix default audiosource so it is sunaudiosink rather than goom.
10139N/A Fixes P2 bug #6698690
10139N/A* Wed Apr 23 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.8. Remove upstream patch gst-plugins-good-03-fixmixer.diff.
10139N/A* Wed Feb 20 2008 - brian.cameron@sun.com
10139N/A- Bump to 0.10.7. Remove upstream patch
10139N/A gst-plugins-good-03-fix-gconf-func.diff.
10139N/A* Thu Jun 21 2007 - damien.carbery@sun.com
10139N/A- Add patch 03-fix-gconf-func to fix 449747, a mismatch in func param types.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.10.6. Remove upstream patch, 02-opendeviceonce. Rename rest.
10139N/A* Tue Jun 14 2007 - irene.huang@sun.com
10139N/A- remove -03-endianess.diff since this patch is for
10139N/A libcdio which we no longer use. And -02-fixgoom.diff
10139N/A which is no longer useful. Renumbering opendeviceonce.diff
10139N/A and cdda.diff.
10139N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10139N/A- Add --with-check=no to configure so as not to pick up SFEcheck package. Build
10139N/A breaks when it finds the package.
10139N/A* Fri Mar 16 2007 - brian.cameron@sun.com
10139N/A- Add patch gst-plugins-good-05-cdda.diff to provide an ioctl based
10139N/A CDDA plugin, and disable the cdio plugin since it is GPL.
10139N/A* Sat Mar 04 2007 - damien.carbery@sun.com
10139N/A- Add intltoolize call to expand MSGFMT_OPTS.
10139N/A* Thu Jan 25 2007 - chris.wang@sun.com
10139N/A- Added patch, 03-endianess, to fix bug that sound-juicer cannot play audio CD
10139N/A properly on Sparc box. Bugzilla 377280.
10139N/A* Thu Dec 21 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.5 and remove patch that updated sunaudiosink to CVS
10139N/A head.
10139N/A* Mon Dec 11 2006 - brian.cameron@sun.com
10139N/A- Remove patches 4, 5, 6 and replace with a patch that updates to
12402N/A CVS head. This fixes all these issues and the performance issues
10139N/A we have been seeing with GStreamer on Solaris.
10139N/A* Mon Nov 27 2006 - brian.cameron@sun.com
10139N/A- Patch to rest function so that on close we flush the input/output
10139N/A buffer. This makes pause/stopping a file much more responsive.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Tue Oct 17 2006 - damien.carbery@sun.com
10139N/A- Remove code that deletes *.a and *.la from %{_libdir} as none are installed
10139N/A there.
10139N/A* Mon Oct 16 2006 - damien.carbery@sun.com
10139N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
10139N/A module source will be seen as a build error and action can be taken.
10139N/A* Mon Sep 11 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.10.4.
10139N/A* Thu Jul 27 2006 - brian.cameron@sun.com
10139N/A- Fix src plugin so it opens nonblocking with the
10139N/A gst-plugins-good-09-srcopen.diff patch.
10139N/A* Fri Jul 21 2006 - brian.cameron@sun.com
10139N/A- Fix CDDA plugin so it doesn't assert & core dump if the CD device
10139N/A is not found.
10139N/A* Thu Jun 29 2006 - brian.cameron@sun.com
10139N/A- Move monitor to "source" tab, so it is more like sdtaudiocontrol.
10139N/A done via patch gst-plugins-good-07-monitorinput.diff.
10139N/A* Tue Jun 27 2006 - brian.cameron@sun.com
10139N/A- Fix sink plugin so it does not always reset port in prepare. If the
10139N/A user has turned off the built-in speaker port in sdtaudiocontrol
18534N/A (or otherwise), then turning it back on causes the speakers to
18534N/A turn back on each time the user changes a track in rhythmbox, totem,
18534N/A etc.
18534N/A* Thu Jun 15 2006 - brian.cameron@sun.com
18489N/A- Now mute works with input tracks, and setting mute in the panel
18489N/A applet and gnome-volume-control doesn't get out-of-sync.
18489N/A* Wed Jun 14 2006 - brian.cameron@sun.com
18466N/A- Add patches to fix mixer and add source plugin.
18466N/A* Tue Jun 13 2006 - brian.cameron@sun.com
18442N/A- Bump to 0.10.3.
18442N/A* Tue Jun 06 2006 - brian.cameron@sun.com
18397N/A- Add patch gst-plugins-good-03-fixmixer.diff so that the mixer no
18397N/A longer core dumps if you check/uncheck the choices in
18325N/A gnome-volume-control preferences. Fix so mute works in
18325N/A gnome-volume-control, and fix so that setting the volume isn't
18325N/A hardcoded to only work with the audio output track.
18278N/A* Wed May 10 2006 - brian.cameron@sun.com
18278N/A- Remove gst-visualize again, this got lost when we migrated from
18259N/A gst-plugins to gst-plugins-base.
18259N/A* Wed Apr 05 2006 - brian.cameron@sun.com
18207N/A- Add patch 2 to fix the sunaudiosink so it allocates the ringbuffer
18207N/A properly instead of using buffer-time property. This fix should be
18207N/A in the next release of gst-plugins-good and can be removed at that
18207N/A time.
18099N/A* Wed Feb 15 2006 - damien.carbery@sun.com
18099N/A- Bump to 0.10.2.
18091N/A- Remove upstream patches, 02-fixconfig, 03-fixsunaudio.
18093N/A* Mon Feb 13 2006 - damien.carbery@sun.com
18093N/A- Add hack to fix infinite loop problem in po/Makefile.
18091N/A* Mon Jan 9 2006 - brian.cameron@sun.com
18091N/A- Update to 0.10.0. This file was copied from the old gst-plugins.spec file
17985N/A and modified to work with gst-plugins-good. The Obsoletes, Provides and
17989N/A packaging sections will need work if someone wants to build this
17989N/A on Linux.
17985N/A* Mon Sep 26 2005 - brian.cameron@sun.com
17975N/A- Add patch 2 which defines "inline" functions as either
17975N/A "static inline" or "extern inline". Just defining
17897N/A functions as "inline" breaks Forte.
17897N/A* Tue Sep 20 2005 - brian.cameron@sun.com
17891N/A- Bump to 0.8.11.
17891N/A* Mon Aug 15 2005 - damien.carbery@sun.com
17891N/A- Bump to 0.8.10.
17891N/A* Tue Aug 02 2005 - balamurali.viswanathan@wipro.com
17866N/A- Enable building of flac
17866N/A* Tue Jul 26 2005 - balamurali.viswanathan@wipro.com
17866N/A- Enable building of speex and theora plugins
17866N/A* Mon Jul 25 2005 - balamurali.viswanathan@wipro.com
17866N/A- Enable building of musicbrainz plugin
17554N/A* Fri Jul 01 2005 - matt.keenan@sun.com
17554N/A- Added patch 02-pkgconfig.diff, for Solairs build with new pkg-config
17481N/A* Mon Jun 06 2005 - brian.cameron@sun.com
17481N/A- Removed patch for modifying uninstalled-pc file since it is no longer
17358N/A needed.
17358N/A* Fri Jun 03 2005 - brian.cameron@sun.com
17259N/A- Add autodetect, equalizer, games, librfb, subparse, tta plugins which
17259N/A are new to 2.8.8.
17081N/A* Fri May 13 2005 - brian.cameron@sun.com
17081N/A- For the previous version of GStreamer, we were copying in a few files
16998N/A to fix GPL headers. Took out this since it isn't needed and was
16998N/A breaking the build.
16976N/A* Tue Mar 15 2005 - balamurali.viswanathan@wipro.com
16976N/A- Add patch gst-plugins-13-query-position-osssrc.diff to fix bug #6238742
16977N/A Patch taken from HEAD.
16918N/A* Fri Feb 25 2005 - balamurali.viswanathan@wipro.com
16918N/A- Add patch gst-plugins-12-query-length-wavparse.diff to fix bug #6226597
16786N/A Patch taken from HEAD.
16786N/A* Fri Jan 28 2005 - ghee.teo@sun.com
16769N/A- Cleaned up some obsoletion and provides conditions for gst-plugins
16769N/A To fix update bug 6222864.
16771N/A* Fri Oct 29 2004 - laca@sun.com
16771N/A- Add gst-launch-ext.1.gz to %files
16690N/A* Thu Oct 28 2004 - matt.keenan@sun.com
16690N/A- Add gst-launch-ext*, libogg.3, libvorbis.3 man pages
16684N/A* Tue Oct 05 2004 - takao.fujiwara@sun.com
16684N/A- Added patch gst-plugins-11-g11n-i18n-ui.diff to localize gnome-volume-control
16684N/A- Fixed 5108713
16676N/A- updated gst-plugins-02-g11n-potfiles.diff
16676N/A* Thu Sep 16 2004 - balamurali.viswanathan@wipro.com
16685N/A- Add patch 09 and 10 for bugs #5102383 and #5102465
16640N/A* Wed Sep 01 2004 - balamurali.viswanathan@wipro.com
16640N/A- Add patch 07 to add an source element to sunaudio plugin
16640N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
16640N/A- Update gst-plugins-02-g11n-potfiles.diff
16614N/A* Thu Aug 26 2004 - brian.cameron@sun.com
16614N/A- No longer delete gstffmpegcolorspace since totem will not work without it.
16614N/A It does not use any MPEG licensed logic (ffmpeg refers to the ffmpeg
16614N/A module not MPEG). Also don't delete libgstaasink.so since we never
16560N/A install it anyway with --disable-aalib.
16560N/A* Thu Aug 26 2004 - ghee.teo@sun.com
16560N/A- Obsoleted external plugin module, colorspace, asf and avi.
16560N/A These are now bundled into gstreamer-plugins.
16560N/A* Tue Aug 24 2004 - niall.power@sun.com
16505N/A- Build breakage fixed. Files removed in %install have to
16505N/A be removed from %files too. gst-visualize-0.8
16486N/A* Fri Aug 20 2004 - brian.cameron@sun.com
16486N/A- Removed dirac plugin. The dirac website says they don't know if
16442N/A if has IP issues and that made SunLegal nervous.
16442N/A* Tue Aug 17 2004 - balamurali.viswanathan@wipro.com
16442N/A- Add patch 06 to add an mixer element to sunaudio plugin
16442N/A* Wed Aug 11 2004 - brian.cameron@sun.com
16436N/A- Add patch 05 to correct GPL licensing problem in gstvideo
16436N/A plugin. Remove gst-visualise from install since it is a
16436N/A test program that we do not want to create a man page for.
16436N/A* Mon Aug 09 2004 - brian.cameron@sun.com
16382N/A- corrected Linux packaging.
16382N/A* Mon Aug 09 2004 - niall.power@sun.com
16356N/A- reset release when the version is bumped
16356N/A* Fri Aug 06 2004 - brian.cameron@sun.com
16347N/A- Fixed --disable arguments so that the appropriate plugins get
16347N/A disabled, added --with-plugins to disable the proper gst
16347N/A plugins.
16155N/A* Thu Aug 05 2004 - brian.cameron@sun.com
16155N/A- Updated to 0.8.3
16026N/A* Thu Jul 29 2004 - brian.cameron@sun.com
16026N/A- Updated to gst-plugins 0.8.2, making patches 1, 4, 5, and 8 go
15858N/A away since they were integrated into CVS head. Fixed libtoolize
15858N/A call so it works for Solaris. Added patch 6 to make wavparse work,
15759N/A and this patch will go away when we upgrade to gst-plugins 0.8.3
15759N/A* Fri Jul 16 2004 - brian.cameron@sun.com
15700N/A- Added patch to change default video sink to ximagesink when
15700N/A building on Solaris, since xvimagesink requires Xvideo which
15693N/A does not exist on Solaris.
15693N/A* Mon Jul 12 2004 - niall.power@sun.com
15624N/A- ported to rpm4
15624N/A* Thu Jul 08 2004 - damien.donlon@sun.com
15528N/A- Updated l10n content to gst-plugins-l10n-po-1.2.tar.bz2
15528N/A* Tue May 25 2004 - yuriy.kuznetsov@sun.com
15528N/A- Added gst-plugins-09-g11n-potfiles.diff
15528N/A* Fri May 14 2004 - brian.cameron@sun.com
15528N/A- added patch 08 from CVS head to support aligned memory access,
15472N/A needed for Solaris.
15474N/A* Wed May 12 2004 - brian.cameron@sun.com
15474N/A- Added changes to patch05 so that it contains more Solaris
15472N/A needed build patches. Renamed patch to a more generic name.
15472N/A* Wed May 12 2004 - damien.donlon@sun.com
15449N/A- Updated l10n content to gst-plugins-l10n-po-1.1.tar.bz2
15449N/A* Wed May 12 2004 - ghee.teo@sun.com
15448N/A- Updated tarball to 0.8.1 as per Laca and Brian's request.
15448N/A* Wed May 12 2004 - laca@sun.com
15301N/A- jds-autotoolize
15301N/A- change order of directories in the aclocal call so that the correct vorbis
15291N/A macro is picked up. The one that comes with SuSE appears to be broken.
15291N/A* Mon May 10 2004 - laca@sun.com
15275N/A- require gstreamer >= 0.8.0
15275N/A* Fri Apr 16 2004 - brian.cameron@sun.com
15219N/A- Removed rm -rf $RPM_BUILD_ROOT from top of %install section since this
15219N/A was breaking Solaris build.
14503N/A* Fri Apr 2 2004 - ghee.teo@sun.com
14503N/A- Updated to 0.8.0 release tarball from 2.6
14464N/A Also removed gst-plugins-04-remove-xopen-source.diff
14464N/A because gstxwindow.c no longer exists in 0.8.0
14420N/A Also changed majorminor to 0.8, updated a number of entries
14420N/A in %files sections.
14420N/A* Fri Apr 2 2004 - brian.cameron@sun.com
14185N/A- Added patch 2 to fix Solaris Makefile issue, and replace tar jxf
14185N/A with the more solaris friendly bzcat piped through tar
14123N/A* Mon Mar 29 2004 - damien.donlon@sun.com
14123N/A- Adding gst-plugins-l10n-po-1.0.tar.bz2 l10n content
13925N/A* Sun Mar 28 2004 Brian Cameron <brian.cameron@sun.com>
13925N/A- Remove _XOPEN_SOURCE #define since it causes the Forte
13932N/A compiler to be unable to compile this file.
13754N/A* Mon Mar 22 2004 Niall Power <niall.power@sun.com>
13754N/A- revert back to previous libtoolize invocation style
13754N/A until I figure out why .so files aren't being built.
13644N/A* Tue Mar 16 2004 takao.fujiwara@sun.com
13644N/A- Added gst-plugins-03-g11n-potfiles.diff
13644N/A* Mon Mar 08 2004 Niall Power <niall.power@sun.com>
13416N/A- add two patches to fix -uninstalled.pc files and
13416N/A to fix a gcc'ism in xwindowlistener.
13416N/A* Wed Mar 03 2004 Ghee Teo <ghee.teo@sun.com>
13379N/A- Corrected the Obsolete modules and sorted them correctly.
13313N/A* Fri Feb 13 2004 Matt Keenan <matt.keenan@sun.com>
13313N/A- Bump to 0.7.4
13300N/A* Mon Jan 05 2004 Ghee Teo <ghee.teo@sun.com>
13300N/A- Removed -%{majorminor} from gst-register because as a distro we do not
13300N/A need a parallel installed version of the program. That is, we should only
13103N/A have one version of the program only.
13103N/A* Sun Nov 23 2003 Christian Schaller <Uraeus@gnome.org>
12988N/A- Update spec file for latest changes
12988N/A- add faad plugin
12972N/A* Thu Oct 16 2003 Christian Schaller <Uraeus@gnome.org>
12972N/A- Add new colorbalance and tuner and xoverlay stuff
12571N/A- Change name of kde-audio-devel to arts-devel
12571N/A* Sat Sep 27 2003 Christian Schaller <Uraeus@gnome.org>
12488N/A- Add majorminor to man page names
12571N/A- add navigation lib to package
12466N/A* Tue Sep 11 2003 Christian Schaller <Uraeus@gnome.org>
12466N/A- Add -%{majorminor} to each instance of gst-register
12413N/A* Tue Aug 19 2003 Christian Schaller <Uraeus@Gnome.org>
12413N/A- Add new plugins
12413N/A* Sat Jul 12 2003 Thomas Vander Stichele <thomas at apestaart dot org>
12402N/A- move gst/ mpeg plugins to base package
12402N/A- remove hermes conditional from snapshot
12402N/A- remove one instance of resample plugin
12402N/A- fix up silly versioned plugins efence and rmdemux
12402N/A* Sat Jul 05 2003 Christian Schaller <Uraeus@gnome.org>
12387N/A- Major overhaul of SPEC file to make it compatible with what Red Hat ships
12387N/A as default
12370N/A- Probably a little less sexy, but cross-distro SPEC files are a myth anyway
12370N/A so making it convenient for RH users wins out
12308N/A- Keeping conditionals even with new re-org so that developers building the
12308N/A RPMS don't need everything installed
12308N/A- Add bunch of obsoletes to ease migration from earlier official GStreamer RPMS
12288N/A- Remove plugins that doesn't exist anymore
12288N/A* Sun Mar 02 2003 Christian Schaller <Uraeus@gnome.org>
12219N/A- Remove USE_RTP statement from RTP plugin
12219N/A- Move RTP plugin to no-deps section
12071N/A* Sat Mar 01 2003 Christian Schaller <Uraeus@gnome.org>
12071N/A- Remove videosink from SPEC
11922N/A* Thu Jan 23 2003 Thomas Vander Stichele <thomas at apestaart dot org>
11922N/A- various fixes
11828N/A- make video output packages provide gstreamer-videosink
11828N/A* Thu Jan 23 2003 Thomas Vander Stichele <thomas at apestaart dot org>
11826N/A- split out ffmpeg stuff to separate plugin
11826N/A* Fri Dec 27 2002 Thomas Vander Stichele <thomas at apestaart dot org>
11819N/A- add virtual provides for audio sources and sinks
11819N/A* Sun Dec 15 2002 Christian Schaller <Uraeus@linuxrising.org>
11416N/A- Update mpeg2dec REQ to be 0.3.1
11416N/A* Tue Dec 10 2002 Thomas Vander Stichele <thomas at apestaart dot org>
11344N/A- only install schema once
11344N/A- move out devel lib stuff to -devel package
11253N/A* Sun Dec 08 2002 Thomas Vander Stichele <thomas at apestaart dot org>
11253N/A- fix location of libgstpng
11183N/A- changes for parallel installability
11183N/A* Thu Nov 28 2002 Christian Schaller <Uraeus@linuxrising.org>
11172N/A- Put in libgstpng plugin
11172N/A- rm the libgstmedia-info stuff until thomas think they are ready
11120N/A* Fri Nov 01 2002 Thomas Vander Stichele <thomas at apestaart dot org>
11120N/A- don't use compprep until ABI issues can be fixed
11087N/A* Wed Oct 30 2002 Thomas Vander Stichele <thomas at apestaart dot org>
11087N/A- added smpte plugin
11067N/A- split out dvdnavread package
11067N/A- fixed snapshot deps and added hermes conditionals
10986N/A* Tue Oct 29 2002 Thomas Vander Stichele <thomas at apestaart dot org>
10986N/A- added -play package, libs, and .pc files
10980N/A* Thu Oct 24 2002 Christian Schaller <Uraeus@linuxrising.org>
10980N/A- Added wavenc to audio formats package
10917N/A* Sat Oct 20 2002 Christian Scchaller <Uraeus@linuxrising.org>
10917N/A- Removed all .la files
10903N/A- added separate non-openquicktime demuxer plugin
10903N/A- added snapshot plugin
10891N/A- added videotest plugin
10891N/A- Split avi plugin out to avi and windec plugins since aviplugin do not depend on avifile
10861N/A- Added cdplayer plugin
10861N/A* Fri Sep 20 2002 Thomas Vander Stichele <thomas@apestaart.org>
10861N/A- added gst-compprep calls
10820N/A* Wed Sep 18 2002 Thomas Vander Stichele <thomas@apestaart.org>
10820N/A- add gst-register-%{majorminor} calls everywhere again since auto-reregister doesn't work
10794N/A- added gstreamer-audio-formats to mad's requires since it needs the typefind
10794N/A to work properly
10742N/A* Mon Sep 9 2002 Christian Schaller <Uraeus@linuxrising.org>
10742N/A- Added v4l2 plugin
10742N/A* Thu Aug 27 2002 Christian Schaller <Uraeus@linuxrising.org>
10704N/A- Fixed USE_DV_TRUE to USE_LIBDV_TRUE
10704N/A- Added Gconf and floatcast headers to gstreamer-plugins-devel package
10640N/A- Added mixmatrix plugin to audio-effects package
10640N/A* Thu Jul 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
10640N/A- fixed oss package to buildrequire instead of require glibc headers
10613N/A* Mon Jul 08 2002 Thomas Vander Stichele <thomas@apestaart.org>
10615N/A- fixed -devel package group
10535N/A* Fri Jul 05 2002 Thomas Vander Stichele <thomas@apestaart.org>
10535N/A- release 0.4.0 !
10476N/A- added gstreamer-libs.pc
10476N/A- removed all gst-register-%{majorminor} calls since this should be done
10476N/A automatically now
10436N/A* Thu Jul 04 2002 Thomas Vander Stichele <thomas@apestaart.org>
10438N/A- fix issue with SDL package
10438N/A- make all packages STRICTLY require the right version to avoid
10438N/A ABI issues
10436N/A- make gst-plugins obsolete gst-plugin-libs
10436N/A- also send output of gst-register-%{majorminor} to /dev/null to lower the
10418N/A noise
10418N/A* Wed Jul 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
10418N/A- require glibc-devel instead of glibc-kernheaders since the latter is only
10418N/A since 7.3 and glibc-devel pulls in the right package anyway
10418N/A* Sun Jun 23 2002 Thomas Vander Stichele <thomas@apestaart.org>
10418N/A- changed header location of plug-in libs
10339N/A* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
10339N/A- major cleanups
10283N/A- adding gst-register-%{majorminor} on postun everywhere
10284N/A- remove ldconfig since we don't actually install libs in system dirs
10169N/A- removed misc package
10169N/A- added video-effects
10139N/A- dot every Summary
10139N/A- uniformify all descriptions a little
10139N/A* Thu Jun 06 2002 Thomas Vander Stichele <thomas@apestaart.org>
10139N/A- various BuildRequires: additions
10139N/A* Tue Jun 04 2002 Thomas Vander Stichele <thomas@apestaart.org>
10139N/A- added USE_LIBADSPA_TRUE bits to ladspa package
10139N/A* Mon Jun 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
10139N/A- Added libfame package
10139N/A* Mon May 12 2002 Christian Fredrik Kalager Schaller <Uraeus@linuxrising.org>
10139N/A- Added jack, dxr3, http packages
10139N/A- Added visualisation plug-ins, effecttv and synaesthesia
10139N/A- Created devel package
10139N/A- Removed gstreamer-plugins-libs package (moved it into gstreamer-plugins)
10139N/A- Replaced prefix/dirname with _macros
10139N/A* Mon May 06 2002 Thomas Vander Stichele <thomas@apestaart.org>
10139N/A- added gstreamer-GConf package
10139N/A* Wed Mar 13 2002 Thomas Vander Stichele <thomas@apestaart.org>
10139N/A- added more BuildRequires and Requires
10139N/A- rearranged some plug-ins
10139N/A- added changelog ;)
10139N/A