gobject-introspection.spec revision 18620
10139N/A#
10139N/A# spec file for package gobject-introspection
10139N/A#
20904N/A# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17836N/A%define owner yippi
17836N/A#
10139N/A%{?!pythonver:%define pythonver 2.6}
17178N/A
17178N/AName: gobject-introspection
17178N/ALicense: LGPL v2+ (giscanner) and GPL v2+ (tools)
10139N/AGroup: Libraries
18596N/AVersion: 0.6.10
10139N/ARelease: 1
20904N/ADistribution: Java Desktop System
10139N/AVendor: Gnome Community
10139N/ASummary: Introspection for GObject libraries
18615N/AURL: http://live.gnome.org/GObjectIntrospection
10139N/ASource: http://download.gnome.org/sources/%{name}/0.6/%{name}-%{version}.tar.bz2
20904N/A# We only deliver one set of the Python files, so it is necessary to modify
10139N/A# /usr/bin/amd64/g-ir-scanner to point to the right python files.
10139N/A# date:2010-04-09 owner:yippi type:feature
10139N/APatch1: gobject-introspection-01-amd64.diff
10139N/A
20075N/ABuildRequires: autoconf >= 2.59
20142N/ABuildRequires: automake >= 1:1.8
10139N/ABuildRequires: bison
10139N/ABuildRequires: glib2-devel >= 1:2.16.0
10139N/ABuildRequires: libffi-devel
10139N/ABuildRequires: libtool
10139N/ABuildRequires: pkgconfig
10139N/ABuildRequires: python >= 1:2.5
10139N/ABuildRequires: python-devel >= 1:2.5
10139N/A
10139N/A%description
10139N/ATools for introspecting GObject-based frameworks.
10139N/A
10139N/A%package devel
10139N/ASummary: Header files for gobject-introspection
10139N/AGroup: Development/Libraries
20075N/ARequires: %{name}-libs = %{version}-%{release}
10139N/ARequires: glib2-devel >= 2.16.0
10139N/A
10139N/A%description devel
10139N/AHeader files for gobject-introspection.
10139N/A
10139N/A%package static
10139N/ASummary: Static gobject-introspection library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name}-devel = %{version}-%{release}
10139N/A
10139N/A%description static
10139N/AStatic gobject-introspection library.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A
20904N/A#FIXME: When #590802 fixed in next release, remove following lines
20904N/Arm -f m4/lt~obsolete.m4
19064N/Arm -f m4/ltoptions.m4
19064N/Arm -f m4/libtool.m4
18595N/Arm -f m4/ltsugar.m4
18595N/Arm -f m4/ltversion.m4
12556N/A
18595N/A%build
12053N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12053N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport PYTHON=%{_bindir}/python%{pythonver}
10139N/A
18595N/A#substitute python to 2.6, CR6924142
10139N/Apyfiles="
18595N/Agiscanner/shlibs.py
10139N/Agiscanner/scannermain.py
18595N/A"
18595N/A
for i in $pyfiles
do
sed -e s,/usr/bin/env\ python,$PYTHON, $i > $i.new
mv $i.new $i
done
libtoolize --copy --force
aclocal $ACLOCAL_FLAGS -I m4
autoheader
automake -a -c -f
autoconf
./configure --prefix=%{_prefix} \
--bindir=%{_bindir} \
--libdir=%{_libdir} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
--mandir=%{_mandir}
# disable parallel builds as it's broken for 0.6.10
#gmake -j $CPU
gmake
%install
gmake install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog README
%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so.1.0.0
%attr(755,root,root) %ghost %{_libdir}/libgirepository-everything-1.0.so.1
%attr(755,root,root) %{_libdir}/libgirepository-1.0.so.0.0.0
%attr(755,root,root) %ghost %{_libdir}/libgirepository-1.0.so.0
%dir %{_libdir}/girepository-1.0
%{_libdir}/girepository-1.0/*.typelib
%defattr(-,root,root)
%attr(755,root,root) %{_bindir}/g-ir-compiler
%attr(755,root,root) %{_bindir}/g-ir-generate
%attr(755,root,root) %{_bindir}/g-ir-scanner
%{_mandir}/man1/g-ir-compiler.1*
%{_mandir}/man1/g-ir-generate.1*
%{_mandir}/man1/g-ir-scanner.1*
%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so
%attr(755,root,root) %{_libdir}/libgirepository-1.0.so
%{_libdir}/pkgconfig/gobject-introspection-1.0.pc
%{_includedir}/gobject-introspection-1.0
%{_libdir}/libgirepository-1.0.la
%{_libdir}/libgirepository-everything-1.0.la
%{_datadir}/aclocal/introspection.m4
%dir %{_datadir}/gir-1.0
%{_datadir}/gir-1.0/*.gir
%files static
%defattr(-,root,root)
%{_libdir}/libgirepository-1.0.a
%{_libdir}/libgirepository-everything-1.0.a
%changelog
* Mon Apr 19 2010 - halton.huo@sun.com
- Bump to 0.6.10
* Fri Apr 09 2010 - brian.cameron@sun.com
- Add patch gobject-introspection-01-amd64.diff.
* Fri Mar 19 2010 - halton.huo@sun.com
- Bump to 0.6.9
* Thu Mar 11 2010 - halton.huo@sun.com
- Bump to 0.6.8
- Remove upstreamed patches: 01-ginvoke.diff, 02-glib-compilation.dif
03-ginfo.diff, 04-big-ending.diff
* Mon Feb 08 2010 - halton.huo@sun.com
- Use python2.6 to scannermain.py and shlibs.py, fixes CR #6924142.
- Remove .pyc and .pyo files.
* Tue Jan 26 2010 - brian.cameron@sun.com
- Use gmake instead of make, fixes doo bug #14155.
* Fri Jan 08 2010 - halton.huo@sun.com
- Add patch ginfo.diff and big-ending.diff to fix bugzilla #606180
* Wed Dec 23 2009 - halton.huo@sun.com
- Bump to 0.6.7
- Add patch -glib-compilation.dif to fix bugzilla #605108.
* Fri Dec 11 2009 - halton.huo@sun.com
- Bump to 0.6.6. Remove upstream patch 64bit.diff.
* Sat Sep 05 2009 - brian.cameron@sun.com
- Bump to 0.6.5. Remove upstream patches.
* Mon Aug 31 2009 - halton.huo@sun.com
- Add patch -64bit to fix 64 bit issue. Bugzilla #593639.
* Sat Aug 29 2009 - halton.huo@sun.com
- Add patch -LD.diff to fix build issue with CBE 1.6.x.
* Mon Aug 24 2009 - halton.huo@sun.com
- Initial version.