gobject-introspection.spec revision 18615
10139N/A#
10139N/A# spec file for package gobject-introspection
10139N/A#
10139N/A# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner yippi
10139N/A#
10139N/A%{?!pythonver:%define pythonver 2.6}
10139N/A
10139N/AName: gobject-introspection
11283N/ALicense: LGPL v2+ (giscanner) and GPL v2+ (tools)
10139N/AGroup: Libraries
10139N/AVersion: 0.6.10
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Gnome Community
10139N/ASummary: Introspection for GObject libraries
10139N/AURL: http://live.gnome.org/GObjectIntrospection
10139N/ASource: http://download.gnome.org/sources/%{name}/0.6/%{name}-%{version}.tar.bz2
10139N/A# We only deliver one set of the Python files, so it is necessary to modify
10139N/A# /usr/bin/amd64/g-ir-scanner to point to the right python files.
10139N/A# date:2010-04-09 owner:yippi type:feature
10139N/APatch1: gobject-introspection-01-amd64.diff
10139N/A
10139N/ABuildRequires: autoconf >= 2.59
10139N/ABuildRequires: automake >= 1:1.8
10139N/ABuildRequires: bison
10139N/ABuildRequires: glib2-devel >= 1:2.16.0
10139N/ABuildRequires: libffi-devel
10139N/ABuildRequires: libtool
10139N/ABuildRequires: pkgconfig
10139N/ABuildRequires: python >= 1:2.5
10139N/ABuildRequires: python-devel >= 1:2.5
10139N/A
10139N/A%description
10139N/ATools for introspecting GObject-based frameworks.
10139N/A
10139N/A%package devel
10139N/ASummary: Header files for gobject-introspection
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name}-libs = %{version}-%{release}
10139N/ARequires: glib2-devel >= 2.16.0
10139N/A
10139N/A%description devel
10139N/AHeader files for gobject-introspection.
10139N/A
10139N/A%package static
10139N/ASummary: Static gobject-introspection library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name}-devel = %{version}-%{release}
10139N/A
10139N/A%description static
10139N/AStatic gobject-introspection library.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A
10139N/A#FIXME: When #590802 fixed in next release, remove following lines
10139N/Arm -f m4/lt~obsolete.m4
10139N/Arm -f m4/ltoptions.m4
10139N/Arm -f m4/libtool.m4
10139N/Arm -f m4/ltsugar.m4
10139N/Arm -f m4/ltversion.m4
10139N/A
10139N/A%build
10139N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport PYTHON=%{_bindir}/python%{pythonver}
10139N/A
10139N/A#substitute python to 2.6, CR6924142
10139N/Apyfiles="
10139N/Agiscanner/shlibs.py
10139N/Agiscanner/scannermain.py
10139N/A"
10139N/A
10139N/Afor i in $pyfiles
10139N/Ado
10139N/A sed -e s,/usr/bin/env\ python,$PYTHON, $i > $i.new
10139N/A mv $i.new $i
10139N/Adone
10139N/A
10139N/Alibtoolize --copy --force
10139N/Aaclocal $ACLOCAL_FLAGS -I m4
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir} \
11283N/A --sysconfdir=%{_sysconfdir} \
11283N/A --mandir=%{_mandir}
11283N/A
10139N/Agmake -j $CPU
10139N/A
10139N/A%install
10139N/Agmake install DESTDIR=$RPM_BUILD_ROOT
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post libs -p /sbin/ldconfig
10139N/A%postun libs -p /sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%doc AUTHORS ChangeLog README
10139N/A%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so.1.0.0
10139N/A%attr(755,root,root) %ghost %{_libdir}/libgirepository-everything-1.0.so.1
10139N/A%attr(755,root,root) %{_libdir}/libgirepository-1.0.so.0.0.0
10139N/A%attr(755,root,root) %ghost %{_libdir}/libgirepository-1.0.so.0
10139N/A%dir %{_libdir}/girepository-1.0
10139N/A%{_libdir}/girepository-1.0/*.typelib
10139N/A
10139N/A%defattr(-,root,root)
10139N/A%attr(755,root,root) %{_bindir}/g-ir-compiler
10139N/A%attr(755,root,root) %{_bindir}/g-ir-generate
10139N/A%attr(755,root,root) %{_bindir}/g-ir-scanner
10139N/A%{_mandir}/man1/g-ir-compiler.1*
10139N/A%{_mandir}/man1/g-ir-generate.1*
10139N/A%{_mandir}/man1/g-ir-scanner.1*
10139N/A%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so
10139N/A%attr(755,root,root) %{_libdir}/libgirepository-1.0.so
10139N/A%{_libdir}/pkgconfig/gobject-introspection-1.0.pc
10139N/A%{_includedir}/gobject-introspection-1.0
10139N/A%{_libdir}/libgirepository-1.0.la
10139N/A%{_libdir}/libgirepository-everything-1.0.la
10139N/A%{_datadir}/aclocal/introspection.m4
10139N/A%dir %{_datadir}/gir-1.0
10139N/A%{_datadir}/gir-1.0/*.gir
10139N/A
10139N/A%files static
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/libgirepository-1.0.a
10139N/A%{_libdir}/libgirepository-everything-1.0.a
10139N/A
10139N/A%changelog
10139N/A* Mon Apr 19 2010 - halton.huo@sun.com
10139N/A- Bump to 0.6.10
10139N/A* Fri Apr 09 2010 - brian.cameron@sun.com
10139N/A- Add patch gobject-introspection-01-amd64.diff.
10139N/A* Fri Mar 19 2010 - halton.huo@sun.com
10139N/A- Bump to 0.6.9
10139N/A* Thu Mar 11 2010 - halton.huo@sun.com
10139N/A- Bump to 0.6.8
10139N/A- Remove upstreamed patches: 01-ginvoke.diff, 02-glib-compilation.dif
10139N/A 03-ginfo.diff, 04-big-ending.diff
10139N/A* Mon Feb 08 2010 - halton.huo@sun.com
10139N/A- Use python2.6 to scannermain.py and shlibs.py, fixes CR #6924142.
10139N/A- Remove .pyc and .pyo files.
10139N/A* Tue Jan 26 2010 - brian.cameron@sun.com
10139N/A- Use gmake instead of make, fixes doo bug #14155.
10139N/A* Fri Jan 08 2010 - halton.huo@sun.com
10139N/A- Add patch ginfo.diff and big-ending.diff to fix bugzilla #606180
10139N/A* Wed Dec 23 2009 - halton.huo@sun.com
- Bump to 0.6.7
- Add patch -glib-compilation.dif to fix bugzilla #605108.
* Fri Dec 11 2009 - halton.huo@sun.com
- Bump to 0.6.6. Remove upstream patch 64bit.diff.
* Sat Sep 05 2009 - brian.cameron@sun.com
- Bump to 0.6.5. Remove upstream patches.
* Mon Aug 31 2009 - halton.huo@sun.com
- Add patch -64bit to fix 64 bit issue. Bugzilla #593639.
* Sat Aug 29 2009 - halton.huo@sun.com
- Add patch -LD.diff to fix build issue with CBE 1.6.x.
* Mon Aug 24 2009 - halton.huo@sun.com
- Initial version.