gobject-introspection.spec revision 18572
20814N/A#
20814N/A# spec file for package gobject-introspection
20814N/A#
20814N/A# Copyright 2010 Sun Microsystems, Inc.
20814N/A# This file and all modifications and additions to the pristine
20814N/A# package are under the same license as the package itself.
20814N/A#
20814N/A%define owner yippi
20814N/A#
20814N/A%{?!pythonver:%define pythonver 2.6}
20814N/A
20814N/AName: gobject-introspection
20814N/ALicense: LGPL v2+ (giscanner) and GPL v2+ (tools)
20814N/AGroup: Libraries
20814N/AVersion: 0.6.9
20814N/ARelease: 1
20814N/ADistribution: Java Desktop System
20814N/AVendor: Sun Microsystems, Inc.
20814N/ASummary: Introspection for GObject libraries
20814N/AURL: http://live.gnome.org/GObjectIntrospection
20814N/ASource: http://download.gnome.org/sources/%{name}/0.6/%{name}-%{version}.tar.bz2
20814N/A# We only deliver one set of the Python files, so it is necessary to modify
20814N/A# /usr/bin/amd64/g-ir-scanner to point to the right python files.
20814N/A# date:2010-04-09 owner:yippi type:feature
20814N/APatch1: gobject-introspection-01-amd64.diff
20814N/A
20814N/ABuildRequires: autoconf >= 2.59
20814N/ABuildRequires: automake >= 1:1.8
20814N/ABuildRequires: bison
20814N/ABuildRequires: glib2-devel >= 1:2.16.0
20814N/ABuildRequires: libffi-devel
20814N/ABuildRequires: libtool
20814N/ABuildRequires: pkgconfig
20814N/ABuildRequires: python >= 1:2.5
20814N/ABuildRequires: python-devel >= 1:2.5
20814N/A
20814N/A%description
20814N/ATools for introspecting GObject-based frameworks.
20814N/A
20814N/A%package devel
20814N/ASummary: Header files for gobject-introspection
20814N/AGroup: Development/Libraries
20814N/ARequires: %{name}-libs = %{version}-%{release}
20814N/ARequires: glib2-devel >= 2.16.0
20814N/A
20814N/A%description devel
20814N/AHeader files for gobject-introspection.
20814N/A
20814N/A%package static
20814N/ASummary: Static gobject-introspection library
20814N/AGroup: Development/Libraries
20814N/ARequires: %{name}-devel = %{version}-%{release}
20814N/A
20814N/A%description static
20814N/AStatic gobject-introspection library.
20814N/A
20814N/A%prep
20814N/A%setup -q
20814N/A%patch1 -p1
20814N/A
20814N/A#FIXME: When #590802 fixed in next release, remove following lines
20814N/Arm -f m4/lt~obsolete.m4
20814N/Arm -f m4/ltoptions.m4
20814N/Arm -f m4/libtool.m4
20814N/Arm -f m4/ltsugar.m4
20814N/Arm -f m4/ltversion.m4
20814N/A
20814N/A%build
20814N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20814N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20814N/A CPUS=1
20814N/Afi
20814N/A
20814N/Aexport PYTHON=%{_bindir}/python%{pythonver}
20814N/A
20814N/A#substitute python to 2.6, CR6924142
20814N/Apyfiles="
20814N/Agiscanner/shlibs.py
20814N/Agiscanner/scannermain.py
20814N/A"
20814N/A
20814N/Afor i in $pyfiles
20814N/Ado
20814N/A sed -e s,/usr/bin/env\ python,$PYTHON, $i > $i.new
20814N/A mv $i.new $i
20814N/Adone
20814N/A
20814N/Alibtoolize --copy --force
20814N/Aaclocal $ACLOCAL_FLAGS -I m4
20814N/Aautoheader
20814N/Aautomake -a -c -f
20814N/Aautoconf
20814N/A
20814N/A./configure --prefix=%{_prefix} \
20814N/A --bindir=%{_bindir} \
20814N/A --libdir=%{_libdir} \
20814N/A --includedir=%{_includedir} \
20814N/A --sysconfdir=%{_sysconfdir} \
20814N/A --mandir=%{_mandir}
20814N/A
20814N/Agmake -j $CPU
20814N/A
20814N/A%install
20814N/Agmake install DESTDIR=$RPM_BUILD_ROOT
20814N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
20814N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
20814N/A
20814N/Afind $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'
20814N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
20814N/A
20814N/A%clean
20814N/Arm -rf $RPM_BUILD_ROOT
20814N/A
20814N/A%post libs -p /sbin/ldconfig
20814N/A%postun libs -p /sbin/ldconfig
20814N/A
20814N/A%files
20814N/A%defattr(-,root,root)
20814N/A%doc AUTHORS ChangeLog README
20814N/A%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so.1.0.0
20814N/A%attr(755,root,root) %ghost %{_libdir}/libgirepository-everything-1.0.so.1
20814N/A%attr(755,root,root) %{_libdir}/libgirepository-1.0.so.0.0.0
20814N/A%attr(755,root,root) %ghost %{_libdir}/libgirepository-1.0.so.0
20814N/A%dir %{_libdir}/girepository-1.0
20814N/A%{_libdir}/girepository-1.0/*.typelib
20814N/A
20814N/A%defattr(-,root,root)
20814N/A%attr(755,root,root) %{_bindir}/g-ir-compiler
20814N/A%attr(755,root,root) %{_bindir}/g-ir-generate
20814N/A%attr(755,root,root) %{_bindir}/g-ir-scanner
20814N/A%{_mandir}/man1/g-ir-compiler.1*
20814N/A%{_mandir}/man1/g-ir-generate.1*
20814N/A%{_mandir}/man1/g-ir-scanner.1*
20814N/A%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so
20814N/A%attr(755,root,root) %{_libdir}/libgirepository-1.0.so
20814N/A%{_libdir}/pkgconfig/gobject-introspection-1.0.pc
20814N/A%{_includedir}/gobject-introspection-1.0
20814N/A%{_libdir}/libgirepository-1.0.la
20814N/A%{_libdir}/libgirepository-everything-1.0.la
20814N/A%{_datadir}/aclocal/introspection.m4
20814N/A%dir %{_datadir}/gir-1.0
20814N/A%{_datadir}/gir-1.0/*.gir
20814N/A
20814N/A%files static
20814N/A%defattr(-,root,root)
20814N/A%{_libdir}/libgirepository-1.0.a
20814N/A%{_libdir}/libgirepository-everything-1.0.a
20814N/A
20814N/A%changelog
20814N/A* Fri Apr 09 2010 - brian.cameron@sun.com
20814N/A- Add patch gobject-introspection-01-amd64.diff.
20814N/A* Fri Mar 19 2010 - halton.huo@sun.com
20814N/A- Bump to 0.6.9
20814N/A* Thu Mar 11 2010 - halton.huo@sun.com
20814N/A- Bump to 0.6.8
20814N/A- Remove upstreamed patches: 01-ginvoke.diff, 02-glib-compilation.dif
20814N/A 03-ginfo.diff, 04-big-ending.diff
20814N/A* Mon Feb 08 2010 - halton.huo@sun.com
20814N/A- Use python2.6 to scannermain.py and shlibs.py, fixes CR #6924142.
20814N/A- Remove .pyc and .pyo files.
20814N/A* Tue Jan 26 2010 - brian.cameron@sun.com
20814N/A- Use gmake instead of make, fixes doo bug #14155.
20814N/A* Fri Jan 08 2010 - halton.huo@sun.com
20814N/A- Add patch ginfo.diff and big-ending.diff to fix bugzilla #606180
20814N/A* Wed Dec 23 2009 - halton.huo@sun.com
20814N/A- Bump to 0.6.7
20814N/A- Add patch -glib-compilation.dif to fix bugzilla #605108.
20814N/A* Fri Dec 11 2009 - halton.huo@sun.com
20814N/A- Bump to 0.6.6. Remove upstream patch 64bit.diff.
20814N/A* Sat Sep 05 2009 - brian.cameron@sun.com
20814N/A- Bump to 0.6.5. Remove upstream patches.
20814N/A* Mon Aug 31 2009 - halton.huo@sun.com
20814N/A- Add patch -64bit to fix 64 bit issue. Bugzilla #593639.
20814N/A* Sat Aug 29 2009 - halton.huo@sun.com
20814N/A- Add patch -LD.diff to fix build issue with CBE 1.6.x.
20814N/A* Mon Aug 24 2009 - halton.huo@sun.com
20814N/A- Initial version.
20814N/A