gobject-introspection.spec revision 18201
#
# spec file for package gobject-introspection
#
# Copyright 2010 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
#
%{?!pythonver:%define pythonver 2.6}
Name: gobject-introspection
License: LGPL v2+ (giscanner) and GPL v2+ (tools)
Group: Libraries
Version: 0.6.7
Release: 1
Distribution: Java Desktop System
Vendor: Sun Microsystems, Inc.
Summary: Introspection for GObject libraries
URL: http://live.gnome.org/GObjectIntrospection
Source: http://download.gnome.org/sources/%{name}/0.6/%{name}-%{version}.tar.bz2
# date:2009-12-18 owner:yippi type:bug state:upstream
Patch1: gobject-introspection-01-ginvoke.diff
# date:2009-12-18 owner:halton type:bug bugzilla:605108
Patch2: gobject-introspection-02-glib-compilation.diff
# date:2010-01-08 owner:halton type:bug bugzilla:604074 state:upstream
Patch3: gobject-introspection-03-ginfo.diff
# date:2010-01-08 owner:halton type:bug bugzilla:606180
Patch4: gobject-introspection-04-big-ending.diff
BuildRequires: autoconf >= 2.59
BuildRequires: automake >= 1:1.8
BuildRequires: bison
BuildRequires: glib2-devel >= 1:2.16.0
BuildRequires: libffi-devel
BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: python >= 1:2.5
BuildRequires: python-devel >= 1:2.5
%description
Tools for introspecting GObject-based frameworks.
%package devel
Summary: Header files for gobject-introspection
Group: Development/Libraries
Requires: %{name}-libs = %{version}-%{release}
Requires: glib2-devel >= 2.16.0
%description devel
Header files for gobject-introspection.
%package static
Summary: Static gobject-introspection library
Group: Development/Libraries
Requires: %{name}-devel = %{version}-%{release}
%description static
Static gobject-introspection library.
%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
#FIXME: When #590802 fixed in next release, remove following lines
rm -f m4/lt~obsolete.m4
rm -f m4/ltoptions.m4
rm -f m4/libtool.m4
rm -f m4/ltsugar.m4
rm -f m4/ltversion.m4
%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
export PYTHON=%{_bindir}/python%{pythonver}
libtoolize --copy --force
aclocal $ACLOCAL_FLAGS -I m4
autoheader
automake -a -c -f
autoconf
./configure --prefix=%{_prefix} \
--bindir=%{_bindir} \
--libdir=%{_libdir} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
--mandir=%{_mandir}
gmake -j $CPU
%install
gmake install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc AUTHORS ChangeLog README
%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so.1.0.0
%attr(755,root,root) %ghost %{_libdir}/libgirepository-everything-1.0.so.1
%attr(755,root,root) %{_libdir}/libgirepository-1.0.so.0.0.0
%attr(755,root,root) %ghost %{_libdir}/libgirepository-1.0.so.0
%dir %{_libdir}/girepository-1.0
%{_libdir}/girepository-1.0/*.typelib
%defattr(-,root,root)
%attr(755,root,root) %{_bindir}/g-ir-compiler
%attr(755,root,root) %{_bindir}/g-ir-generate
%attr(755,root,root) %{_bindir}/g-ir-scanner
%{_mandir}/man1/g-ir-compiler.1*
%{_mandir}/man1/g-ir-generate.1*
%{_mandir}/man1/g-ir-scanner.1*
%attr(755,root,root) %{_libdir}/libgirepository-everything-1.0.so
%attr(755,root,root) %{_libdir}/libgirepository-1.0.so
%{_libdir}/pkgconfig/gobject-introspection-1.0.pc
%{_includedir}/gobject-introspection-1.0
%{_libdir}/libgirepository-1.0.la
%{_libdir}/libgirepository-everything-1.0.la
%{_datadir}/aclocal/introspection.m4
%dir %{_datadir}/gir-1.0
%{_datadir}/gir-1.0/*.gir
%files static
%defattr(-,root,root)
%{_libdir}/libgirepository-1.0.a
%{_libdir}/libgirepository-everything-1.0.a
%changelog
* Tue Jan 26 2010 - brian.cameron@sun.com
- Use gmake instead of make, fixes doo bug #14155.
* Fri Jan 08 2010 - halton.huo@sun.com
- Add patch ginfo.diff and big-ending.diff to fix bugzilla #606180
* Wed Dec 23 2009 - halton.huo@sun.com
- Bump to 0.6.7
- Add patch -glib-compilation.dif to fix bugzilla #605108.
* Fri Dec 11 2009 - halton.huo@sun.com
- Bump to 0.6.6. Remove upstream patch 64bit.diff.
* Sat Sep 05 2009 - brian.cameron@sun.com
- Bump to 0.6.5. Remove upstream patches.
* Mon Aug 31 2009 - halton.huo@sun.com
- Add patch -64bit to fix 64 bit issue. Bugzilla #593639.
* Sat Aug 29 2009 - halton.huo@sun.com
- Add patch -LD.diff to fix build issue with CBE 1.6.x.
* Mon Aug 24 2009 - halton.huo@sun.com
- Initial version.