gnome-speech.spec revision 12199
10139N/A#
10139N/A# spec file for package gnome-speech
10139N/A#
12153N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17765N/A# Owner: jedy
10139N/A#
17178N/AName: gnome-speech
17178N/ALicense: LGPL
17178N/AGroup: System/Libraries
15153N/AVersion: 0.4.18
10139N/ARelease: 201
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
18357N/ASummary: GNOME text-to-speech engine
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.4/%{name}-%{version}.tar.bz2
10139N/AURL: http://developer.gnome.org/projects/gap/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
18189N/AAutoreqprov: on
12773N/APrereq: /sbin/ldconfig
15153N/A
15153N/A%define libbonobo_version 2.4.0
12773N/A%define java_access_bridge_version 1.4.6
11389N/A%define freetts_version 1.2.1
11248N/A
11963N/ABuildRequires: jdk
11412N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
13544N/ABuildRequires: java-access-bridge >= %{java_access_bridge_version}
13451N/ABuildRequires: freetts >= %{freetts_version}
13964N/ARequires: jdk
13964N/ARequires: libbonobo >= %{libbonobo_version}
16644N/ARequires: freetts >= %{freetts_version}
17810N/A
16644N/A%description
16370N/Agnome-speech module is the GNOME text-to-speech engine.
12916N/A
10139N/A%package devel
10139N/ASummary: GNOME text-to-speech engine
10139N/AGroup: Development/System/Libraries
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
17810N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/A
10139N/A%description devel
10139N/Agnome-speech module is the GNOME text-to-speech engine.
10139N/A
10139N/A%prep
10139N/A%setup -q
17810N/A
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/A%if %option_with_java
10139N/A%ifos solaris
10139N/ACFLAGS="-I/usr/jdk/jdk1.5.0/include -I/usr/jdk/jdk1.5.0/include/solaris $RPM_OPT_FLAGS" \
10139N/A%else
10139N/A%define jdk_version 1.5.0_03
10139N/Aexport PATH="/usr/java/jdk%{jdk_version}/bin:$PATH"
10139N/ACFLAGS="-I/usr/java/jdk%{jdk_version}/include -I/usr/java/jdk%{jdk_version}include/linux $RPM_OPT_FLAGS" \
10139N/A%endif
10139N/A%define java_home_option
10139N/A%else
10139N/A%define java_home_option --with-java-home=/dont/find/me --without-freetts-dir
10139N/A%endif
10139N/A
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --with-freetts-dir=%{_datadir}/lib/freetts \
10139N/A %java_home_option
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A#Clean up unpackaged files
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
15153N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
15153N/Arm -f $RPM_BUILD_ROOT%{_bindir}/theta-synthesis-driver
15153N/Arm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Theta.server
15153N/A
15153N/A%clean
11248N/Arm -rf $RPM_BUILD_ROOT
11412N/A
13451N/A%post
13964N/A/sbin/ldconfig
16370N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/festival-synthesis-driver
10139N/A%{_bindir}/freetts-synthesis-driver
10139N/A%{_bindir}/test-speech
10139N/A%{_libdir}/bonobo/servers/*
10139N/A%{_libdir}/orbit-2.0/*.so
10139N/A%{_libdir}/*.so*
10139N/A%{_datadir}/jar/*.jar
10139N/A%{_datadir}/gnome-speech
17810N/A%{_datadir}/idl/gnome-speech-1.0/*
10139N/A
10139N/A%files devel
12773N/A%defattr(-,root,root)
12773N/A%{_includedir}/gnome-speech-1.0/*
12773N/A%{_libdir}/pkgconfig/*.pc
12773N/A
12773N/A%changelog
10139N/A* Tue Jan 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.18.
10139N/A* Tue Dec 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.17.
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- disable java stuff if the --without-java option is used
10139N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.16.
10139N/A* Mon Jul 09 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.15.
10139N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.14.
10139N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.13.
13059N/A* Tue May 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.12.
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.11.
10139N/A* Tue Feb 27 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.10.
10139N/A* Mon Feb 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.9.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.8.
12252N/A* Thu Dec 14 2006 - damien.carbery@sun.com
12252N/A- Bump to 0.4.7.
12252N/A* Mon Nov 06 2006 - damien.carbery@sun.com
12252N/A- Bump to 0.4.6.
12252N/A* Tue Aug 29 2006 - damien.carbery@sun.com
12252N/A- Bump to 0.4.5.
12252N/A* Tue Aug 22 2006 - damien.carbery@sun.com
12252N/A- Bump to 0.4.4.
10139N/A* Mon Aug 07 2006 - damien.carbery@sun.com
10139N/A- Update to 0.4.3
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Update to 0.4.2
10139N/A* Wed Jul 12 2006 - william.walker@sun.com
10139N/A- Update to 0.4.1
10139N/A* Wed Jun 14 2006 - william.walker@sun.com
10139N/A- Add patch for festival core dump (see bugzilla bug 341405)
10139N/A* Thu Feb 23 2006 - william.walker@sun.com
10139N/A- Bump to 0.3.10
10139N/A* Mon Nov 14 2005 - william.walker@sun.com
10139N/A- Bump to 0.3.9
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.3.8
10139N/A* Tue Aug 23 2005 - damien.carbery@sun.com
18357N/A- Add variable to make updating JDK version easier.
18357N/A* Tue May 10 2005 - bill.haneman@sun.com
18291N/A- Upgrade to gnome-speech 0.3.7; completes fix for bug #6216633.
18291N/A- Remove unnecessary patch 1 which is now in the tarball.
18189N/A- Remove Theta drivers if they happen to have been built.
18189N/A* Mon May 09 2005 - dermot.mccluskey@sun.com
18131N/A- New jdk (1.5.0_03)
18131N/A* Mon Feb 28 2005 - william.walker@sun.com
17810N/A- Upgrade to FreeTTS 1.2.1, fix for bug #6228329.
17810N/A* Fri Oct 08 2004 - bill.haneman@sun.com
17810N/A- Added patch gnome-speech-01-freetts-perf.diff, part of fix for bug
17810N/A #5087408.
17810N/A* Mon Sep 20 2004 - dermotm.mccluskey@sun.com
17810N/A- new path for JDK 1.5.0
16370N/A* Mon Aug 30 2004 - bill.haneman@sun.com
16370N/A- Removed patch (it's in CVS now), and bumped to 0.3.5.
16370N/A* Wed Aug 18 2004 - brian.cameron@sun.com
16370N/A- removed --disable-gtk-doc since this isn't an option this module's
16226N/A configure takes.
16226N/A* Thu Jul 22 2004 - bill.haneman@sun.com
16160N/A- Add patch to fix CLASSPATH in freetts-synthesis-driver script.
16160N/A (Please remove patch when upgrading to gnome-speech-0.3.4)
16030N/A* Thu Jul 22 2004 - damien.carbery@sun.com
16030N/A- Remove source1 tarball. Incorrectly overwrites source with old files.
15153N/A* Mon Jul 12 2004 - niall.power@sun.com
15153N/A- ported to rpm4
14479N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
14479N/A- added "-j $CPUS" to make to speed up builds
14211N/A* Thu Jun 10 2004 - bill.haneman@sun.com
14211N/A- Upgrade to version 0.3.3, depend on FreeTTS 1.2 beta.
13984N/A* Tue Jun 01 2004 - damien.carbery@sun.com
13984N/A- Correct JDK path in CFLAGS for Solaris.
13964N/A* Sun May 30 2004 - dermot.mccluskey
13964N/A- new JDK
13964N/A* Mon May 03 2004 - dermot.mccluskey@sun.com
13544N/A- moved Java to 1.5.0
13544N/A* Thu Apr 15 2004 - damien.carbery@sun.com
13544N/A- Move bin and jar files from devel to root rpm.
13312N/A* Mon Mar 15 2004 - damien.carbery@sun.com
13312N/A- Add JDK path to CFLAGS and PATH for Linux.
13312N/A* Thu Mar 11 2004 - damien.carbery@sun.com
13312N/A- Bump ver to 1.3.2. Reset release. Add --with-freetts-dir configure switch.
13059N/A- Add files created for freetts support.
13059N/A* Tue Mar 02 2004 - damien.carbery@sun.com
13059N/A- Correct line for .so files - was omitting libgnomespeech.so.
13059N/A* Tue Feb 24 2004 - damien.carbery@sun.com
12923N/A- Created new spec file for gnome-speech
12916N/A