10139N/A#
10139N/A# spec file for package gnome-speech
10139N/A#
12199N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner liyuan
10139N/A#
17177N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17177N/A
10139N/AName: gnome-speech
15311N/ALicense: LGPL v2
10139N/AGroup: System/Libraries
19975N/A# please update Version in SUNWgnome-a11y-speech.spec when the version number
19975N/A# below is >= 0.5.11
15844N/AVersion: 0.4.25
10139N/ARelease: 201
10139N/ADistribution: Java Desktop System
18615N/AVendor: Gnome Community
10139N/ASummary: GNOME text-to-speech engine
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.4/%{name}-%{version}.tar.bz2
13899N/A# date:2008-08-15 owner:ww36193 type:bug
13899N/APatch1: gnome-speech-01-espeak.diff
10139N/AURL: http://developer.gnome.org/projects/gap/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define libbonobo_version 2.4.0
10139N/A%define java_access_bridge_version 1.4.6
10139N/A%define freetts_version 1.2.1
10139N/A
10139N/ABuildRequires: jdk
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: java-access-bridge >= %{java_access_bridge_version}
10139N/ABuildRequires: freetts >= %{freetts_version}
10139N/ARequires: jdk
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: freetts >= %{freetts_version}
10139N/A
10139N/A%description
10139N/Agnome-speech module is the GNOME text-to-speech engine.
10139N/A
10139N/A%package devel
10139N/ASummary: GNOME text-to-speech engine
10139N/AGroup: Development/System/Libraries
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/A
10139N/A%description devel
10139N/Agnome-speech module is the GNOME text-to-speech engine.
10139N/A
10139N/A%prep
10139N/A%setup -q
13899N/A%patch1 -p1
10139N/A
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
17054N/A# Prevent missing symbols from happening with espeak-synthesis-driver
17054N/A#
17054N/A%ifos solaris
17054N/Aexport LDFLAGS="-Wl,-zcombreloc -Wl,-Bdirect"
17054N/A%endif
17054N/A
11314N/A%if %option_with_java
10139N/A%ifos solaris
13899N/Aexport CFLAGS="-I/usr/jdk/jdk1.5.0/include -I/usr/jdk/jdk1.5.0/include/solaris $RPM_OPT_FLAGS" \
10139N/A%else
10139N/A%define jdk_version 1.5.0_03
10139N/Aexport PATH="/usr/java/jdk%{jdk_version}/bin:$PATH"
13899N/Aexport CFLAGS="-I/usr/java/jdk%{jdk_version}/include -I/usr/java/jdk%{jdk_version}include/linux $RPM_OPT_FLAGS" \
10139N/A%endif
11314N/A%define java_home_option
11314N/A%else
11314N/A%define java_home_option --with-java-home=/dont/find/me --without-freetts-dir
11314N/A%endif
11314N/A
15785N/Alibtoolize -f
13899N/Aaclocal $ACLOCAL_FLAGS
13899N/Aautomake
13899N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
11314N/A --with-freetts-dir=%{_datadir}/lib/freetts \
11314N/A %java_home_option
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A#Clean up unpackaged files
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
10139N/Arm -f $RPM_BUILD_ROOT%{_bindir}/theta-synthesis-driver
10139N/Arm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Theta.server
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/festival-synthesis-driver
10139N/A%{_bindir}/freetts-synthesis-driver
10139N/A%{_bindir}/test-speech
10139N/A%{_libdir}/bonobo/servers/*
10139N/A%{_libdir}/orbit-2.0/*.so
10139N/A%{_libdir}/*.so*
10139N/A%{_datadir}/jar/*.jar
10139N/A%{_datadir}/gnome-speech
10139N/A%{_datadir}/idl/gnome-speech-1.0/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_includedir}/gnome-speech-1.0/*
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A
10139N/A%changelog
17054N/A* Tue Aug 18 2009 - william.walker@sun.com
17054N/A- Move LDFLAGS outside of %option_with_java since LDFLAGS is to
17054N/A prevent missing symbols in the espeak-synthesis driver
15844N/A* Mon Feb 16 2009 - dave.lin@sun.com
15844N/A- Bump to 0.4.25
15785N/A* Fri Feb 06 2009 - li.yuan@sun.com
15785N/A- Bump to 0.4.23. Run libtoolize before aclocal.
15311N/A* Wed Nov 05 2008 - li.yuan@sun.com
15311N/A- Change copyright information.
13899N/A* Mon Aug 18 2008 - william.walker@sun.com
13899N/A- Handle the fallout of porting eSpeak to SunStudio.
13764N/A* Tue Aug 05 2008 - damien.carbery@sun.com
13764N/A- Bump to 0.4.21.
13426N/A* Tue Jun 17 2008 - damien.carbery@sun.com
13426N/A- Bump to 0.4.20.
12904N/A* Fri Apr 18 2008 - damien.carbery@sun.com
13426N/A- Bump to 0.4.19.
12904N/A* Tue Jan 15 2008 - damien.carbery@sun.com
12199N/A- Bump to 0.4.18.
12072N/A* Tue Dec 18 2007 - damien.carbery@sun.com
12072N/A- Bump to 0.4.17.
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- disable java stuff if the --without-java option is used
10972N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10972N/A- Bump to 0.4.16.
10911N/A* Mon Jul 09 2007 - damien.carbery@sun.com
10911N/A- Bump to 0.4.15.
10810N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10810N/A- Bump to 0.4.14.
10746N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10746N/A- Bump to 0.4.13.
10637N/A* Tue May 15 2007 - damien.carbery@sun.com
10637N/A- Bump to 0.4.12.
10473N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10473N/A- Bump to 0.4.11.
10473N/A* Tue Feb 27 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.10.
10473N/A* Mon Feb 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.9.
10473N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.4.8.
10139N/A* Thu Dec 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.7.
10139N/A* Mon Nov 06 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.6.
10139N/A* Tue Aug 29 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.5.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.4.
10139N/A* Mon Aug 07 2006 - damien.carbery@sun.com
10139N/A- Update to 0.4.3
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Update to 0.4.2
10139N/A* Wed Jul 12 2006 - william.walker@sun.com
10139N/A- Update to 0.4.1
10139N/A* Wed Jun 14 2006 - william.walker@sun.com
10139N/A- Add patch for festival core dump (see bugzilla bug 341405)
10139N/A* Thu Feb 23 2006 - william.walker@sun.com
10139N/A- Bump to 0.3.10
10139N/A* Mon Nov 14 2005 - william.walker@sun.com
10139N/A- Bump to 0.3.9
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.3.8
10139N/A* Tue Aug 23 2005 - damien.carbery@sun.com
10139N/A- Add variable to make updating JDK version easier.
10139N/A* Tue May 10 2005 - bill.haneman@sun.com
10139N/A- Upgrade to gnome-speech 0.3.7; completes fix for bug #6216633.
10139N/A- Remove unnecessary patch 1 which is now in the tarball.
10139N/A- Remove Theta drivers if they happen to have been built.
10139N/A* Mon May 09 2005 - dermot.mccluskey@sun.com
10139N/A- New jdk (1.5.0_03)
10139N/A* Mon Feb 28 2005 - william.walker@sun.com
10139N/A- Upgrade to FreeTTS 1.2.1, fix for bug #6228329.
10139N/A* Fri Oct 08 2004 - bill.haneman@sun.com
10139N/A- Added patch gnome-speech-01-freetts-perf.diff, part of fix for bug
10139N/A #5087408.
10139N/A* Mon Sep 20 2004 - dermotm.mccluskey@sun.com
10139N/A- new path for JDK 1.5.0
10139N/A* Mon Aug 30 2004 - bill.haneman@sun.com
10139N/A- Removed patch (it's in CVS now), and bumped to 0.3.5.
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- removed --disable-gtk-doc since this isn't an option this module's
10139N/A configure takes.
10139N/A* Thu Jul 22 2004 - bill.haneman@sun.com
10139N/A- Add patch to fix CLASSPATH in freetts-synthesis-driver script.
10139N/A (Please remove patch when upgrading to gnome-speech-0.3.4)
10139N/A* Thu Jul 22 2004 - damien.carbery@sun.com
10139N/A- Remove source1 tarball. Incorrectly overwrites source with old files.
10139N/A* Mon Jul 12 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Thu Jun 10 2004 - bill.haneman@sun.com
10139N/A- Upgrade to version 0.3.3, depend on FreeTTS 1.2 beta.
10139N/A* Tue Jun 01 2004 - damien.carbery@sun.com
10139N/A- Correct JDK path in CFLAGS for Solaris.
10139N/A* Sun May 30 2004 - dermot.mccluskey
10139N/A- new JDK
10139N/A* Mon May 03 2004 - dermot.mccluskey@sun.com
10139N/A- moved Java to 1.5.0
10139N/A* Thu Apr 15 2004 - damien.carbery@sun.com
10139N/A- Move bin and jar files from devel to root rpm.
10139N/A* Mon Mar 15 2004 - damien.carbery@sun.com
10139N/A- Add JDK path to CFLAGS and PATH for Linux.
10139N/A* Thu Mar 11 2004 - damien.carbery@sun.com
10139N/A- Bump ver to 1.3.2. Reset release. Add --with-freetts-dir configure switch.
10139N/A- Add files created for freetts support.
10139N/A* Tue Mar 02 2004 - damien.carbery@sun.com
10139N/A- Correct line for .so files - was omitting libgnomespeech.so.
10139N/A* Tue Feb 24 2004 - damien.carbery@sun.com
10139N/A- Created new spec file for gnome-speech