gnome-settings-daemon.spec revision 14453
10139N/A#
10139N/A# spec file for package gnome-settings-daemon.
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: dkenny
10139N/A#
10139N/A%include l10n.inc
10139N/AName: gnome-settings-daemon
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
10139N/AVersion: 2.23.92
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: The GNOME Settings Daemon
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gnome-settings-daemon/2.23/gnome-settings-daemon-%{version}.tar.bz2
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A%endif
10139N/A# TODO - l10n extraction from existing gnome-control-center.
10139N/A#Source1: %{name}-po-sun-%{po_sun_version}.tar.bz2
10142N/A# date:2006-12-07 owner:dcarbery type:bug bugzilla:383356
10142N/APatch1: gnome-settings-daemon-01-no-libgnomekbd.diff
10139N/A# date:2004-10-06 owner:dkenny type:bug bugster:5101706
10139N/APatch2: gnome-settings-daemon-02-logout-shortcut.diff
10139N/A# date:2004-10-19 owner:dkenny type:feature bugster:4878555
10139N/APatch3: gnome-settings-daemon-03-custom-keybinding.diff
10139N/A# date:2006-06-30 owner:stephen type:feature
10139N/APatch4: gnome-settings-daemon-04-trusted-extensions.diff
10139N/A# date:2006-08-28 owner:pwade type:bug bugster:6327546
10139N/APatch5: gnome-settings-daemon-05-sticky-timeout.diff
10139N/A# date:2008-01-24 owner:dkenny type:bug bugzilla:511733
10139N/APatch6: gnome-settings-daemon-06-xft.diff
10139N/A# date:2008-01-24 owner:erwannc type:bug bugzilla:146 bugster:6717847
10139N/APatch7: gnome-settings-daemon-07-default-dpi-and-aa.diff
10139N/A
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/control-center2
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/APrereq: GConf
10139N/A
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define esound_version 0.2.33
10139N/A%define gnome_desktop_version 2.6.1
10139N/A%define metacity_version 2.8.0
10139N/A%define nautilus_version 2.6.1
10139N/A%define fontilus_version 2.4.0
10139N/A%define acme_version 2.4.2
10139N/A%define desktop_file_utils_version 0.10
10139N/A%define xft_version 2.1.7
10139N/A
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: esound-devel >= %{esound_version}
10139N/ABuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
10139N/ABuildRequires: metacity >= %{metacity_version}
10139N/ABuildRequires: nautilus-devel >= %{nautilus_version}
10139N/ABuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
10139N/ABuildRequires: automake >= 1.9
10139N/ABuildRequires: evolution-data-server-devel
10139N/ABuildRequires: gstreamer-plugins-devel
10139N/A
10139N/ARequires: gst-plugins-base
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: esound >= %{esound_version}
10139N/ARequires: gnome-desktop >= %{gnome_desktop_version}
10139N/ARequires: nautilus >= %{nautilus_version}
10139N/ARequires: evolution-data-server
10139N/A
10139N/AObsoletes: fontilus < %{fontilus_version}
10139N/AProvides: fontilus = %{fontilus_version}
10139N/AObsoletes: acme < %{acme_version}
10139N/AProvides: acme = %{acme_version}
10139N/A
10139N/A%description
10139N/AThis package contains the new control-center for the GNOME desktop.
10142N/A
10139N/A%package devel
10139N/ASummary: Development files for the GNOME Settings Daemon
10139N/AGroup: Development/Libraries/GNOME
10139N/ARequires: %name = %version-%release
10139N/A
10139N/A%description devel
10139N/AThis package contains the files need for development of GNOME control center capplets
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A# TODO - l10n extraction from existing gnome-control-center.
10139N/A#%if %build_l10n
10139N/A#bzcat %SOURCE1 | tar xf -
10139N/A#cd po-sun; make; cd ..
10139N/A#%endif
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A
10139N/A# Rename dir so that #include does not have to change on gnome-control-center.
10139N/A# Combines with patch mv-src-dir.diff (see bugzilla 511820).
10139N/A##mv src gnome-settings-daemon
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/ALC_ALL=
10139N/ALANG=
10139N/Aexport LC_ALL LANG
10139N/Agnome-doc-common
10139N/Agnome-doc-prepare --force
10139N/Alibtoolize --force
10139N/Aglib-gettextize -f
10139N/Aintltoolize --force --copy
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10142N/A%endif
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/A%if %with_hal
10139N/Aexport ENABLE_HAL_CONFIG="--enable-hal"
10139N/A%else
10139N/Aexport ENABLE_HAL_CONFIG="--disable-hal"
10139N/A%endif
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/X11/share/include" \
10139N/A ./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --datadir=%{_datadir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --disable-scrollkeeper \
10139N/A --enable-aboutme \
10139N/A --disable-gswitchit \
10139N/A $ENABLE_HAL_CONFIG
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-2.0/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-2.0/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="apps_gnome_settings_daemon_default_editor.schemas apps_gnome_settings_daemon_screensaver.schemas desktop_gnome_font_rendering.schemas desktop_gnome_peripherals_keyboard_xkb.schemas apps_gnome_settings_daemon_keybindings.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%doc AUTHORS COPYING ChangeLog NEWS README
10139N/A%defattr (-, root, root)
10139N/A%{_prefix}/bin/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/pixmaps/*
10139N/A%{_datadir}/idl/*.idl
10139N/A%{_datadir}/control-center-2.0/*
10139N/A%{_sysconfdir}/gconf/schemas/*.schemas
10139N/A%{_sysconfdir}/gnome-vfs-2.0/modules/*
10139N/A%{_datadir}/gnome/vfolders/*
10139N/A%{_datadir}/gnome/cursor-fonts/*
10139N/A%{_datadir}/gnome/help/*
10139N/A%{_datadir}/omf
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/icons/hicolor/*
10139N/A%{_datadir}/gnome-background-properties
10139N/A%{_datadir}/gnome-default-applications
10139N/A%{_libdir}/*.so.*
10139N/A%{_libdir}/bonobo/servers/*
10139N/A%{_libdir}/gnome-vfs-2.0/modules/*.so*
10139N/A%{_libdir}/nautilus/extensions-2.0/*.so
10139N/A%{_libdir}/window-manager-settings/*.so
10139N/A%{_libexecdir}/gnome-settings-daemon
10139N/A%{_mandir}/man1/*
10139N/A
10139N/A%files devel
10139N/A%{_includedir}/gnome-window-settings-2.0/*.h
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_libdir}/*.so
10139N/A
10139N/A%changelog
10139N/A* Sun Sep 21 2008 - christian.kelly@sun.com
10139N/A- Bump to 2.23.92.
10139N/A* Tue Sep 02 2008 - christian.kelly@sun.com
10139N/A- Bump to 2.23.91.
10139N/A* Wed Aug 20 2008 - darren.kenny@sun.com
10139N/A- Attempt to fix gnome-settings-daemon-05-sticky-timeout.diff to apply.
10139N/A* Tue Aug 19 2008 - dave.lin@sun.com
10139N/A- Bump to 2.23.90
10139N/A* Tue Aug 05 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.6.
10139N/A* Fri Jul 25 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.5. Remove upstream patch, 07-uninstalled. Renumber
10139N/A 08-use-default-dpi to 07.
10139N/A* Tue Jun 17 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.4. Remove upstream patch, 08-esound-prefix-branding.
10139N/A* Wed Jun 04 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.3. Remove upstream patch, 08-gnomeinit. Renumber remainder.
10139N/A* Fri May 30 - darren.kenny@sun.com
10139N/A- Bump to 2.23.1.1.
10139N/A* Wed May 28 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.22.2.
10139N/A* Fri May 16 2008 - stephen.browne@sun.com
10139N/A- remove conditional build of tx patch
10139N/A* Thu May 06 2008 - lin.ma@sun.com
10139N/A- Fix g-s-d so that it can find /usr/lib/esd.
10139N/A* Thu May 01 2008 - brian.cameron@sun.com
10139N/A- Fix g-s-d so that it will start up if the user doesn't have a writable
10139N/A $HOME directory via patch gnome-settings-daemon-08-gnomeinit.diff. This
10139N/A is needed for the new GDM rewrite, which needs to run g-s-d and does not
10139N/A have a writable $HOME directory.
10139N/A* Tue Mar 11 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.22.0.
10139N/A* Mon Mar 3 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.92.
10139N/A* Fri Feb 15 2008 - damien.carbery@sun.com
10139N/A- Add patch 07-uninstalled to correct Cflags path in the uninstalled.pc.in file. Correct path to the plugins.
10139N/A* Tue Feb 12 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.91. Remove upstream patches 07-uninstalled and 09-mv-src-dir.
10139N/A Remove 06-relocate-plugins as the change is implemented in configure.
10139N/A* Fri Feb 01 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.90.2.
10139N/A* Tue Jan 29 2008 - brian.cameron@sun.com
10139N/A- Bump to 2.21.90.1.
10139N/A* Thu Jan 24 2007 - damien.carbery@sun.com
10139N/A- Add patch 10-mv-src-dir to rename 'src' to 'gnome-settings-daemon' to
10139N/A simplify uninstalled building. Bugzilla 511820.
10139N/A* Thu Jan 24 2007 - darren.kenny@sun.com
10139N/A- Add patch 09-xft to fix bugzilla 511733.
10139N/A* Wed Jan 23 2007 - damien.carbery@sun.com
10139N/A- Add patch 08-uninstalled to create an uninstalled.pc.in file to permit
10139N/A building.
10139N/A* Wed Jan 23 2007 - darren.kenny@sun.com
10139N/A- Initial SPEC file for new g-s-d project.
10139N/A Extracted from control-center project.
10139N/A- Removed gnome screensaver patch which isn't needed (and was actually
10139N/A ineffective).
10139N/A