gnome-settings-daemon.spec revision 13919
11844N/A#
11844N/A# spec file for package gnome-settings-daemon.
11844N/A#
11844N/A# Copyright (c) 2008 Sun Microsystems, Inc.
11844N/A# This file and all modifications and additions to the pristine
18221N/A# package are under the same license as the package itself.
11844N/A#
11844N/A# Owner: dkenny
11844N/A#
17185N/A%include l10n.inc
12332N/AName: gnome-settings-daemon
11844N/ALicense: GPL
19806N/AGroup: System/GUI/GNOME
11844N/AVersion: 2.23.90
17176N/ARelease: 1
17176N/ADistribution: Java Desktop System
11844N/AVendor: Sun Microsystems, Inc.
12542N/ASummary: The GNOME Settings Daemon
11844N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gnome-settings-daemon/2.23/gnome-settings-daemon-%{version}.tar.bz2
18710N/A%if %build_l10n
11844N/ASource1: l10n-configure.sh
11844N/A%endif
18616N/A# TODO - l10n extraction from existing gnome-control-center.
11844N/A#Source1: %{name}-po-sun-%{po_sun_version}.tar.bz2
18221N/A# date:2006-12-07 owner:dcarbery type:bug bugzilla:383356
11844N/APatch1: gnome-settings-daemon-01-no-libgnomekbd.diff
11844N/A# date:2004-10-06 owner:dkenny type:bug bugster:5101706
11844N/APatch2: gnome-settings-daemon-02-logout-shortcut.diff
11844N/A# date:2004-10-19 owner:dkenny type:feature bugster:4878555
11844N/APatch3: gnome-settings-daemon-03-custom-keybinding.diff
11844N/A# date:2006-06-30 owner:stephen type:feature
11844N/APatch4: gnome-settings-daemon-04-trusted-extensions.diff
11844N/A# date:2006-08-28 owner:pwade type:bug bugster:6327546
11844N/APatch5: gnome-settings-daemon-05-sticky-timeout.diff
11844N/A# date:2008-01-24 owner:dkenny type:bug bugzilla:511733
11844N/APatch6: gnome-settings-daemon-06-xft.diff
11844N/A# date:2008-01-24 owner:erwannc type:bug bugster:146
11844N/APatch7: gnome-settings-daemon-07-use-default-dpi.diff
11844N/A
11844N/AURL: http://www.gnome.org
15395N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11844N/ADocdir: %{_defaultdocdir}/control-center2
11844N/AAutoreqprov: on
11844N/APrereq: /sbin/ldconfig
11844N/APrereq: GConf
11844N/A
11844N/A%define libgnomeui_version 2.6.0
11844N/A%define esound_version 0.2.33
11844N/A%define gnome_desktop_version 2.6.1
11844N/A%define metacity_version 2.8.0
11844N/A%define nautilus_version 2.6.1
11844N/A%define fontilus_version 2.4.0
11844N/A%define acme_version 2.4.2
11844N/A%define desktop_file_utils_version 0.10
11844N/A%define xft_version 2.1.7
11844N/A
11844N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
18710N/ABuildRequires: esound-devel >= %{esound_version}
18710N/ABuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
18221N/ABuildRequires: metacity >= %{metacity_version}
18221N/ABuildRequires: nautilus-devel >= %{nautilus_version}
17652N/ABuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
17652N/ABuildRequires: automake >= 1.9
17652N/ABuildRequires: evolution-data-server-devel
16369N/ABuildRequires: gstreamer-plugins-devel
16369N/A
15758N/ARequires: gst-plugins-base
15758N/ARequires: libgnomeui >= %{libgnomeui_version}
15395N/ARequires: esound >= %{esound_version}
15395N/ARequires: gnome-desktop >= %{gnome_desktop_version}
15361N/ARequires: nautilus >= %{nautilus_version}
15361N/ARequires: evolution-data-server
11844N/A
11846N/AObsoletes: fontilus < %{fontilus_version}
11846N/AProvides: fontilus = %{fontilus_version}
11846N/AObsoletes: acme < %{acme_version}
Provides: acme = %{acme_version}
%description
This package contains the new control-center for the GNOME desktop.
%package devel
Summary: Development files for the GNOME Settings Daemon
Group: Development/Libraries/GNOME
Requires: %name = %version-%release
%description devel
This package contains the files need for development of GNOME control center capplets
%prep
%setup -q
# TODO - l10n extraction from existing gnome-control-center.
#%if %build_l10n
#bzcat %SOURCE1 | tar xf -
#cd po-sun; make; cd ..
#%endif
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
#%patch5 -p1
%patch6 -p1
%patch7 -p1
# Rename dir so that #include does not have to change on gnome-control-center.
# Combines with patch mv-src-dir.diff (see bugzilla 511820).
##mv src gnome-settings-daemon
%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
LC_ALL=
LANG=
export LC_ALL LANG
gnome-doc-common
gnome-doc-prepare --force
libtoolize --force
glib-gettextize -f
intltoolize --force --copy
%if %build_l10n
bash -x %SOURCE1 --enable-copyright
%endif
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf
%if %with_hal
export ENABLE_HAL_CONFIG="--enable-hal"
%else
export ENABLE_HAL_CONFIG="--disable-hal"
%endif
CFLAGS="$RPM_OPT_FLAGS -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/X11/share/include" \
./configure \
--prefix=%{_prefix} \
--datadir=%{_datadir} \
--libexecdir=%{_libexecdir} \
--sysconfdir=%{_sysconfdir} \
--disable-scrollkeeper \
--enable-aboutme \
--disable-gswitchit \
$ENABLE_HAL_CONFIG
make -j $CPUS
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-2.0/*.a
rm $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-2.0/*.la
%clean
rm -rf $RPM_BUILD_ROOT
%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="apps_gnome_settings_daemon_default_editor.schemas apps_gnome_settings_daemon_screensaver.schemas desktop_gnome_font_rendering.schemas desktop_gnome_peripherals_keyboard_xkb.schemas apps_gnome_settings_daemon_keybindings.schemas"
for S in $SCHEMAS; do
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
%postun
/sbin/ldconfig
%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_prefix}/bin/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/pixmaps/*
%{_datadir}/idl/*.idl
%{_datadir}/control-center-2.0/*
%{_sysconfdir}/gconf/schemas/*.schemas
%{_sysconfdir}/gnome-vfs-2.0/modules/*
%{_datadir}/gnome/vfolders/*
%{_datadir}/gnome/cursor-fonts/*
%{_datadir}/gnome/help/*
%{_datadir}/omf
%{_datadir}/applications/*
%{_datadir}/icons/hicolor/*
%{_datadir}/gnome-background-properties
%{_datadir}/gnome-default-applications
%{_libdir}/*.so.*
%{_libdir}/bonobo/servers/*
%{_libdir}/gnome-vfs-2.0/modules/*.so*
%{_libdir}/nautilus/extensions-2.0/*.so
%{_libdir}/window-manager-settings/*.so
%{_libexecdir}/gnome-settings-daemon
%{_mandir}/man1/*
%files devel
%{_includedir}/gnome-window-settings-2.0/*.h
%{_libdir}/pkgconfig/*.pc
%{_libdir}/*.so
%changelog
* Tue Aug 19 2008 - dave.lin@sun.com
- Bump to 2.23.90
* Tue Aug 05 2008 - damien.carbery@sun.com
- Bump to 2.23.6.
* Fri Jul 25 2008 - damien.carbery@sun.com
- Bump to 2.23.5. Remove upstream patch, 07-uninstalled. Renumber
08-use-default-dpi to 07.
* Tue Jun 17 2008 - damien.carbery@sun.com
- Bump to 2.23.4. Remove upstream patch, 08-esound-prefix-branding.
* Wed Jun 04 2008 - damien.carbery@sun.com
- Bump to 2.23.3. Remove upstream patch, 08-gnomeinit. Renumber remainder.
* Fri May 30 - darren.kenny@sun.com
- Bump to 2.23.1.1.
* Wed May 28 2008 - damien.carbery@sun.com
- Bump to 2.22.2.
* Fri May 16 2008 - stephen.browne@sun.com
- remove conditional build of tx patch
* Thu May 06 2008 - lin.ma@sun.com
- Fix g-s-d so that it can find /usr/lib/esd.
* Thu May 01 2008 - brian.cameron@sun.com
- Fix g-s-d so that it will start up if the user doesn't have a writable
$HOME directory via patch gnome-settings-daemon-08-gnomeinit.diff. This
is needed for the new GDM rewrite, which needs to run g-s-d and does not
have a writable $HOME directory.
* Tue Mar 11 2008 - damien.carbery@sun.com
- Bump to 2.22.0.
* Mon Mar 3 2008 - damien.carbery@sun.com
- Bump to 2.21.92.
* Fri Feb 15 2008 - damien.carbery@sun.com
- Add patch 07-uninstalled to correct Cflags path in the uninstalled.pc.in file. Correct path to the plugins.
* Tue Feb 12 2008 - damien.carbery@sun.com
- Bump to 2.21.91. Remove upstream patches 07-uninstalled and 09-mv-src-dir.
Remove 06-relocate-plugins as the change is implemented in configure.
* Fri Feb 01 2008 - damien.carbery@sun.com
- Bump to 2.21.90.2.
* Tue Jan 29 2008 - brian.cameron@sun.com
- Bump to 2.21.90.1.
* Thu Jan 24 2007 - damien.carbery@sun.com
- Add patch 10-mv-src-dir to rename 'src' to 'gnome-settings-daemon' to
simplify uninstalled building. Bugzilla 511820.
* Thu Jan 24 2007 - darren.kenny@sun.com
- Add patch 09-xft to fix bugzilla 511733.
* Wed Jan 23 2007 - damien.carbery@sun.com
- Add patch 08-uninstalled to create an uninstalled.pc.in file to permit
building.
* Wed Jan 23 2007 - darren.kenny@sun.com
- Initial SPEC file for new g-s-d project.
Extracted from control-center project.
- Removed gnome screensaver patch which isn't needed (and was actually
ineffective).