gnome-session.spec revision 13383
20814N/A#
20814N/A# spec file for package gnome-session
20814N/A#
20814N/A# Copyright 2008 Sun Microsystems, Inc.
20814N/A# This file and all modifications and additions to the pristine
20814N/A# package are under the same license as the package itself.
20814N/A#
20814N/A# Owner: niall
20814N/A#
20814N/A%include l10n.inc
20814N/AName: gnome-session
20814N/ALicense: GPL
20814N/AGroup: System/GUI/GNOME
20814N/AVersion: 2.22.2
20814N/ARelease: 1
20814N/ADistribution: Java Desktop System
20814N/AVendor: Sun Microsystems, Inc.
20814N/ASummary: Session Manager for the GNOME Desktop
20814N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.22/%{name}-%{version}.tar.bz2
20814N/ASource1: gnome-splash.png
20814N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
20814N/A%if %build_l10n
20814N/ASource3: l10n-configure.sh
20814N/A%endif
20814N/ASource4: indiana-splash.jpg
20814N/A#owner:gheet date:2004-08-06 type:bug bugster:5025823
20814N/APatch1: gnome-session-01-gnome-atom.diff
20814N/A#owner:alo date:2005-03-14 type:bug bugster:5099423
20814N/APatch2: gnome-session-02-logout-effect.diff
20814N/A%if %option_with_sun_branding
20814N/A#owner:yippi date:2004-11-04 type:branding
20814N/APatch3: gnome-session-03-gnome-about.diff
20814N/A%endif
20814N/A#owner:stephen date:2006-06-29 type:feature bugster:6444179
20814N/APatch4: gnome-session-04-wait-for-postrun.diff
20814N/A#owner:gheet date:2006-11-03 type:feature bugster:6393728
20814N/APatch5: gnome-session-05-trusted-extensions.diff
20814N/A#owner:niall date:2004-11-10 type:branding bugster:6188905
20814N/A# We only want to run gnome-volcheck by default if we aren't building with HAL.
20814N/APatch6: gnome-session-06-gnome-volcheck-default-session.diff
20814N/A#owner:erwannc date:2003-07-29 type:branding
20814N/APatch7: gnome-session-07-busy-cursor.diff
20814N/A%if %option_with_sun_branding
20814N/A#owner:erwannc date:2005-05-11 type:branding
20814N/APatch8: gnome-session-08-solaris-branding.diff
20814N/A%endif
20814N/A# This patch works around a bug in D-Bus. When this bug is actually fixed
20814N/A# in D-Bus, then this workaround patch should be removed.
20814N/A#owner:yippi date:2008-01-08 type:bug bugzilla:508231
20814N/APatch9: gnome-session-09-find-dbus-daemon.diff
20814N/A#owner:jefftsai date:2008-01-08 type:branding
20814N/APatch10: gnome-session-10-disable-ssh.diff
20814N/A#owner:yippi date:2008-02-29 type:branding
20814N/APatch11: gnome-session-11-Xsession.diff
20814N/A#owner:erwannc date:2008-03-07 type:feature bugster:6672099
20814N/APatch12: gnome-session-12-compiz-integration.diff
20814N/A#owner:erwannc date:2008-03-27 type:branding
20814N/APatch13: gnome-session-13-indiana-splash-hack.diff
20814N/A
20814N/AURL: http://www.gnome.org
20814N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20814N/ADocdir: %{_defaultdocdir}/%{name}
20814N/AAutoreqprov: on
20814N/APrereq: GConf
20814N/A
20814N/A%define libgnomeui_version 2.2.0
20814N/A%define libwnck_version 2.2.1
20814N/A
20814N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
20814N/ABuildRequires: libwnck-devel >= %{libwnck_version}
20814N/ARequires: libgnomeui >= %{libgnomeui_version}
20814N/ARequires: libwnck >= %{libwnck_version}
20814N/A
20814N/A%description
20814N/AThis package provides the basic session manager and tools for the GNOME Desktop.
20814N/A
20814N/A%prep
20814N/A%setup -q
20814N/A%if %build_l10n
20814N/Abzcat %SOURCE2 | tar xf -
20814N/Acd po-sun; make; cd ..
20814N/Acd po-logout; make; cd ..
20814N/A%endif
20814N/A%patch1 -p1
20814N/A%patch2 -p1
20814N/A%if %option_with_sun_branding
20814N/A%patch3 -p1
20814N/A%endif
20814N/A%patch4 -p1
20814N/A%patch5 -p1
20814N/A%if %with_hal
20814N/A%else
20814N/A%patch6 -p1
20814N/A%endif
20814N/A%patch7 -p1
20814N/A%if %option_with_sun_branding
20814N/A%patch8 -p1
20814N/Acp %SOURCE1 gnome-session/gnome-splash.png
20814N/A%endif
20814N/A%patch9 -p1
20814N/A%patch10 -p1
20814N/A%if %option_without_dt
20814N/A%else
20814N/A%patch11 -p1
20814N/A%endif
20814N/A%patch12 -p1
20814N/A%if %option_with_indiana_branding
20814N/Acp %SOURCE4 data
20814N/A%patch13 -p1
20814N/A%endif
20814N/A
20814N/A
20814N/A%build
20814N/A%ifos linux
20814N/Aif [ -x /usr/bin/getconf ]; then
20814N/A CPUS=`getconf _NPROCESSORS_ONLN`
20814N/Afi
20814N/A%else
20814N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20814N/A%endif
20814N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20814N/A CPUS=1
20814N/Afi
20814N/A
20814N/A%ifos solaris
20814N/A%define poweroff /usr/sbin/poweroff
20814N/A%define reboot /usr/sbin/reboot
20814N/A%else
20814N/A%define poweroff /usr/bin/poweroff
20814N/A%define reboot /usr/bin/reboot
20814N/A%endif
20814N/A
20814N/Alibtoolize --force
20814N/Aintltoolize -c -f --automake
20814N/A
20814N/A%if %build_l10n
20814N/Abash -x %SOURCE3 --enable-copyright
20814N/A%endif
20814N/A
20814N/Aaclocal $ACLOCAL_FLAGS -I .
20814N/Aautoheader
20814N/Aautomake -a -c -f
20814N/Aautoconf
20814N/ACFLAGS="$RPM_OPT_FLAGS" \
20814N/A./configure --prefix=%{_prefix} \
20814N/A --libexecdir=%{_libexecdir} \
20814N/A --sysconfdir=%{_sysconfdir} \
20814N/A --mandir=%{_mandir} \
20814N/A --with-halt-command=%poweroff \
20814N/A --with-reboot-command=%reboot
20814N/Amake -j $CPUS
20814N/A
20814N/A%install
20814N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
20814N/Amake DESTDIR=$RPM_BUILD_ROOT install
20814N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
20814N/A
20814N/A%clean
20814N/Arm -rf $RPM_BUILD_ROOT
20814N/A
20814N/A%post
20814N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
20814N/ASCHEMAS="gnome-session.schemas"
20814N/Afor S in $SCHEMAS; do
20814N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
20814N/Adone
20814N/A
20814N/A%files
20814N/A%defattr(-,root,root)
20814N/A%{_bindir}/*
20814N/A%{_datadir}/pixmaps/*
20814N/A%{_mandir}/man1/*
20814N/A%{_mandir}/man5/*
20814N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
20814N/A%{_datadir}/gnome/default.session
20814N/A%{_datadir}/gnome/default.wm
20814N/A%{_datadir}/applications/
20814N/A%{_sysconfdir}/gconf/schemas/*
20814N/A
20814N/A%changelog
20814N/A* Thu Jun 12 2008 - takao.fujiwara@sun.com
20814N/A- Add po-logout to avoid UI freeze.
20814N/A* Fri Jun 06 2008 - simon.zheng@sun.com
20814N/A- Remove 13-logout-shutdown-dialog.diff and 14-
20814N/A* Sat May 31 2008 - brian.cameron@sun.com
20814N/A- Add patch so that the "Switch User" button does not show up on
20814N/A Solaris. Fixes bugzilla:535892.
20814N/A* Tue May 27 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.22.2.
20814N/A* Wed May 07 2008 - simon.zheng@sun.com
20814N/A- Add patch 13-logout-shutdown-dialog.
20814N/A* Fri Apr 11 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.22.1.1.
20814N/A* Thu Apr 10 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.22.1.
20814N/A* Tue Mar 11 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.22.0.
20814N/A* Fri Mar 07 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.21.93.
20814N/A* Fri Feb 29 2008 - brian.cameron@sun.com
20814N/A- When building with DT (CDE login), then make sure the gnome.desktop
20814N/A file calls /usr/dt/bin/Xsession.jds rather than gnome-session.
20814N/A* Fri Feb 29 2008 - jeff.cai@sun.com
20814N/A- Bump to 2.21.92. Add patch 10-disable-ssh to revert patch #503278. This
20814N/A removes the gnome-session dependency on gnome-keyring.
20814N/A* Thu Feb 28 2008 - damien.carbery@sun.com
20814N/A- Revert to 2.21.91 because 2.21.92 requires a new version of gnome-keyring,
20814N/A which breaks.
20814N/A* Wed Feb 27 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.21.92.
20814N/A* Fri Feb 15 2008 - damien.carbery@sun.com
20814N/A- Remove upstream patch 10-gsd-header-dir.
20814N/A* Wed Feb 13 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.21.91.
20814N/A* Tue Feb 05 2008 - damien.carbery@sun.com
20814N/A- Add patch 10-gsd-header-dir to work with change in gnome-settings-daemon.
20814N/A Bugzilla 511820.
20814N/A* Tue Jan 29 2008 - takao.fujiwara@sun.com
20814N/A- Add l10n tarball.
20814N/A* Mon Jan 28 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.21.90.
20814N/A* Thu Jan 17 2007 - brian.cameron@sun.com
20814N/A- Remove patch gnome-session-09-fixdbus.diff. No longer needed
20814N/A now that we use D-Bus 1.1.3.
20814N/A* Thu Jan 17 2008 - damien.carbery@sun.com
20814N/A- Bump to 2.21.5.
20814N/A* Tue Jan 08 2007 - brian.cameron@sun.com
20814N/A- Add patch 9 and 10 to allow gnome-session to launch D-Bus.
20814N/A* Tue Jan 08 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.20.3.
20814N/A* Fri Oct 19 2007 - laca@sun.com
20814N/A- only display gnome-about on 1st login if --with-sun-branding is used
20814N/A* Fri Oct 19 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.20.1.
20814N/A* Fri Oct 12 2007 - laca@sun.com
20814N/A- always apply the tjds patch even if --with-tjds is not used, otherwise
20814N/A some patches that follow it fail and it doesn't hurt anyway
20814N/A* Tue Sep 18 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.20.0.
20814N/A* Wed Sep 05 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.19.92.
20814N/A* Wed Aug 15 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.19.90.
20814N/A* Tue Jul 31 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.19.6.
20814N/A* Tue Jul 17 2007 - ghee.teo@sun.com
20814N/A- Remove gnome-session-04-purge-warn-delay.diff
20814N/A after sun patch day review.
20814N/A* Mon Jul 09 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.19.5.
20814N/A* Mon Jun 18 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.19.4. Remove upstream patch, 08-fixtime.
20814N/A* Wed Jun 06 2007 - irene.huang@sun.com
20814N/A- %if %with_hal then do not apply patch7, volcheck.diff
20814N/A so that this patch will not be applied when HAL is enabled. Also modify
20814N/A the source path so that the source can be found.
20814N/A* Tue Jun 05 2007 - brian.cameron@sun.com
20814N/A- Bump to 2.19.3
20814N/A* Mon May 28 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.18.2.
20814N/A* Tue Mar 13 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.18.0.
20814N/A* Tue Feb 27 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.17.92.
20814N/A* Tue Feb 13 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.17.91.
20814N/A* Thu Feb 01 2007 - damien.carbery@sun.com
20814N/A- Remove upstream patch, 08-lXau; renumber remainder.
20814N/A* Sun Jan 28 2007 - laca@sun.com
20814N/A- add %if %build_tjds guard around tjds patch so we can build without trusted
20814N/A jds support
20814N/A* Mon Jan 22 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.17.90.1.
20814N/A* Mon Jan 22 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.17.90.
20814N/A* Tue Jan 09 2007 - damien.carbery@sun.com
20814N/A- Bump to 2.17.5.
20814N/A* Sat Dec 30 2006 - li.yuan@sun.com
20814N/A- Add gnome-session-11-remove-filter.diff to fix bugzilla #390882.
20814N/A Remove filter when it is not needed.
20814N/A* Fri Dec 15 2006 - li.yuan@sun.com
20814N/A- Add libexecdir option to configure to make gnome-session know
20814N/A where the at-spi-registryd is.
20814N/A* Sun Dec 03 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.17.3.
20814N/A* Wed Nov 22 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.17.2.
20814N/A* Fri Nov 03 2006 - ghee.teo@sun.com
20814N/A- Fixed up gnome-session-09-trusted-extensions.diff for 2.16
20814N/A* Tue Oct 31 2006 - takao.fujiwara@sun.com
20814N/A- Added intltoolize to read LINGAS file. Fixes 6488189.
20814N/A* Mon Oct 30 2006 - irene.huang@sun.com
20814N/A- add patch gnome-session-10-gnome-volcheck-default-session.diff
20814N/A which is orignally
20814N/A Solaris/patches/gnome-session-01-gnome-volcheck-default-session.diff
20814N/A* Mon Oct 23 2006 - glynn.foster@sun.com
20814N/A- Fix up fuzziness of the gnome-session patches. Merge the logout
20814N/A effect patches together, remove the non-existant a11y patch, and
20814N/A comment out the broken trusted extensions patch.
20814N/A* Tue Oct 03 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.16.1.
20814N/A* Mon Sep 04 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.16.0.
20814N/A* Fri Aug 25 2006 - damien.carbery@sun.com
20814N/A- Add patch, 12-lXau, to link libXau in.
20814N/A* Tue Aug 22 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.15.92.
20814N/A- Remove upstream patch, 10-fixcrash, renumber remainder.
20814N/A* Tue Aug 08 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.15.91.
20814N/A* Fri Jul 28 2006 - brian.cameron@sun.com
20814N/A- Move gnome-session-07-gnome-volcheck-default-session.diff to
20814N/A Solaris/patches so we can only apply this if HAL package is
20814N/A installed.
20814N/A* Fri Jul 28 2006 - dermot.mccluskey@sun.com
20814N/A- Fix minor typo.
20814N/A* Mon Jul 24 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.15.90.
20814N/A* Mon Jul 24 2006 - padraig.obriain@sun.com
20814N/A- Bump to 2.15.4.
20814N/A* Fri Jun 23 2006 - brian.cameron@sun.com
20814N/A- Bump to 2.14.2.
20814N/A* Fri May 05 2006 - brian.cameron@sun.com
20814N/A- Add patch to fix crash when HAL is enabled, caused by printing of a NULL
20814N/A string.
20814N/A* Fri Apr 10 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.14.1.
20814N/A* Tue Mar 14 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.14.0.
20814N/A* Thu Mar 9 2006 - damien.carbery@sun.com
20814N/A- Add patch, 10-G_DEBUG-off, to not set G_DEBUG=fatal_criticals as it exposes
20814N/A a lot of crashes in Evolution.
20814N/A* Tue Feb 28 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.13.92.
20814N/A* Tue Feb 14 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.13.91.
20814N/A- Remove unneeded glib-gettextize and intltoolize calls.
20814N/A* Sun Jan 29 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.13.90
20814N/A* Sun Jan 22 2006 - damien.carbery@sun.com
20814N/A- Call intltoolize and glib-gettextize to avoid infinite loop.
20814N/A* Fri Jan 20 2006 - damien.carbery@sun.com
20814N/A- Bump to 2.13.5.
20814N/A* Sat Sep 17 2005 - glynn.foster@sun.com
20814N/A- Bump to 2.12.0
20814N/A* Mon Aug 15 2005 - damien.carbery@sun.com
20814N/A- Bump to 2.11.91.
20814N/A* Fri Aug 05 2005 - glynn.foster@sun.com
20814N/A- Merge the 2 splashes into one. Remove the linux splash branding patch
20814N/A to focus on one for the moment - we can bring it back later if need
20814N/A be.
20814N/A* Tue Jun 14 2005 - bill.haneman@sun.com
20814N/A- Set GNOME_DISABLE_CRASH_DIALOG to '1', not 'true', for
20814N/A bug #6273175. (Previous patch set it to 'true', which failed to work).
20814N/A* Fri May 20 2005 - bill.haneman@sun.com
20814N/A- Edit gnome-session-09-load-a11y-modules.diff to set
20814N/A GNOME_DISABLE_CRASH_DIALOG when a11y is on, fix for bug #6273175.
20814N/A* Wed May 11 2005 - balamurali.viswanathan@wipro.com
20814N/A- Bump to 2.10.0
20814N/A* Wed Jan 23 2005 - arvind.samptur@wipro.com
20814N/A- Edit patch gnome-session-09-load-a11y-modules.diff to set
20814N/A the GTK_MODULES env before gnome_program_init (). This way
20814N/A b-a-s will get this env and will pass it on to all the factories
20814N/A that it would spawn.
20814N/A* Fri Jan 21 2005 - bill.haneman@sun.com
20814N/A- Edited patch gnome-session-09-load-a11y-modules.diff to fix bug
20814N/A 6202413. We now putenv("NO_J2D_DGA=true") when a11y is enabled,
20814N/A and the env variable isnt already set.
20814N/A* Thu Jan 14 2005 - ghee.teo@sun.com
20814N/A- Reduce the purge_delay and warn_delay to 30seconds which essentially
20814N/A revert back the bugzilla#94754. This patch is to partially fix bq2
20814N/A #4978659. The Mozilla team has fixed the mozilla side of the problem by
20814N/A 5068301, however, reducing this timeouts will benefit other badly broken
20814N/A session apps.
20814N/A* Mon Jan 10 2005 - kieran.colfer@sun.com
20814N/A- changing date on previous changelog entry - was causing rpmbuild
20814N/A to fail with "%changelog not in descending chronological order" :-)
20814N/A* Mon Jan 03 2005 - arvind.samptur@wipro.com
20814N/A- Now that gnome-settings-daemon starts per display, the
20814N/A patch gnome-session-07-sunray-screensaver.diff should not
20814N/A be required. Corresponding g-s-d patch is
20814N/A control-center-27-settings-daemon-per-display.diff
20814N/A* Thu Nov 12 2004 - alvaro.lopez@sun.com
20814N/A- Added patch #12. It fixes #5099423
20814N/A* Thu Nov 10 2004 - alvaro.lopez@sun.com
20814N/A- Source header fixed.
20814N/A* Wed Nov 10 2004 - leena.gunda@wipro.com
20814N/A- Added patch gnome-session-11-gnome-volcheck-default-session.diff
20814N/A to start gnome-volcheck for Solaris.
20814N/A* Thu Nov 04 2004 - brian.cameron@sun.com
20814N/A- Added patch 10 so that gnome-about launches on first-time login.
20814N/A* Fri Oct 29 2004 - laca@sun.com
20814N/A- Add gnome-session-remove.1 man page to %files
20814N/A* Thu Oct 28 2004 - matt.keenan@sun.com
20814N/A- Add gnome-session-remove.1 man page
20814N/A* Thu Oct 28 2004 - muktha.narayan@wipro.com
20814N/A- Load the a11y libraries by setting the GTK_MODULES env variable.
20814N/A Fixes issues addressed in bug #5097456.
20814N/A* Sat Sep 11 2004 - laca@sun.com
20814N/A- Move Solaris specific LDFLAGS to the Solaris spec file
20814N/A* Fri Sep 10 2004 - damien.carbery@sun.com
20814N/A- Set LDFLAGS so Xrandr and Xrender can be found.
20814N/A* Fri Aug 13 2004 - ghee.teo@sun.com
20814N/A- Forward ported sun-patches/gnome-session/560-4780014-s.diff
20814N/A as gnome-session-07-sunray-screensaver.diff. This is a security fix but
20814N/A really only affects Sunray.
20814N/A* Tue Aug 10 2004 - matt.keenan@sun.com
20814N/A- Bug:5084286, forward ported patch from mercury for logout effect.
20814N/A* Thu Jul 08 2004 - damien.donlon@sun.com
20814N/A- Updated l10n content to gnome-session-l10n-po-1.2.tar.bz2
20814N/A* Wed Jul 07 2004 - niall.power@sun.com
20814N/A- ported to rpm4
20814N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
20814N/A- added "-j $CPUS" to make to speed up builds
20814N/A* Wed Jun 09 2004 - ghee.teo@sun.com
20814N/A- do not compile patch1 on Solaris as it is a linux only patch.
20814N/A so use ifos linux to compile in
20814N/A gnome-session-01-magicdev-default-session.diff
20814N/A* Wed May 12 2004 - damien.donlon@sun.com
20814N/A- Updated l10n content to gnome-session-l10n-po-1.1.tar.bz2
20814N/A* Fri May 07 2004 - <matt.keenan@sun.com>
20814N/A- Bump to 2.6.1.
20814N/A* Tue Apr 06 2004 - arvind.samptur@wipro.com
20814N/A- Add patch to create an atom for legacy X apps to determine
20814N/A if they are running currently under GNOME
20814N/A* Mon Mar 29 2004 - damien.donlon@sun.com
20814N/A- Updated l10n content to gnome-session-l10n-po-1.0.tar.bz2
20814N/A* Tue Mar 24 2004 - <glynn.foster@sun.com>
20814N/A- Bump to 2.6.0. Remove man page and logout effect. Seems like
20814N/A a not hugely useful branding patch that it might be good to
20814N/A remove.
20814N/A* Tue Feb 24 2004 - <glynn.foster@sun.com>
20814N/A- Bump to 2.5.90
20814N/A* Fri Dec 15 2003 - <glynn.foster@sun.com>
20814N/A- Bump to 2.5.2
20814N/A* Wed Aug 06 2003 - <glynn.foster@sun.com>
20814N/A- Remove splash icons for non-important apps
20814N/A* Wed Jul 30 2003 - <markmc@sun.com>
20814N/A- Add magicdev correctly
20814N/A* Mon Jul 21 2003 - <markmc@sun.com>
20814N/A- Make it use the consolehelper versions of reboot and poweroff.
20814N/A* Fri Jul 11 2003 - <matt.keenan@sun.com>
20814N/A- Add patch for logout effect
20814N/A* Thu Jul 10 2003 - <glynn.foster@sun.com>
20814N/A- Add an icon to the splash widget.
20814N/A* Thu Jul 10 2003 - <glynn.foster@sun.com>
20814N/A- Add magicdev to the default session.
20814N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
20814N/A- add in sun po files
20814N/A* Mon Jun 30 2003 - <markmc@sun.com>
20814N/A- run autoheader so config.h contains gets HAVE_RANDR
20814N/A* Mon Jun 30 2003 - <markmc@sun.com>
20814N/A- add display properties restoration patch
20814N/A- copy the splash screen into the build tree in
20814N/A %prep rather than manually installing it in %install
20814N/A* Tue May 13 2003 - <ghee.teo@Sun.COM>
20814N/A- Created new spec file for gnome-session
20814N/A