gnome-session.spec revision 13113
15341N/A#
15341N/A# spec file for package gnome-session
15341N/A#
18540N/A# Copyright 2008 Sun Microsystems, Inc.
15341N/A# This file and all modifications and additions to the pristine
15341N/A# package are under the same license as the package itself.
15341N/A#
17185N/A# Owner: niall
15341N/A#
15341N/A%include l10n.inc
18603N/AName: gnome-session
15341N/ALicense: GPL
15341N/AGroup: System/GUI/GNOME
15341N/AVersion: 2.22.2
15341N/ARelease: 1
17575N/ADistribution: Java Desktop System
15341N/AVendor: Sun Microsystems, Inc.
15341N/ASummary: Session Manager for the GNOME Desktop
18615N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.22/%{name}-%{version}.tar.bz2
15341N/ASource1: gnome-splash.png
15341N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
15955N/A%if %build_l10n
16995N/ASource3: l10n-configure.sh
16995N/A%endif
15531N/A#owner:gheet date:2004-08-06 type:bug bugster:5025823
18179N/APatch1: gnome-session-01-gnome-atom.diff
15341N/A#owner:alo date:2005-03-14 type:bug bugster:5099423
15341N/APatch2: gnome-session-02-logout-effect.diff
15341N/A%if %option_with_sun_branding
15341N/A#owner:yippi date:2004-11-04 type:branding
19805N/APatch3: gnome-session-03-gnome-about.diff
15406N/A%endif
15341N/A#owner:stephen date:2006-06-29 type:feature bugster:6444179
15341N/APatch4: gnome-session-04-wait-for-postrun.diff
15341N/A#owner:gheet date:2006-11-03 type:feature bugster:6393728
15341N/APatch5: gnome-session-05-trusted-extensions.diff
15341N/A#owner:niall date:2004-11-10 type:branding bugster:6188905
15341N/A# We only want to run gnome-volcheck by default if we aren't building with HAL.
15341N/APatch6: gnome-session-06-gnome-volcheck-default-session.diff
15341N/A#owner:erwannc date:2003-07-29 type:branding
15341N/APatch7: gnome-session-07-busy-cursor.diff
15341N/A%if %option_with_sun_branding
15341N/A#owner:erwannc date:2005-05-11 type:branding
15341N/APatch8: gnome-session-08-solaris-branding.diff
15341N/A%endif
15341N/A# This patch works around a bug in D-Bus. When this bug is actually fixed
15341N/A# in D-Bus, then this workaround patch should be removed.
15341N/A#owner:yippi date:2008-01-08 type:bug bugzilla:508231
15341N/APatch9: gnome-session-09-find-dbus-daemon.diff
15341N/A#owner:jefftsai date:2008-01-08 type:branding
15341N/APatch10: gnome-session-10-disable-ssh.diff
15341N/A#owner:yippi date:2008-02-29 type:branding
15341N/APatch11: gnome-session-11-Xsession.diff
15341N/A#owner:erwannc date:2008-03-07 type:feature bugster:6672099
15341N/APatch12: gnome-session-12-compiz-integration.diff
15341N/A#owner:xz159989 date:2008-05-07 type:branding
15341N/APatch13: gnome-session-13-logout-shutdown-dialog.diff
15341N/A
15341N/AURL: http://www.gnome.org
15341N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15341N/ADocdir: %{_defaultdocdir}/%{name}
15341N/AAutoreqprov: on
15428N/APrereq: GConf
15428N/A
15341N/A%define libgnomeui_version 2.2.0
15341N/A%define libwnck_version 2.2.1
15341N/A
15341N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
15341N/ABuildRequires: libwnck-devel >= %{libwnck_version}
15341N/ARequires: libgnomeui >= %{libgnomeui_version}
15341N/ARequires: libwnck >= %{libwnck_version}
15341N/A
15341N/A%description
15341N/AThis package provides the basic session manager and tools for the GNOME Desktop.
15341N/A
15341N/A%prep
15341N/A%setup -q
16120N/A%if %build_l10n
15406N/Abzcat %SOURCE2 | tar xf -
15500N/Acd po-sun; make; cd ..
16995N/A%endif
16995N/A%patch1 -p1
15500N/A%patch2 -p1
15341N/A%if %option_with_sun_branding
15500N/A%patch3 -p1
15341N/A%endif
15341N/A%patch4 -p1
15341N/A%patch5 -p1
15341N/A%if %with_hal
15341N/A%else
15341N/A%patch6 -p1
15341N/A%endif
15341N/A%patch7 -p1
15341N/A%if %option_with_sun_branding
15341N/A%patch8 -p1
15341N/Acp %SOURCE1 gnome-session/gnome-splash.png
15341N/A%endif
18791N/A%patch9 -p1
15341N/A%patch10 -p1
15341N/A%if %option_without_dt
15341N/A%else
15341N/A%patch11 -p1
15341N/A%endif
15341N/A%patch12 -p1
15341N/A%patch13 -p1
15341N/A
15341N/A%build
15341N/A%ifos linux
15341N/Aif [ -x /usr/bin/getconf ]; then
15341N/A CPUS=`getconf _NPROCESSORS_ONLN`
15341N/Afi
15406N/A%else
15406N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15406N/A%endif
15406N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15406N/A CPUS=1
15406N/Afi
15406N/A
15406N/A%ifos solaris
15406N/A%define poweroff /usr/sbin/poweroff
15406N/A%define reboot /usr/sbin/reboot
15406N/A%else
15406N/A%define poweroff /usr/bin/poweroff
15341N/A%define reboot /usr/bin/reboot
15341N/A%endif
15341N/A
15341N/Alibtoolize --force
15341N/Aintltoolize -c -f --automake
15341N/A
15341N/A%if %build_l10n
15341N/Abash -x %SOURCE3 --enable-copyright
15341N/A%endif
15341N/A
15341N/Aaclocal $ACLOCAL_FLAGS -I .
15341N/Aautoheader
15341N/Aautomake -a -c -f
15341N/Aautoconf
15341N/ACFLAGS="$RPM_OPT_FLAGS" \
15341N/A./configure --prefix=%{_prefix} \
15341N/A --libexecdir=%{_libexecdir} \
15341N/A --sysconfdir=%{_sysconfdir} \
15341N/A --mandir=%{_mandir} \
15341N/A --with-halt-command=%poweroff \
15341N/A --with-reboot-command=%reboot
15341N/Amake -j $CPUS
15341N/A
15341N/A%install
15341N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
15341N/Amake DESTDIR=$RPM_BUILD_ROOT install
15341N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
15341N/A
15341N/A%clean
15341N/Arm -rf $RPM_BUILD_ROOT
18179N/A
18179N/A%post
17687N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
17687N/ASCHEMAS="gnome-session.schemas"
17575N/Afor S in $SCHEMAS; do
17575N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
17575N/Adone
16995N/A
16995N/A%files
16995N/A%defattr(-,root,root)
16995N/A%{_bindir}/*
15531N/A%{_datadir}/pixmaps/*
15531N/A%{_mandir}/man1/*
15500N/A%{_mandir}/man5/*
15500N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
15428N/A%{_datadir}/gnome/default.session
15428N/A%{_datadir}/gnome/default.wm
15428N/A%{_datadir}/applications/
15406N/A%{_sysconfdir}/gconf/schemas/*
15406N/A
15344N/A%changelog
15344N/A* Tue May 27 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.22.2.
15341N/A* Wed May 07 2008 - simon.zheng@sun.com
15341N/A- Add patch 13-logout-shutdown-dialog.
15341N/A* Fri Apr 11 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.22.1.1.
15341N/A* Thu Apr 10 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.22.1.
15341N/A* Tue Mar 11 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.22.0.
15341N/A* Fri Mar 07 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.21.93.
15341N/A* Fri Feb 29 2008 - brian.cameron@sun.com
15341N/A- When building with DT (CDE login), then make sure the gnome.desktop
15341N/A file calls /usr/dt/bin/Xsession.jds rather than gnome-session.
15341N/A* Fri Feb 29 2008 - jeff.cai@sun.com
15341N/A- Bump to 2.21.92. Add patch 10-disable-ssh to revert patch #503278. This
15341N/A removes the gnome-session dependency on gnome-keyring.
15341N/A* Thu Feb 28 2008 - damien.carbery@sun.com
15341N/A- Revert to 2.21.91 because 2.21.92 requires a new version of gnome-keyring,
15341N/A which breaks.
15341N/A* Wed Feb 27 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.21.92.
15341N/A* Fri Feb 15 2008 - damien.carbery@sun.com
15341N/A- Remove upstream patch 10-gsd-header-dir.
15341N/A* Wed Feb 13 2008 - damien.carbery@sun.com
15341N/A- Bump to 2.21.91.
* Tue Feb 05 2008 - damien.carbery@sun.com
- Add patch 10-gsd-header-dir to work with change in gnome-settings-daemon.
Bugzilla 511820.
* Tue Jan 29 2008 - takao.fujiwara@sun.com
- Add l10n tarball.
* Mon Jan 28 2008 - damien.carbery@sun.com
- Bump to 2.21.90.
* Thu Jan 17 2007 - brian.cameron@sun.com
- Remove patch gnome-session-09-fixdbus.diff. No longer needed
now that we use D-Bus 1.1.3.
* Thu Jan 17 2008 - damien.carbery@sun.com
- Bump to 2.21.5.
* Tue Jan 08 2007 - brian.cameron@sun.com
- Add patch 9 and 10 to allow gnome-session to launch D-Bus.
* Tue Jan 08 2007 - damien.carbery@sun.com
- Bump to 2.20.3.
* Fri Oct 19 2007 - laca@sun.com
- only display gnome-about on 1st login if --with-sun-branding is used
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 2.20.1.
* Fri Oct 12 2007 - laca@sun.com
- always apply the tjds patch even if --with-tjds is not used, otherwise
some patches that follow it fail and it doesn't hurt anyway
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 2.20.0.
* Wed Sep 05 2007 - damien.carbery@sun.com
- Bump to 2.19.92.
* Wed Aug 15 2007 - damien.carbery@sun.com
- Bump to 2.19.90.
* Tue Jul 31 2007 - damien.carbery@sun.com
- Bump to 2.19.6.
* Tue Jul 17 2007 - ghee.teo@sun.com
- Remove gnome-session-04-purge-warn-delay.diff
after sun patch day review.
* Mon Jul 09 2007 - damien.carbery@sun.com
- Bump to 2.19.5.
* Mon Jun 18 2007 - damien.carbery@sun.com
- Bump to 2.19.4. Remove upstream patch, 08-fixtime.
* Wed Jun 06 2007 - irene.huang@sun.com
- %if %with_hal then do not apply patch7, volcheck.diff
so that this patch will not be applied when HAL is enabled. Also modify
the source path so that the source can be found.
* Tue Jun 05 2007 - brian.cameron@sun.com
- Bump to 2.19.3
* Mon May 28 2007 - damien.carbery@sun.com
- Bump to 2.18.2.
* Tue Mar 13 2007 - damien.carbery@sun.com
- Bump to 2.18.0.
* Tue Feb 27 2007 - damien.carbery@sun.com
- Bump to 2.17.92.
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 2.17.91.
* Thu Feb 01 2007 - damien.carbery@sun.com
- Remove upstream patch, 08-lXau; renumber remainder.
* Sun Jan 28 2007 - laca@sun.com
- add %if %build_tjds guard around tjds patch so we can build without trusted
jds support
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.17.90.1.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.17.90.
* Tue Jan 09 2007 - damien.carbery@sun.com
- Bump to 2.17.5.
* Sat Dec 30 2006 - li.yuan@sun.com
- Add gnome-session-11-remove-filter.diff to fix bugzilla #390882.
Remove filter when it is not needed.
* Fri Dec 15 2006 - li.yuan@sun.com
- Add libexecdir option to configure to make gnome-session know
where the at-spi-registryd is.
* Sun Dec 03 2006 - damien.carbery@sun.com
- Bump to 2.17.3.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 2.17.2.
* Fri Nov 03 2006 - ghee.teo@sun.com
- Fixed up gnome-session-09-trusted-extensions.diff for 2.16
* Tue Oct 31 2006 - takao.fujiwara@sun.com
- Added intltoolize to read LINGAS file. Fixes 6488189.
* Mon Oct 30 2006 - irene.huang@sun.com
- add patch gnome-session-10-gnome-volcheck-default-session.diff
which is orignally
Solaris/patches/gnome-session-01-gnome-volcheck-default-session.diff
* Mon Oct 23 2006 - glynn.foster@sun.com
- Fix up fuzziness of the gnome-session patches. Merge the logout
effect patches together, remove the non-existant a11y patch, and
comment out the broken trusted extensions patch.
* Tue Oct 03 2006 - damien.carbery@sun.com
- Bump to 2.16.1.
* Mon Sep 04 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Fri Aug 25 2006 - damien.carbery@sun.com
- Add patch, 12-lXau, to link libXau in.
* Tue Aug 22 2006 - damien.carbery@sun.com
- Bump to 2.15.92.
- Remove upstream patch, 10-fixcrash, renumber remainder.
* Tue Aug 08 2006 - damien.carbery@sun.com
- Bump to 2.15.91.
* Fri Jul 28 2006 - brian.cameron@sun.com
- Move gnome-session-07-gnome-volcheck-default-session.diff to
Solaris/patches so we can only apply this if HAL package is
installed.
* Fri Jul 28 2006 - dermot.mccluskey@sun.com
- Fix minor typo.
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 2.15.90.
* Mon Jul 24 2006 - padraig.obriain@sun.com
- Bump to 2.15.4.
* Fri Jun 23 2006 - brian.cameron@sun.com
- Bump to 2.14.2.
* Fri May 05 2006 - brian.cameron@sun.com
- Add patch to fix crash when HAL is enabled, caused by printing of a NULL
string.
* Fri Apr 10 2006 - damien.carbery@sun.com
- Bump to 2.14.1.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Bump to 2.14.0.
* Thu Mar 9 2006 - damien.carbery@sun.com
- Add patch, 10-G_DEBUG-off, to not set G_DEBUG=fatal_criticals as it exposes
a lot of crashes in Evolution.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 2.13.92.
* Tue Feb 14 2006 - damien.carbery@sun.com
- Bump to 2.13.91.
- Remove unneeded glib-gettextize and intltoolize calls.
* Sun Jan 29 2006 - damien.carbery@sun.com
- Bump to 2.13.90
* Sun Jan 22 2006 - damien.carbery@sun.com
- Call intltoolize and glib-gettextize to avoid infinite loop.
* Fri Jan 20 2006 - damien.carbery@sun.com
- Bump to 2.13.5.
* Sat Sep 17 2005 - glynn.foster@sun.com
- Bump to 2.12.0
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.91.
* Fri Aug 05 2005 - glynn.foster@sun.com
- Merge the 2 splashes into one. Remove the linux splash branding patch
to focus on one for the moment - we can bring it back later if need
be.
* Tue Jun 14 2005 - bill.haneman@sun.com
- Set GNOME_DISABLE_CRASH_DIALOG to '1', not 'true', for
bug #6273175. (Previous patch set it to 'true', which failed to work).
* Fri May 20 2005 - bill.haneman@sun.com
- Edit gnome-session-09-load-a11y-modules.diff to set
GNOME_DISABLE_CRASH_DIALOG when a11y is on, fix for bug #6273175.
* Wed May 11 2005 - balamurali.viswanathan@wipro.com
- Bump to 2.10.0
* Wed Jan 23 2005 - arvind.samptur@wipro.com
- Edit patch gnome-session-09-load-a11y-modules.diff to set
the GTK_MODULES env before gnome_program_init (). This way
b-a-s will get this env and will pass it on to all the factories
that it would spawn.
* Fri Jan 21 2005 - bill.haneman@sun.com
- Edited patch gnome-session-09-load-a11y-modules.diff to fix bug
6202413. We now putenv("NO_J2D_DGA=true") when a11y is enabled,
and the env variable isnt already set.
* Thu Jan 14 2005 - ghee.teo@sun.com
- Reduce the purge_delay and warn_delay to 30seconds which essentially
revert back the bugzilla#94754. This patch is to partially fix bq2
#4978659. The Mozilla team has fixed the mozilla side of the problem by
5068301, however, reducing this timeouts will benefit other badly broken
session apps.
* Mon Jan 10 2005 - kieran.colfer@sun.com
- changing date on previous changelog entry - was causing rpmbuild
to fail with "%changelog not in descending chronological order" :-)
* Mon Jan 03 2005 - arvind.samptur@wipro.com
- Now that gnome-settings-daemon starts per display, the
patch gnome-session-07-sunray-screensaver.diff should not
be required. Corresponding g-s-d patch is
control-center-27-settings-daemon-per-display.diff
* Thu Nov 12 2004 - alvaro.lopez@sun.com
- Added patch #12. It fixes #5099423
* Thu Nov 10 2004 - alvaro.lopez@sun.com
- Source header fixed.
* Wed Nov 10 2004 - leena.gunda@wipro.com
- Added patch gnome-session-11-gnome-volcheck-default-session.diff
to start gnome-volcheck for Solaris.
* Thu Nov 04 2004 - brian.cameron@sun.com
- Added patch 10 so that gnome-about launches on first-time login.
* Fri Oct 29 2004 - laca@sun.com
- Add gnome-session-remove.1 man page to %files
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add gnome-session-remove.1 man page
* Thu Oct 28 2004 - muktha.narayan@wipro.com
- Load the a11y libraries by setting the GTK_MODULES env variable.
Fixes issues addressed in bug #5097456.
* Sat Sep 11 2004 - laca@sun.com
- Move Solaris specific LDFLAGS to the Solaris spec file
* Fri Sep 10 2004 - damien.carbery@sun.com
- Set LDFLAGS so Xrandr and Xrender can be found.
* Fri Aug 13 2004 - ghee.teo@sun.com
- Forward ported sun-patches/gnome-session/560-4780014-s.diff
as gnome-session-07-sunray-screensaver.diff. This is a security fix but
really only affects Sunray.
* Tue Aug 10 2004 - matt.keenan@sun.com
- Bug:5084286, forward ported patch from mercury for logout effect.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-session-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed Jun 09 2004 - ghee.teo@sun.com
- do not compile patch1 on Solaris as it is a linux only patch.
so use ifos linux to compile in
gnome-session-01-magicdev-default-session.diff
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-session-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - <matt.keenan@sun.com>
- Bump to 2.6.1.
* Tue Apr 06 2004 - arvind.samptur@wipro.com
- Add patch to create an atom for legacy X apps to determine
if they are running currently under GNOME
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-session-l10n-po-1.0.tar.bz2
* Tue Mar 24 2004 - <glynn.foster@sun.com>
- Bump to 2.6.0. Remove man page and logout effect. Seems like
a not hugely useful branding patch that it might be good to
remove.
* Tue Feb 24 2004 - <glynn.foster@sun.com>
- Bump to 2.5.90
* Fri Dec 15 2003 - <glynn.foster@sun.com>
- Bump to 2.5.2
* Wed Aug 06 2003 - <glynn.foster@sun.com>
- Remove splash icons for non-important apps
* Wed Jul 30 2003 - <markmc@sun.com>
- Add magicdev correctly
* Mon Jul 21 2003 - <markmc@sun.com>
- Make it use the consolehelper versions of reboot and poweroff.
* Fri Jul 11 2003 - <matt.keenan@sun.com>
- Add patch for logout effect
* Thu Jul 10 2003 - <glynn.foster@sun.com>
- Add an icon to the splash widget.
* Thu Jul 10 2003 - <glynn.foster@sun.com>
- Add magicdev to the default session.
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Mon Jun 30 2003 - <markmc@sun.com>
- run autoheader so config.h contains gets HAVE_RANDR
* Mon Jun 30 2003 - <markmc@sun.com>
- add display properties restoration patch
- copy the splash screen into the build tree in
%prep rather than manually installing it in %install
* Tue May 13 2003 - <ghee.teo@Sun.COM>
- Created new spec file for gnome-session