gnome-session.spec revision 12162
10139N/A#
10139N/A# spec file for package gnome-session
10139N/A#
20783N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: niall
10139N/A#
17178N/AName: gnome-session
18603N/ALicense: GPL
17178N/AGroup: System/GUI/GNOME
10139N/AVersion: 2.20.3
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
20783N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Session Manager for the GNOME Desktop
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.20/%{name}-%{version}.tar.bz2
18616N/ASource1: gnome-splash.png
10139N/A#owner:gheet date:2004-08-06 type:bug bugster:5025823
20783N/APatch1: gnome-session-01-gnome-atom.diff
20783N/A#owner:alo date:2005-03-14 type:bug bugster:5099423
10139N/APatch2: gnome-session-02-logout-effect.diff
10139N/A%if %option_with_sun_branding
10139N/A#owner:yippi date:2004-11-04 type:branding
10139N/APatch3: gnome-session-03-gnome-about.diff
10139N/A%endif
10139N/A#owner:stephen date:2006-06-29 type:feature bugster:6444179
10139N/APatch4: gnome-session-04-wait-for-postrun.diff
10139N/A#owner:gheet date:2006-11-03 type:feature bugster:6393728
10139N/APatch5: gnome-session-05-trusted-extensions.diff
10139N/A#owner:niall date:2004-11-10 type:branding bugster:6188905
10139N/A# We only want to run gnome-volcheck by default if we aren't building with HAL.
10139N/APatch6: gnome-session-06-gnome-volcheck-default-session.diff
10139N/A#owner:erwannc date:2003-07-29 type:branding
10139N/APatch7: gnome-session-07-busy-cursor.diff
10139N/A%if %option_with_sun_branding
10139N/A#owner:erwannc date:2005-05-11 type:branding
10139N/APatch8: gnome-session-08-solaris-branding.diff
10139N/A%endif
10139N/A# This patch works around a bug in D-Bus. When this bug is actually fixed
10139N/A# in D-Bus, then this workaround patch should be removed.
10139N/A#owner:yippi date:2008-01-08 type:bug bugzilla:395488
10139N/APatch9: gnome-session-09-fixdbus.diff
10139N/A#owner:yippi date:2008-01-08 type:bug bugzilla:508231
10139N/APatch10: gnome-session-10-find-dbus-daemon.diff
10139N/A
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/APrereq: GConf
10139N/A
10139N/A%define libgnomeui_version 2.2.0
10139N/A%define libwnck_version 2.2.1
10139N/A
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: libwnck-devel >= %{libwnck_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: libwnck >= %{libwnck_version}
10139N/A
10139N/A%description
10139N/AThis package provides the basic session manager and tools for the GNOME Desktop.
10139N/A
12889N/A%prep
12889N/A%setup -q
12889N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%if %option_with_sun_branding
10139N/A%patch3 -p1
10139N/A%endif
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%if %with_hal
10139N/A%else
10139N/A%patch6 -p1
10139N/A%endif
10139N/A%patch7 -p1
10139N/A%if %option_with_sun_branding
10139N/A%patch8 -p1
10139N/Acp %SOURCE1 gnome-session/gnome-splash.png
10139N/A%endif
10139N/A%patch9 -p1
10139N/A%patch10 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
20783N/Aif [ -x /usr/bin/getconf ]; then
20783N/A CPUS=`getconf _NPROCESSORS_ONLN`
12889N/Afi
12889N/A%else
10332N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10332N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/A%ifos solaris
10139N/A%define poweroff /usr/sbin/poweroff
10139N/A%define reboot /usr/sbin/reboot
10139N/A%else
10139N/A%define poweroff /usr/bin/poweroff
10139N/A%define reboot /usr/bin/reboot
10139N/A%endif
10139N/A
10139N/Alibtoolize --force
intltoolize -c -f --automake
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
--libexecdir=%{_libexecdir} \
--sysconfdir=%{_sysconfdir} \
--mandir=%{_mandir} \
--with-halt-command=%poweroff \
--with-reboot-command=%reboot
make -j $CPUS
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
%clean
rm -rf $RPM_BUILD_ROOT
%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-session.schemas"
for S in $SCHEMAS; do
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
%files
%defattr(-,root,root)
%{_bindir}/*
%{_datadir}/pixmaps/*
%{_mandir}/man1/*
%{_mandir}/man5/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/gnome/default.session
%{_datadir}/gnome/default.wm
%{_datadir}/applications/
%{_sysconfdir}/gconf/schemas/*
%changelog
* Tue Jan 08 2007 - brian.cameron@sun.com
- Add patch 9 and 10 to allow gnome-session to launch D-Bus.
* Tue Jan 08 2007 - damien.carbery@sun.com
- Bump to 2.20.3.
* Fri Oct 19 2007 - laca@sun.com
- only display gnome-about on 1st login if --with-sun-branding is used
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 2.20.1.
* Fri Oct 12 2007 - laca@sun.com
- always apply the tjds patch even if --with-tjds is not used, otherwise
some patches that follow it fail and it doesn't hurt anyway
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 2.20.0.
* Wed Sep 05 2007 - damien.carbery@sun.com
- Bump to 2.19.92.
* Wed Aug 15 2007 - damien.carbery@sun.com
- Bump to 2.19.90.
* Tue Jul 31 2007 - damien.carbery@sun.com
- Bump to 2.19.6.
* Tue Jul 17 2007 - ghee.teo@sun.com
- Remove gnome-session-04-purge-warn-delay.diff
after sun patch day review.
* Mon Jul 09 2007 - damien.carbery@sun.com
- Bump to 2.19.5.
* Mon Jun 18 2007 - damien.carbery@sun.com
- Bump to 2.19.4. Remove upstream patch, 08-fixtime.
* Wed Jun 06 2007 - irene.huang@sun.com
- %if %with_hal then do not apply patch7, volcheck.diff
so that this patch will not be applied when HAL is enabled. Also modify
the source path so that the source can be found.
* Tue Jun 05 2007 - brian.cameron@sun.com
- Bump to 2.19.3
* Mon May 28 2007 - damien.carbery@sun.com
- Bump to 2.18.2.
* Tue Mar 13 2007 - damien.carbery@sun.com
- Bump to 2.18.0.
* Tue Feb 27 2007 - damien.carbery@sun.com
- Bump to 2.17.92.
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 2.17.91.
* Thu Feb 01 2007 - damien.carbery@sun.com
- Remove upstream patch, 08-lXau; renumber remainder.
* Sun Jan 28 2007 - laca@sun.com
- add %if %build_tjds guard around tjds patch so we can build without trusted
jds support
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.17.90.1.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.17.90.
* Tue Jan 09 2007 - damien.carbery@sun.com
- Bump to 2.17.5.
* Sat Dec 30 2006 - li.yuan@sun.com
- Add gnome-session-11-remove-filter.diff to fix bugzilla #390882.
Remove filter when it is not needed.
* Fri Dec 15 2006 - li.yuan@sun.com
- Add libexecdir option to configure to make gnome-session know
where the at-spi-registryd is.
* Sun Dec 03 2006 - damien.carbery@sun.com
- Bump to 2.17.3.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 2.17.2.
* Fri Nov 03 2006 - ghee.teo@sun.com
- Fixed up gnome-session-09-trusted-extensions.diff for 2.16
* Tue Oct 31 2006 - takao.fujiwara@sun.com
- Added intltoolize to read LINGAS file. Fixes 6488189.
* Mon Oct 30 2006 - irene.huang@sun.com
- add patch gnome-session-10-gnome-volcheck-default-session.diff
which is orignally
Solaris/patches/gnome-session-01-gnome-volcheck-default-session.diff
* Mon Oct 23 2006 - glynn.foster@sun.com
- Fix up fuzziness of the gnome-session patches. Merge the logout
effect patches together, remove the non-existant a11y patch, and
comment out the broken trusted extensions patch.
* Tue Oct 03 2006 - damien.carbery@sun.com
- Bump to 2.16.1.
* Mon Sep 04 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Fri Aug 25 2006 - damien.carbery@sun.com
- Add patch, 12-lXau, to link libXau in.
* Tue Aug 22 2006 - damien.carbery@sun.com
- Bump to 2.15.92.
- Remove upstream patch, 10-fixcrash, renumber remainder.
* Tue Aug 08 2006 - damien.carbery@sun.com
- Bump to 2.15.91.
* Fri Jul 28 2006 - brian.cameron@sun.com
- Move gnome-session-07-gnome-volcheck-default-session.diff to
Solaris/patches so we can only apply this if HAL package is
installed.
* Fri Jul 28 2006 - dermot.mccluskey@sun.com
- Fix minor typo.
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 2.15.90.
* Mon Jul 24 2006 - padraig.obriain@sun.com
- Bump to 2.15.4.
* Fri Jun 23 2006 - brian.cameron@sun.com
- Bump to 2.14.2.
* Fri May 05 2006 - brian.cameron@sun.com
- Add patch to fix crash when HAL is enabled, caused by printing of a NULL
string.
* Fri Apr 10 2006 - damien.carbery@sun.com
- Bump to 2.14.1.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Bump to 2.14.0.
* Thu Mar 9 2006 - damien.carbery@sun.com
- Add patch, 10-G_DEBUG-off, to not set G_DEBUG=fatal_criticals as it exposes
a lot of crashes in Evolution.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 2.13.92.
* Tue Feb 14 2006 - damien.carbery@sun.com
- Bump to 2.13.91.
- Remove unneeded glib-gettextize and intltoolize calls.
* Sun Jan 29 2006 - damien.carbery@sun.com
- Bump to 2.13.90
* Sun Jan 22 2006 - damien.carbery@sun.com
- Call intltoolize and glib-gettextize to avoid infinite loop.
* Fri Jan 20 2006 - damien.carbery@sun.com
- Bump to 2.13.5.
* Sat Sep 17 2005 - glynn.foster@sun.com
- Bump to 2.12.0
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.91.
* Fri Aug 05 2005 - glynn.foster@sun.com
- Merge the 2 splashes into one. Remove the linux splash branding patch
to focus on one for the moment - we can bring it back later if need
be.
* Tue Jun 14 2005 - bill.haneman@sun.com
- Set GNOME_DISABLE_CRASH_DIALOG to '1', not 'true', for
bug #6273175. (Previous patch set it to 'true', which failed to work).
* Fri May 20 2005 - bill.haneman@sun.com
- Edit gnome-session-09-load-a11y-modules.diff to set
GNOME_DISABLE_CRASH_DIALOG when a11y is on, fix for bug #6273175.
* Wed May 11 2005 - balamurali.viswanathan@wipro.com
- Bump to 2.10.0
* Wed Jan 23 2005 - arvind.samptur@wipro.com
- Edit patch gnome-session-09-load-a11y-modules.diff to set
the GTK_MODULES env before gnome_program_init (). This way
b-a-s will get this env and will pass it on to all the factories
that it would spawn.
* Fri Jan 21 2005 - bill.haneman@sun.com
- Edited patch gnome-session-09-load-a11y-modules.diff to fix bug
6202413. We now putenv("NO_J2D_DGA=true") when a11y is enabled,
and the env variable isnt already set.
* Thu Jan 14 2005 - ghee.teo@sun.com
- Reduce the purge_delay and warn_delay to 30seconds which essentially
revert back the bugzilla#94754. This patch is to partially fix bq2
#4978659. The Mozilla team has fixed the mozilla side of the problem by
5068301, however, reducing this timeouts will benefit other badly broken
session apps.
* Mon Jan 10 2005 - kieran.colfer@sun.com
- changing date on previous changelog entry - was causing rpmbuild
to fail with "%changelog not in descending chronological order" :-)
* Mon Jan 03 2005 - arvind.samptur@wipro.com
- Now that gnome-settings-daemon starts per display, the
patch gnome-session-07-sunray-screensaver.diff should not
be required. Corresponding g-s-d patch is
control-center-27-settings-daemon-per-display.diff
* Thu Nov 12 2004 - alvaro.lopez@sun.com
- Added patch #12. It fixes #5099423
* Thu Nov 10 2004 - alvaro.lopez@sun.com
- Source header fixed.
* Wed Nov 10 2004 - leena.gunda@wipro.com
- Added patch gnome-session-11-gnome-volcheck-default-session.diff
to start gnome-volcheck for Solaris.
* Thu Nov 04 2004 - brian.cameron@sun.com
- Added patch 10 so that gnome-about launches on first-time login.
* Fri Oct 29 2004 - laca@sun.com
- Add gnome-session-remove.1 man page to %files
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add gnome-session-remove.1 man page
* Thu Oct 28 2004 - muktha.narayan@wipro.com
- Load the a11y libraries by setting the GTK_MODULES env variable.
Fixes issues addressed in bug #5097456.
* Sat Sep 11 2004 - laca@sun.com
- Move Solaris specific LDFLAGS to the Solaris spec file
* Fri Sep 10 2004 - damien.carbery@sun.com
- Set LDFLAGS so Xrandr and Xrender can be found.
* Fri Aug 13 2004 - ghee.teo@sun.com
- Forward ported sun-patches/gnome-session/560-4780014-s.diff
as gnome-session-07-sunray-screensaver.diff. This is a security fix but
really only affects Sunray.
* Tue Aug 10 2004 - matt.keenan@sun.com
- Bug:5084286, forward ported patch from mercury for logout effect.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-session-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed Jun 09 2004 - ghee.teo@sun.com
- do not compile patch1 on Solaris as it is a linux only patch.
so use ifos linux to compile in
gnome-session-01-magicdev-default-session.diff
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-session-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - <matt.keenan@sun.com>
- Bump to 2.6.1.
* Tue Apr 06 2004 - arvind.samptur@wipro.com
- Add patch to create an atom for legacy X apps to determine
if they are running currently under GNOME
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-session-l10n-po-1.0.tar.bz2
* Tue Mar 24 2004 - <glynn.foster@sun.com>
- Bump to 2.6.0. Remove man page and logout effect. Seems like
a not hugely useful branding patch that it might be good to
remove.
* Tue Feb 24 2004 - <glynn.foster@sun.com>
- Bump to 2.5.90
* Fri Dec 15 2003 - <glynn.foster@sun.com>
- Bump to 2.5.2
* Wed Aug 06 2003 - <glynn.foster@sun.com>
- Remove splash icons for non-important apps
* Wed Jul 30 2003 - <markmc@sun.com>
- Add magicdev correctly
* Mon Jul 21 2003 - <markmc@sun.com>
- Make it use the consolehelper versions of reboot and poweroff.
* Fri Jul 11 2003 - <matt.keenan@sun.com>
- Add patch for logout effect
* Thu Jul 10 2003 - <glynn.foster@sun.com>
- Add an icon to the splash widget.
* Thu Jul 10 2003 - <glynn.foster@sun.com>
- Add magicdev to the default session.
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Mon Jun 30 2003 - <markmc@sun.com>
- run autoheader so config.h contains gets HAVE_RANDR
* Mon Jun 30 2003 - <markmc@sun.com>
- add display properties restoration patch
- copy the splash screen into the build tree in
%prep rather than manually installing it in %install
* Tue May 13 2003 - <ghee.teo@Sun.COM>
- Created new spec file for gnome-session