gnome-session.spec revision 10810
8904N/A#
8904N/A# spec file for package gnome-session
8904N/A#
8904N/A# Copyright (c) 2005 Sun Microsystems, Inc.
8904N/A# This file and all modifications and additions to the pristine
8904N/A# package are under the same license as the package itself.
8904N/A#
8904N/A# Owner: niall
8904N/A#
8904N/AName: gnome-session
8904N/ALicense: GPL
8904N/AGroup: System/GUI/GNOME
8904N/AVersion: 2.19.4
8904N/ARelease: 7
8904N/ADistribution: Java Desktop System
8904N/AVendor: Sun Microsystems, Inc.
8904N/ASummary: Session Manager for the GNOME Desktop
8904N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.19/%{name}-%{version}.tar.bz2
8904N/ASource1: gnome-splash.png
8904N/A#owner:gheet date:2004-08-06 type:bug bugster:5025823
8904N/APatch1: gnome-session-01-gnome-atom.diff
8904N/A#owner:alo date:2005-03-14 type:bug bugster:5099423
8904N/APatch2: gnome-session-02-logout-effect.diff
8904N/A#owner:yippi date:2004-11-04 type:branding
8904N/APatch3: gnome-session-03-gnome-about.diff
8904N/A#owner:gheet date:2005-01-14 type:bug bugster:4978659
8904N/APatch4: gnome-session-04-reduce-purge-warn-delay.diff
8904N/A#owner:stephen date:2006-06-29 type:bug bugster:6444179
8904N/APatch5: gnome-session-05-wait-for-postrun.diff
8904N/A#owner:gheet date:2006-11-03 type:feature bugster:6393728
8904N/APatch6: gnome-session-06-trusted-extensions.diff
8904N/A#owner:niall date:2004-11-10 type:bug bugster:6188905
8904N/APatch7: gnome-session-07-gnome-volcheck-default-session.diff
8904N/A
8904N/A#FIXME - these patches need rework for 2.19.
8904N/A#owner:erwannc date:2003-07-29 type:branding
8904N/APatch9: gnome-session-XX-busy-cursor.diff
8904N/A#owner:niall date:2005-05-11 type:branding
8904N/APatch10: gnome-session-XX-solaris-branding.diff
8904N/A
8904N/AURL: http://www.gnome.org
8904N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
8904N/ADocdir: %{_defaultdocdir}/%{name}
8904N/AAutoreqprov: on
8904N/APrereq: GConf
8904N/A
8904N/A%define libgnomeui_version 2.2.0
8904N/A%define libwnck_version 2.2.1
8904N/A
8904N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
8904N/ABuildRequires: libwnck-devel >= %{libwnck_version}
8904N/ARequires: libgnomeui >= %{libgnomeui_version}
8904N/ARequires: libwnck >= %{libwnck_version}
8904N/A
8904N/A%description
8904N/AThis package provides the basic session manager and tools for the GNOME Desktop.
8904N/A
8904N/A%prep
8904N/A%setup -q
8904N/A%patch1 -p1
8904N/A%patch2 -p1
8904N/A%patch3 -p1
8904N/A%patch4 -p1
8904N/A%patch5 -p1
8904N/A%if %build_tjds
8904N/A%patch6 -p1
8904N/A%endif
8904N/A%if %with_hal
8904N/A%else
8904N/A%patch7 -p1
8904N/A%endif
8904N/A
8904N/Acp %SOURCE1 gnome-session/gnome-splash.png
8904N/A
8904N/A%build
8904N/A%ifos linux
8904N/Aif [ -x /usr/bin/getconf ]; then
8904N/A CPUS=`getconf _NPROCESSORS_ONLN`
8904N/Afi
8904N/A%else
8904N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
8904N/A%endif
8904N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
8904N/A CPUS=1
8904N/Afi
8904N/A
8904N/A%ifos solaris
8904N/A%define poweroff /usr/sbin/poweroff
8904N/A%define reboot /usr/sbin/reboot
8904N/A%else
8904N/A%define poweroff /usr/bin/poweroff
8904N/A%define reboot /usr/bin/reboot
8904N/A%endif
8904N/A
8904N/Alibtoolize --force
8904N/Aintltoolize -c -f --automake
8904N/Aaclocal $ACLOCAL_FLAGS -I .
8904N/Aautoheader
8904N/Aautomake -a -c -f
8904N/Aautoconf
8904N/ACFLAGS="$RPM_OPT_FLAGS" \
8904N/A./configure --prefix=%{_prefix} \
8904N/A --libexecdir=%{_libexecdir} \
8904N/A --sysconfdir=%{_sysconfdir} \
8904N/A --mandir=%{_mandir} \
8904N/A --with-halt-command=%poweroff \
8904N/A --with-reboot-command=%reboot
8904N/Amake -j $CPUS
8904N/A
8904N/A%install
8904N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
8904N/Amake DESTDIR=$RPM_BUILD_ROOT install
8904N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
8904N/A
8904N/A%clean
8904N/Arm -rf $RPM_BUILD_ROOT
8904N/A
8904N/A%post
8904N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
8904N/ASCHEMAS="gnome-session.schemas"
8904N/Afor S in $SCHEMAS; do
8904N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
8904N/Adone
8904N/A
8904N/A%files
8904N/A%defattr(-,root,root)
8904N/A%{_bindir}/*
8904N/A%{_datadir}/pixmaps/*
8904N/A%{_mandir}/man1/*
8904N/A%{_mandir}/man5/*
8904N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
8904N/A%{_datadir}/gnome/default.session
8904N/A%{_datadir}/gnome/default.wm
8904N/A%{_datadir}/applications/
8904N/A%{_sysconfdir}/gconf/schemas/*
8904N/A
8904N/A%changelog
8904N/A* Mon Jun 18 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.19.4. Remove upstream patch, 08-fixtime.
8904N/A* Wed Jun 06 2007 - irene.huang@sun.com
8904N/A- %if %with_hal then do not apply patch7, volcheck.diff
8904N/A so that this patch will not be applied when HAL is enabled. Also modify
8904N/A the source path so that the source can be found.
8904N/A* Tue Jun 05 2007 - brian.cameron@sun.com
8904N/A- Bump to 2.19.3
8904N/A* Mon May 28 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.18.2.
8904N/A* Tue Mar 13 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.18.0.
8904N/A* Tue Feb 27 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.17.92.
8904N/A* Tue Feb 13 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.17.91.
8904N/A* Thu Feb 01 2007 - damien.carbery@sun.com
8904N/A- Remove upstream patch, 08-lXau; renumber remainder.
8904N/A* Sun Jan 28 2007 - laca@sun.com
8904N/A- add %if %build_tjds guard around tjds patch so we can build without trusted
8904N/A jds support
8904N/A* Mon Jan 22 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.17.90.1.
8904N/A* Mon Jan 22 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.17.90.
8904N/A* Tue Jan 09 2007 - damien.carbery@sun.com
8904N/A- Bump to 2.17.5.
8904N/A* Sat Dec 30 2006 - li.yuan@sun.com
8904N/A- Add gnome-session-11-remove-filter.diff to fix bugzilla #390882.
8904N/A Remove filter when it is not needed.
8904N/A* Fri Dec 15 2006 - li.yuan@sun.com
8904N/A- Add libexecdir option to configure to make gnome-session know
8904N/A where the at-spi-registryd is.
8904N/A* Sun Dec 03 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.17.3.
8904N/A* Wed Nov 22 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.17.2.
8904N/A* Fri Nov 03 2006 - ghee.teo@sun.com
8904N/A- Fixed up gnome-session-09-trusted-extensions.diff for 2.16
8904N/A* Tue Oct 31 2006 - takao.fujiwara@sun.com
8904N/A- Added intltoolize to read LINGAS file. Fixes 6488189.
8904N/A* Mon Oct 30 2006 - irene.huang@sun.com
8904N/A- add patch gnome-session-10-gnome-volcheck-default-session.diff
8904N/A which is orignally
8904N/A Solaris/patches/gnome-session-01-gnome-volcheck-default-session.diff
8904N/A* Mon Oct 23 2006 - glynn.foster@sun.com
8904N/A- Fix up fuzziness of the gnome-session patches. Merge the logout
8904N/A effect patches together, remove the non-existant a11y patch, and
8904N/A comment out the broken trusted extensions patch.
8904N/A* Tue Oct 03 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.16.1.
8904N/A* Mon Sep 04 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.16.0.
8904N/A* Fri Aug 25 2006 - damien.carbery@sun.com
8904N/A- Add patch, 12-lXau, to link libXau in.
8904N/A* Tue Aug 22 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.15.92.
8904N/A- Remove upstream patch, 10-fixcrash, renumber remainder.
8904N/A* Tue Aug 08 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.15.91.
8904N/A* Fri Jul 28 2006 - brian.cameron@sun.com
8904N/A- Move gnome-session-07-gnome-volcheck-default-session.diff to
8904N/A Solaris/patches so we can only apply this if HAL package is
8904N/A installed.
8904N/A* Fri Jul 28 2006 - dermot.mccluskey@sun.com
8904N/A- Fix minor typo.
8904N/A* Mon Jul 24 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.15.90.
8904N/A* Mon Jul 24 2006 - padraig.obriain@sun.com
8904N/A- Bump to 2.15.4.
8904N/A* Fri Jun 23 2006 - brian.cameron@sun.com
8904N/A- Bump to 2.14.2.
8904N/A* Fri May 05 2006 - brian.cameron@sun.com
8904N/A- Add patch to fix crash when HAL is enabled, caused by printing of a NULL
8904N/A string.
8904N/A* Fri Apr 10 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.14.1.
8904N/A* Tue Mar 14 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.14.0.
8904N/A* Thu Mar 9 2006 - damien.carbery@sun.com
8904N/A- Add patch, 10-G_DEBUG-off, to not set G_DEBUG=fatal_criticals as it exposes
8904N/A a lot of crashes in Evolution.
8904N/A* Tue Feb 28 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.13.92.
8904N/A* Tue Feb 14 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.13.91.
8904N/A- Remove unneeded glib-gettextize and intltoolize calls.
8904N/A* Sun Jan 29 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.13.90
8904N/A* Sun Jan 22 2006 - damien.carbery@sun.com
8904N/A- Call intltoolize and glib-gettextize to avoid infinite loop.
8904N/A* Fri Jan 20 2006 - damien.carbery@sun.com
8904N/A- Bump to 2.13.5.
8904N/A* Sat Sep 17 2005 - glynn.foster@sun.com
8904N/A- Bump to 2.12.0
8904N/A* Mon Aug 15 2005 - damien.carbery@sun.com
8904N/A- Bump to 2.11.91.
8904N/A* Fri Aug 05 2005 - glynn.foster@sun.com
8904N/A- Merge the 2 splashes into one. Remove the linux splash branding patch
8904N/A to focus on one for the moment - we can bring it back later if need
8904N/A be.
8904N/A* Tue Jun 14 2005 - bill.haneman@sun.com
8904N/A- Set GNOME_DISABLE_CRASH_DIALOG to '1', not 'true', for
8904N/A bug #6273175. (Previous patch set it to 'true', which failed to work).
8904N/A* Fri May 20 2005 - bill.haneman@sun.com
8904N/A- Edit gnome-session-09-load-a11y-modules.diff to set
8904N/A GNOME_DISABLE_CRASH_DIALOG when a11y is on, fix for bug #6273175.
8904N/A* Wed May 11 2005 - balamurali.viswanathan@wipro.com
8904N/A- Bump to 2.10.0
8904N/A* Wed Jan 23 2005 - arvind.samptur@wipro.com
8904N/A- Edit patch gnome-session-09-load-a11y-modules.diff to set
8904N/A the GTK_MODULES env before gnome_program_init (). This way
8904N/A b-a-s will get this env and will pass it on to all the factories
8904N/A that it would spawn.
8904N/A* Fri Jan 21 2005 - bill.haneman@sun.com
8904N/A- Edited patch gnome-session-09-load-a11y-modules.diff to fix bug
8904N/A 6202413. We now putenv("NO_J2D_DGA=true") when a11y is enabled,
8904N/A and the env variable isnt already set.
8904N/A* Thu Jan 14 2005 - ghee.teo@sun.com
8904N/A- Reduce the purge_delay and warn_delay to 30seconds which essentially
8904N/A revert back the bugzilla#94754. This patch is to partially fix bq2
8904N/A #4978659. The Mozilla team has fixed the mozilla side of the problem by
8904N/A 5068301, however, reducing this timeouts will benefit other badly broken
8904N/A session apps.
8904N/A* Mon Jan 10 2005 - kieran.colfer@sun.com
8904N/A- changing date on previous changelog entry - was causing rpmbuild
8904N/A to fail with "%changelog not in descending chronological order" :-)
8904N/A* Mon Jan 03 2005 - arvind.samptur@wipro.com
8904N/A- Now that gnome-settings-daemon starts per display, the
8904N/A patch gnome-session-07-sunray-screensaver.diff should not
8904N/A be required. Corresponding g-s-d patch is
8904N/A control-center-27-settings-daemon-per-display.diff
8904N/A* Thu Nov 12 2004 - alvaro.lopez@sun.com
8904N/A- Added patch #12. It fixes #5099423
8904N/A* Thu Nov 10 2004 - alvaro.lopez@sun.com
8904N/A- Source header fixed.
8904N/A* Wed Nov 10 2004 - leena.gunda@wipro.com
8904N/A- Added patch gnome-session-11-gnome-volcheck-default-session.diff
8904N/A to start gnome-volcheck for Solaris.
8904N/A* Thu Nov 04 2004 - brian.cameron@sun.com
8904N/A- Added patch 10 so that gnome-about launches on first-time login.
8904N/A* Fri Oct 29 2004 - laca@sun.com
8904N/A- Add gnome-session-remove.1 man page to %files
8904N/A* Thu Oct 28 2004 - matt.keenan@sun.com
8904N/A- Add gnome-session-remove.1 man page
8904N/A* Thu Oct 28 2004 - muktha.narayan@wipro.com
8904N/A- Load the a11y libraries by setting the GTK_MODULES env variable.
8904N/A Fixes issues addressed in bug #5097456.
8904N/A* Sat Sep 11 2004 - laca@sun.com
8904N/A- Move Solaris specific LDFLAGS to the Solaris spec file
8904N/A* Fri Sep 10 2004 - damien.carbery@sun.com
8904N/A- Set LDFLAGS so Xrandr and Xrender can be found.
8904N/A* Fri Aug 13 2004 - ghee.teo@sun.com
8904N/A- Forward ported sun-patches/gnome-session/560-4780014-s.diff
8904N/A as gnome-session-07-sunray-screensaver.diff. This is a security fix but
8904N/A really only affects Sunray.
8904N/A* Tue Aug 10 2004 - matt.keenan@sun.com
8904N/A- Bug:5084286, forward ported patch from mercury for logout effect.
8904N/A* Thu Jul 08 2004 - damien.donlon@sun.com
8904N/A- Updated l10n content to gnome-session-l10n-po-1.2.tar.bz2
8904N/A* Wed Jul 07 2004 - niall.power@sun.com
8904N/A- ported to rpm4
8904N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
8904N/A- added "-j $CPUS" to make to speed up builds
8904N/A* Wed Jun 09 2004 - ghee.teo@sun.com
8904N/A- do not compile patch1 on Solaris as it is a linux only patch.
8904N/A so use ifos linux to compile in
8904N/A gnome-session-01-magicdev-default-session.diff
8904N/A* Wed May 12 2004 - damien.donlon@sun.com
8904N/A- Updated l10n content to gnome-session-l10n-po-1.1.tar.bz2
8904N/A* Fri May 07 2004 - <matt.keenan@sun.com>
8904N/A- Bump to 2.6.1.
8904N/A* Tue Apr 06 2004 - arvind.samptur@wipro.com
8904N/A- Add patch to create an atom for legacy X apps to determine
8904N/A if they are running currently under GNOME
8904N/A* Mon Mar 29 2004 - damien.donlon@sun.com
8904N/A- Updated l10n content to gnome-session-l10n-po-1.0.tar.bz2
8904N/A* Tue Mar 24 2004 - <glynn.foster@sun.com>
8904N/A- Bump to 2.6.0. Remove man page and logout effect. Seems like
8904N/A a not hugely useful branding patch that it might be good to
8904N/A remove.
8904N/A* Tue Feb 24 2004 - <glynn.foster@sun.com>
8904N/A- Bump to 2.5.90
8904N/A* Fri Dec 15 2003 - <glynn.foster@sun.com>
8904N/A- Bump to 2.5.2
8904N/A* Wed Aug 06 2003 - <glynn.foster@sun.com>
8904N/A- Remove splash icons for non-important apps
8904N/A* Wed Jul 30 2003 - <markmc@sun.com>
8904N/A- Add magicdev correctly
8904N/A* Mon Jul 21 2003 - <markmc@sun.com>
8904N/A- Make it use the consolehelper versions of reboot and poweroff.
8904N/A* Fri Jul 11 2003 - <matt.keenan@sun.com>
8904N/A- Add patch for logout effect
8904N/A* Thu Jul 10 2003 - <glynn.foster@sun.com>
8904N/A- Add an icon to the splash widget.
8904N/A* Thu Jul 10 2003 - <glynn.foster@sun.com>
8904N/A- Add magicdev to the default session.
8904N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
8904N/A- add in sun po files
8904N/A* Mon Jun 30 2003 - <markmc@sun.com>
8904N/A- run autoheader so config.h contains gets HAVE_RANDR
8904N/A* Mon Jun 30 2003 - <markmc@sun.com>
8904N/A- add display properties restoration patch
8904N/A- copy the splash screen into the build tree in
8904N/A %prep rather than manually installing it in %install
8904N/A* Tue May 13 2003 - <ghee.teo@Sun.COM>
8904N/A- Created new spec file for gnome-session
8904N/A