10139N/A#
10139N/A# spec file for package gnome-pilot
10139N/A#
15905N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17255N/A%define owner wangke
10139N/A#
17180N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17180N/A
10139N/A%include l10n.inc
10139N/AName: gnome-pilot
15294N/ALicense: GPL v2
10139N/AGroup: Applications/Communications
15623N/AVersion: 2.0.17
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: Gnome Community
10139N/ASummary: PalmOS link utilities
15905N/ASource: http://download.gnome.org/sources/%{name}/2.0/%{name}-%{version}.tar.bz2
10142N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
12773N/A%if %build_l10n
12773N/ASource2: l10n-configure.sh
12773N/A%endif
10139N/A#date:2006-03-20 owner:gman bugzilla:313203 type:bug
12518N/APatch1: gnome-pilot-01-capplet-install.diff
10139N/A#date:2006-11-15 owner:calumb bugster:6489289 bugzilla:375639 type:bug
12518N/APatch2: gnome-pilot-02-launch-menu-item.diff
20307N/A#date:2006-12-13 owner:wangke type:bug bugzilla:584904
12518N/APatch3: gnome-pilot-03-disable-gob-check.diff
20307N/A#date:2006-12-18 owner:wangke type:branding
12518N/APatch4: gnome-pilot-04-usb-default.diff
20307N/A#date:2009-06-09 owner:wangke type:bug bugzilla:584894 state:upstream
16637N/APatch5: gnome-pilot-05-fix-missing-icons.diff
10139N/AURL: http://ftp.gnome.org/pub/GNOME/sources/gnome-pilot
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/ADocdir: %{_defaultdocdir}/gnome-pilot
10139N/AAutoreqprov: on
10139N/APrereq: GConf
10139N/A
10139N/A%define pilot_link_version 0.11.8
10139N/A%define scrollkeeper_version 0.3.14
10139N/A%define gnome_panel_version 2.6.1
10139N/A
10139N/ARequires: gnome-panel >= %{gnome_panel_version}
10139N/ARequires: pilot-link >= %{pilot_link_version}
10139N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10139N/ABuildRequires: pilot-link-devel >= %{pilot_link_version}
10139N/A
10139N/A%description
10139N/AGNOME Pilot is a collection of programs and daemons for using
10139N/APalm OS-based systems with GNOME, the complete user-friendly desktop
10139N/Abased entirely on free software.
10139N/A
10139N/A%package -n gnome-pilot-devel
10139N/ASummary: Pilot development header files.
10139N/AGroup: Development/Libraries
10139N/ARequires: gnome-pilot = %{version}-%{release}
10139N/ARequires: pilot-link-devel >= %{pilot_link_version}
10139N/A
10139N/A%description -n gnome-pilot-devel
10139N/AGNOME Pilot is a collection of programs and daemons for using
10139N/APalm OS-based systems with GNOME, the complete user-friendly desktop
10139N/Abased entirely on free software.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10142N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
12518N/A%patch1 -p1
12518N/A%patch2 -p1
10139N/A%patch3 -p1
12518N/A%patch4 -p1
16637N/A%patch5 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/ALC_ALL=
10139N/ALANG=
10139N/Aexport LC_ALL LANG
10139N/Alibtoolize --force
11140N/Aintltoolize --force --copy --automake
12773N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE2 --enable-copyright
12773N/A%endif
12773N/A
16637N/Aaclocal $ACLOCAL_FLAGS -I macros
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --localstatedir=/var \
10139N/A --disable-pilotlinktest \
10139N/A --with-pisock=yes \
10139N/A --with-hal=no
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/conduits/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/conduits/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="pilot.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/idl/*
10139N/A%{_datadir}/mime-info/*
10139N/A%{_datadir}/pixmaps/*
10139N/A%{_bindir}/*
10139N/A%{_libexecdir}/*
10139N/A%{_libdir}/bonobo/servers/*
10139N/A%{_libdir}/gnome-pilot/conduits/*.so
10139N/A%dir %{_datadir}/gnome-pilot
10139N/A%dir %{_datadir}/gnome-pilot/glade
10139N/A%{_datadir}/gnome-pilot/conduits
10139N/A%{_datadir}/gnome-pilot/glade/*.png
10139N/A%{_datadir}/gnome-pilot/glade/*.glade
10139N/A%{_datadir}/gnome-pilot/*.xml
10139N/A%{_datadir}/gnome/help/*
10139N/A%{_datadir}/omf/*
10139N/A%{_sysconfdir}/gconf/schemas/pilot.schemas
10139N/A%{_libdir}/*.so.*
10139N/A%{_mandir}/man1/*
10139N/A
10139N/A%files -n gnome-pilot-devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/*.so
10139N/A
10139N/A%changelog
16637N/A* Tue Jun 09 2009 - halton.huo@sun.com
16637N/A- Add patch fix-missing-icons.diff to fix bugzilla 584894.
15623N/A* Thu Jan 8 2008 - jijun.yu@sun.com
15623N/A- Bump to 2.0.17.
15623N/A- Remove upstream patch.
12898N/A* Fri Apr 18 2008 - jijun.yu@sun.com
12898N/A- Add a patch to fix bug 6690026 and 6668371.
12518N/A* Mon Mar 03 2008 - jijun.yu@sun.com
12518N/A- Rename the patches.
12477N/A* Wed Feb 27 2008 - jijun.yu@sun.com
12477N/A- Bump to 2.0.16
12477N/A- Remove 4 upstream patches
12477N/A- Rework 2 patches
11140N/A* Wed Aug 29 2007 - damien.carbery@sun.com
11140N/A- Add intltoolize call to update intltool scripts.
10139N/A* Wed Feb 28 2007 - jijun.yu@sun.com
10139N/A- Remove upstream patch gnome-pilot-02-pilot_connect.diff
10139N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Thu Jan 04 2007 - jijun.yu@sun.com
10139N/A- Update to new version 2.0.15
10139N/A* Wed Dec 06 2006 - takao.fujiwara@sun.com
10139N/A- Add gnome-pilot-08-g11n-i18n-ui.diff. bugzilla #138628
10139N/A* Wed Nov 15 2006 - calum.benson@sun.com
10139N/A- Patch menu item to match latest UI spec.
10139N/A* Wed Oct 24 2006 - glynn.foster@sun.com
10139N/A- Add patch to fix #6437924, and fix up some of the window icons so they look
10139N/A a little more consistent. This is bugzilla #364589.
10139N/A* Wed Jun 28 2006 - halton.huo@sun.com.
10139N/A- Add patch gnome-pilot-04-remove-nouse-libs.diff to fix #6434263.
20307N/A- Add patch gnome-pilot-05-disable-gob-check.diff to remove gob build
20307N/A dependency.
10139N/A* Tue Jun 06 2006 - halton.huo@sun.com
10139N/A- Remove patch gnome-pilot-01-configure-in.diff and reorder,
10139N/A build require gob2.
10139N/A* Mon Mar 20 2006 - glynn.foster@sun.com
10139N/A- Install capplet in the right directory - #313203
10139N/A* Tue Jan 10 2006 - halton.huo@sun.com
10139N/A- Replace patches by pdasync.prc team:
10139N/A deleted: gnome-pilot-01-menu-entry.diff
10139N/A gnome-pilot-02-g11n-i18n-ui.diff
10139N/A gnome-pilot-03-automake-fix.diff
10139N/A added : gnome-pilot-01-configure-in.diff
10139N/A gnome-pilot-02-all-in-one.diff
10139N/A
10139N/A* Tue Nov 29 2005 - laca.com
10139N/A- remove javahelp stuff
10139N/A* Tue May 17 2005 - glynn.foster@sun.com
10139N/A- Port to 2.0.13
10139N/A* Fri Feb 11 2005 - dinoop.thomas@wipro.com
10139N/A- Added patch to make help button in gnome-pilot settings point to
10139N/A correct location.Fixes bug 6225082
10139N/A* Mon Jan 31 2005 - ghee.teo@sun.com
10139N/A- Increased the Release number by 200. The problem is that the release
10139N/A counter has been reset during the JDS 3 release cycle but the version
10139N/A number has not changed. This causes an update problem because the version
10139N/A in JDS 2 appears to be newer than this version. Fixes 6222834.
10139N/A* Wed Jan 26 2005 - damien.carbery@sun.com
10139N/A- Update docs with Linux specific tarball from eugene.oconnor@sun.com.
10139N/A* Fri Jan 14 2005 - kazuhiko.maekawa@sun.com
10139N/A- Updated l10n help tarball for cinnabar-linux
10139N/A* Wed Nov 17 2004 - matt.keenan@sun.com
10139N/A- #6195855, install correct man page
10139N/A* Thu Oct 28 2004 - matt.keenan@sun.com
10139N/A- Add gpilot-install-file.1, gpilotd-control-applet.1 man pages
10139N/A* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
10139N/A- Added l10n help files with patch
10139N/A* Thu Aug 19 2004 - damien.carbery@sun.com
10139N/A- Integrated updated docs tarball from eugene.oconnor@sun.com.
10139N/A* Mon Aug 16 2004 - vinay.mandyakoppal@wipro.com
10139N/A- Help invocation for the applet is implemented.
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-pilot-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed Jun 09 2004 - damien.carbery@sun.com
10139N/A- Integrated docs and associated patch from eugene.oconnor@sun.com
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-pilot-l10n-po-1.1.tar.bz2
10139N/A* Sun Apr 18 2004 - laca@sun.com
10139N/A- enable javahelp conversion on Solaris
10139N/A* Thu Apr 01 2004 - matt.keenan@sun.com
10139N/A- Javahelp conversion
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-pilot-l10n-po-1.0.tar.bz2
10139N/A* Tue Mar 16 2004 - laca@sun.com
10139N/A- add patch5 to fix build with newer versions of automake
10139N/A- add --libexecdir
10139N/A* Fri Mar 05 2004 - takao.fujiwara@sun.com
10139N/A- Modified %files section in spec file to fix 4932068
20307N/A- Changed gnome-pilot-04-trans-pilot-menu.diff to
20307N/A gnome-pilot-04-g11n-i18n-ui.diff
10139N/A* Wed Feb 18 2004 - matt.keenan@sun.com
10139N/A- Updated distro to Cinnabar, added l10n stuff
10139N/A- Port patchs 03/04, and libtoolize it
10139N/A* Fri Oct 31 2003 - glynn.foster@sun.com
10139N/A- Remove the Sun Settings keyword from the
10139N/A menu entry patch.
10139N/A* Fri Oct 10 2003 - laszlo.kovacs@sun.com
10139N/A- upgrade deps versions
10139N/A* Fri Oct 03 2003 - <matt.keenan@sun.com>
10139N/A- remove man pages
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- remove *.a, *.la
10139N/A* Mon Aug 01 2003 - glynn.foster@sun.com
10139N/A- Add some menu categorization
10139N/A* Mon Jul 28 2003 - michael.twomey@sun.com
10139N/A- Updated POTFILES.in
10139N/A* Fri Jul 28 2003 - glynn.foster@sun.com
10139N/A- Install the applet as part of the main
10139N/A package. There is no reason to have an
10139N/A extra package for this one.
10139N/A* Fri Jul 25 2003 - niall.power@sun.com
10139N/A- Base package requires pilot-link
10139N/A* Thu Jul 24 2003 - <matt.keenan@sun.com>
10139N/A- Initial version