gnome-netstatus.spec revision 15153
10292N/A#
10292N/A# Copyright (c) 2003-2004 Sun Microsystems, Inc.
10292N/A# This file and all modifications and additions to the pristine
18540N/A# package are under the same license as the package itself.
10292N/A# Owner: migi
10292N/A#
10292N/A%include l10n.inc
20246N/AName: gnome-netstatus
10292N/ALicense: GPL
17178N/AGroup: System/GUI/GNOME
18603N/AVersion: 2.12.2
17178N/ARelease: 1
15153N/ADistribution: Java Desktop System
10292N/AVendor: Sun Microsystems, Inc.
15314N/ASummary: The GNOME Network Monitor Applet
10292N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gnome-netstatus/2.12/%{name}-%{version}.tar.bz2
15501N/A%if %build_l10n
15501N/ASource1: l10n-configure.sh
15501N/A%endif
10292N/ASource2: gnome-netstatus-wireless-icons-0.2.tar.gz
10292N/A%if %build_l10n
18615N/ASource3: %{name}-po-sun-%{po_sun_version}.tar.bz2
10292N/A%endif
15536N/A#owner:gman date:2005-02-03 type:branding
15153N/APatch1: gnome-netstatus-01-restart.diff
15153N/A#owner:gman date:2005-02-03 type:branding
15153N/APatch2: gnome-netstatus-02-kstat-solaris.diff
13879N/A#owner:dcarbery date:2006-11-16 type:bug bugzilla:375932
15501N/APatch3: gnome-netstatus-03-icon-symlink.diff
13011N/A#owner:mattman date:2007-08-24 type:bug bugster:6577129 bugzilla:469864
20255N/APatch4: gnome-netstatus-04-default-interface.diff
20255N/A#owner:davelam date:2008-05-14 type:bug bugzilla:532095
20255N/APatch5: gnome-netstatus-05-add-ldlibs.diff
10292N/A#owner:dkenny date:2008-06-23 type:feature
10292N/APatch6: gnome-netstatus-06-wifi-info.diff
10292N/AURL: http://www.gnome.org
10292N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10292N/ADocdir: %{_defaultdocdir}/gnome-netstatus
10292N/AAutoreqprov: on
10292N/A
10292N/A%define libglade_version 2.3.6
10292N/A%define gnome_panel_version 2.6.1
10292N/A
10292N/ARequires: libglade >= %{libglade_version}
10292N/ARequires: gnome-panel >= %{gnome_panel_version}
10292N/A
10292N/ABuildRequires: libglade-devel >= %{libglade_version}
10292N/ABuildRequires: gnome-panel-devel >= %{gnome_panel_version}
10292N/A
10292N/A%description
10292N/AThis package contains an applet which provides information
10292N/Aabout a network interface on your panel.
10292N/A
10292N/A%prep
10292N/A%setup -q
10292N/A%if %build_l10n
10292N/Abzcat %SOURCE3 | tar xf -
10292N/Acd po-sun; make; cd ..
10292N/A%endif
10292N/A
10292N/A%patch1 -p1
10292N/A%patch2 -p1
10292N/A%patch3 -p1
10292N/A%patch4 -p1
10292N/A%patch5 -p1
10292N/A%patch6 -p1
10292N/A
10292N/Acd icons
10292N/Agzip -cd %SOURCE2 | tar xvf -
10292N/Acd ..
10292N/A
10292N/A#FIXME: see below
10292N/Aecho > po/ne.po
10292N/A
10292N/A%build
10292N/A%ifos linux
10292N/Aif [ -x /usr/bin/getconf ]; then
10292N/A CPUS=`getconf _NPROCESSORS_ONLN`
10292N/Afi
15153N/A%else
15153N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15153N/A%endif
15153N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15153N/A CPUS=1
15501N/Afi
20255N/A
10292N/Agnome-doc-common
10292N/Agnome-doc-prepare
10292N/Alibtoolize --force
10292N/Aintltoolize -f -c --automake
10292N/A
10292N/A%if %build_l10n
10292N/Abash -x %SOURCE1 --enable-copyright
10292N/A%endif
10292N/A
10292N/Aaclocal $ACLOCAL_FLAGS
10292N/Aautoheader
10292N/Aautomake -a -c -f
10292N/Aautoconf
13011N/A
13011N/A#FIXME: "ne" po file seems broken, disabling for now
13011N/ALINGUAS="ar az bg bn bs ca cs cy da de el en_CA en_GB es et eu fa fi fr ga gl gu hi hr hu id it ja ko lt mn ms nb nl nn no pa pl pt pt_BR ro ru rw sk sq
13011N/Asr sr@Latn sv ta th tr vi uk wa xh zh_CN zh_TW"
13011N/Aexport LINGUAS
13011N/ACFLAGS="$RPM_OPT_FLAGS" \
13011N/A ./configure \
13011N/A --prefix=%{_prefix} \
10292N/A --libexecdir=%{_libexecdir} \
10292N/A --sysconfdir=%{_sysconfdir} \
10292N/A --disable-scrollkeeper
10292N/A
10292N/Amake -j $CPUS
10292N/A
10292N/A%install
10292N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10292N/Amake install DESTDIR=$RPM_BUILD_ROOT
10292N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10292N/A
10292N/A%clean
10292N/Arm -rf $RPM_BUILD_ROOT
10292N/A
10292N/A%post
10292N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10292N/ASCHEMAS="netstatus.schemas"
10292N/Afor S in $SCHEMAS; do
10292N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10292N/Adone
10292N/A
10292N/A%files
10292N/A%defattr(-,root,root)
10292N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10292N/A%doc %{_datadir}/gnome/help/gnome-netstatus
10292N/A%config %{_sysconfdir}/gconf/schemas/*.schemas
10292N/A%{_libdir}/bonobo/servers/*.server
10292N/A%{_libexecdir}/*
10292N/A%{_datadir}/pixmaps/*
10292N/A%{_datadir}/gnome-netstatus/
10292N/A%{_datadir}/gnome/help/*
10292N/A%{_datadir}/gnome-2.0/ui/*.xml
10292N/A%{_datadir}/icons/hicolor/*
10292N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
20255N/A%{_datadir}/omf/gnome-netstatus/*.omf
20255N/A
20255N/A%changelog
15153N/A* Wed Oct 01 2008 - takao.fujiwara@sun.com
15153N/A- Add l10n tarball.
15153N/A
14470N/A* Mon Sep 28 2008 - darren.kenny@sun.com
14470N/A- Bump to 2.12.2 remove upstream patch gnome-netstatus-06-icon-dirs.diff, and
14470N/A renumber existing patches.
14184N/A
14184N/A* Mon Sep 15 2008 - darren.kenny@sun.com
14272N/A- Fix bug#6748400, to update to use new mechanism for icons and enable support
14184N/A for nimbus icons.
13992N/A
13992N/A* Fri Aug 22 2008 - darren.kenny@sun.com
13992N/A- Add patch gnome-netstatus-06-icon-dirs.diff, taken from upstream, to fix
13946N/A location of application icons - bugzilla#435668.
13946N/A- Add wireless support on Solaris - gnome-netstatus-07-wifi-info.diff
13946N/A RFE#6740396.
13879N/A
13879N/A* Wed May 14 2008 - dave.lin@sun.com
13879N/A- Add patch gnome-netstatus-05-add-ldlibs.diff to fix build error
13108N/A
13108N/A* Fri Aug 24 2007 - matt.keenan@sun.com
13108N/A- Fix #6577129 : Default to working interface
13098N/A
13098N/A* Tue Feb 13 2007 - damien.carbery@sun.com
13094N/A- Bump to 2.12.1.
13059N/A
13059N/A* Wed Dec 06 2006 - takao.fujiwara@sun.com
13059N/A- Added intltoolize to read ALL_LINGUAS. Fixes 6499663
13059N/A
13059N/A* Thu Nov 16 2006 - damien.carbery@sun.com
13011N/A- Add patch 04-icon-symlink to make l10n image symlinks relative rather than
13011N/A absolute. Fixes WOS integration issue which prohibits absolute symlinks.
13011N/A Bugzilla 375932.
13011N/A
13011N/A* Mon Oct 03 2005 - damien.carbery@sun.com
12351N/A- Add patch to fix po/ne.po (dos2unix required). Bugzilla 316750.
12351N/A Remove javahelp-convert code as the docs are no longer used.
12351N/A
12305N/A* Thu Sep 15 2005 - brian.cameron@sun.com
12305N/A- Bump to 2.12.0
12305N/A
12147N/A* Fri Jan 14 2005 - kazuhiko.maekawa@sun.com
12147N/A- Updated l10n help tarball for cinnabar-linux
12147N/A
12066N/A* Tue Dec 21 2004 - vinay.mandyakoppal@wipro.com
12066N/A- Added gnome-netstatus-06-Shift+F10-not-working.diff to make
12066N/A Shift+F10 work. Fixes bug#6193273.
12066N/A
11364N/A* Thu Oct 28 2004 - kazuhiko.maekawa@sun.com
11364N/A- Updated l10n help tarball and added pt_BR
11364N/A
11230N/A* Tue Oct 05 2004 - matt.keenan@sun.com
11230N/A- Removed patch 03-docs.diff #5108690
11230N/A- Renamed patch 05-g11n-alllinguas.diff to 03-g11n-alllinguas.diff
10821N/A
10821N/A* Fri Sep 17 2004 - ciaran.mcdermott@sun.com
10821N/A- Added gnome-netstatus-05-g11n-alllinguas.diff to add zh_TW lingua
10659N/A
10659N/A* Mon Sep 06 2004 - matt.keenan@sun.com
10659N/A- Added javahelp-convert for gnome-netstatus docs
10292N/A
10292N/A* Wed Aug 25 2004 - damien.carbery@sun.com
10292N/A- Integrated updated docs tarball from breda.mccolgan@sun.com.
* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
- Added l10n help contents
* Fri Aug 13 2004 - damien.carbery@sun.com
- Change absolute symlinks to relative for s10 integration. Patch wos_symlinks.
* Mon Aug 09 2004 - takao.fujiwara@sun.com
- Fixed build error.
* Thu Aug 05 2004 - damien.carbery@sun.com
- Integrated docs tarball from breda.mccolgan@sun.com
- Added patch to omit non-C locales from help.
* Fri Jul 23 2004 - muktha.narayan@wipro.com
- Added gnome-netstatus-02-kstat-solaris.diff to use kstat
in Solaris.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Adding gnome-netstatus-l10n-po-1.2.tar.bz2 l10n content
* Thu Jul 08 2004 - stephen.browne@sun.com
- ported to rpm4/suse91
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Mon Jun 14 2004 - misha@sun.com
- Removed upstream patch gnome-netstatus-01-right-click-help.diff
Removed upstream patch gnome-netstatus-02-include-socket-h.diff
Removed upstream patch gnome-netstatus-04-g11n-potfiles.diff
Removed broken patch gnome-netstatus-03-wireless.diff
* Tue Jun 08 2004 - misha@sun.com
- Bump to 2.7.1
Network interface restart patch is added.
* Mon May 23 2004 - yuriy.kuznetsov@sun.com
- Added patch gnome-netstatus-04-g11n-potfiles.diff
* Mon May 17 2004 - damien.carbery@sun.com
- Correct Requires line: iwlib -> wireless-tools.
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-netstatus-l10n-po-1.1.tar.bz2
* Tue May 12 2004 - mark.carey@sun.com
- add patch #3 (wireless support linux only)
* Fri May 07 2004 - matt.keenan@sun.com
- Bump to 2.6.1
* Sun May 02 2004 - laca@sun.com
- add patch #2 (include-socket-h) to fix build on Solaris
* Fri Apr 30 2004 - muktha.narayan@wipro.com
- Modified gnome-netstatus-01-right-click-help.diff to
include the 'Help' menu item in GNOME_NetstatusApplet.xml file,
fix a warning and open the correct help page for preference tab.
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-netstatus-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - <glynn.foster@sun.com>
- Bump to 2.6.0. Remove l10n and socksio headers, upstream.
Refactor help patch not to use egg stuff.
* Wed Mar 03 2004 - <niall.power@sun.com>
- Patch #03 to fix build on solaris.
- replace "tar jxf" with "bzcat | tar -xf -"
- run gnome-doc-common and autoheader in build
- specify libexecdir in configure args
* Fri Feb 27 2004 - <matt.keenan@sun.com>
- Fix gnome-netstatus-02-right-click-help.diff as it was not applying... should have bee tested !
- Fix gnome-netstatus-01-i18n.diff : zh_HK bug in patch.... hmmm
* Tue Feb 24 2004 - <shakti.sen@wipro.com>
- Added gnome-netstatus-02-right-click-help.diff to provide right-click help
support for the applet as well as support for multi-head.
* Tue Feb 10 2004 - <matt.keenan@sun.com>
- Bump to 0.14, add docs/l10n, port patches 01/02
* Mon Jul 07 2003 - <markmc@sun.com>
- Move to 0.11
* Thu Jun 12 2003 - <markmc@sun.com>
- Move to 0.10
* Thu Jun 12 2003 - <markmc@sun.com>
- Initial spec file