gnome-mount.spec revision 20785
11844N/A#
11844N/A# spec file for package gnome-volume-manager
11844N/A#
11844N/A# Copyright (c) 2006, 2011, Oracle and/or its affiliates. All rights reserved.
11844N/A# This file and all modifications and additions to the pristine
15395N/A# package are under the same license as the package itself.
11844N/A#
11844N/A%define owner stephen
11844N/A
11844N/A%define OSR 12727:0.x
12332N/A
11844N/AName: gnome-mount
15395N/ALicense: GPL
11844N/AGroup: System/GUI/GNOME
17176N/A# Note: HAL may need to be bumped before gnome-mount.
17176N/AVersion: 0.4
11844N/ARelease: 1
12542N/ADistribution: Java Desktop System
11844N/AVendor: Other
16369N/ASummary: Programs for mounting, unmounting and ejecting storage devices.
11844N/ASource: http://hal.freedesktop.org/releases/%name-%version.tar.gz
11844N/A%if %build_l10n
11844N/ASource1: l10n-configure.sh
11844N/A%endif
16369N/A# This patch addresses two separate Sun-specific bugs which are both
11844N/A# upstream. Note that bugster bug #6790821 is not fully resolved
11844N/A# with the patch. However, backporting some code from upstream did
11844N/A# improve the situation significantly so this patch partially
11844N/A# addresses this bug.
11844N/A#owner:yippi date:2006-06-20 type:bug bugzilla:400499 bugster:6790821 state:upstream
11844N/APatch1: gnome-mount-01-sun-patch.diff
11844N/AURL: www.gnome.org
11844N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11844N/ADocdir: %{_defaultdocdir}
11844N/AAutoreqprov: on
11844N/APrereq: /usr/sbin/groupadd
11844N/APrereq: /usr/sbin/useradd
11844N/APrereq: /sbin/nologin
11844N/APrereq: sed
11844N/APrereq: coreutils
15395N/A
11844N/A%description
11844N/AHandles mount/umount/eject by using HAL.
11844N/A
11844N/A%prep
11844N/A%setup -q
11844N/A%patch1 -p1
11844N/A
11844N/A%build
11844N/A%ifos linux
11844N/Aif [ -x /usr/bin/getconf ]; then
11844N/A CPUS=`getconf _NPROCESSORS_ONLN`
11844N/Afi
11844N/A%else
11844N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
11844N/A%endif
11844N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
16369N/A CPUS=1
16369N/Afi
15758N/A
15758N/Aexport CFLAGS="$RPM_OPT_FLAGS"
15395N/Aautoheader
15395N/Aautoconf
15361N/Alibtoolize --force
15361N/Aglib-gettextize -c -f
11844N/Aintltoolize --copy --force --automake
11846N/A
11846N/A%if %build_l10n
11846N/Abash -x %SOURCE1 --enable-copyright
%endif
aclocal $ACLOCAL_FLAGS
autoconf
autoheader
automake -a -c -f
%ifos solaris
ENABLE_MULTIUSER=--enable-multiuser=no
%else
ENABLE_MULTIUSER=--enable-multiuser=yes
%endif
./configure \
--prefix=%{_prefix} \
--sysconfdir=%{_sysconfdir} \
--localstatedir=/var/lib \
--mandir=%{_mandir} \
--libexecdir=%{_libexecdir} $ENABLE_MULTIUSER
make -j $CPUS
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
cd $RPM_BUILD_ROOT%{_bindir}
# Build symlinks as relative instead of full path.
#
rm -rf gnome-umount
rm -fr gnome-eject
ln -s gnome-mount gnome-umount
ln -s gnome-mount gnome-eject
%clean
rm -rf $RPM_BUILD_ROOT
%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-volume-manager.schemas"
for S in $SCHEMAS; do
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
%files
%config %attr(-,gdm,gdm) %{_sysconfdir}/X11/gdm
%config %attr(-,root,root) %{_sysconfdir}/X11/dm
%{_datadir}/locale/*/LC_MESSAGES/gdm*.mo
%{_sbindir}/*
%{_bindir}/*
%{_libdir}/gtk-2.0/modules/*.so
%{_libexecdir}/*
%{_datadir}/gdm
%{_datadir}/applications/*
%{_datadir}/pixmaps/*.png
%{_datadir}/pixmaps/faces/*.jpg
%{_datadir}/pixmaps/faces/*.png
%{_datadir}/icons
%{_datadir}/gnome/help/*
%{_datadir}/xsessions/*
%{_mandir}/man1/*
%{_datadir}/omf/*
%attr(-,gdm,gdm) /var/lib/gdm
%config /etc/pam.d/*
%config /etc/security/*
%changelog
* Tue Jul 12 2011 - brian.cameron@oracle.com
- Fix download link to freedesktop.
* Wed Apr 01 2009 - brian.cameron@sun.com
- Merge both upstream Sun-specific patches into one patch.
* Fri Feb 20 2009 - brian.cameron@sun.com
- Add patch gnome-mount-02-fixdelay.diff. This patch is from upstream, and
helps to ensure that gnome-mount waits for mount operations to complete.
* Tue Jun 20 2006 - <brian.cameron@sun.com>
- Bump to 0.4 and add patch needed for Solaris support
* Wed May 03 2006 - <brian.cameron@sun.com>
- Created