10139N/A#
10139N/A# spec file for package gnome-volume-manager
10139N/A#
20785N/A# Copyright (c) 2006, 2011, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner stephen
17178N/A
17178N/A%define OSR 12727:0.x
17178N/A
10139N/AName: gnome-mount
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
10317N/A# Note: HAL may need to be bumped before gnome-mount.
10139N/AVersion: 0.4
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: Other
10139N/ASummary: Programs for mounting, unmounting and ejecting storage devices.
20785N/ASource: http://hal.freedesktop.org/releases/%name-%version.tar.gz
12773N/A%if %build_l10n
12773N/ASource1: l10n-configure.sh
12773N/A%endif
16428N/A# This patch addresses two separate Sun-specific bugs which are both
16428N/A# upstream. Note that bugster bug #6790821 is not fully resolved
16428N/A# with the patch. However, backporting some code from upstream did
16428N/A# improve the situation significantly so this patch partially
16428N/A# addresses this bug.
16291N/A#owner:yippi date:2006-06-20 type:bug bugzilla:400499 bugster:6790821 state:upstream
10139N/APatch1: gnome-mount-01-sun-patch.diff
10139N/AURL: www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}
10139N/AAutoreqprov: on
10139N/APrereq: /usr/sbin/groupadd
10139N/APrereq: /usr/sbin/useradd
10139N/APrereq: /sbin/nologin
10139N/APrereq: sed
10139N/APrereq: coreutils
10139N/A
10139N/A%description
10139N/AHandles mount/umount/eject by using HAL.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport CFLAGS="$RPM_OPT_FLAGS"
10139N/Aautoheader
10139N/Aautoconf
10139N/Alibtoolize --force
10139N/Aglib-gettextize -c -f
10139N/Aintltoolize --copy --force --automake
12773N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE1 --enable-copyright
12773N/A%endif
12773N/A
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoconf
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/A%ifos solaris
10139N/AENABLE_MULTIUSER=--enable-multiuser=no
10139N/A%else
10139N/AENABLE_MULTIUSER=--enable-multiuser=yes
10139N/A%endif
10139N/A
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --localstatedir=/var/lib \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} $ENABLE_MULTIUSER
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A
10139N/Acd $RPM_BUILD_ROOT%{_bindir}
10139N/A
10139N/A# Build symlinks as relative instead of full path.
10139N/A#
10139N/Arm -rf gnome-umount
10139N/Arm -fr gnome-eject
10139N/Aln -s gnome-mount gnome-umount
10139N/Aln -s gnome-mount gnome-eject
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="gnome-volume-manager.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%config %attr(-,gdm,gdm) %{_sysconfdir}/X11/gdm
10139N/A%config %attr(-,root,root) %{_sysconfdir}/X11/dm
10139N/A%{_datadir}/locale/*/LC_MESSAGES/gdm*.mo
10139N/A%{_sbindir}/*
10139N/A%{_bindir}/*
10139N/A%{_libdir}/gtk-2.0/modules/*.so
10139N/A%{_libexecdir}/*
10139N/A%{_datadir}/gdm
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/pixmaps/*.png
10139N/A%{_datadir}/pixmaps/faces/*.jpg
10139N/A%{_datadir}/pixmaps/faces/*.png
10139N/A%{_datadir}/icons
10139N/A%{_datadir}/gnome/help/*
10139N/A%{_datadir}/xsessions/*
10139N/A%{_mandir}/man1/*
10139N/A%{_datadir}/omf/*
10139N/A%attr(-,gdm,gdm) /var/lib/gdm
10139N/A%config /etc/pam.d/*
10139N/A%config /etc/security/*
10139N/A
10139N/A%changelog
20785N/A* Tue Jul 12 2011 - brian.cameron@oracle.com
20785N/A- Fix download link to freedesktop.
16291N/A* Wed Apr 01 2009 - brian.cameron@sun.com
16291N/A- Merge both upstream Sun-specific patches into one patch.
15940N/A* Fri Feb 20 2009 - brian.cameron@sun.com
15940N/A- Add patch gnome-mount-02-fixdelay.diff. This patch is from upstream, and
15940N/A helps to ensure that gnome-mount waits for mount operations to complete.
10139N/A* Tue Jun 20 2006 - <brian.cameron@sun.com>
10139N/A- Bump to 0.4 and add patch needed for Solaris support
10139N/A* Wed May 03 2006 - <brian.cameron@sun.com>
10139N/A- Created