gnome-keyring.spec revision 17554
10139N/A#
10139N/A# spec file for package gnome-keyring
10139N/A#
10139N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner jefftsai
10139N/A#
10139N/A
10139N/A%define OSR gnome.org:0
10139N/A
10139N/AName: gnome-keyring
12104N/ALicense: GPL v2, LGPL v2
10139N/AGroup: System/GUI/GNOME
10139N/AVersion: 2.28.1
10139N/ARelease: 4
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
12104N/AURL: http://www.gnome.org
10142N/ASummary: GNOME Key Ring
10142N/ASource: http://download.gnome.org/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
10139N/A%if %build_l10n
12104N/ASource1: l10n-configure.sh
10139N/A%endif
10139N/A# date:2009-03-03 owner:jefftsai type:branding
10139N/APatch1: gnome-keyring-01-not-check-asn1parser.diff
12104N/A# date:2009-03-03 owner:jefftsai type:bug bugzilla:572527
10139N/APatch2: gnome-keyring-02-ssh-agent.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
12104N/A%define gtk_doc_version 1.1
11438N/A
12104N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
11419N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
12104N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
11419N/A
11419N/A%description
11419N/Agnome-keyring is a program that keep password and other secrets for
11419N/Ausers. It is run as a daemon in the session, similar to ssh-agent, and
11438N/Aother applications can locate it by an environment variable.
12104N/A
11878N/AThe program can manage several keyrings, each with its own master
12104N/Apassword, and there is also a session keyring which is never stored to
11981N/Adisk, but forgotten when the session ends.
11981N/A
10139N/AThe library libgnome-keyring is used by applications to integrate with
10139N/Athe gnome keyring system.
10139N/A
10139N/A%package devel
10139N/ASummary: GNOME Key Ring Library
10139N/AGroup: Development/Libraries/GNOME
10139N/ARequires: %{name} = %{version}
10139N/ARequires: gtk2-devel >= %{gtk2_version}
10139N/A
10139N/A%description devel
10139N/Agnome-keyring is a program that keep password and other secrets for
10139N/Ausers. It is run as a daemon in the session, similar to ssh-agent, and
10139N/Aother applications can locate it by an environment variable.
10139N/A
10139N/AThe program can manage several keyrings, each with its own master
10139N/Apassword, and there is also a session keyring which is never stored to
10139N/Adisk, but forgotten when the session ends.
10139N/A
10139N/AThe library libgnome-keyring is used by applications to integrate with
10139N/Athe gnome keyring system.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aintltoolize -f -c --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoconf
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS -D_POSIX_PTHREAD_SEMANTICS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --disable-pam \
10139N/A --libexecdir=%{_libexecdir}
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/Arm $RPM_BUILD_ROOT%{_bindir}/gnome-keyring
10139N/A
10139N/A#%check
10142N/Amake check
10139N/A
10139N/A%clean
12104N/Arm -rf $RPM_BUILD_ROOT
10139N/A
12104N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
12104N/A/sbin/ldconfig
12104N/A
11855N/A%files
12104N/A%{_datadir}/locale/*/LC_MESSAGES/*
11855N/A%{_bindir}/*
11855N/A%{_libdir}/lib*.so.*
11855N/A%{_libexecdir}/gnome-keyring-ask
11855N/A
10981N/A%files devel
12104N/A%{_libdir}/pkgconfig/*.pc
10981N/A%{_includedir}/gnome-keyring-1/*
12104N/A%{_libdir}/lib*.so
11981N/A
10139N/A%changelog
10139N/A* Oct 20 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.28.1
10139N/A* Sep 22 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.28.0
10142N/A* Sep 14 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.27.92
10139N/A- Upstream path -03-timer-shutdown
10139N/A* Tue Aug 11 2009 - jeff.cai@sun.com
10139N/A- Add patch -03-timer-shutdown, fix bugzilla #591415 doo #10488
10139N/A Not join timer thread since it might already ends.
10139N/A* Tue Aug 11 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.27.90.
10139N/A* Tue Jul 28 2009 - christian.kelly@sun.com
10139N/A- Bump to 2.27.5.
10139N/A* Tue Jul 14 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.27.4
10139N/A* Tue Apr 14 2009 - halton.huo@sun.com
10139N/A- Bump to 2.26.1
10139N/A* Mon Mar 16 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.26.0
10139N/A- Remove patch -01-disable-im, upstreamed.
10139N/A- Add patch 01-not-check-asn1parser to disable checking
10139N/A asn1parser since it is not shipped by libtasn1 due to
10139N/A GPLv3 issue.
10139N/A* Tue Mar 03 2009 - jeff.cai@sun.com
10139N/A- Add patch -02-ssh-agent, if one slot is correct, not
10139N/A return error. Fix #572527
10139N/A* Tue Mar 03 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.92
10139N/A- Remove -02-secure-memory-union, upstreamed.
10139N/A* Thu Feb 19 2009 - jeff.cai@sun.com
10139N/A- Remove /usr/bin/gnome-keyring since it is only a tool
10139N/A and not complete yet.
10139N/A* Mon Feb 16 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.91
10139N/A- Add patch -02-secure-memory-union to fix uname union,
10139N/A Fix bugzilla #571951
10139N/A* Fri Feb 13 2009 - jeff.cai@sun.com
10139N/A- Change the owner to jeff cai.
10139N/A* Wed Feb 04 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.90
10139N/A* Wed Jan 20 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.5
10139N/A- Remove patch -02-return-void, upstreamed
10139N/A* Wed Jan 09 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.4.2
10139N/A- Add patch -02-return-void, fix #567121.
10139N/A* Fri Dec 12 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.25.2
10139N/A- Remove patch -02-hal-error.diff, upstreamed
10139N/A- Remove patch -03-libtasn1.diff, upstreamed
10139N/A* Mon Dec 08 2008 - jeff.cai@sun.com
10139N/A- Add patch -03-libtasn to get building flag with pkg-config
10139N/A Fix #563702
10139N/A* Fri Nov 28 2008 - jeff.cai@sun.com
10139N/A- Add patch -02-hal-error.diff to not print null string in printf.
10139N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
10139N/A- Add gnome-keyring-01-disable-im.diff to disable input method in password.
10139N/A* Tue Nov 07 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.25.1
10139N/A* Tue Nov 04 2008 - halton.huo@sun.com
10139N/A- Bump to 2.24.1
10139N/A- Remove upstreamed patch logout.diff
10139N/A* Fri Oct 31 2008 - jeff.cai@sun.com
10139N/A- Change the license tag.
10139N/A* Wed Oct 15 2008 - jeff.cai@sun.com
10139N/A- Add bugzilla bug id for -01-logout patch.
10139N/A* Mon Sep 22 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.24.0
10139N/A* Tue Sep 09 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.23.92
10139N/A- Remove patch 02-timegm.diff
10139N/A* Fri Sep 05 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.23.91
10139N/A- Add patch -02-timegm.diff
10139N/A* Mon Aug 26 2008 - jeff.cai@sun.com
10139N/A- Change the bug comment.
10139N/A* Mon Aug 19 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.23.90
10139N/A
10139N/A* Mon Aug 18 2008 - jeff.cai@sun.com
10139N/A- Remove gnome-keyring-pkcs11.la
10139N/A
10139N/A* Tue Aug 05 2008 - jeff.cai@sun.com
10139N/A- Add patch -01-logout.diff
10139N/A Fix bugster 6732147.
10139N/A
10139N/A* Tue Aug 05 2008 - jeff.cai@sun.com
12104N/A- Bump to 2.23.6.
12104N/A
11981N/A* Tue Jul 22 2008 - damien.carbery@sun.com
11981N/A- Bump to 2.23.5.
11878N/A
11878N/A* Wed Jun 18 2008 - jeff.cai@sun.com
11855N/A- Bump to 2.22.2. Remove -01-strsep, -02-gulong2gsize
11855N/A
11438N/A* Wed Apr 16 2008 - damien.carbery@sun.com
11438N/A- Add 'make check' call after %install.
11419N/A
11419N/A* Thu Feb 14 2008 - damien.carbery@sun.com
11419N/A- Add patch 02-gulong2gsize to sync with changes in glib 2.15.5. Also modify
11252N/A CFLAGS to find a glib header.
11252N/A
11115N/A* Wed Jan 30 2008 - damien.carbery@sun.com
11115N/A- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.
11070N/A
11070N/A* Tue Jan 29 2008 - patrick.ale@gmail.com
10986N/A- Fix typo in download URL
10986N/A
10981N/A* Tue Jan 29 2008 - damien.carbery@sun.com
10981N/A- Bump to 2.21.90.
10921N/A
10921N/A* Sun Jan 20 2008 - patrick.ale@gmail.com
10821N/A- Version unbumped to 2.20 by damien but download directory
10821N/A was still 2.21. Fixed by changing to /pub/SOURCES/2.20
10746N/A
10746N/A* Fri Jan 18 2008 - damien.carbery@sun.com
10637N/A- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.
10637N/A
10454N/A* Thu Jan 17 2008 - damien.carbery@sun.com
10454N/A- Bump to 2.21.5.
10264N/A
10264N/A* Mon Jan 07 2008 - damien.carbery@sun.com
10176N/A- Bump to 2.20.3.
10176N/A
10139N/A* Wed Dec 19 2007 - patrick.ale@gmail.com
10139N/A- Version unbumped to 2.20 by damien but download directory
10139N/A was still 2.21. Fixed by changing to /pub/SOURCES/2.20
10139N/A
10139N/A* Tue Dec 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.4.
10139N/A
10139N/A* Tue Nov 27 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.2.
10139N/A
10139N/A* Fri Oct 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.1. Remove upstream patch, 02-new-keyring-bug.
10139N/A
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.0. Remove upstream patch, 02-export-symbols. Renumber rest.
10139N/A
10139N/A* Thu Sep 13 2007 - darren.kenny@sun.com
10139N/A- Added patch for bugzilla bug: 476644, which presents issues when creating a
10139N/A new keyring where non existed before : gnome-keyring-03-new-keyring-bug.diff
10139N/A
10139N/A* Wed Sep 05 2007 - halton.huo@sun.com
10139N/A- Bump to 2.19.91.
10139N/A- Add patch 02-export-symbols for bugzilla #473796
10139N/A- Remove upstream patches, XX-err_to_g_error and XX-string_header
10139N/A
10139N/A* Thu Aug 16 2007 - damien.carbery@sun.com
10139N/A- Unbump to 2.19.6.1 because of build error I cannot figure out.
10139N/A
10139N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.90. Remove upstream patches, 01-err_to_g_error and
10139N/A 02-string_header.
10139N/A
10139N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10139N/A- Add 3 patches, 01-err_to_g_error, 02-string_header and 03-strsep to fix
10139N/A Solaris specific build issues.
10139N/A
10139N/A* Tue Jul 31 2007 - halton.huo@sun.com
10139N/A- Bump to 2.19.6.1.
10139N/A
10139N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.6. Remove upstream patch, 01-suncc-build-fail.
10139N/A
10139N/A* Mon Jul 09 2007 - halton.huo@sun.com
10139N/A- Bump to 2.19.5.
10139N/A- Add patch suncc-build-fail.diff to let build pass.
10139N/A
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.4.1.
10139N/A
10139N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.4.
10139N/A
10139N/A* Tue May 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.2. Remove unneeded patch, 01-pkcs. gnome-keyring uses libgcrypt
10139N/A now.
10139N/A
10139N/A* Sun Apr 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.8.1. Remove upstream patch, 02-crash.
10139N/A
10139N/A* Tue Mar 27 2007 - halton.huo@sun.com
10139N/A- Add patch crash.diff.
10139N/A
10139N/A* Mon Mar 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.8.
10139N/A
10139N/A* Tue Mar 06 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.7.92.
10139N/A
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.7.91.
10139N/A
10139N/A* Fri Jan 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.7.3.
10139N/A
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.7.2.
10139N/A
10139N/A* Wed Dec 06 2006 - takao.fujiwara@sun.com
10139N/A- Add intltoolize to read LIGUAS file. Fixes 6498950
10139N/A
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.6.0.
10139N/A
10139N/A* Fri Jul 20 2006 - padraig.obriain@sun.com
10139N/A- Bump to 0.5.1.
10139N/A
10139N/A* Tue May 02 2006 - damien.carbery@sun.com
10139N/A- Remove unneeded intltoolize call.
10139N/A
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.9.
10139N/A
10139N/A* Tue Feb 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.8.
10139N/A
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.7.
10139N/A- Add hack to fix infinite loop problem in po/Makefile.
10139N/A
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.4.6.
10139N/A
10139N/A* Thu Sep 15 2005 - brian.cameron@sun.com
10139N/A- Bump to 0.4.5.
10139N/A
10139N/A* Fri Sep 09 2005 - laca@sun.com
10139N/A- call intltoolize so that the correct Makefile.in.in is copied to po
10139N/A
10139N/A* Tue Sep 06 2005 - damien.carbery@sun.com
10139N/A- Call glib-gettextize as po/Makefile.in.in not in tarball. Add patch to
10139N/A skip the 'ar' locale as its files has problems #315335.
10139N/A
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.4.4.
10139N/A
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.4.3.
10139N/A
10139N/A* Wed Jun 15 2005 - laca@sun.com
10139N/A- Add more libs to LDADD so that it builds with the new pkgconfig
10139N/A
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 0.4.2
10139N/A
10139N/A* Fri Aug 29 2004 - brian.cameron@sun.com
10139N/A- Added patch 01 for pkcs support.
10139N/A
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- removed --disable-gtk-doc since this isn't an option this module's
10139N/A configure takes.
10139N/A
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-keyring-l10n-po-1.2.tar.bz2
10139N/A
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-keyring-l10n-po-1.1.tar.bz2
10139N/A
10139N/A* Tue Apr 13 2004 - laszlo.kovacs@sun.com
10139N/A- upgraded tarball
10139N/A* Wed Mar 31 2004 - brian.cameron@sun.com
10139N/A- replace tar jxf with the more solaris friendly
10139N/A bzcat piped through tar
10139N/A
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Adding gnome-keyring-l10n-po-1.0.tar.bz2 l10n content
10139N/A
10139N/A* Fri Mar 19 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.1.91 and remove the uninstalled pc patch
10139N/A since it's upstream.
10139N/A
10139N/A* Fri Mar 12 2004 - niall.power@sun.com
10139N/A- define libexecdir in configure args
10139N/A
10139N/A* Mon Feb 02 2004 - niall.power@sun.com
10139N/A- bump to 0.1.2
10139N/A- Add patch to generate an -uninstalled.pc file
10139N/A- Add ACLOCAL_FLAGS env to aclocal invocation
10139N/A
10139N/A* Mon Dec 15 2003 - glynn.foster@sun.com
10139N/A- Initial Sun release
10139N/A