gnome-keyring.spec revision 16480
18970N/A#
18970N/A# spec file for package gnome-keyring
18970N/A#
18970N/A# Copyright 2009 Sun Microsystems, Inc.
18970N/A# This file and all modifications and additions to the pristine
18970N/A# package are under the same license as the package itself.
18970N/A#
18970N/A# Owner: jefftsai
18970N/A#
18970N/AName: gnome-keyring
18970N/ALicense: GPL v2, LGPL v2
18970N/AGroup: System/GUI/GNOME
18970N/AVersion: 2.26.1
18970N/ARelease: 4
18970N/ADistribution: Java Desktop System
18970N/AVendor: Sun Microsystems, Inc.
18970N/AURL: http://www.gnome.org
18970N/ASummary: GNOME Key Ring
18970N/ASource: http://download.gnome.org/sources/%{name}/2.26/%{name}-%{version}.tar.bz2
18970N/A%if %build_l10n
18970N/ASource1: l10n-configure.sh
18970N/A%endif
18970N/A# date:2009-03-03 owner:jefftsai type:branding
18970N/APatch1: gnome-keyring-01-not-check-asn1parser.diff
18970N/A# date:2009-03-03 owner:jefftsai type:bug bugzilla:572527
18970N/APatch2: gnome-keyring-02-ssh-agent.diff
18970N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18970N/AAutoreqprov: on
18970N/APrereq: /sbin/ldconfig
18970N/A
18970N/A%define gtk2_version 2.4.0
18970N/A%define pkgconfig_version 0.15.0
18970N/A%define gtk_doc_version 1.1
18970N/A
18970N/ARequires: gtk2 >= %{gtk2_version}
18970N/ABuildRequires: gtk2-devel >= %{gtk2_version}
18970N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
18970N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
18970N/A
18970N/A%description
18970N/Agnome-keyring is a program that keep password and other secrets for
18970N/Ausers. It is run as a daemon in the session, similar to ssh-agent, and
18970N/Aother applications can locate it by an environment variable.
18970N/A
18970N/AThe program can manage several keyrings, each with its own master
18970N/Apassword, and there is also a session keyring which is never stored to
18970N/Adisk, but forgotten when the session ends.
18970N/A
18970N/AThe library libgnome-keyring is used by applications to integrate with
18970N/Athe gnome keyring system.
18970N/A
18970N/A%package devel
18970N/ASummary: GNOME Key Ring Library
18970N/AGroup: Development/Libraries/GNOME
18970N/ARequires: %{name} = %{version}
18970N/ARequires: gtk2-devel >= %{gtk2_version}
18970N/A
18970N/A%description devel
18970N/Agnome-keyring is a program that keep password and other secrets for
18970N/Ausers. It is run as a daemon in the session, similar to ssh-agent, and
18970N/Aother applications can locate it by an environment variable.
18970N/A
18970N/AThe program can manage several keyrings, each with its own master
18970N/Apassword, and there is also a session keyring which is never stored to
18970N/Adisk, but forgotten when the session ends.
18970N/A
18970N/AThe library libgnome-keyring is used by applications to integrate with
18970N/Athe gnome keyring system.
18970N/A
18970N/A%prep
18970N/A%setup -q
18970N/A%patch1 -p1
18970N/A%patch2 -p1
18970N/A
18970N/A%build
18970N/A%ifos linux
18970N/Aif [ -x /usr/bin/getconf ]; then
18970N/A CPUS=`getconf _NPROCESSORS_ONLN`
18970N/Afi
18970N/A%else
18970N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18970N/A%endif
18970N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18970N/A CPUS=1
18970N/Afi
18970N/A
18970N/Alibtoolize --force
18970N/Aintltoolize -f -c --automake
18970N/A
18970N/A%if %build_l10n
18970N/Abash -x %SOURCE1 --enable-copyright
18970N/A%endif
18970N/A
18970N/Aaclocal $ACLOCAL_FLAGS -I .
18970N/Aautoconf
18970N/Aautoheader
18970N/Aautomake -a -c -f
18970N/A
18970N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
18970N/A./configure --prefix=%{_prefix} \
18970N/A --sysconfdir=%{_sysconfdir} \
18970N/A --mandir=%{_mandir} \
18970N/A --disable-pam \
18970N/A --libexecdir=%{_libexecdir}
18970N/A
18970N/A# FIXME: hack: stop the build from looping
18970N/Atouch po/stamp-it
18970N/A
18970N/Amake -j $CPUS
18970N/A
18970N/A%install
18970N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18970N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
18970N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
18970N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
18970N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
18970N/Arm $RPM_BUILD_ROOT%{_bindir}/gnome-keyring
18970N/A
18970N/A#%check
18970N/Amake check
18970N/A
18970N/A%clean
18970N/Arm -rf $RPM_BUILD_ROOT
18970N/A
18970N/A%post
18970N/A/sbin/ldconfig
18970N/A
18970N/A%postun
18970N/A/sbin/ldconfig
18970N/A
18970N/A%files
18970N/A%{_datadir}/locale/*/LC_MESSAGES/*
18970N/A%{_bindir}/*
18970N/A%{_libdir}/lib*.so.*
18970N/A%{_libexecdir}/gnome-keyring-ask
18970N/A
18970N/A%files devel
18970N/A%{_libdir}/pkgconfig/*.pc
18970N/A%{_includedir}/gnome-keyring-1/*
18970N/A%{_libdir}/lib*.so
18970N/A
18970N/A%changelog
18970N/A* Tue Apr 14 2009 - halton.huo@sun.com
18970N/A- Bump to 2.26.1
18970N/A* Mon Mar 16 2009 - jeff.cai@sun.com
18970N/A- Bump to 2.26.0
18970N/A- Remove patch -01-disable-im, upstreamed.
18970N/A- Add patch 01-not-check-asn1parser to disable checking
18970N/A asn1parser since it is not shipped by libtasn1 due to
18970N/A GPLv3 issue.
18970N/A* Tue Mar 03 2009 - jeff.cai@sun.com
18970N/A- Add patch -02-ssh-agent, if one slot is correct, not
18970N/A return error. Fix #572527
18970N/A* Tue Mar 03 2009 - jeff.cai@sun.com
18970N/A- Bump to 2.25.92
18970N/A- Remove -02-secure-memory-union, upstreamed.
18970N/A* Thu Feb 19 2009 - jeff.cai@sun.com
18970N/A- Remove /usr/bin/gnome-keyring since it is only a tool
18970N/A and not complete yet.
18970N/A* Mon Feb 16 2009 - jeff.cai@sun.com
18970N/A- Bump to 2.25.91
18970N/A- Add patch -02-secure-memory-union to fix uname union,
18970N/A Fix bugzilla #571951
18970N/A* Fri Feb 13 2009 - jeff.cai@sun.com
18970N/A- Change the owner to jeff cai.
18970N/A* Wed Feb 04 2009 - jeff.cai@sun.com
18970N/A- Bump to 2.25.90
18970N/A* Wed Jan 20 2009 - jeff.cai@sun.com
18970N/A- Bump to 2.25.5
18970N/A- Remove patch -02-return-void, upstreamed
18970N/A* Wed Jan 09 2009 - jeff.cai@sun.com
18970N/A- Bump to 2.25.4.2
18970N/A- Add patch -02-return-void, fix #567121.
18970N/A* Fri Dec 12 2008 - jeff.cai@sun.com
18970N/A- Bump to 2.25.2
18970N/A- Remove patch -02-hal-error.diff, upstreamed
18970N/A- Remove patch -03-libtasn1.diff, upstreamed
18970N/A* Mon Dec 08 2008 - jeff.cai@sun.com
18970N/A- Add patch -03-libtasn to get building flag with pkg-config
18970N/A Fix #563702
18970N/A* Fri Nov 28 2008 - jeff.cai@sun.com
18970N/A- Add patch -02-hal-error.diff to not print null string in printf.
18970N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
18970N/A- Add gnome-keyring-01-disable-im.diff to disable input method in password.
18970N/A* Tue Nov 07 2008 - jeff.cai@sun.com
18970N/A- Bump to 2.25.1
18970N/A* Tue Nov 04 2008 - halton.huo@sun.com
18970N/A- Bump to 2.24.1
18970N/A- Remove upstreamed patch logout.diff
18970N/A* Fri Oct 31 2008 - jeff.cai@sun.com
18970N/A- Change the license tag.
18970N/A* Wed Oct 15 2008 - jeff.cai@sun.com
18970N/A- Add bugzilla bug id for -01-logout patch.
* Mon Sep 22 2008 - jeff.cai@sun.com
- Bump to 2.24.0
* Tue Sep 09 2008 - jeff.cai@sun.com
- Bump to 2.23.92
- Remove patch 02-timegm.diff
* Fri Sep 05 2008 - jeff.cai@sun.com
- Bump to 2.23.91
- Add patch -02-timegm.diff
* Mon Aug 26 2008 - jeff.cai@sun.com
- Change the bug comment.
* Mon Aug 19 2008 - jeff.cai@sun.com
- Bump to 2.23.90
* Mon Aug 18 2008 - jeff.cai@sun.com
- Remove gnome-keyring-pkcs11.la
* Tue Aug 05 2008 - jeff.cai@sun.com
- Add patch -01-logout.diff
Fix bugster 6732147.
* Tue Aug 05 2008 - jeff.cai@sun.com
- Bump to 2.23.6.
* Tue Jul 22 2008 - damien.carbery@sun.com
- Bump to 2.23.5.
* Wed Jun 18 2008 - jeff.cai@sun.com
- Bump to 2.22.2. Remove -01-strsep, -02-gulong2gsize
* Wed Apr 16 2008 - damien.carbery@sun.com
- Add 'make check' call after %install.
* Thu Feb 14 2008 - damien.carbery@sun.com
- Add patch 02-gulong2gsize to sync with changes in glib 2.15.5. Also modify
CFLAGS to find a glib header.
* Wed Jan 30 2008 - damien.carbery@sun.com
- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.
* Tue Jan 29 2008 - patrick.ale@gmail.com
- Fix typo in download URL
* Tue Jan 29 2008 - damien.carbery@sun.com
- Bump to 2.21.90.
* Sun Jan 20 2008 - patrick.ale@gmail.com
- Version unbumped to 2.20 by damien but download directory
was still 2.21. Fixed by changing to /pub/SOURCES/2.20
* Fri Jan 18 2008 - damien.carbery@sun.com
- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.
* Thu Jan 17 2008 - damien.carbery@sun.com
- Bump to 2.21.5.
* Mon Jan 07 2008 - damien.carbery@sun.com
- Bump to 2.20.3.
* Wed Dec 19 2007 - patrick.ale@gmail.com
- Version unbumped to 2.20 by damien but download directory
was still 2.21. Fixed by changing to /pub/SOURCES/2.20
* Tue Dec 18 2007 - damien.carbery@sun.com
- Bump to 2.21.4.
* Tue Nov 27 2007 - damien.carbery@sun.com
- Bump to 2.20.2.
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 2.20.1. Remove upstream patch, 02-new-keyring-bug.
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 2.20.0. Remove upstream patch, 02-export-symbols. Renumber rest.
* Thu Sep 13 2007 - darren.kenny@sun.com
- Added patch for bugzilla bug: 476644, which presents issues when creating a
new keyring where non existed before : gnome-keyring-03-new-keyring-bug.diff
* Wed Sep 05 2007 - halton.huo@sun.com
- Bump to 2.19.91.
- Add patch 02-export-symbols for bugzilla #473796
- Remove upstream patches, XX-err_to_g_error and XX-string_header
* Thu Aug 16 2007 - damien.carbery@sun.com
- Unbump to 2.19.6.1 because of build error I cannot figure out.
* Wed Aug 15 2007 - damien.carbery@sun.com
- Bump to 2.19.90. Remove upstream patches, 01-err_to_g_error and
02-string_header.
* Mon Jul 30 2007 - damien.carbery@sun.com
- Add 3 patches, 01-err_to_g_error, 02-string_header and 03-strsep to fix
Solaris specific build issues.
* Tue Jul 31 2007 - halton.huo@sun.com
- Bump to 2.19.6.1.
* Mon Jul 30 2007 - damien.carbery@sun.com
- Bump to 2.19.6. Remove upstream patch, 01-suncc-build-fail.
* Mon Jul 09 2007 - halton.huo@sun.com
- Bump to 2.19.5.
- Add patch suncc-build-fail.diff to let build pass.
* Tue Jun 19 2007 - damien.carbery@sun.com
- Bump to 2.19.4.1.
* Mon Jun 18 2007 - damien.carbery@sun.com
- Bump to 2.19.4.
* Tue May 15 2007 - damien.carbery@sun.com
- Bump to 2.19.2. Remove unneeded patch, 01-pkcs. gnome-keyring uses libgcrypt
now.
* Sun Apr 08 2007 - damien.carbery@sun.com
- Bump to 0.8.1. Remove upstream patch, 02-crash.
* Tue Mar 27 2007 - halton.huo@sun.com
- Add patch crash.diff.
* Mon Mar 12 2007 - damien.carbery@sun.com
- Bump to 0.8.
* Tue Mar 06 2007 - damien.carbery@sun.com
- Bump to 0.7.92.
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 0.7.91.
* Fri Jan 05 2007 - damien.carbery@sun.com
- Bump to 0.7.3.
* Tue Dec 19 2006 - damien.carbery@sun.com
- Bump to 0.7.2.
* Wed Dec 06 2006 - takao.fujiwara@sun.com
- Add intltoolize to read LIGUAS file. Fixes 6498950
* Mon Sep 04 2006 - damien.carbery@sun.com
- Bump to 0.6.0.
* Fri Jul 20 2006 - padraig.obriain@sun.com
- Bump to 0.5.1.
* Tue May 02 2006 - damien.carbery@sun.com
- Remove unneeded intltoolize call.
* Mon Mar 13 2006 - damien.carbery@sun.com
- Bump to 0.4.9.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 0.4.8.
* Mon Feb 13 2006 - damien.carbery@sun.com
- Bump to 0.4.7.
- Add hack to fix infinite loop problem in po/Makefile.
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 0.4.6.
* Thu Sep 15 2005 - brian.cameron@sun.com
- Bump to 0.4.5.
* Fri Sep 09 2005 - laca@sun.com
- call intltoolize so that the correct Makefile.in.in is copied to po
* Tue Sep 06 2005 - damien.carbery@sun.com
- Call glib-gettextize as po/Makefile.in.in not in tarball. Add patch to
skip the 'ar' locale as its files has problems #315335.
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 0.4.4.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 0.4.3.
* Wed Jun 15 2005 - laca@sun.com
- Add more libs to LDADD so that it builds with the new pkgconfig
* Fri May 06 2005 - glynn.foster@sun.com
- Bump to 0.4.2
* Fri Aug 29 2004 - brian.cameron@sun.com
- Added patch 01 for pkcs support.
* Wed Aug 18 2004 - brian.cameron@sun.com
- removed --disable-gtk-doc since this isn't an option this module's
configure takes.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-keyring-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-keyring-l10n-po-1.1.tar.bz2
* Tue Apr 13 2004 - laszlo.kovacs@sun.com
- upgraded tarball
* Wed Mar 31 2004 - brian.cameron@sun.com
- replace tar jxf with the more solaris friendly
bzcat piped through tar
* Mon Mar 29 2004 - damien.donlon@sun.com
- Adding gnome-keyring-l10n-po-1.0.tar.bz2 l10n content
* Fri Mar 19 2004 - glynn.foster@sun.com
- Bump to 0.1.91 and remove the uninstalled pc patch
since it's upstream.
* Fri Mar 12 2004 - niall.power@sun.com
- define libexecdir in configure args
* Mon Feb 02 2004 - niall.power@sun.com
- bump to 0.1.2
- Add patch to generate an -uninstalled.pc file
- Add ACLOCAL_FLAGS env to aclocal invocation
* Mon Dec 15 2003 - glynn.foster@sun.com
- Initial Sun release