10139N/A#
10139N/A# spec file for package gnome-keyring
10139N/A#
16362N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner jefftsai
10139N/A#
17178N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17178N/A
10139N/AName: gnome-keyring
15291N/ALicense: GPL v2, LGPL v2
10139N/AGroup: System/GUI/GNOME
18910N/AVersion: 2.30.3
10139N/ARelease: 4
10139N/ADistribution: Java Desktop System
18615N/AVendor: Gnome Community
15298N/AURL: http://www.gnome.org
18185N/ASummary: GNOME Keyring
18536N/ASource: http://download.gnome.org/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
12773N/A%if %build_l10n
15298N/ASource1: l10n-configure.sh
12773N/A%endif
16480N/A# date:2009-03-03 owner:jefftsai type:bug bugzilla:572527
18269N/APatch1: gnome-keyring-01-ssh-agent.diff
20364N/A# date:2011-06-14 owner:jefftsai type:bug bugster:7052843
20364N/APatch2: gnome-keyring-02-remove-prompt.diff
20369N/A# date:2011-06-15 owner:jefftsai type:bug bugster:6772733 bugzilla:561331
20369N/APatch3: gnome-keyring-03-disable-im.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
10139N/A%define gtk_doc_version 1.1
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
10139N/A%description
10139N/Agnome-keyring is a program that keep password and other secrets for
10139N/Ausers. It is run as a daemon in the session, similar to ssh-agent, and
10139N/Aother applications can locate it by an environment variable.
10139N/A
10139N/AThe program can manage several keyrings, each with its own master
10139N/Apassword, and there is also a session keyring which is never stored to
10139N/Adisk, but forgotten when the session ends.
10139N/A
10139N/AThe library libgnome-keyring is used by applications to integrate with
10139N/Athe gnome keyring system.
10139N/A
10139N/A%package devel
10139N/ASummary: GNOME Key Ring Library
10139N/AGroup: Development/Libraries/GNOME
10139N/ARequires: %{name} = %{version}
10139N/ARequires: gtk2-devel >= %{gtk2_version}
10139N/A
10139N/A%description devel
10139N/Agnome-keyring is a program that keep password and other secrets for
10139N/Ausers. It is run as a daemon in the session, similar to ssh-agent, and
10139N/Aother applications can locate it by an environment variable.
10139N/A
10139N/AThe program can manage several keyrings, each with its own master
10139N/Apassword, and there is also a session keyring which is never stored to
10139N/Adisk, but forgotten when the session ends.
10139N/A
10139N/AThe library libgnome-keyring is used by applications to integrate with
10139N/Athe gnome keyring system.
10139N/A
10139N/A%prep
10139N/A%setup -q
15370N/A%patch1 -p1
20364N/A%patch2 -p1
20369N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE1 --enable-copyright
12773N/A%endif
12773N/A
18646N/Aexport LDFLAGS="%{_ldflags} -ltasn1"
10139N/A
17297N/ACFLAGS="$RPM_OPT_FLAGS -D_POSIX_PTHREAD_SEMANTICS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
11204N/A --disable-pam \
10139N/A --libexecdir=%{_libexecdir}
10139N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/Atouch po/stamp-it
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
15298N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
15298N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
15298N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
15298N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
15298N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
15909N/Arm $RPM_BUILD_ROOT%{_bindir}/gnome-keyring
10139N/A
12889N/A#%check
12889N/Amake check
12889N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*
10139N/A%{_bindir}/*
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_libexecdir}/gnome-keyring-ask
10139N/A
10139N/A%files devel
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_includedir}/gnome-keyring-1/*
10139N/A%{_libdir}/lib*.so
10139N/A
10139N/A%changelog
20369N/A* Jun 15 2011 - jeff.cai@oracle.com
20369N/A- Add patch -03-disable-im to fix bug bugster 6772733, bugzilla 561331
20364N/A* Jun 14 2011 - jeff.cai@Oracle.com
20364N/A- Add patch -02-remove-prompt to fix bug 7052843
20364N/A remove unnessary prompts to console
18910N/A* Jun 22 2010 - jeff.cai@sun.com
18910N/A- Bump to 2.30.3
18910N/A- Upstream the patch -02-unlock
18758N/A* May 20 2010 - jeff.cai@sun.com
18758N/A- Add patch -02-unlock to fix doo #15962, gnome #616071
18685N/A* Mon Apr 26 2010 - christian.kelly@oracle.com
18685N/A- Bump to 2.30.1.
18646N/A* Wed Apr 21 2010 - christian.kelly@oracle.com
18646N/A- Re-work %build section.
18536N/A* Mar 31 2010 - jeff.cai@sun.com
18536N/A- Bump to 2.30.0
18442N/A* Mar 12 2010 - jeff.cai@sun.com
18442N/A- Bump to 2.29.92
18269N/A* Feb 09 2010 - jeff.cai@sun.com
18269N/A- Bump to 2.29.90
18269N/A- Upstream patch -01-disable-eggdbus.diff
18269N/A- Rework patch -02-return-void.diff
18269N/A- Upstream patch -04-wait.diff
18185N/A* Jan 26 2010 - jeff.cai@sun.com
18185N/A- Bump to 2.29.5
18185N/A- Add patch -03-return-void to fix
18185N/A- Add patch -04-wait to fix
18185N/A- Add patch -01-disable-eggdbus
18185N/A- Remove patch -01-not-check-asn1parser libtasn1 shipped asn1Parser
18185N/A
18185N/A* Dec 28 2009 - jeff.cai@sun.com
18185N/A- Bump to 2.29.4
17554N/A* Oct 20 2009 - jeff.cai@sun.com
17554N/A- Bump to 2.28.1
17358N/A* Sep 22 2009 - jeff.cai@sun.com
17358N/A- Bump to 2.28.0
17297N/A* Sep 14 2009 - jeff.cai@sun.com
17297N/A- Bump to 2.27.92
17297N/A- Upstream path -03-timer-shutdown
16980N/A* Tue Aug 11 2009 - jeff.cai@sun.com
16982N/A- Add patch -03-timer-shutdown, fix bugzilla #591415 doo #10488
16982N/A Not join timer thread since it might already ends.
16982N/A* Tue Aug 11 2009 - jeff.cai@sun.com
16980N/A- Bump to 2.27.90.
16899N/A* Tue Jul 28 2009 - christian.kelly@sun.com
16899N/A- Bump to 2.27.5.
16769N/A* Tue Jul 14 2009 - jeff.cai@sun.com
16769N/A- Bump to 2.27.4
16362N/A* Tue Apr 14 2009 - halton.huo@sun.com
16362N/A- Bump to 2.26.1
16146N/A* Mon Mar 16 2009 - jeff.cai@sun.com
16146N/A- Bump to 2.26.0
16146N/A- Remove patch -01-disable-im, upstreamed.
16146N/A- Add patch 01-not-check-asn1parser to disable checking
16146N/A asn1parser since it is not shipped by libtasn1 due to
16146N/A GPLv3 issue.
16026N/A* Tue Mar 03 2009 - jeff.cai@sun.com
16034N/A- Add patch -02-ssh-agent, if one slot is correct, not
16034N/A return error. Fix #572527
16034N/A* Tue Mar 03 2009 - jeff.cai@sun.com
16026N/A- Bump to 2.25.92
16026N/A- Remove -02-secure-memory-union, upstreamed.
15909N/A* Thu Feb 19 2009 - jeff.cai@sun.com
15909N/A- Remove /usr/bin/gnome-keyring since it is only a tool
15909N/A and not complete yet.
15837N/A* Mon Feb 16 2009 - jeff.cai@sun.com
15837N/A- Bump to 2.25.91
15837N/A- Add patch -02-secure-memory-union to fix uname union,
15837N/A Fix bugzilla #571951
15830N/A* Fri Feb 13 2009 - jeff.cai@sun.com
15830N/A- Change the owner to jeff cai.
15759N/A* Wed Feb 04 2009 - jeff.cai@sun.com
15759N/A- Bump to 2.25.90
15692N/A* Wed Jan 20 2009 - jeff.cai@sun.com
15692N/A- Bump to 2.25.5
15692N/A- Remove patch -02-return-void, upstreamed
15637N/A* Wed Jan 09 2009 - jeff.cai@sun.com
15637N/A- Bump to 2.25.4.2
15637N/A- Add patch -02-return-void, fix #567121.
15515N/A* Fri Dec 12 2008 - jeff.cai@sun.com
15515N/A- Bump to 2.25.2
15515N/A- Remove patch -02-hal-error.diff, upstreamed
15515N/A- Remove patch -03-libtasn1.diff, upstreamed
15478N/A* Mon Dec 08 2008 - jeff.cai@sun.com
15478N/A- Add patch -03-libtasn to get building flag with pkg-config
15478N/A Fix #563702
15424N/A* Fri Nov 28 2008 - jeff.cai@sun.com
15424N/A- Add patch -02-hal-error.diff to not print null string in printf.
15370N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
15370N/A- Add gnome-keyring-01-disable-im.diff to disable input method in password.
15319N/A* Tue Nov 07 2008 - jeff.cai@sun.com
15319N/A- Bump to 2.25.1
15298N/A* Tue Nov 04 2008 - halton.huo@sun.com
15298N/A- Bump to 2.24.1
15298N/A- Remove upstreamed patch logout.diff
15291N/A* Fri Oct 31 2008 - jeff.cai@sun.com
15291N/A- Change the license tag.
15219N/A* Wed Oct 15 2008 - jeff.cai@sun.com
15219N/A- Add bugzilla bug id for -01-logout patch.
14457N/A* Mon Sep 22 2008 - jeff.cai@sun.com
14457N/A- Bump to 2.24.0
14185N/A* Tue Sep 09 2008 - jeff.cai@sun.com
14185N/A- Bump to 2.23.92
14188N/A- Remove patch 02-timegm.diff
14163N/A* Fri Sep 05 2008 - jeff.cai@sun.com
14163N/A- Bump to 2.23.91
14163N/A- Add patch -02-timegm.diff
14015N/A* Mon Aug 26 2008 - jeff.cai@sun.com
14015N/A- Change the bug comment.
13908N/A* Mon Aug 19 2008 - jeff.cai@sun.com
13908N/A- Bump to 2.23.90
13908N/A
13889N/A* Mon Aug 18 2008 - jeff.cai@sun.com
13889N/A- Remove gnome-keyring-pkcs11.la
13889N/A
13758N/A* Tue Aug 05 2008 - jeff.cai@sun.com
13767N/A- Add patch -01-logout.diff
13767N/A Fix bugster 6732147.
13767N/A
13767N/A* Tue Aug 05 2008 - jeff.cai@sun.com
13758N/A- Bump to 2.23.6.
13758N/A
13624N/A* Tue Jul 22 2008 - damien.carbery@sun.com
13624N/A- Bump to 2.23.5.
13624N/A
13439N/A* Wed Jun 18 2008 - jeff.cai@sun.com
13439N/A- Bump to 2.22.2. Remove -01-strsep, -02-gulong2gsize
13624N/A
12889N/A* Wed Apr 16 2008 - damien.carbery@sun.com
12889N/A- Add 'make check' call after %install.
13624N/A
12379N/A* Thu Feb 14 2008 - damien.carbery@sun.com
12379N/A- Add patch 02-gulong2gsize to sync with changes in glib 2.15.5. Also modify
12379N/A CFLAGS to find a glib header.
12379N/A
12303N/A* Wed Jan 30 2008 - damien.carbery@sun.com
12303N/A- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.
12303N/A
12294N/A* Tue Jan 29 2008 - patrick.ale@gmail.com
12294N/A- Fix typo in download URL
12303N/A
12288N/A* Tue Jan 29 2008 - damien.carbery@sun.com
12288N/A- Bump to 2.21.90.
12288N/A
12231N/A* Sun Jan 20 2008 - patrick.ale@gmail.com
12231N/A- Version unbumped to 2.20 by damien but download directory
12231N/A was still 2.21. Fixed by changing to /pub/SOURCES/2.20
12288N/A
12229N/A* Fri Jan 18 2008 - damien.carbery@sun.com
12229N/A- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.
12229N/A
12219N/A* Thu Jan 17 2008 - damien.carbery@sun.com
12219N/A- Bump to 2.21.5.
12219N/A
12219N/A* Mon Jan 07 2008 - damien.carbery@sun.com
12147N/A- Bump to 2.20.3.
12147N/A
12082N/A* Wed Dec 19 2007 - patrick.ale@gmail.com
12082N/A- Version unbumped to 2.20 by damien but download directory
12082N/A was still 2.21. Fixed by changing to /pub/SOURCES/2.20
12147N/A
12071N/A* Tue Dec 18 2007 - damien.carbery@sun.com
12071N/A- Bump to 2.21.4.
12071N/A
11989N/A* Tue Nov 27 2007 - damien.carbery@sun.com
11989N/A- Bump to 2.20.2.
11989N/A
11416N/A* Fri Oct 19 2007 - damien.carbery@sun.com
11417N/A- Bump to 2.20.1. Remove upstream patch, 02-new-keyring-bug.
11416N/A
11257N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11257N/A- Bump to 2.20.0. Remove upstream patch, 02-export-symbols. Renumber rest.
11257N/A
11234N/A* Thu Sep 13 2007 - darren.kenny@sun.com
11234N/A- Added patch for bugzilla bug: 476644, which presents issues when creating a
11234N/A new keyring where non existed before : gnome-keyring-03-new-keyring-bug.diff
11257N/A
11191N/A* Wed Sep 05 2007 - halton.huo@sun.com
11191N/A- Bump to 2.19.91.
11191N/A- Add patch 02-export-symbols for bugzilla #473796
11191N/A- Remove upstream patches, XX-err_to_g_error and XX-string_header
11191N/A
11085N/A* Thu Aug 16 2007 - damien.carbery@sun.com
11085N/A- Unbump to 2.19.6.1 because of build error I cannot figure out.
11085N/A
11066N/A* Wed Aug 15 2007 - damien.carbery@sun.com
11066N/A- Bump to 2.19.90. Remove upstream patches, 01-err_to_g_error and
11066N/A 02-string_header.
11066N/A
10977N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10977N/A- Add 3 patches, 01-err_to_g_error, 02-string_header and 03-strsep to fix
10977N/A Solaris specific build issues.
10977N/A
10975N/A* Tue Jul 31 2007 - halton.huo@sun.com
10975N/A- Bump to 2.19.6.1.
10975N/A
10972N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10972N/A- Bump to 2.19.6. Remove upstream patch, 01-suncc-build-fail.
10972N/A
10909N/A* Mon Jul 09 2007 - halton.huo@sun.com
10909N/A- Bump to 2.19.5.
10909N/A- Add patch suncc-build-fail.diff to let build pass.
10909N/A
10821N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10821N/A- Bump to 2.19.4.1.
10821N/A
10810N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10810N/A- Bump to 2.19.4.
10810N/A
10645N/A* Tue May 15 2007 - damien.carbery@sun.com
10645N/A- Bump to 2.19.2. Remove unneeded patch, 01-pkcs. gnome-keyring uses libgcrypt
10645N/A now.
10645N/A
10435N/A* Sun Apr 08 2007 - damien.carbery@sun.com
10435N/A- Bump to 0.8.1. Remove upstream patch, 02-crash.
10435N/A
10371N/A* Tue Mar 27 2007 - halton.huo@sun.com
10371N/A- Add patch crash.diff.
10371N/A
10270N/A* Mon Mar 12 2007 - damien.carbery@sun.com
10271N/A- Bump to 0.8.
10270N/A
10200N/A* Tue Mar 06 2007 - damien.carbery@sun.com
10200N/A- Bump to 0.7.92.
10200N/A
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.7.91.
10139N/A
10139N/A* Fri Jan 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.7.3.
10139N/A
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.7.2.
10139N/A
10139N/A* Wed Dec 06 2006 - takao.fujiwara@sun.com
10139N/A- Add intltoolize to read LIGUAS file. Fixes 6498950
10139N/A
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.6.0.
10139N/A
10139N/A* Fri Jul 20 2006 - padraig.obriain@sun.com
10139N/A- Bump to 0.5.1.
10139N/A
10139N/A* Tue May 02 2006 - damien.carbery@sun.com
10139N/A- Remove unneeded intltoolize call.
10139N/A
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.9.
10139N/A
10139N/A* Tue Feb 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.8.
10139N/A
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.4.7.
10139N/A- Add hack to fix infinite loop problem in po/Makefile.
10139N/A
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.4.6.
10139N/A
10139N/A* Thu Sep 15 2005 - brian.cameron@sun.com
10139N/A- Bump to 0.4.5.
10139N/A
10139N/A* Fri Sep 09 2005 - laca@sun.com
10139N/A- call intltoolize so that the correct Makefile.in.in is copied to po
10139N/A
10139N/A* Tue Sep 06 2005 - damien.carbery@sun.com
10139N/A- Call glib-gettextize as po/Makefile.in.in not in tarball. Add patch to
10139N/A skip the 'ar' locale as its files has problems #315335.
10139N/A
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.4.4.
10139N/A
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.4.3.
10139N/A
10139N/A* Wed Jun 15 2005 - laca@sun.com
10139N/A- Add more libs to LDADD so that it builds with the new pkgconfig
10139N/A
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 0.4.2
10139N/A
10139N/A* Fri Aug 29 2004 - brian.cameron@sun.com
10139N/A- Added patch 01 for pkcs support.
10139N/A
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- removed --disable-gtk-doc since this isn't an option this module's
10139N/A configure takes.
10139N/A
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-keyring-l10n-po-1.2.tar.bz2
10139N/A
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-keyring-l10n-po-1.1.tar.bz2
10139N/A
10139N/A* Tue Apr 13 2004 - laszlo.kovacs@sun.com
10139N/A- upgraded tarball
10139N/A* Wed Mar 31 2004 - brian.cameron@sun.com
10139N/A- replace tar jxf with the more solaris friendly
10139N/A bzcat piped through tar
10139N/A
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Adding gnome-keyring-l10n-po-1.0.tar.bz2 l10n content
10139N/A
10139N/A* Fri Mar 19 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.1.91 and remove the uninstalled pc patch
10139N/A since it's upstream.
10139N/A
10139N/A* Fri Mar 12 2004 - niall.power@sun.com
10139N/A- define libexecdir in configure args
10139N/A
10139N/A* Mon Feb 02 2004 - niall.power@sun.com
10139N/A- bump to 0.1.2
10139N/A- Add patch to generate an -uninstalled.pc file
10139N/A- Add ACLOCAL_FLAGS env to aclocal invocation
10139N/A
10139N/A* Mon Dec 15 2003 - glynn.foster@sun.com
10139N/A- Initial Sun release