gnome-games.spec revision 13114
10139N/A#
10139N/A# spec file for package gnome-games
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: migi
10139N/A#
10139N/AName: gnome-games
10139N/ALicense: GPL
10139N/AGroup: Amusements/Games
10285N/AVersion: 2.22.2
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: GNOME games
10285N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.22/%{name}-%{version}.tar.bz2
10139N/A# owner:davelam date:2008-05-14 type:bug bugziall:532093
10139N/APatch1: gnome-games-01-add-libz.diff
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/APrereq: GConf
10139N/A
10139N/A%define python_version 2.4
10139N/A%define libgnomeui_version 2.2.0
10139N/A%define scrollkeeper_version 0.3.11
10139N/A
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10139N/ABuildRequires: intltool
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/A
10139N/A%description
10139N/AThe gnome-games package includes some small games that come with the
10139N/AGNOME desktop environment but can be used under any desktop.
10139N/AThe games are mostly puzzle or solitaire games.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport install_user=$LOGNAME
10139N/Aexport install_group=`groups | awk '{print $1}'`
10139N/A
10139N/A# Force the update of aclocal.m4 to incorporate the modified sdl.m4. Otherwise
10139N/A# configure fails because /usr/bin/xgettext is checked instead of the CBE
10139N/A# version which is GNU xgettext.
10139N/Aaclocal --force $ACLOCAL_FLAGS -I m4
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --with-scores-user=$install_user \
10139N/A --with-scores-group=$install_group \
10139N/A --with-sound=gstreamer \
10139N/A --disable-setgid \
10139N/A --disable-scrollkeeper \
10139N/A --with-libggz-includes=%{libggz_build_dir}/src \
10139N/A --with-libggz-libraries=%{libggz_build_dir}/src/.libs \
10139N/A --with-ggzmod-includes=%{ggzclient_build_dir}/ggzmod \
10139N/A --with-ggzmod-libraries=%{ggzclient_build_dir}/ggzmod/.libs \
10139N/A --enable-omitgames=aisleriot,blackjack,gnometris
10139N/A
10139N/Amake -j $CPUS \
10139N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/A%makeinstall localstatedir=%{_localstatedir}/lib \
10139N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A
10139N/A## things we just don't want in the package
10139N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
10139N/A
10139N/A## install desktop files
10139N/A
10139N/A%find_lang %{name}
10139N/A
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
10139N/Adone
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files -f %{name}.lang
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING ChangeLog
10139N/A
10139N/A# these are not setgid games
10139N/A%{_bindir}/games-server.py
10139N/A%{_bindir}/gnect
10139N/A%{_bindir}/blackjack
10139N/A
10139N/A%{_localstatedir}/lib
10139N/A
10139N/A# these are setgid games
10139N/A%attr(2551, root, games) %{_bindir}/gnomine
10139N/A%attr(2551, root, games) %{_bindir}/same-gnome
10139N/A%attr(2551, root, games) %{_bindir}/mahjongg
10139N/A%attr(2551, root, games) %{_bindir}/gtali
10139N/A%attr(2551, root, games) %{_bindir}/gnobots2
10139N/A%attr(2551, root, games) %{_bindir}/gataxx
10139N/A%attr(2551, root, games) %{_bindir}/gnotravex
10139N/A%attr(2551, root, games) %{_bindir}/gnotski
10139N/A%attr(2551, root, games) %{_bindir}/gnibbles
10139N/A%attr(2551, root, games) %{_bindir}/glines
10139N/A%attr(2551, root, games) %{_bindir}/iagno
10139N/A
10139N/A%{_datadir}/applications
10285N/A%{_datadir}/blackjack
10285N/A%{_datadir}/gnect
10179N/A%{_datadir}/gnibbles
10187N/A%{_datadir}/gnobots2
10139N/A%{_datadir}/gnome
10139N/A%{_datadir}/gnome-games
10139N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/A%{_datadir}/omf
10139N/A%{_datadir}/pixmaps
10139N/A%{_datadir}/sounds
10139N/A%{_sysconfdir}/gconf/schemas/*
10139N/A%config %{_sysconfdir}/sound/events/*
10139N/A
10139N/A%changelog
10139N/A* Tue May 27 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.22.2.
10139N/A* Wed May 14 2008 - dave.lin@sun.com
10139N/A- Add patch gnome-games-01-add-libz.diff to fix build error
10139N/A* Wed Apr 09 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.22.1.1. Remove upstream patch 01-skip-ggz-check.
10139N/A* Tue Mar 25 2008 - damien.carbery@sun.com
10139N/A- Add --with-sound=gstreamer to configure to ensure that sound support is built
10139N/A in.
10139N/A* Tue Mar 11 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.22.0.
10139N/A* Thu Feb 28 2008 - brian.cameron@sun.com
10139N/A- Use %{ggzclient_build_dir} instead of %{ggzmod_build_dir} since this
10139N/A is more accurate naming. The module is ggz_client_libs.
10139N/A* Tue Feb 26 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.92.
10139N/A* Wed Feb 13 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.91.
10139N/A* Tue Jan 29 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.90.
10139N/A* Fri Jan 25 2008 - damien.carbery@sun.com
10139N/A- Force the update of aclocal.m4 to incorporate the modified sdl.m4. Otherwise
10139N/A configure fails because /usr/bin/xgettext is checked instead of the CBE
10139N/A version which is GNU xgettext.
10139N/A* Tue Jan 15 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.5.
10139N/A* Wed Jan 09 2008 - damien.carbery@sun.com
10139N/A- Remove 02-msgfmt patch, instead set ACLOCAL_FLAGS in SUNWgnome-games.spec to
10139N/A pick up modified intltool.m4.
10139N/A* Mon Jan 07 2008 - patrick.ale@gmail.com
10139N/A- Add patch gnome-games-02-msgfmt.diff
10139N/A* Mon Jan 07 2008 - damien.carbery@sun.com
10139N/A- Specify ggzmod location in configure.
10139N/A* Wed Jan 02 2008 - damien.carbery@sun.com
10139N/A- Use variable from SUNWgnome-games.spec to specify libggz location. Add patch
10139N/A 01-skip-ggz-check to set compiler flags to get libggz search test work.
10139N/A* Tue Dec 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.4.
10139N/A* Tue Dec 04 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.3.
10139N/A* Tue Nov 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.2.
10139N/A* Tue Oct 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.1.
10139N/A* Fri Oct 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.1.
10139N/A* Tue Oct 9 2007 - damien.carbery@sun.com
10139N/A- Add --disable-setgid to configure so that the games are not setgid-bin, which
10139N/A violates ARC rules.
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.0.1. Remove upstream patch, 01-func-decl.
10139N/A* Mon Sep 03 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.92. Add patch, 01-func-decl, to fix #473327.
10139N/A* Wed Aug 29 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.91.1.
10139N/A* Tue Aug 28 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.91. Remove upstream patch, gnome-menus-05-iconv-solaris.
10139N/A* Thu Aug 16 2007 - damien.carbery@sun.com
10139N/A- Add patch gnome-menus-05-iconv-solaris to fix #467309. Modify
10139N/A intltool-merge.in to allow use of non-GNU iconv.
10139N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.90.1.
10139N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
10139N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
10139N/A Renumber remainder.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
10139N/A* Mon Jun 11 2007 - damien.carbery@sun.com
10139N/A- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
10139N/A bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
10139N/A file (modified in patch3).
10139N/A* Fri Jun 08 2007 - damien.carbery@sun.com
10139N/A- Add patch, 03-signed-char, for #445556.
10139N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.3. Add patches to fix some build errors.
10139N/A* Fri May 18 2007 - matt.keenan@sun.com
10139N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
10139N/A* Wed May 16 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.2.
10139N/A* Wed May 09 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.1.
10139N/A* Fri May 04 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.1.
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.
10139N/A* Thu Apr 05 2007 - matt.keenan@sun.com
10139N/A- Remove glchess.desktop, until glchess is made functional on Solaris
10139N/A- Bugzilla : 426538, bugster : 6537569
10139N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.1.
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.
10139N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
10139N/A* Thu Feb 15 2007 - damien.carbery@sun.com
10139N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
10139N/A Specify build user/group so that chown calls don't fail; disable building
10139N/A of aisleriot game (removing code from SUNWgnome-games.spec).
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.91.
10139N/A* Wed Jan 24 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90.1.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90.
10139N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
10139N/A* Wed Dec 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.
10139N/A* Thu Dec 07 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
10139N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
10139N/A Install python libs to vendor-packages dir and remove *.pyo files.
10139N/A* Fri Nov 24 2006 - damien.carbery@sun.com
10139N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
10139N/A* Wed Nov 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.1.
10139N/A* Thu Nov 09 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.1.1.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.1.
10139N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.0.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.92.
10139N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.6.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.5.
10139N/A* Web Jul 21 2006 - dermot.mccluskey@sun.com
10139N/A- Bump to 2.15.4.
10139N/A* Mon Jun 26 2006 - laca@sun.com
10139N/A- remove patch menu-entry.diff since gnome-games is moving back to /usr
10139N/A* Fri Jun 23 2006 - brian.cameron@sun.com
10139N/A- Bump to 2.14.2.
10139N/A* Fri Apr 10 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.
10139N/A* Thu Feb 23 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.8.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.7.
10139N/A* Sat Jan 21 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 02-illegal-cast.
10139N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.5
10139N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.4.
10139N/A* Sat Jan 07 2006 - damien.carbery@sun.com
10139N/A- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10139N/A- Bump to 2.13.3
10139N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
10139N/A- Added gnome-games-01-sfw-path.diff to use the absolute path of the
executable in the .desktop file as usr/sfw/bin should not be
included in $PATH.
Fixes bug #6345489.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 2.12.2.
* Wed Oct 12 2005 - damien.carbery@sun.com
- Remove patch as offending struct is no longer empty.
* Tue Oct 11 2005 - damien.carbery@sun.com
- Bump to 2.12.1
* Sat Sep 17 2005 - glynn.foster@sun.com
- Bump to 2.12.0
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.5.
* Fri Sep 02 2005 - damien.carbery@sun.com
- Add patch to fix zero sized struct Solaris build error.
* Wed Aug 24 2005 - damien.carbery@sun.com
- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.4.
* Fri May 20 2005 - glynn.foster@sun.com
- Bump to 2.10.1
* Wed May 11 2005 - ciaran.mcdermott@sun.com
- added gnome-games-05-g11n-desktop-fix.diff
- to fix CR 6266891
* Wed Apr 27 2005 - kieran.colfer@sun.com
- added gnome-games-04-po-install-fixes.diff for CR 6243601
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected on
Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- removed sol from files
* Thu Sep 04 2004 - laslzo.kovacs@sun.com
- packaged sol
* Thu Aug 26 2004 - damien.carbery@sun.com
- Put scores files in %{_localstatedir}/lib.
* Wed Aug 25 2004 - damien.carbery@sun.com
- Add unpackaged files to %files.
* Mon Aug 23 2004 - niall.power@sun.com
- remove auto*-jds tool dependencies
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Tue Jun 1 2004 - glynn.foster@sun.com
- Fix up schema install
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - matt.keenan@sun.com
- Bump to 2.6.1
* Wed Apr 21 2004 - laca@sun.com
- disable javahelp conversion for stuff not built on Solaris
* Sun Apr 18 2004 - laca@sun.com
- enable javahelp conversion on Solaris
* Fri Apr 02 2004 - brian.cameron@sun.com
- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
configure line.
* Thu Apr 01 2004 - matt.keenan@sun.com
- javahelp conversion
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - glynn.foster@sun.com
- Use JDS autotools
* Tue Mar 23 2004 - glynn.foster@sun.com
- Bump to 2.6.0. Remove 2 potfile patches and
replace with a single one.
* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
- added gnome-games-03-g11n-potfiles.diff
* Fri Feb 06 2004 - <matt.keenan@sun.com>
- Bump up 2.5.5, remove intltool-merge patch
- re-engineered patch-01, as automake etc is commented out.
- This could be changed again if automake 1.7 was being used not 1.6 !!
* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
- add patch 03 for intltool-merge and dep. on intltool
* Fri Dec 29 2003 - <niall.power@sun.com>
- comment out libtool, aclocal etc. which
is causing build failure
* Fri Dec 29 2003 - <glynn.foster@sun.com>
- Bump to 2.5.3
* Wed Dec 17 2003 - <glynn.foster@sun.com>
- Bump to 2.5.2
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported keyword from the desktop
files. We're removing the Extras menu.
* Wed Oct 22 2003 - <glynn.foster@sun.com>
- Add blackjack into the build
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to GNOME 2.4.0 version
- Removed freecell entries
- Moved gnome-games-03-menu-entry.diff patch to
gnome-games-01-menu-entry.diff
- Dropped gnome-games-04-glines-preferences.diff patch.
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.so, *.a, *.la
* Wed Aug 06 2003 - <glynn.foster@sun.com>
- fix glines preference dialog
* Thu Jul 17 2003 - <glynn.foster@sun.com>
- remove more xbill stuff
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Tue Jul 08 2003 - glynn.foster@sun.com
- Add menu icon for freecell, and add aclocal, automake checks
* Tue May 13 2003 - ghee.teo@Sun.COM
- Created new spec file for gnome-games